Update to latest upstream version
- Move things around make docs dir actually working - Add proper requires on vim-filesystem - Run testsuite - Split music and latex support to subpackages
This commit is contained in:
parent
def7d3cb88
commit
c7abc941a4
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
asciidoc-8.4.5.tar.gz
|
asciidoc-8.4.5.tar.gz
|
||||||
|
/asciidoc-8.6.8.tar.gz
|
||||||
|
@ -1,86 +0,0 @@
|
|||||||
diff -up asciidoc-8.4.5/asciidoc.py.datadir asciidoc-8.4.5/asciidoc.py
|
|
||||||
--- asciidoc-8.4.5/asciidoc.py.datadir 2009-05-26 05:12:38.000000000 +0300
|
|
||||||
+++ asciidoc-8.4.5/asciidoc.py 2009-09-08 00:25:23.000000000 +0300
|
|
||||||
@@ -651,6 +651,8 @@ def filter_lines(filter_cmd, lines, attr
|
|
||||||
if not found:
|
|
||||||
found = findfilter(filtername, CONF_DIR, cmd)
|
|
||||||
if not found:
|
|
||||||
+ found = findfilter(filtername, DATA_DIR, cmd)
|
|
||||||
+ if not found:
|
|
||||||
found = findfilter(filtername, APP_DIR, cmd)
|
|
||||||
else:
|
|
||||||
if os.path.isfile(cmd):
|
|
||||||
@@ -4997,6 +4999,7 @@ APP_DIR = None # This file'
|
|
||||||
USER_DIR = None # ~/.asciidoc
|
|
||||||
# Global configuration files directory (set by Makefile build target).
|
|
||||||
CONF_DIR = '/etc/asciidoc'
|
|
||||||
+DATA_DIR = '/usr/share/asciidoc'
|
|
||||||
HELP_FILE = 'help.conf' # Default (English) help file.
|
|
||||||
|
|
||||||
# Globals
|
|
||||||
diff -up asciidoc-8.4.5/Makefile.in.datadir asciidoc-8.4.5/Makefile.in
|
|
||||||
--- asciidoc-8.4.5/Makefile.in.datadir 2009-04-24 01:49:43.000000000 +0300
|
|
||||||
+++ asciidoc-8.4.5/Makefile.in 2009-09-08 00:28:23.000000000 +0300
|
|
||||||
@@ -23,6 +23,7 @@ srcdir = @srcdir@
|
|
||||||
VPATH = @srcdir@
|
|
||||||
|
|
||||||
ASCIIDOCCONF = $(sysconfdir)/asciidoc
|
|
||||||
+ASCIIDOCDATA = $(datadir)/asciidoc
|
|
||||||
|
|
||||||
prog = asciidoc.py a2x
|
|
||||||
progdir = $(bindir)
|
|
||||||
@@ -35,25 +36,26 @@ manpdir = $(mandir)/man1
|
|
||||||
conf = $(wildcard *.conf)
|
|
||||||
confdir = $(ASCIIDOCCONF)
|
|
||||||
|
|
||||||
-filtersdir = $(ASCIIDOCCONF)/filters
|
|
||||||
+filtersdir = $(ASCIIDOCDATA)/filters
|
|
||||||
+filtersconfdir = $(ASCIIDOCCONF)/filters
|
|
||||||
|
|
||||||
codefilter = filters/code/code-filter.py
|
|
||||||
codefilterdir = $(filtersdir)/code
|
|
||||||
codefilterconf = filters/code/code-filter.conf
|
|
||||||
-codefilterconfdir = $(filtersdir)/code
|
|
||||||
+codefilterconfdir = $(filtersconfdir)/code
|
|
||||||
|
|
||||||
graphvizfilter = filters/graphviz/graphviz2png.py
|
|
||||||
graphvizfilterdir = $(filtersdir)/graphviz
|
|
||||||
graphvizfilterconf = filters/graphviz/graphviz-filter.conf
|
|
||||||
-graphvizfilterconfdir = $(filtersdir)/graphviz
|
|
||||||
+graphvizfilterconfdir = $(filtersconfdir)/graphviz
|
|
||||||
|
|
||||||
musicfilter = filters/music/music2png.py
|
|
||||||
musicfilterdir = $(filtersdir)/music
|
|
||||||
musicfilterconf = filters/music/music-filter.conf
|
|
||||||
-musicfilterconfdir = $(filtersdir)/music
|
|
||||||
+musicfilterconfdir = $(filtersconfdir)/music
|
|
||||||
|
|
||||||
sourcefilterconf = filters/source/source-highlight-filter.conf
|
|
||||||
-sourcefilterconfdir = $(filtersdir)/source
|
|
||||||
+sourcefilterconfdir = $(filtersconfdir)/source
|
|
||||||
|
|
||||||
docbook = $(wildcard docbook-xsl/*.xsl)
|
|
||||||
docbookdir = $(ASCIIDOCCONF)/docbook-xsl
|
|
||||||
@@ -126,6 +128,13 @@ fixconfpath:
|
|
||||||
mv $$f.out $$f; \
|
|
||||||
done
|
|
||||||
|
|
||||||
+fixdatapath:
|
|
||||||
+ @for f in $(prog); do \
|
|
||||||
+ echo "Fixing DATA_DIR in $$f"; \
|
|
||||||
+ $(SED) "s#^DATA_DIR = '.*'#DATA_DIR = '$(ASCIIDOCDATA)'#; s#^DATA_DIR=.*#DATA_DIR=$(ASCIIDOCDATA)#" $$f > $$f.out; \
|
|
||||||
+ mv $$f.out $$f; \
|
|
||||||
+ done
|
|
||||||
+
|
|
||||||
install-vim:
|
|
||||||
@for d in $(DESTDIR)/$(vimdir) /etc/vim; do \
|
|
||||||
if ! test -d $$d; then continue; fi ; \
|
|
||||||
@@ -145,7 +154,7 @@ uninstall-vim:
|
|
||||||
done
|
|
||||||
|
|
||||||
|
|
||||||
-build: fixconfpath
|
|
||||||
+build: fixconfpath fixdatapath
|
|
||||||
|
|
||||||
install: all $(PROGTARGETS) $(DATATARGETS) progsymlink install-vim
|
|
||||||
|
|
@ -1,38 +0,0 @@
|
|||||||
diff -up asciidoc-8.4.5/asciidoc.py.default-unsafe asciidoc-8.4.5/asciidoc.py
|
|
||||||
--- asciidoc-8.4.5/asciidoc.py.default-unsafe 2009-05-25 22:12:38.000000000 -0400
|
|
||||||
+++ asciidoc-8.4.5/asciidoc.py 2009-07-16 02:27:09.000000000 -0400
|
|
||||||
@@ -1138,7 +1138,7 @@ class Document:
|
|
||||||
self.level = 0 # 0 => front matter. 1,2,3 => sect1,2,3.
|
|
||||||
self.has_errors = False # Set true if processing errors were flagged.
|
|
||||||
self.has_warnings = False # Set true if warnings were flagged.
|
|
||||||
- self.safe = True # Default safe mode.
|
|
||||||
+ self.safe = False # Default safe mode.
|
|
||||||
def update_attributes(self):
|
|
||||||
# Set implicit attributes.
|
|
||||||
if self.infile and os.path.exists(self.infile):
|
|
||||||
@@ -5205,8 +5205,8 @@ def execute(cmd,opts,args):
|
|
||||||
for o,v in opts:
|
|
||||||
if o in ('--help','-h'):
|
|
||||||
help_option = True
|
|
||||||
- if o == '--unsafe':
|
|
||||||
- document.safe = False
|
|
||||||
+ if o == '--safe':
|
|
||||||
+ document.safe = True
|
|
||||||
if o == '--version':
|
|
||||||
print('asciidoc %s' % VERSION)
|
|
||||||
sys.exit(0)
|
|
||||||
diff -up asciidoc-8.4.5/doc/asciidoc.1.default-unsafe asciidoc-8.4.5/doc/asciidoc.1
|
|
||||||
--- asciidoc-8.4.5/doc/asciidoc.1.default-unsafe 2009-05-26 02:38:36.000000000 -0400
|
|
||||||
+++ asciidoc-8.4.5/doc/asciidoc.1 2009-08-12 23:51:09.000000000 -0400
|
|
||||||
@@ -123,9 +123,9 @@ Auto\-number HTML article section titles
|
|
||||||
\fB\-a numbered\fR\.
|
|
||||||
.RE
|
|
||||||
.PP
|
|
||||||
-\fB\-\-unsafe\fR
|
|
||||||
+\fB\-\-safe\fR
|
|
||||||
.RS 4
|
|
||||||
-Disable safe mode\. Safe mode is enabled by default, disabling it is potentially dangerous\.
|
|
||||||
+Enable safe mode\. Safe mode is disabled by default\.
|
|
||||||
.RE
|
|
||||||
.PP
|
|
||||||
\fB\-v, \-\-verbose\fR
|
|
132
asciidoc.spec
132
asciidoc.spec
@ -1,35 +1,70 @@
|
|||||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
%global vimdir %{_datadir}/vim/vimfiles
|
||||||
|
|
||||||
Summary: Text based document generation
|
Summary: Text based document generation
|
||||||
Name: asciidoc
|
Name: asciidoc
|
||||||
Version: 8.4.5
|
Version: 8.6.8
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
# The python code does not specify a version.
|
# The python code does not specify a version.
|
||||||
# The javascript example code is GPLv2+.
|
# The javascript example code is GPLv2+.
|
||||||
License: GPL+ and GPLv2+
|
License: GPL+ and GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
|
|
||||||
URL: http://www.methods.co.nz/asciidoc/
|
URL: http://www.methods.co.nz/asciidoc/
|
||||||
Source0: http://www.methods.co.nz/asciidoc/%{name}-%{version}.tar.gz
|
Source: http://sourceforge.net/projects/asciidoc/files/%{name}/%{version}/%{name}-%{version}.tar.gz
|
||||||
# http://groups.google.com/group/asciidoc/browse_thread/thread/7f7a633c5b11ddc3
|
|
||||||
Patch0: asciidoc-8.4.5-datadir.patch
|
BuildRequires: python2-devel
|
||||||
# https://bugzilla.redhat.com/506953
|
BuildRequires: dblatex
|
||||||
Patch1: asciidoc-8.4.5-use-unsafe-mode-by-default.patch
|
BuildRequires: graphviz
|
||||||
BuildRequires: python >= 2.4
|
BuildRequires: libxslt
|
||||||
|
BuildRequires: lilypond
|
||||||
|
BuildRequires: source-highlight
|
||||||
|
BuildRequires: texlive-dvipng-bin
|
||||||
|
BuildRequires: vim-filesystem
|
||||||
|
|
||||||
|
|
||||||
Requires: python >= 2.4
|
Requires: python >= 2.4
|
||||||
Requires: docbook-style-xsl
|
Requires: docbook-style-xsl
|
||||||
|
Requires: graphviz
|
||||||
Requires: libxslt
|
Requires: libxslt
|
||||||
|
Requires: libxslt
|
||||||
|
Requires: source-highlight
|
||||||
|
Requires: vim-filesystem
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
AsciiDoc is a text document format for writing short documents,
|
AsciiDoc is a text document format for writing short documents,
|
||||||
articles, books and UNIX man pages. AsciiDoc files can be translated
|
articles, books and UNIX man pages. AsciiDoc files can be translated
|
||||||
to HTML and DocBook markups using the asciidoc(1) command.
|
to HTML and DocBook markups using the asciidoc(1) command.
|
||||||
|
|
||||||
|
%package doc
|
||||||
|
Summary: Additional documentation and examples for asciidoc
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package latex
|
||||||
|
Summary: Support for asciidoc latex output
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: dblatex
|
||||||
|
Requires: texlive-dvipng-bin
|
||||||
|
|
||||||
|
%description latex
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package music
|
||||||
|
Summary: Support for asciidoc music output
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: lilypond
|
||||||
|
|
||||||
|
%description music
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .datadir
|
|
||||||
%patch1 -p1 -b .use-unsafe-mode-by-default
|
|
||||||
|
|
||||||
# Fix line endings on COPYRIGHT file
|
# Fix line endings on COPYRIGHT file
|
||||||
sed -i "s/\r//g" COPYRIGHT
|
sed -i "s/\r//g" COPYRIGHT
|
||||||
@ -45,40 +80,81 @@ done
|
|||||||
%configure
|
%configure
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
make install docs DESTDIR=%{buildroot}
|
||||||
make install DESTDIR=%{buildroot}
|
|
||||||
|
|
||||||
|
install -dm 755 %{buildroot}%{_datadir}/asciidoc/
|
||||||
# real conf data goes to sysconfdir, rest to datadir; symlinks so asciidoc works
|
# real conf data goes to sysconfdir, rest to datadir; symlinks so asciidoc works
|
||||||
for d in dblatex docbook-xsl images javascripts stylesheets ; do
|
for d in dblatex docbook-xsl images javascripts stylesheets; do
|
||||||
mv %{buildroot}%{_sysconfdir}/asciidoc/$d \
|
mv -v %{buildroot}%{_sysconfdir}/asciidoc/$d \
|
||||||
%{buildroot}%{_datadir}/asciidoc
|
%{buildroot}%{_datadir}/asciidoc/
|
||||||
ln -s %{_datadir}/asciidoc/$d %{buildroot}%{_sysconfdir}/asciidoc/
|
ln -s %{_datadir}/%{name}/$d %{buildroot}%{_sysconfdir}/%{name}/
|
||||||
|
|
||||||
|
# let's symlink stuff for documentation as well so we don't duplicate things
|
||||||
|
rm -rf %{buildroot}%{_docdir}/%{name}/$d
|
||||||
|
ln -s %{_datadir}/%{name}/$d %{buildroot}%{_docdir}/%{name}/
|
||||||
done
|
done
|
||||||
|
|
||||||
# Python API
|
# Python API
|
||||||
install -Dpm 644 asciidocapi.py %{buildroot}%{python_sitelib}/asciidocapi.py
|
install -Dpm 644 asciidocapi.py %{buildroot}%{python_sitelib}/asciidocapi.py
|
||||||
|
|
||||||
# Make it easier to %exclude these with both rpm < and >= 4.7
|
# Make it easier to %exclude these with both rpm < and >= 4.7
|
||||||
for file in %{buildroot}{%{_bindir},%{_datadir}/asciidoc/filters/*}/*.py ; do
|
for file in %{buildroot}{%{_bindir},%{_sysconfdir}/asciidoc/filters/*}/*.py ; do
|
||||||
touch ${file}{c,o}
|
touch ${file}{c,o}
|
||||||
done
|
done
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{vimdir}/{ftdetect,syntax}
|
||||||
|
for file in $(cd vim; find * -type f); do
|
||||||
|
install -m 0644 vim/$file %{buildroot}%{vimdir}/$file
|
||||||
|
done
|
||||||
|
|
||||||
%clean
|
%check
|
||||||
rm -rf %{buildroot}
|
export PATH="../:$PATH"
|
||||||
|
cd tests
|
||||||
|
python testasciidoc.py update
|
||||||
|
python testasciidoc.py run
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,0755)
|
%doc COPYING COPYRIGHT BUGS CHANGELOG README
|
||||||
%config(noreplace) %{_sysconfdir}/asciidoc
|
%doc %{_mandir}/man1/a2x.1*
|
||||||
%exclude %{_bindir}/*.py[co]
|
%doc %{_mandir}/man1/asciidoc.1*
|
||||||
%{_bindir}/*
|
%config(noreplace) %{_sysconfdir}/asciidoc/
|
||||||
%{_mandir}/man1/*
|
%{_bindir}/a2x
|
||||||
|
%{_bindir}/a2x.py
|
||||||
|
%{_bindir}/asciidoc
|
||||||
|
%{_bindir}/asciidoc.py
|
||||||
%{_datadir}/asciidoc/
|
%{_datadir}/asciidoc/
|
||||||
%exclude %{_datadir}/asciidoc/filters/*/*.py[co]
|
|
||||||
%{python_sitelib}/asciidocapi.py*
|
%{python_sitelib}/asciidocapi.py*
|
||||||
%doc README BUGS CHANGELOG COPYRIGHT
|
%{vimdir}/ftdetect/asciidoc_filetype.vim
|
||||||
|
%{vimdir}/syntax/asciidoc.vim
|
||||||
|
%exclude %{_bindir}/*.py[co]
|
||||||
|
%exclude %{_sysconfdir}/asciidoc/filters/*/*.py[co]
|
||||||
|
%exclude %{_sysconfdir}/asciidoc/filters/latex
|
||||||
|
%exclude %{_sysconfdir}/asciidoc/filters/music
|
||||||
|
|
||||||
|
%files doc
|
||||||
|
%{_docdir}/%{name}
|
||||||
|
%exclude %{_docdir}/%{name}/{BUGS,CHANGELOG,COPYING,COPYRIGHT,README}
|
||||||
|
|
||||||
|
%files latex
|
||||||
|
%dir %{_sysconfdir}/asciidoc/filters/latex
|
||||||
|
%{_sysconfdir}/asciidoc/filters/latex/*.py
|
||||||
|
%{_sysconfdir}/asciidoc/filters/latex/*.conf
|
||||||
|
|
||||||
|
%files music
|
||||||
|
%dir %{_sysconfdir}/asciidoc/filters/music
|
||||||
|
%{_sysconfdir}/asciidoc/filters/music/*.conf
|
||||||
|
%{_sysconfdir}/asciidoc/filters/music/*.py
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 7 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 8.6.8-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
- Move things around make docs dir actually working
|
||||||
|
- Add proper requires on vim-filesystem
|
||||||
|
- Run testsuite
|
||||||
|
- Split music and latex support to subpackages
|
||||||
|
|
||||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.4.5-9
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.4.5-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
@ -162,7 +238,7 @@ rm -rf %{buildroot}
|
|||||||
- Build as noarch (Petr Klíma)
|
- Build as noarch (Petr Klíma)
|
||||||
|
|
||||||
* Sat Jun 11 2005 Terje Røsten <terje.rosten@ntnu.no> - 7.0.0-0.3
|
* Sat Jun 11 2005 Terje Røsten <terje.rosten@ntnu.no> - 7.0.0-0.3
|
||||||
- Add include patch
|
- Add include patch
|
||||||
|
|
||||||
* Fri Jun 10 2005 Terje Røsten <terje.rosten@ntnu.no> - 7.0.0-0.2
|
* Fri Jun 10 2005 Terje Røsten <terje.rosten@ntnu.no> - 7.0.0-0.2
|
||||||
- Fix stylesheets according to Stuart
|
- Fix stylesheets according to Stuart
|
||||||
|
Loading…
Reference in New Issue
Block a user