New upstream release

Version: 4.1
This commit is contained in:
Pavel Raiskup 2022-10-31 09:44:49 +01:00
parent e5a5220978
commit 0c8678315c
4 changed files with 26 additions and 37 deletions

View File

@ -1,4 +1,4 @@
%if 0%{?fedora} %if 0%{?fedora} || 0%{?rhel} >= 9
%bcond_without pyproject %bcond_without pyproject
%bcond_with python2 %bcond_with python2
%bcond_with python3 %bcond_with python3
@ -27,8 +27,8 @@ There is a limited support for (deprecated) optparse objects, too.
Name: argparse-manpage Name: argparse-manpage
Version: 3 Version: 4
Release: 4%{?dist} Release: 1%{?dist}
Summary: %{sum Python} Summary: %{sum Python}
BuildArch: noarch BuildArch: noarch
@ -36,10 +36,6 @@ License: ASL 2.0
URL: https://github.com/praiskup/%{name} URL: https://github.com/praiskup/%{name}
Source0: https://github.com/praiskup/%name/releases/download/v%version/%name-%version.tar.gz Source0: https://github.com/praiskup/%name/releases/download/v%version/%name-%version.tar.gz
# Fix tests compatibility with pip >= 21.3
# Fixed upstream: https://github.com/praiskup/argparse-manpage/pull/60
Patch1: fix-pip-21.3-compat.patch
%if %{with python2} %if %{with python2}
BuildRequires: python2-setuptools python2-devel BuildRequires: python2-setuptools python2-devel
%if %{with check} %if %{with check}
@ -60,6 +56,8 @@ BuildRequires: python3-pytest
%if %{with pyproject} %if %{with pyproject}
BuildRequires: python3-devel BuildRequires: python3-devel
# EL9 needs this explicitly
BuildRequires: pyproject-rpm-macros
%if %{with check} %if %{with check}
BuildRequires: python3-pytest BuildRequires: python3-pytest
%endif %endif
@ -77,6 +75,7 @@ Requires: python2-%name = %version-%release
%package -n python2-%name %package -n python2-%name
Summary: %{sum Python 2} Summary: %{sum Python 2}
Requires: python2-setuptools
%description -n python2-%name %description -n python2-%name
%{desc} %{desc}
@ -84,14 +83,21 @@ Summary: %{sum Python 2}
%package -n python3-%name %package -n python3-%name
Summary: %{sum Python 3} Summary: %{sum Python 3}
%if %{without pyproject}
Requires: python3-setuptools
%endif
%description -n python3-%name %description -n python3-%name
%{desc} %{desc}
%if %{with pyproject}
%pyproject_extras_subpkg -n python3-%{name} setuptools
%endif
%prep %prep
%setup -q %setup -q
%patch1 -p1
%if %{with pyproject} %if %{with pyproject}
%generate_buildrequires %generate_buildrequires
@ -143,9 +149,9 @@ PYTHONPATH=%buildroot%python3_sitearch %__python3 -m pytest -vv
%{_bindir}/argparse-manpage %{_bindir}/argparse-manpage
%_mandir/man1/argparse-manpage.1.* %_mandir/man1/argparse-manpage.1.*
%if %{with python3} || %{with pyproject} %if %{with python3} || %{with pyproject}
%python3_sitelib/build_manpages/cli.py %python3_sitelib/argparse_manpage/cli.py
%else %else
%python2_sitelib/build_manpages/cli.py %python2_sitelib/argparse_manpage/cli.py
%endif %endif
@ -153,8 +159,9 @@ PYTHONPATH=%buildroot%python3_sitearch %__python3 -m pytest -vv
%files -n python2-%name %files -n python2-%name
%license LICENSE %license LICENSE
%python2_sitelib/build_manpages %python2_sitelib/build_manpages
%python2_sitelib/argparse_manpage
%python2_sitelib/argparse_manpage-%{version}*.egg-info %python2_sitelib/argparse_manpage-%{version}*.egg-info
%exclude %python2_sitelib/build_manpages/cli.py %exclude %python2_sitelib/argparse_manpages/cli.py
%endif %endif
@ -162,16 +169,21 @@ PYTHONPATH=%buildroot%python3_sitearch %__python3 -m pytest -vv
%files -n python3-%name %files -n python3-%name
%license LICENSE %license LICENSE
%python3_sitelib/build_manpages %python3_sitelib/build_manpages
%python3_sitelib/argparse_manpage
%if %{with pyproject} %if %{with pyproject}
%python3_sitelib/argparse_manpage-*dist-info %python3_sitelib/argparse_manpage-*dist-info
%else %else
%python3_sitelib/argparse_manpage-%{version}*.egg-info %python3_sitelib/argparse_manpage-%{version}*.egg-info
%endif %endif
%exclude %python3_sitelib/build_manpages/cli.py %exclude %python3_sitelib/argparse_manpage/cli.py
%endif %endif
%changelog %changelog
* Mon Oct 31 2022 Pavel Raiskup <praiskup@redhat.com> - 4-1
- new upstream release:
https://github.com/praiskup/argparse-manpage/releases/tag/v4
* Fri Jul 22 2022 Charalampos Stratakis <cstratak@redhat.com> - 3-4 * Fri Jul 22 2022 Charalampos Stratakis <cstratak@redhat.com> - 3-4
- Fix tests compatibility with pip >= 21.3 - Fix tests compatibility with pip >= 21.3

View File

@ -4,7 +4,7 @@
# script. # script.
main=main main=main
branches="$main epel7 epel8 epel9 f34 f35 f36" branches="$main epel7 epel8 epel9 f34 f35 f36 f37"
exit_handler () exit_handler ()
{ {

View File

@ -1,22 +0,0 @@
diff --git a/tests/test_examples.py b/tests/test_examples.py
index 66d2352..7886861 100644
--- a/tests/test_examples.py
+++ b/tests/test_examples.py
@@ -49,8 +49,15 @@ def _rmtree(directory):
def run_pip(args):
environ = os.environ.copy()
environ['PYTHONPATH'] = ':'.join(sys.path)
- subprocess.call([sys.executable, '-m', 'pip'] + args + ["--use-feature=in-tree-build", "."],
- env=environ)
+ from pip import __version__
+
+ pip_version = tuple([int(x) for x in __version__.split('.')[:2]])
+ if pip_version < (21, 3):
+ subprocess.call(
+ [sys.executable, '-m', 'pip'] + args + ["--use-feature=in-tree-build", "."],
+ env=environ)
+ else:
+ subprocess.call([sys.executable, '-m', 'pip'] + args + ["."], env=environ)
def run_setup_py(args):

View File

@ -1,2 +1 @@
SHA512 (argparse-manpage-2.2.tar.gz) = 39bb51687dd8359930527b2492469166de7654ea12e456c5ea5b78a7293cb4e792307706b9a9e0280373ce4ea18a2a0bf16bd6b739508634e93fde284033bf13 SHA512 (argparse-manpage-4.tar.gz) = ebc17c4b4e9bcf360a285757c3407dfc4a4102e2512b918148c4edddc62023bbd47ba15947dc55f9655fa093d7d2305977a2a062fdb2eb931c3fc5d7cdba52aa
SHA512 (argparse-manpage-3.tar.gz) = 8bddfc91396ee6c9594baa21126fb3128ebabb8fb96dba1461e0631e0e3070677973b709d998dcea26e31b6d11a9f37a8b37005bb78f7769d45a29be3186a088