re-import sources as agreed with the maintainer

This commit is contained in:
Adam Samalik 2023-06-29 10:52:18 +02:00
parent 74dceae157
commit d629db521a
13 changed files with 28 additions and 320 deletions

View File

@ -1 +0,0 @@
1

25
.gitignore vendored
View File

@ -1,2 +1,25 @@
SOURCES/3.5.0.REL.tar.gz
/aqute-service.tar.gz
/bnd-0.0.363.jar
/2.4.1.REL.tar.gz
/biz.aQute.bnd-2.4.1.pom
/biz.aQute.bndlib-2.4.1.pom
/3.2.0.REL.tar.gz
/aQute.libg-3.2.0.pom
/biz.aQute.bnd-3.2.0.pom
/biz.aQute.bndlib-3.2.0.pom
/biz.aQute.bnd.annotation-3.2.0.pom
/3.3.0.REL.tar.gz
/aQute.libg-3.3.0.pom
/biz.aQute.bnd-3.3.0.pom
/biz.aQute.bndlib-3.3.0.pom
/biz.aQute.bnd.annotation-3.3.0.pom
/3.4.0.REL.tar.gz
/aQute.libg-3.4.0.pom
/biz.aQute.bnd-3.4.0.pom
/biz.aQute.bndlib-3.4.0.pom
/biz.aQute.bnd.annotation-3.4.0.pom
/3.5.0.REL.tar.gz
/aQute.libg-3.5.0.pom
/biz.aQute.bnd-3.5.0.pom
/biz.aQute.bndlib-3.5.0.pom
/biz.aQute.bnd.annotation-3.5.0.pom

View File

@ -1,102 +0,0 @@
From 64a36cbc8d7c8234dfa2af8670c2e1ea4a5c3909 Mon Sep 17 00:00:00 2001
From: Marian Koncek <mkoncek@redhat.com>
Date: Thu, 11 Jul 2019 14:29:26 +0200
Subject: [PATCH] Port to OSGI 7.0.0
---
.../src/aQute/bnd/junit/ConsoleLogger.java | 62 +++++++++++++++++++
1 file changed, 62 insertions(+)
diff --git a/biz.aQute.bndlib/src/aQute/bnd/junit/ConsoleLogger.java b/biz.aQute.bndlib/src/aQute/bnd/junit/ConsoleLogger.java
index 9c2591f..569b20e 100644
--- a/biz.aQute.bndlib/src/aQute/bnd/junit/ConsoleLogger.java
+++ b/biz.aQute.bndlib/src/aQute/bnd/junit/ConsoleLogger.java
@@ -15,9 +15,11 @@ import org.osgi.framework.ServiceFactory;
import org.osgi.framework.ServiceReference;
import org.osgi.framework.ServiceRegistration;
import org.osgi.service.log.LogEntry;
+import org.osgi.service.log.LogLevel;
import org.osgi.service.log.LogListener;
import org.osgi.service.log.LogReaderService;
import org.osgi.service.log.LogService;
+import org.osgi.service.log.Logger;
@Deprecated // see biz.aQute.bnd.remote.junit
public class ConsoleLogger implements LogReaderService {
@@ -76,6 +78,36 @@ public class ConsoleLogger implements LogReaderService {
return time;
}
+ @Override
+ public LogLevel getLogLevel() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public String getLoggerName() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public long getSequence() {
+ // TODO Auto-generated method stub
+ return 0;
+ }
+
+ @Override
+ public String getThreadInfo() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public StackTraceElement getLocation() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
}
public class Facade implements LogService {
@@ -112,6 +144,36 @@ public class ConsoleLogger implements LogReaderService {
}
+ @Override
+ public Logger getLogger(String name) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public Logger getLogger(Class<?> clazz) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public <L extends Logger> L getLogger(String name, Class<L> loggerType) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public <L extends Logger> L getLogger(Class<?> clazz, Class<L> loggerType) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public <L extends Logger> L getLogger(Bundle bundle, String name, Class<L> loggerType) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
}
public ConsoleLogger(BundleContext context) {
--
2.20.1

View File

@ -1,42 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>biz.aQute.bnd</groupId>
<artifactId>aQute.libg</artifactId>
<version>3.5.0</version>
<description>A library to be statically linked. Contains many small utilities. This bundle should not be installed in a framework, it is compile only.</description>
<name>aQute.libg</name>
<url>http://bnd.bndtools.org/</url>
<organization>
<name>Bndtools</name>
<url>http://bndtools.org/</url>
</organization>
<licenses>
<license>
<name>Apache-2.0</name>
<url>http://www.apache.org/licenses/LICENSE-2.0</url>
<distribution>repo</distribution>
<comments>Apache License, Version 2.0</comments>
</license>
</licenses>
<scm>
<url>https://github.com/bndtools/bnd</url>
<connection>scm:git:https://github.com/bndtools/bnd.git</connection>
<developerConnection>scm:git:git@github.com:bndtools/bnd.git</developerConnection>
<tag>3.5.0.REL</tag>
</scm>
<developers>
<developer>
<id>pkriens</id>
<email>Peter.Kriens@aQute.biz</email>
<name>Peter Kriens</name>
<organization>Bndtools</organization>
<organizationUrl>https://github.com/bndtools</organizationUrl>
<roles>
<role>architect</role>
<role>developer</role>
</roles>
<timezone>1</timezone>
</developer>
</developers>
</project>

View File

@ -1,42 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>biz.aQute.bnd</groupId>
<artifactId>biz.aQute.bnd</artifactId>
<version>3.5.0</version>
<description>This command line utility is the Swiss army knife of OSGi. It provides you with a breadth of tools to understand and manage OSGi based systems. This project basically uses bndlib.</description>
<name>biz.aQute.bnd</name>
<url>http://bnd.bndtools.org/</url>
<organization>
<name>Bndtools</name>
<url>http://bndtools.org/</url>
</organization>
<licenses>
<license>
<name>Apache-2.0</name>
<url>http://www.apache.org/licenses/LICENSE-2.0</url>
<distribution>repo</distribution>
<comments>Apache License, Version 2.0</comments>
</license>
</licenses>
<scm>
<url>https://github.com/bndtools/bnd</url>
<connection>scm:git:https://github.com/bndtools/bnd.git</connection>
<developerConnection>scm:git:git@github.com:bndtools/bnd.git</developerConnection>
<tag>3.5.0.REL</tag>
</scm>
<developers>
<developer>
<id>pkriens</id>
<email>Peter.Kriens@aQute.biz</email>
<name>Peter Kriens</name>
<organization>Bndtools</organization>
<organizationUrl>https://github.com/bndtools</organizationUrl>
<roles>
<role>architect</role>
<role>developer</role>
</roles>
<timezone>1</timezone>
</developer>
</developers>
</project>

View File

@ -1,42 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>biz.aQute.bnd</groupId>
<artifactId>biz.aQute.bnd.annotation</artifactId>
<version>3.5.0</version>
<description>Contains only the annotations for bnd.</description>
<name>bnd Annotations Library</name>
<url>http://www.aQute.biz/Code/Bnd</url>
<organization>
<name>Bndtools</name>
<url>http://bndtools.org/</url>
</organization>
<licenses>
<license>
<name>Apache-2.0</name>
<url>http://www.apache.org/licenses/LICENSE-2.0</url>
<distribution>repo</distribution>
<comments>Apache License, Version 2.0</comments>
</license>
</licenses>
<scm>
<url>https://github.com/bndtools/bnd</url>
<connection>scm:git:https://github.com/bndtools/bnd.git</connection>
<developerConnection>scm:git:git@github.com:bndtools/bnd.git</developerConnection>
<tag>3.5.0.REL</tag>
</scm>
<developers>
<developer>
<id>pkriens</id>
<email>Peter.Kriens@aQute.biz</email>
<name>Peter Kriens</name>
<organization>Bndtools</organization>
<organizationUrl>https://github.com/bndtools</organizationUrl>
<roles>
<role>architect</role>
<role>developer</role>
</roles>
<timezone>1</timezone>
</developer>
</developers>
</project>

View File

@ -1,38 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>biz.aQute.bnd</groupId>
<artifactId>biz.aQute.bndlib</artifactId>
<version>3.5.0</version>
<description>A Swiss Army Knife for OSGi</description>
<name>bndlib</name>
<url>http://bnd.bndtools.org/</url>
<organization>
<name>Bndtools</name>
<url>http://bndtools.org/</url>
</organization>
<licenses>
<license>
<name>Apache-2.0</name>
<url>http://www.apache.org/licenses/LICENSE-2.0</url>
<distribution>repo</distribution>
<comments>Apache License, Version 2.0</comments>
</license>
</licenses>
<scm>
<url>https://github.com/bndtools/bnd</url>
<connection>scm:git:https://github.com/bndtools/bnd.git</connection>
<developerConnection>scm:git:git@github.com:bndtools/bnd.git</developerConnection>
<tag>3.5.0.REL</tag>
</scm>
<developers>
<developer>
<id>peter.kriens@aQute.biz</id>
<email>peter.kriens@aQute.biz</email>
</developer>
<developer>
<id>njbartlett@gmail.com</id>
<email>njbartlett@gmail.com</email>
</developer>
</developers>
</project>

View File

@ -1,9 +0,0 @@
--- !Policy
product_versions:
- rhel-9
decision_contexts:
- osci_compose_gate
rules:
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
# https://docs.engineering.redhat.com/display/RHELPLAN/Maven+Bootstrap+manual+gating+test
- !PassingTestCaseRule {test_case_name: manual.sst_cs_apps.maven.bootstrap}

View File

@ -1,31 +0,0 @@
#!/bin/bash
set -e
name=aqute-bnd
version="$(sed -n 's/Version:\s*//p' *.spec)"
# RETRIEVE
wget "https://github.com/bndtools/bnd/archive/${version}.REL.tar.gz" -O "${name}-${version}.orig.tar.gz"
rm -rf tarball-tmp
mkdir tarball-tmp
pushd tarball-tmp
tar -xf "../${name}-${version}.orig.tar.gz"
mv "bnd-${version}.REL" "${name}-${version}"
# CLEAN TARBALL
rm -rf "${name}-${version}/docs"
find -name '*.jar' -delete
find -name '*.class' -delete
find -name '*.ar' -delete
find -name '*.tar' -delete
find -name '*.gz' -delete
find -name '*.bz2' -delete
find -name '*.xz' -delete
find -name '*.zip' -delete
find -name '*.exe' -delete
find -name '*.dll' -delete
tar -czf "../${name}-${version}.tar.gz" *
popd
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"

View File

@ -1,8 +0,0 @@
summary: Regression test
execute:
script:
# Regression tests for for rhbz#2033709
- jar tf /usr/share/java/aqute-bnd/biz.aQute.bnd.jar | grep -c \\.class$
- jar tf /usr/share/java/aqute-bnd/aQute.libg.jar | grep -c \\.class$
- jar tf /usr/share/java/aqute-bnd/biz.aQute.bnd.annotation.jar | grep -c \\.class$
- jar tf /usr/share/java/aqute-bnd/biz.aQute.bndlib.jar | grep -c \\.class$

View File

@ -1,4 +0,0 @@
summary: Basic smoke test
execute:
script:
- bnd print /usr/share/java/osgi-core/osgi.core.jar

0
repack-tarball.sh Executable file → Normal file
View File

View File

@ -1 +1,5 @@
SHA512 (3.5.0.REL.tar.gz) = c0e1fb6370881ab5012bbfbeae8093c23b25083a8a82599a9ae1179d8efc051c3b4a5cf99473072b7cf1e84440e08f19a5731b6f3c8bb805f849aa4823c16062
SHA512 (aQute.libg-3.5.0.pom) = 81a7f1350296c2bdd48755c38804520c80df2ed968186a35842284d55b4ac951092646c780a5bc91fca161f43515e3061b9003aa6674dd199297159b9a59eb60
SHA512 (biz.aQute.bnd-3.5.0.pom) = 60ff58f4d366dccb26cee5ac3d0749a564e0eab41b4e493df1727c7a79d7159f0913d3d1dcd406963580b7063d8b76cd92088d9eee46a01a0f9dd33643a5c345
SHA512 (biz.aQute.bndlib-3.5.0.pom) = 3987110f4fc1bedb13f3ad777cb33dc9db75ad81135fcbc49763dfb243c5053ea864d76d16f271547666c01f6dfbb104a9d4ee52496e62e6fb80dcfc02d23f75
SHA512 (biz.aQute.bnd.annotation-3.5.0.pom) = c968e0586f55accb37d4caf4d8a6d509fd6f88982dcc464cfb0fd41f863eb0b7945aadafb97c79ba2d6d1fda59ef12e5bac4556e302599924130d69fb99ac31f