diff --git a/aqute-bnd.spec b/aqute-bnd.spec
index 61a3ddd..bb2b604 100644
--- a/aqute-bnd.spec
+++ b/aqute-bnd.spec
@@ -1,7 +1,7 @@
Name: aqute-bnd
Version: 4.3.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: BND Tool
# Part of jpm is under BSD, but jpm is not included in binary RPM
License: ASL 2.0 or EPL-2.0
@@ -55,6 +55,8 @@ BuildRequires: mvn(org.osgi:osgi.core)
BuildRequires: mvn(org.slf4j:slf4j-api)
BuildRequires: mvn(org.slf4j:slf4j-simple)
BuildRequires: mvn(org.sonatype.plexus:plexus-build-api)
+# Requires self to generate OSGi metadata
+BuildRequires: mvn(biz.aQute.bnd:bnd-maven-plugin)
# Explicit javapackages-tools requires since bnd script uses
# /usr/share/java-utils/java-functions
@@ -103,6 +105,7 @@ rm gradlew*
sed 's/@VERSION@/%{version}/' %SOURCE2 > pom.xml
sed -i 's|${Bundle-Version}|%{version}|' biz.aQute.bndlib/src/aQute/bnd/osgi/bnd.info
+sed -i -e '/-include/d' cnf/includes/jdt.bnd
# libg
pushd aQute.libg
@@ -139,6 +142,20 @@ cp -p %{SOURCE5} pom.xml
%pom_add_dep org.osgi:osgi.cmpn
%pom_add_dep biz.aQute.bnd:aQute.libg:%{version}
%pom_add_dep biz.aQute.bnd:biz.aQute.bnd.annotation:%{version}
+%pom_add_plugin biz.aQute.bnd:bnd-maven-plugin . "
+
+
+
+ bnd-process
+
+
+"
+%pom_add_plugin org.apache.maven.plugins:maven-jar-plugin . "
+
+
+ \${project.build.outputDirectory}/META-INF/MANIFEST.MF
+
+"
popd
# bnd.annotation
@@ -219,7 +236,8 @@ popd
%mvn_package biz.aQute.bnd:bnd-plugin-parent __noinstall
%build
-%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
+%mvn_build -- -Dproject.build.sourceEncoding=UTF-8 -Dworkspace=$(pwd) \
+ -Dorg.eclipse.jdt.core.compiler.source=1.8 -Dorg.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
%install
%mvn_install
@@ -243,6 +261,9 @@ echo "aqute-bnd slf4j/api slf4j/simple osgi-annotation osgi-core osgi-compendium
%license LICENSE
%changelog
+* Wed Nov 25 2020 Mat Booth - 4.3.1-2
+- Add OSGi metadata
+
* Tue Jul 28 2020 Mat Booth - 4.3.1-1
- Update to latest 4.x release