9dd114d0b9
Only apr-configure-c99-6.patch is not yet upstream. Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
143 lines
3.8 KiB
Diff
143 lines
3.8 KiB
Diff
------------------------------------------------------------------------
|
|
r1906595 | jorton | 2023-01-11 10:44:46 +0100 (Wed, 11 Jan 2023) | 7 lines
|
|
|
|
Merge r1906594 from trunk:
|
|
|
|
Fix further strict C99 compliance issue. (fixes #37)
|
|
|
|
PR: 66408
|
|
Submitted by: Sam James <sam gentoo.org>
|
|
|
|
------------------------------------------------------------------------
|
|
|
|
diff --git a/build/apr_network.m4 b/build/apr_network.m4
|
|
index d330ba16f38f649f..f70431a800f2dfdd 100644
|
|
--- a/build/apr_network.m4
|
|
+++ b/build/apr_network.m4
|
|
@@ -66,6 +66,12 @@ AC_DEFUN([APR_CHECK_WORKING_GETADDRINFO], [
|
|
#ifdef HAVE_STDLIB_H
|
|
#include <stdlib.h>
|
|
#endif
|
|
+#ifdef HAVE_NETINET_IN_H
|
|
+#include <netinet/in.h>
|
|
+#endif
|
|
+#ifdef HAVE_ARPA_INET_H
|
|
+#include <arpa/inet.h>
|
|
+#endif
|
|
|
|
int main(void) {
|
|
struct addrinfo hints, *ai;
|
|
@@ -397,9 +403,11 @@ AC_DEFUN([APR_CHECK_TCP_NODELAY_INHERITED], [
|
|
AC_CACHE_CHECK(if TCP_NODELAY setting is inherited from listening sockets, ac_cv_tcp_nodelay_inherited,[
|
|
AC_TRY_RUN( [
|
|
#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
#ifdef HAVE_SYS_TYPES_H
|
|
#include <sys/types.h>
|
|
#endif
|
|
+#include <string.h>
|
|
#ifdef HAVE_SYS_SOCKET_H
|
|
#include <sys/socket.h>
|
|
#endif
|
|
@@ -749,6 +757,12 @@ AC_TRY_COMPILE([
|
|
#ifdef HAVE_ARPA_INET_H
|
|
#include <arpa/inet.h>
|
|
#endif
|
|
+#ifdef HAVE_SYS_SOCKET_H
|
|
+#include <sys/socket.h>
|
|
+#endif
|
|
+#ifdef HAVE_NETINET_IN_H
|
|
+#include <netinet/in.h>
|
|
+#endif
|
|
],[
|
|
inet_addr("127.0.0.1");
|
|
],[
|
|
@@ -769,6 +783,10 @@ fi
|
|
AC_DEFUN([APR_CHECK_INET_NETWORK], [
|
|
AC_CACHE_CHECK(for inet_network, ac_cv_func_inet_network,[
|
|
AC_TRY_COMPILE([
|
|
+#include <sys/socket.h>
|
|
+#ifdef HAVE_NETINET_IN_H
|
|
+#include <netinet/in.h>
|
|
+#endif
|
|
#ifdef HAVE_SYS_TYPES_H
|
|
#include <sys/types.h>
|
|
#endif
|
|
@@ -942,7 +960,9 @@ AC_DEFUN([APR_CHECK_MCAST], [
|
|
AC_CACHE_CHECK([for struct ip_mreq], [apr_cv_struct_ipmreq], [
|
|
AC_TRY_COMPILE([
|
|
#include <sys/types.h>
|
|
+#ifdef HAVE_NETINET_IN_H
|
|
#include <netinet/in.h>
|
|
+#endif
|
|
], [
|
|
struct ip_mreq mip;
|
|
mip.imr_interface.s_addr = INADDR_ANY;
|
|
diff --git a/configure.in b/configure.in
|
|
index 7f6352860dfe41d5..7ab8277a2782dbef 100644
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -1440,8 +1440,6 @@ AC_CHECK_FUNCS(sigaction, [ have_sigaction="1" ], [ have_sigaction="0" ])
|
|
AC_DECL_SYS_SIGLIST
|
|
|
|
AC_CHECK_FUNCS(fork, [ fork="1" ], [ fork="0" ])
|
|
-APR_CHECK_INET_ADDR
|
|
-APR_CHECK_INET_NETWORK
|
|
AC_SUBST(apr_inaddr_none)
|
|
AC_CHECK_FUNC(_getch)
|
|
AC_CHECK_FUNCS(strerror_r, [ strerror_r="1" ], [ strerror_r="0" ])
|
|
@@ -1547,6 +1545,9 @@ APR_FLAG_HEADERS(
|
|
sys/un.h \
|
|
sys/wait.h)
|
|
|
|
+APR_CHECK_INET_ADDR
|
|
+APR_CHECK_INET_NETWORK
|
|
+
|
|
# IRIX 6.5 has a problem in <netinet/tcp.h> which prevents it from
|
|
# being included by itself. Check for <netinet/tcp.h> manually,
|
|
# including another header file first.
|
|
@@ -2249,7 +2250,7 @@ AC_TRY_RUN([
|
|
#ifndef SEM_FAILED
|
|
#define SEM_FAILED (-1)
|
|
#endif
|
|
-main()
|
|
+int main()
|
|
{
|
|
sem_t *psem;
|
|
const char *sem_name = "/apr_autoconf";
|
|
@@ -2440,6 +2441,8 @@ int fd;
|
|
struct flock proc_mutex_lock_it = {0};
|
|
const char *fname = "conftest.fcntl";
|
|
|
|
+int lockit();
|
|
+
|
|
int main()
|
|
{
|
|
int rc, status;;
|
|
diff --git a/poll/os2/pollset.c b/poll/os2/pollset.c
|
|
index 2ec848105be1e1bf..87b3c1841f7e64f3 100644
|
|
--- a/poll/os2/pollset.c
|
|
+++ b/poll/os2/pollset.c
|
|
@@ -308,7 +308,7 @@ APR_DECLARE(apr_status_t) apr_pollset_wakeup(apr_pollset_t *pollset)
|
|
|
|
|
|
|
|
-APR_DECLARE(const char *) apr_poll_method_defname()
|
|
+APR_DECLARE(const char *) apr_poll_method_defname(void)
|
|
{
|
|
return "select";
|
|
}
|
|
diff --git a/poll/unix/pollset.c b/poll/unix/pollset.c
|
|
index 8fa817330f65e515..11b57365257bec54 100644
|
|
--- a/poll/unix/pollset.c
|
|
+++ b/poll/unix/pollset.c
|
|
@@ -188,7 +188,7 @@ APR_DECLARE(const char *) apr_pollset_method_name(apr_pollset_t *pollset)
|
|
return pollset->provider->name;
|
|
}
|
|
|
|
-APR_DECLARE(const char *) apr_poll_method_defname()
|
|
+APR_DECLARE(const char *) apr_poll_method_defname(void)
|
|
{
|
|
const apr_pollset_provider_t *provider = NULL;
|
|
|