re-enable RTLD_DEEPBIND (#1739287)
This commit is contained in:
parent
22052015ea
commit
b3b8f2e062
15
apr-1.7.0-deepbind.patch
Normal file
15
apr-1.7.0-deepbind.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
|
||||||
|
Conflicting e.g. libldap vs libldap_r problems still exist
|
||||||
|
inside httpd. Use RTLD_DEEPBIND by default.
|
||||||
|
|
||||||
|
--- apr-1.7.0/dso/unix/dso.c.deepbind
|
||||||
|
+++ apr-1.7.0/dso/unix/dso.c
|
||||||
|
@@ -123,7 +123,7 @@
|
||||||
|
void *os_handle = dlopen((char *)path, RTLD_NOW | RTLD_GLOBAL);
|
||||||
|
|
||||||
|
#else
|
||||||
|
- int flags = RTLD_NOW | RTLD_GLOBAL;
|
||||||
|
+ int flags = RTLD_NOW | RTLD_GLOBAL | RTLD_DEEPBIND;
|
||||||
|
void *os_handle;
|
||||||
|
#ifdef _AIX
|
||||||
|
if (strchr(path + 1, '(') && path[strlen(path) - 1] == ')')
|
7
apr.spec
7
apr.spec
@ -6,7 +6,7 @@
|
|||||||
Summary: Apache Portable Runtime library
|
Summary: Apache Portable Runtime library
|
||||||
Name: apr
|
Name: apr
|
||||||
Version: 1.7.0
|
Version: 1.7.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
# ASL 2.0: everything
|
# ASL 2.0: everything
|
||||||
# ISC: network_io/apr-1.4.6/network_io/unix/inet_?to?.c
|
# ISC: network_io/apr-1.4.6/network_io/unix/inet_?to?.c
|
||||||
# BSD with advertising: strings/apr_snprintf.c, strings/apr_fnmatch.c,
|
# BSD with advertising: strings/apr_snprintf.c, strings/apr_fnmatch.c,
|
||||||
@ -19,6 +19,7 @@ Source0: https://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
|
|||||||
Source1: apr-wrapper.h
|
Source1: apr-wrapper.h
|
||||||
Patch1: apr-1.2.2-libdir.patch
|
Patch1: apr-1.2.2-libdir.patch
|
||||||
Patch2: apr-1.2.7-pkgconf.patch
|
Patch2: apr-1.2.7-pkgconf.patch
|
||||||
|
Patch3: apr-1.7.0-deepbind.patch
|
||||||
BuildRequires: gcc, autoconf, libtool, libuuid-devel, python3
|
BuildRequires: gcc, autoconf, libtool, libuuid-devel, python3
|
||||||
# To enable SCTP support
|
# To enable SCTP support
|
||||||
BuildRequires: lksctp-tools-devel
|
BuildRequires: lksctp-tools-devel
|
||||||
@ -44,6 +45,7 @@ C data structures and routines.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .libdir
|
%patch1 -p1 -b .libdir
|
||||||
%patch2 -p1 -b .pkgconf
|
%patch2 -p1 -b .pkgconf
|
||||||
|
%patch3 -p1 -b .deepbind
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# regenerate configure script etc.
|
# regenerate configure script etc.
|
||||||
@ -121,6 +123,9 @@ popd
|
|||||||
%{_datadir}/aclocal/*.m4
|
%{_datadir}/aclocal/*.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 4 2020 Joe Orton <jorton@redhat.com> - 1.7.0-4
|
||||||
|
- re-enable RTLD_DEEPBIND (#1739287)
|
||||||
|
|
||||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-3
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user