parent
a50a63cf24
commit
b0314131c3
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ apr-1.3.9.tar.bz2
|
||||
/apr-1.5.2.tar.bz2
|
||||
/apr-1.6.2.tar.bz2
|
||||
/apr-1.6.3.tar.bz2
|
||||
/apr-1.6.5.tar.bz2
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -ur apr-1.6.3.orig/test/teststr.c apr-1.6.3/test/teststr.c
|
||||
--- apr-1.6.3.orig/test/teststr.c 2016-03-03 17:11:16.000000000 +0100
|
||||
+++ apr-1.6.3/test/teststr.c 2018-01-29 18:54:44.748931098 +0100
|
||||
@@ -307,10 +307,15 @@
|
||||
for (; off < 999999999; off += 999) {
|
||||
apr_strfsize(off, buf);
|
||||
}
|
||||
- for (off = 1; off < LONG_MAX && off > 0; off *= 2) {
|
||||
+
|
||||
+ off = 1;
|
||||
+ while (1) {
|
||||
apr_strfsize(off, buf);
|
||||
apr_strfsize(off + 1, buf);
|
||||
apr_strfsize(off - 1, buf);
|
||||
+ if (off > LONG_MAX / 2)
|
||||
+ break;
|
||||
+ off *= 2;
|
||||
}
|
||||
|
||||
ABTS_ASSERT(tc, "strfsize overflowed", buf[5] == '$');
|
9
apr.spec
9
apr.spec
@ -5,8 +5,8 @@
|
||||
|
||||
Summary: Apache Portable Runtime library
|
||||
Name: apr
|
||||
Version: 1.6.3
|
||||
Release: 9%{?dist}
|
||||
Version: 1.6.5
|
||||
Release: 1%{?dist}
|
||||
# ASL 2.0: everything
|
||||
# ISC: network_io/apr-1.4.6/network_io/unix/inet_?to?.c
|
||||
# BSD with advertising: strings/apr_snprintf.c, strings/apr_fnmatch.c,
|
||||
@ -22,7 +22,6 @@ Patch1: apr-1.6.3-r1834495.patch
|
||||
Patch2: apr-1.2.2-locktimeout.patch
|
||||
Patch3: apr-1.2.2-libdir.patch
|
||||
Patch4: apr-1.2.7-pkgconf.patch
|
||||
Patch5: apr-rh1539844.patch
|
||||
BuildRequires: gcc, autoconf, libtool, libuuid-devel, python3
|
||||
# To enable SCTP support
|
||||
BuildRequires: lksctp-tools-devel
|
||||
@ -51,7 +50,6 @@ C data structures and routines.
|
||||
%patch2 -p1 -b .locktimeout
|
||||
%patch3 -p1 -b .libdir
|
||||
%patch4 -p1 -b .pkgconf
|
||||
%patch5 -p1 -b .rh1539844
|
||||
|
||||
%build
|
||||
# regenerate configure script etc.
|
||||
@ -131,6 +129,9 @@ popd
|
||||
%{_datadir}/aclocal/*.m4
|
||||
|
||||
%changelog
|
||||
* Mon Sep 17 2018 Joe Orton <jorton@redhat.com> - 1.6.5-1
|
||||
- update to 1.6.5 (#1628934)
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.3-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (apr-1.6.3.tar.bz2) = f6b8679ae7fafff793c825c78775c84a646267c441710a50664589850e13148719b4eab48ab6e7c95b7aed085cff831115687434a7b160dcc2faa0eae63ac996
|
||||
SHA512 (apr-1.6.5.tar.bz2) = d3511e320457b5531f565813e626e7941f6b82864852db6aa03dd298a65dbccdcdc4bd580f5314f8be45d268388edab25efe88cf8340b7d2897a4dbe9d0a41fc
|
||||
|
Loading…
Reference in New Issue
Block a user