- fix build with libtool 2.2

This commit is contained in:
jorton 2009-02-04 11:41:01 +00:00
parent 14d0c2f3bb
commit 9fc74c4779
2 changed files with 39 additions and 1 deletions

33
apr-1.3.3-libtool22.patch Normal file
View File

@ -0,0 +1,33 @@
http://svn.apache.org/viewvc?rev=733052&view=rev
--- apr-1.3.3/buildconf.libtool22
+++ apr-1.3.3/buildconf
@@ -45,6 +45,14 @@ $libtoolize --copy --automake
if [ -f libtool.m4 ]; then
ltfile=`pwd`/libtool.m4
+elif grep all_pkgmacro_files $libtoolize > /dev/null; then
+ # libtool 2.x
+ aclocal_dir=`sed -n '/^aclocaldir=/{s/.*=//;p;q;}' < $libtoolize`
+ ltfiles=`sed -n '/^all_pkgmacro_files=/{s/.*=//;;s/"//;p;q;}' < $libtoolize`
+ for f in $ltfiles; do
+ test -f "$aclocal_dir/$f" && cp "$aclocal_dir/$f" build
+ done
+ ltfile=$aclocal_dir/libtool.m4
else
ltfindcmd="`sed -n \"/=[^\\\`]/p;/libtool_m4=/{s/.*=/echo /p;q;}\" \
< $libtoolize`"
--- apr-1.3.3/configure.in.libtool22
+++ apr-1.3.3/configure.in
@@ -20,6 +20,10 @@ sinclude(build/apr_win32.m4)
sinclude(build/apr_hints.m4)
sinclude(build/libtool.m4)
sinclude(build/ltsugar.m4)
+sinclude(build/argz.m4)
+sinclude(build/ltoptions.m4)
+sinclude(build/ltversion.m4)
+sinclude(build/lt~obsolete.m4)
dnl Hard-coded inclusion at the tail end of apr_private.h:
AH_BOTTOM([

View File

@ -6,7 +6,7 @@
Summary: Apache Portable Runtime library
Name: apr
Version: 1.3.3
Release: 2%{?dist}
Release: 3%{?dist}
License: ASL 2.0
Group: System Environment/Libraries
URL: http://apr.apache.org/
@ -16,6 +16,7 @@ Patch1: apr-0.9.7-deepbind.patch
Patch2: apr-1.2.2-locktimeout.patch
Patch3: apr-1.2.2-libdir.patch
Patch4: apr-1.2.7-pkgconf.patch
Patch5: apr-1.3.3-libtool22.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: autoconf, libtool, e2fsprogs-devel, python
@ -43,6 +44,7 @@ C data structures and routines.
%patch2 -p1 -b .locktimeout
%patch3 -p1 -b .libdir
%patch4 -p1 -b .pkgconf
%patch5 -p1 -b .libtool22
%build
# regenerate configure script etc.
@ -121,6 +123,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/aclocal/*.m4
%changelog
* Wed Feb 4 2009 Joe Orton <jorton@redhat.com> 1.3.3
- fix build with libtool 2.2
* Fri Jan 2 2009 Joe Orton <jorton@redhat.com> 1.3.3
- rebuild