- update to 1.2.7
- use pkg-config in apr-1-config to make it libdir-agnostic
This commit is contained in:
parent
3d244a2e8b
commit
959d65450e
@ -1,2 +1 @@
|
||||
apr-1.2.6.tar.gz
|
||||
clog
|
||||
apr-1.2.7.tar.gz
|
||||
|
36
apr-1.2.7-pkgconf.patch
Normal file
36
apr-1.2.7-pkgconf.patch
Normal file
@ -0,0 +1,36 @@
|
||||
|
||||
This is a fugly hack to make apr-1-config libdir-agnostic, by using
|
||||
pkg-config to determine the libdir setting. pkg-config will
|
||||
magically determine the appropriate libdir setting.
|
||||
|
||||
This allows apr-devel.i386 and apr-devel.x86_64 to be
|
||||
installed in parallel.
|
||||
|
||||
--- apr-1.2.7/Makefile.in.pkgconf
|
||||
+++ apr-1.2.7/Makefile.in
|
||||
@@ -60,7 +60,7 @@
|
||||
|
||||
# Create apr-config script suitable for the install tree
|
||||
apr-config.out: $(APR_CONFIG)
|
||||
- sed 's,^\(location=\).*$$,\1installed,' < $(APR_CONFIG) > $@
|
||||
+ sed 's,^\(location=\).*$$,\1installed,;s,^\(APR_.*_DIR\)=.*,\1="$${libdir}/build",' < $(APR_CONFIG) > $@
|
||||
|
||||
# Create apr_rules.mk suitable for the install tree
|
||||
build/apr_rules.out: build/apr_rules.mk
|
||||
--- apr-1.2.7/apr-config.in.pkgconf
|
||||
+++ apr-1.2.7/apr-config.in
|
||||
@@ -24,11 +24,12 @@
|
||||
prefix="@prefix@"
|
||||
exec_prefix="@exec_prefix@"
|
||||
bindir="@bindir@"
|
||||
-libdir="@libdir@"
|
||||
datadir="@datadir@"
|
||||
-installbuilddir="@installbuilddir@"
|
||||
includedir="@includedir@"
|
||||
|
||||
+libdir=`pkg-config --variable=libdir apr-@APR_MAJOR_VERSION@`
|
||||
+installbuilddir="${libdir}/build"
|
||||
+
|
||||
CC="@CC@"
|
||||
CPP="@CPP@"
|
||||
SHELL="@SHELL@"
|
22
apr.spec
22
apr.spec
@ -2,16 +2,17 @@
|
||||
|
||||
Summary: Apache Portable Runtime library
|
||||
Name: apr
|
||||
Version: 1.2.6
|
||||
Version: 1.2.7
|
||||
Release: 2
|
||||
License: Apache Software License
|
||||
Group: System Environment/Libraries
|
||||
URL: http://apr.apache.org/
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Patch1: apr-0.9.6-readdir64.patch
|
||||
Patch3: apr-0.9.7-deepbind.patch
|
||||
Patch6: apr-1.2.2-locktimeout.patch
|
||||
Patch7: apr-1.2.2-libdir.patch
|
||||
Patch2: apr-0.9.7-deepbind.patch
|
||||
Patch3: apr-1.2.2-locktimeout.patch
|
||||
Patch4: apr-1.2.2-libdir.patch
|
||||
Patch5: apr-1.2.7-pkgconf.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||
BuildPrereq: autoconf, libtool, doxygen
|
||||
Conflicts: subversion < 0.20.1-2
|
||||
@ -26,7 +27,7 @@ including Unices, MS Win32, BeOS and OS/2.
|
||||
Group: Development/Libraries
|
||||
Summary: APR library development kit
|
||||
Conflicts: subversion-devel < 0.20.1-2
|
||||
Requires: apr = %{version}-%{release}, gcc = %(gcc -dumpversion)
|
||||
Requires: apr = %{version}-%{release}, gcc = %(gcc -dumpversion), pkgconfig
|
||||
# shipped libtool hard-codes paths to gcc libraries in versioned dir
|
||||
|
||||
%description devel
|
||||
@ -38,9 +39,10 @@ C data structures and routines.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .readdir64
|
||||
%patch3 -p1 -b .deepbind
|
||||
%patch6 -p1 -b .locktimeout
|
||||
%patch7 -p1 -b .libdir
|
||||
%patch2 -p1 -b .deepbind
|
||||
%patch3 -p1 -b .locktimeout
|
||||
%patch4 -p1 -b .libdir
|
||||
%patch5 -p1 -b .pkgconf
|
||||
|
||||
%build
|
||||
# regenerate configure script etc.
|
||||
@ -112,6 +114,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/apr-%{aprver}/*.h
|
||||
|
||||
%changelog
|
||||
* Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
|
||||
- update to 1.2.7
|
||||
- use pkg-config in apr-1-config to make it libdir-agnostic
|
||||
|
||||
* Thu Apr 6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
|
||||
- update to 1.2.6
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
d36790357acd43224000a2e493d7c701 apr-1.2.6.tar.gz
|
||||
aea926cbe588f844ad9e317157d60175 apr-1.2.7.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user