- fix API/ABI of 32-bit builds (#254241)
This commit is contained in:
parent
3f36b84de2
commit
7fc85ae8a7
11
apr-1.2.9-openlfs.patch
Normal file
11
apr-1.2.9-openlfs.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- apr-1.2.9/configure.in.openlfs
|
||||
+++ apr-1.2.9/configure.in
|
||||
@@ -448,7 +448,7 @@ void main(void)
|
||||
|
||||
if (sizeof(off64_t) != 8 || sizeof(off_t) != 4)
|
||||
exit(1);
|
||||
- if ((fd = open("conftest.lfs", O_LARGEFILE|O_CREAT|O_WRONLY)) < 0)
|
||||
+ if ((fd = open("conftest.lfs", O_LARGEFILE|O_CREAT|O_WRONLY, 0600)) < 0)
|
||||
exit(2);
|
||||
if (ftruncate64(fd, off) != 0)
|
||||
ret = 3;
|
8
apr.spec
8
apr.spec
@ -6,7 +6,7 @@
|
||||
Summary: Apache Portable Runtime library
|
||||
Name: apr
|
||||
Version: 1.2.9
|
||||
Release: 2
|
||||
Release: 3
|
||||
License: ASL 2.0
|
||||
Group: System Environment/Libraries
|
||||
URL: http://apr.apache.org/
|
||||
@ -60,6 +60,7 @@ export ac_cv_search_shm_open=no
|
||||
--includedir=%{_includedir}/apr-%{aprver} \
|
||||
--with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
|
||||
--with-devrandom=/dev/urandom
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
@ -84,6 +85,8 @@ install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp \
|
||||
$RPM_BUILD_ROOT%{_libdir}/libapr-*.a
|
||||
|
||||
%check
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -111,6 +114,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/apr-%{aprver}/*.h
|
||||
|
||||
%changelog
|
||||
* Fri Aug 31 2007 Joe Orton <jorton@redhat.com> 1.2.9-3
|
||||
- fix API/ABI of 32-bit builds (#254241)
|
||||
|
||||
* Tue Aug 21 2007 Joe Orton <jorton@redhat.com> 1.2.9-2
|
||||
- fix License
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user