pull fix for apr_mcast_hops from upstream
This commit is contained in:
parent
fedb3aa5d1
commit
4c9101e0c5
43
apr-1.4.6-r1309386.patch
Normal file
43
apr-1.4.6-r1309386.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
|
||||||
|
http://svn.apache.org/viewvc?view=revision&revision=1309386
|
||||||
|
|
||||||
|
--- apr-1.4.6/network_io/unix/multicast.c
|
||||||
|
+++ apr-1.4.6/network_io/unix/multicast.c
|
||||||
|
@@ -194,7 +194,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
static apr_status_t do_mcast_opt(int type, apr_socket_t *sock,
|
||||||
|
- apr_byte_t value)
|
||||||
|
+ apr_uint32_t value)
|
||||||
|
{
|
||||||
|
apr_status_t rv = APR_SUCCESS;
|
||||||
|
|
||||||
|
@@ -205,24 +205,19 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
#if APR_HAVE_IPV6
|
||||||
|
- else if (sock_is_ipv6(sock) && type == IP_MULTICAST_LOOP) {
|
||||||
|
- unsigned int loopopt = value;
|
||||||
|
- type = IPV6_MULTICAST_LOOP;
|
||||||
|
- if (setsockopt(sock->socketdes, IPPROTO_IPV6, type,
|
||||||
|
- (const void *) &loopopt, sizeof(loopopt)) == -1) {
|
||||||
|
- rv = errno;
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
else if (sock_is_ipv6(sock)) {
|
||||||
|
if (type == IP_MULTICAST_TTL) {
|
||||||
|
type = IPV6_MULTICAST_HOPS;
|
||||||
|
}
|
||||||
|
+ else if (type == IP_MULTICAST_LOOP) {
|
||||||
|
+ type = IPV6_MULTICAST_LOOP;
|
||||||
|
+ }
|
||||||
|
else {
|
||||||
|
return APR_ENOTIMPL;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (setsockopt(sock->socketdes, IPPROTO_IPV6, type,
|
||||||
|
- &value, sizeof(value)) == -1) {
|
||||||
|
+ (const void *) &value, sizeof(value)) == -1) {
|
||||||
|
rv = errno;
|
||||||
|
}
|
||||||
|
}
|
7
apr.spec
7
apr.spec
@ -6,7 +6,7 @@
|
|||||||
Summary: Apache Portable Runtime library
|
Summary: Apache Portable Runtime library
|
||||||
Name: apr
|
Name: apr
|
||||||
Version: 1.4.6
|
Version: 1.4.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://apr.apache.org/
|
URL: http://apr.apache.org/
|
||||||
@ -15,6 +15,7 @@ Source1: apr-wrapper.h
|
|||||||
Patch2: apr-1.2.2-locktimeout.patch
|
Patch2: apr-1.2.2-locktimeout.patch
|
||||||
Patch3: apr-1.2.2-libdir.patch
|
Patch3: apr-1.2.2-libdir.patch
|
||||||
Patch4: apr-1.2.7-pkgconf.patch
|
Patch4: apr-1.2.7-pkgconf.patch
|
||||||
|
Patch5: apr-1.4.6-r1309386.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||||
BuildRequires: autoconf, libtool, libuuid-devel, python
|
BuildRequires: autoconf, libtool, libuuid-devel, python
|
||||||
# To enable SCTP support
|
# To enable SCTP support
|
||||||
@ -43,6 +44,7 @@ C data structures and routines.
|
|||||||
%patch2 -p1 -b .locktimeout
|
%patch2 -p1 -b .locktimeout
|
||||||
%patch3 -p1 -b .libdir
|
%patch3 -p1 -b .libdir
|
||||||
%patch4 -p1 -b .pkgconf
|
%patch4 -p1 -b .pkgconf
|
||||||
|
%patch5 -p1 -b .r1309386
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# regenerate configure script etc.
|
# regenerate configure script etc.
|
||||||
@ -123,6 +125,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/*.m4
|
%{_datadir}/aclocal/*.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 6 2012 Joe Orton <jorton@redhat.com> - 1.4.6-2
|
||||||
|
- pull fix for apr_mcast_hops from upstream
|
||||||
|
|
||||||
* Tue Feb 14 2012 Bojan Smojver <bojan@rexursive.com> - 1.4.6-1
|
* Tue Feb 14 2012 Bojan Smojver <bojan@rexursive.com> - 1.4.6-1
|
||||||
- bump up to 1.4.6
|
- bump up to 1.4.6
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user