- use RTLD_DEEPBIND in apr_dso_open by default
This commit is contained in:
parent
93c7b32e12
commit
2cc98bc59f
16
apr-0.9.7-deepbind.patch
Normal file
16
apr-0.9.7-deepbind.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
|
||||||
|
Use RTLD_DEEPBIND by default. Should really be done with a
|
||||||
|
new function and a caller-specified flag but that got vetoed
|
||||||
|
upstream, and DEEPBIND is a good default.
|
||||||
|
|
||||||
|
--- apr-0.9.7/dso/unix/dso.c.deepbind
|
||||||
|
+++ apr-0.9.7/dso/unix/dso.c
|
||||||
|
@@ -122,7 +122,7 @@
|
||||||
|
void *os_handle = dlopen((char *)path, RTLD_NOW | RTLD_GLOBAL);
|
||||||
|
|
||||||
|
#else
|
||||||
|
- int flags = RTLD_NOW | RTLD_GLOBAL;
|
||||||
|
+ int flags = RTLD_NOW | RTLD_GLOBAL | RTLD_DEEPBIND;
|
||||||
|
void *os_handle;
|
||||||
|
#ifdef _AIX
|
||||||
|
if (strchr(path + 1, '(') && path[strlen(path) - 1] == ')')
|
7
apr.spec
7
apr.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: Apache Portable Runtime library
|
Summary: Apache Portable Runtime library
|
||||||
Name: apr
|
Name: apr
|
||||||
Version: 0.9.7
|
Version: 0.9.7
|
||||||
Release: 2
|
Release: 3
|
||||||
License: Apache Software License
|
License: Apache Software License
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://apr.apache.org/
|
URL: http://apr.apache.org/
|
||||||
@ -17,6 +17,7 @@ Patch21: apr-0.9.4-lp64psem.patch
|
|||||||
Patch23: apr-0.9.6-readdir64.patch
|
Patch23: apr-0.9.6-readdir64.patch
|
||||||
Patch26: apr-0.9.6-tcpopts.patch
|
Patch26: apr-0.9.6-tcpopts.patch
|
||||||
Patch27: apr-0.9.6-procexit.patch
|
Patch27: apr-0.9.6-procexit.patch
|
||||||
|
Patch28: apr-0.9.7-deepbind.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||||
BuildPrereq: autoconf, libtool, doxygen
|
BuildPrereq: autoconf, libtool, doxygen
|
||||||
Conflicts: subversion < 0.20.1-2
|
Conflicts: subversion < 0.20.1-2
|
||||||
@ -51,6 +52,7 @@ C data structures and routines.
|
|||||||
%patch23 -p1 -b .readdir64
|
%patch23 -p1 -b .readdir64
|
||||||
%patch26 -p1 -b .tcpopts
|
%patch26 -p1 -b .tcpopts
|
||||||
%patch27 -p1 -b .procexit
|
%patch27 -p1 -b .procexit
|
||||||
|
%patch28 -p1 -b .deepbind
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# regenerate configure script etc.
|
# regenerate configure script etc.
|
||||||
@ -123,6 +125,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_includedir}/apr-%{aprver}/*.h
|
%{_includedir}/apr-%{aprver}/*.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
|
||||||
|
- use RTLD_DEEPBIND in apr_dso_open by default
|
||||||
|
|
||||||
* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
|
* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
|
||||||
- update to 0.9.7
|
- update to 0.9.7
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user