diff --git a/apr-1.2.7-pkgconf.patch b/apr-1.2.7-pkgconf.patch
index 42c3050..880c07c 100644
--- a/apr-1.2.7-pkgconf.patch
+++ b/apr-1.2.7-pkgconf.patch
@@ -17,9 +17,23 @@ installed in parallel.
  
  # Create apr_rules.mk suitable for the install tree
  build/apr_rules.out: build/apr_rules.mk
+--- apr-1.2.7/apr.pc.in.pkgconf
++++ apr-1.2.7/apr.pc.in
+@@ -3,9 +3,10 @@
+ libdir=@libdir@
+ APR_MAJOR_VERSION=@APR_MAJOR_VERSION@
+ includedir=@includedir@
++CPPFLAGS=@EXTRA_CPPFLAGS@
+ 
+ Name: APR
+ Description: The Apache Portable Runtime library
+ Version: @APR_DOTTED_VERSION@
+ Libs: -L${libdir} -l@APR_LIBNAME@ @EXTRA_LIBS@
+-Cflags: @EXTRA_CPPFLAGS@ @EXTRA_CFLAGS@ -I${includedir}
++Cflags: ${CPPFLAGS} @EXTRA_CFLAGS@ -I${includedir}
 --- apr-1.2.7/apr-config.in.pkgconf
 +++ apr-1.2.7/apr-config.in
-@@ -24,11 +24,12 @@
+@@ -24,15 +24,16 @@
  prefix="@prefix@"
  exec_prefix="@exec_prefix@"
  bindir="@bindir@"
@@ -34,3 +48,8 @@ installed in parallel.
  CC="@CC@"
  CPP="@CPP@"
  SHELL="@SHELL@"
+-CPPFLAGS="@EXTRA_CPPFLAGS@"
++CPPFLAGS=`pkg-config --variable=CPPFLAGS apr-@APR_MAJOR_VERSION@`
+ CFLAGS="@EXTRA_CFLAGS@"
+ LDFLAGS="@EXTRA_LDFLAGS@"
+ LIBS="@EXTRA_LIBS@"
diff --git a/apr.spec b/apr.spec
index 586cee9..d2b88f2 100644
--- a/apr.spec
+++ b/apr.spec
@@ -6,7 +6,7 @@
 Summary: Apache Portable Runtime library
 Name: apr
 Version: 1.2.7
-Release: 6
+Release: 7
 License: Apache Software License
 Group: System Environment/Libraries
 URL: http://apr.apache.org/
@@ -126,6 +126,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/apr-%{aprver}/*.h
 
 %changelog
+* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
+- fix another multilib conflict (#192659)
+
 * Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
 - BR e2fsprogs-devel for libuuid