diff --git a/apache-commons-parent-remove-build-plugin.patch b/apache-commons-parent-remove-build-plugin.patch
deleted file mode 100644
index 18b2350..0000000
--- a/apache-commons-parent-remove-build-plugin.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- pom.xml 2012-10-19 23:01:18.419198466 +0200
-+++ pom.xml 2012-10-19 23:01:52.119423986 +0200
-@@ -332,8 +331,0 @@
-- org.apache.commons
-- commons-build-plugin
-- 1.4
--
-- ${commons.release.name}
--
--
--
-@@ -429,4 +420,0 @@
-- org.apache.commons
-- commons-build-plugin
--
--
-@@ -1144,11 +1131,0 @@
--
--
-- ${project.artifactId}-${commons.release.version}
--
-- -bin
-- ${project.artifactId}-${commons.release.2.version}
--
-- -bin
-- ${project.artifactId}-${commons.release.3.version}
--
-- -bin
diff --git a/apache-commons-parent.spec b/apache-commons-parent.spec
index 9313c5e..96359a1 100644
--- a/apache-commons-parent.spec
+++ b/apache-commons-parent.spec
@@ -1,9 +1,8 @@
-%global base_name parent
-%global short_name commons-%{base_name}
+%global short_name commons-parent
Name: apache-%{short_name}
Version: 26
-Release: 6%{?dist}
+Release: 7%{?dist}
Summary: Apache Commons Parent Pom
Group: Development/Libraries
License: ASL 2.0
@@ -13,55 +12,39 @@ URL: http://svn.apache.org/repos/asf/commons/proper/%{short_name}/t
# tar caf commons-parent-26.tar.xz commons-parent-26
Source0: %{short_name}-%{version}.tar.xz
-#common-build-plugin not in fedora yet
-Patch1: %{name}-remove-build-plugin.patch
BuildArch: noarch
BuildRequires: maven-local
BuildRequires: java-devel
-
BuildRequires: mvn(org.apache:apache)
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
-BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
-BuildRequires: mvn(org.apache.maven.plugins:maven-compiler-plugin)
-BuildRequires: mvn(org.apache.maven.plugins:maven-jar-plugin)
-BuildRequires: mvn(org.apache.maven.plugins:maven-surefire-plugin)
BuildRequires: mvn(org.apache.rat:apache-rat-plugin)
BuildRequires: mvn(org.codehaus.mojo:buildnumber-maven-plugin)
-
-Requires: mvn(org.apache:apache)
-Requires: mvn(org.apache.felix:maven-bundle-plugin)
-Requires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
-Requires: mvn(org.apache.maven.plugins:maven-compiler-plugin)
-Requires: mvn(org.apache.maven.plugins:maven-jar-plugin)
-Requires: mvn(org.apache.maven.plugins:maven-surefire-plugin)
-Requires: mvn(org.apache.rat:apache-rat-plugin)
Requires: mvn(org.codehaus.mojo:buildnumber-maven-plugin)
-
%description
The Project Object Model files for the apache-commons packages.
%prep
%setup -q -n %{short_name}-%{version}
-%patch1 -p0
+
+# Plugin is not in fedora
+%pom_remove_plugin org.apache.commons:commons-build-plugin
%build
-mvn-rpmbuild install
+%mvn_build
%install
-# poms
-install -d -m 755 %{buildroot}%{_mavenpomdir}
-install -pm 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{short_name}.pom
+%mvn_install
-%add_maven_depmap JPP-%{short_name}.pom
-
-%files
-%doc LICENSE.txt NOTICE.txt
-%{_mavenpomdir}/*
-%{_mavendepmapfragdir}/*
+%files -f .mfiles
+%doc LICENSE.txt NOTICE.txt RELEASE-NOTES.txt
%changelog
+* Tue Aug 06 2013 Mat Booth - 26-7
+- Use pom macros instead of patching
+- Update spec for latest guidelines
+
* Sat Aug 03 2013 Fedora Release Engineering - 26-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild