Initial import (#589168).

This commit is contained in:
Stanislav Ochotnicky 2010-05-07 07:10:04 +00:00
parent 4c9e2ff63f
commit b2b4590a50
6 changed files with 213 additions and 0 deletions

View File

@ -0,0 +1 @@
commons-logging-1.1.1-src.tar.gz

151
apache-commons-logging.spec Normal file
View File

@ -0,0 +1,151 @@
%global base_name logging
%global short_name commons-%{base_name}
%global section free
Name: apache-%{short_name}
Version: 1.1.1
Release: 3%{?dist}
Summary: Apache Commons Logging
License: ASL 2.0
Group: Development/Libraries
URL: http://commons.apache.org/%{base_name}
Source0: http://www.apache.org/dist/commons/%{base_name}/source/%{short_name}-%{version}-src.tar.gz
Source1: %{short_name}.depmap
Patch0: %{short_name}-maven-release-plugin.patch
BuildArch: noarch
BuildRequires: java-devel >= 1:1.6.0
BuildRequires: jpackage-utils >= 0:1.6
BuildRequires: avalon-framework
BuildRequires: avalon-logkit
BuildRequires: maven-doxia-sitetools
BuildRequires: maven-plugin-build-helper
BuildRequires: maven-plugin-bundle
BuildRequires: maven-surefire-maven-plugin
BuildRequires: maven2-plugin-antrun
BuildRequires: maven2-plugin-assembly
BuildRequires: maven2-plugin-compiler
BuildRequires: maven2-plugin-install
BuildRequires: maven2-plugin-idea
BuildRequires: maven2-plugin-jar
BuildRequires: maven2-plugin-javadoc
BuildRequires: maven2-plugin-resources
BuildRequires: maven2-plugin-site
# this will go away after we update maven to use tomcat6
BuildRequires: tomcat5
Requires: java >= 1:1.6.0
Requires: jpackage-utils >= 0:1.6
Requires(post): jpackage-utils
Requires(postun):jpackage-utils
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
Provides: jakarta-commons-logging = 0:1.0.4
Obsoletes: jakarta-commons-logging <= 0:1.0.4
%description
The commons-logging package provides a simple, component oriented
interface (org.apache.commons.logging.Log) together with wrappers for
logging systems. The user can choose at runtime which system they want
to use. In addition, a small number of basic implementations are
provided to allow users to use the package standalone.
commons-logging was heavily influenced by Avalon's Logkit and Log4J. The
commons-logging abstraction is meant to minimize the differences between
the two, and to allow a developer to not tie himself to a particular
logging implementation.
%package javadoc
Summary: API documentation for %{name}
Group: Documentation
%description javadoc
Javadoc for %{name}.
# -----------------------------------------------------------------------------
%prep
%setup -q -n %{short_name}-%{version}-src
%patch0 -p1 -b .rhbug_588142
sed -i 's/\r//' RELEASE-NOTES.txt LICENSE.txt
# -----------------------------------------------------------------------------
%build
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
mkdir -p $MAVEN_REPO_LOCAL
# TODO remove test.skip=true once maven is updated
mvn-jpp -Dmaven2.jpp.depmap.file="%{SOURCE1}" \
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
-Dmaven.test.skip=true \
install javadoc:javadoc
# -----------------------------------------------------------------------------
%install
rm -rf $RPM_BUILD_ROOT
# jars
install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
install -p -m 644 target/%{short_name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
install -p -m 644 target/%{short_name}-api-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-api-%{version}.jar
install -p -m 644 target/%{short_name}-adapters-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-adapters-%{version}.jar
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|apache-||g"`; done)
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{short_name}.pom
%add_to_maven_depmap org.apache.maven %{name} %{version} JPP %{name}
# javadoc
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
ln -sf %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
# -----------------------------------------------------------------------------
%clean
rm -rf $RPM_BUILD_ROOT
# -----------------------------------------------------------------------------
%post
%update_maven_depmap
%postun
%update_maven_depmap
# -----------------------------------------------------------------------------
%files
%defattr(-,root,root,-)
%doc PROPOSAL.html STATUS.html LICENSE.txt RELEASE-NOTES.txt
%{_javadir}/*
%{_mavenpomdir}/JPP-%{short_name}.pom
%{_mavendepmapfragdir}/*
%files javadoc
%defattr(-,root,root,-)
%{_javadocdir}/%{name}*
# -----------------------------------------------------------------------------
%changelog
* Thu May 6 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-3
- Revert to using default permissions
- Drop "Package" from summary, improve javadoc summary text
* Thu May 6 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-2
- Fix EOLs on docs
- Create javadoc symlinks during install
- Use version macro in Source0 URL, use _mavenpomdir macro
* Thu May 6 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-1
- Rename and rebase from jakarta-commons-logging

View File

@ -0,0 +1,33 @@
diff --git a/pom.xml b/pom.xml
index 8efaf6d..4b3e8f9 100644
--- a/pom.xml
+++ b/pom.xml
@@ -308,21 +308,6 @@ under the License.
</plugin>
<plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-release-plugin</artifactId>
- <version>2.0-beta-6</version>
- <configuration>
- <!--
- - The site needs to be built prior to deploy,
- - because it is included in the assembly.
- -->
- <goals>site deploy</goals>
- <!-- Pass these arguments to the deploy plugin. -->
- <arguments>-Prelease</arguments>
- </configuration>
- </plugin>
-
- <plugin>
<!--
- Many of JCL's tests use tricky techniques to place the generated
- JCL jarfiles on the classpath in various configurations. This means
@@ -520,4 +505,4 @@ under the License.
<maven.compile.source>1.2</maven.compile.source>
<maven.compile.target>1.1</maven.compile.target>
</properties>
-</project>
\ No newline at end of file
+</project>

26
commons-logging.depmap Normal file
View File

@ -0,0 +1,26 @@
<dependencies>
<dependency>
<maven>
<groupId>logkit</groupId>
<artifactId>logkit</artifactId>
<version>1.0.1</version>
</maven>
<jpp>
<groupId>JPP</groupId>
<artifactId>avalon-logkit</artifactId>
<version>1.0.8</version>
</jpp>
</dependency>
<dependency>
<maven>
<groupId>avalon-framework</groupId>
<artifactId>avalon-framework</artifactId>
<version>4.1.3</version>
</maven>
<jpp>
<groupId>JPP</groupId>
<artifactId>avalon-framework</artifactId>
<version>4.1.4</version>
</jpp>
</dependency>
</dependencies>

1
import.log Normal file
View File

@ -0,0 +1 @@
apache-commons-logging-1_1_1-3_fc12:HEAD:apache-commons-logging-1.1.1-3.fc12.src.rpm:1273216139

View File

@ -0,0 +1 @@
e5cfa8cca13152d7545fde6b1783c60a commons-logging-1.1.1-src.tar.gz