Initial import from Fedora
Resolves: rhbz#2083112
This commit is contained in:
parent
69c5cec718
commit
6612e66d92
4
.gitignore
vendored
4
.gitignore
vendored
@ -0,0 +1,4 @@
|
||||
commons-logging-1.1.1-src.tar.gz
|
||||
/commons-logging-1.1.2-src.tar.gz
|
||||
/commons-logging-1.1.3-src.tar.gz
|
||||
/commons-logging-1.2-src.tar.gz
|
@ -0,0 +1,99 @@
|
||||
From d71aa7acc93b944b159ac63f85d9ba1a566f5a8d Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Tue, 29 Jul 2014 09:00:03 +0200
|
||||
Subject: [PATCH 1/2] Generate different Bundle-SymbolicName for different JARs
|
||||
|
||||
---
|
||||
pom.xml | 55 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 55 insertions(+)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index cdad31c..5707595 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -179,6 +179,52 @@ under the License.
|
||||
<build>
|
||||
<plugins>
|
||||
|
||||
+ <plugin>
|
||||
+ <groupId>org.apache.felix</groupId>
|
||||
+ <artifactId>maven-bundle-plugin</artifactId>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>tests-bundle-manifest</id>
|
||||
+ <phase>process-classes</phase>
|
||||
+ <goals>
|
||||
+ <goal>manifest</goal>
|
||||
+ </goals>
|
||||
+ <configuration>
|
||||
+ <manifestLocation>${project.build.directory}/osgi-tests</manifestLocation>
|
||||
+ <instructions>
|
||||
+ <Bundle-SymbolicName>${commons.osgi.symbolicName}.tests</Bundle-SymbolicName>
|
||||
+ </instructions>
|
||||
+ </configuration>
|
||||
+ </execution>
|
||||
+ <execution>
|
||||
+ <id>api-bundle-manifest</id>
|
||||
+ <phase>process-classes</phase>
|
||||
+ <goals>
|
||||
+ <goal>manifest</goal>
|
||||
+ </goals>
|
||||
+ <configuration>
|
||||
+ <manifestLocation>${project.build.directory}/osgi-api</manifestLocation>
|
||||
+ <instructions>
|
||||
+ <Bundle-SymbolicName>${commons.osgi.symbolicName}.api</Bundle-SymbolicName>
|
||||
+ </instructions>
|
||||
+ </configuration>
|
||||
+ </execution>
|
||||
+ <execution>
|
||||
+ <id>adapters-bundle-manifest</id>
|
||||
+ <phase>process-classes</phase>
|
||||
+ <goals>
|
||||
+ <goal>manifest</goal>
|
||||
+ </goals>
|
||||
+ <configuration>
|
||||
+ <manifestLocation>${project.build.directory}/osgi-adapters</manifestLocation>
|
||||
+ <instructions>
|
||||
+ <Bundle-SymbolicName>${commons.osgi.symbolicName}.adapters</Bundle-SymbolicName>
|
||||
+ </instructions>
|
||||
+ </configuration>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ </plugin>
|
||||
+
|
||||
<!--
|
||||
- We want to create four jarfiles from this project: normal, tests, api
|
||||
- and adapters. The first two are handled by the normal jar:jar and
|
||||
@@ -202,6 +248,9 @@ under the License.
|
||||
</goals>
|
||||
<configuration>
|
||||
<jarName>commons-logging</jarName>
|
||||
+ <archive>
|
||||
+ <manifestFile>${project.build.directory}/osgi-tests/MANIFEST.MF</manifestFile>
|
||||
+ </archive>
|
||||
</configuration>
|
||||
</execution>
|
||||
|
||||
@@ -213,6 +262,9 @@ under the License.
|
||||
</goals>
|
||||
<configuration>
|
||||
<jarName>${project.artifactId}-api-${project.version}</jarName>
|
||||
+ <archive>
|
||||
+ <manifestFile>${project.build.directory}/osgi-api/MANIFEST.MF</manifestFile>
|
||||
+ </archive>
|
||||
<includes>
|
||||
<include>org/apache/commons/logging/*.class</include>
|
||||
<include>org/apache/commons/logging/impl/LogFactoryImpl*.class</include>
|
||||
@@ -237,6 +289,9 @@ under the License.
|
||||
</goals>
|
||||
<configuration>
|
||||
<jarName>${project.artifactId}-adapters-${project.version}</jarName>
|
||||
+ <archive>
|
||||
+ <manifestFile>${project.build.directory}/osgi-adapters/MANIFEST.MF</manifestFile>
|
||||
+ </archive>
|
||||
<includes>
|
||||
<include>org/apache/commons/logging/impl/**.class</include>
|
||||
<include>META-INF/LICENSE.txt</include>
|
||||
--
|
||||
2.5.5
|
||||
|
160
0002-Port-to-maven-jar-plugin-3.0.0.patch
Normal file
160
0002-Port-to-maven-jar-plugin-3.0.0.patch
Normal file
@ -0,0 +1,160 @@
|
||||
From d8356a58efde0808cabede14b4f1b2473fa73170 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Tue, 31 May 2016 10:52:12 +0200
|
||||
Subject: [PATCH 2/2] Port to maven-jar-plugin 3.0.0
|
||||
|
||||
---
|
||||
pom.xml | 47 +++++-----------------
|
||||
.../logging/pathable/ChildFirstTestCase.java | 8 ++--
|
||||
.../logging/pathable/ParentFirstTestCase.java | 8 ++--
|
||||
3 files changed, 17 insertions(+), 46 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 5707595..c5d8d37 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -237,6 +237,10 @@ under the License.
|
||||
<artifactId>maven-jar-plugin</artifactId>
|
||||
<executions>
|
||||
<execution>
|
||||
+ <id>default-jar</id>
|
||||
+ <phase>skip</phase>
|
||||
+ </execution>
|
||||
+ <execution>
|
||||
<!--
|
||||
- The custom test framework requires the unit test code to be
|
||||
- in a jarfile so it can control its place in the classpath.
|
||||
@@ -261,7 +265,7 @@ under the License.
|
||||
<goal>jar</goal>
|
||||
</goals>
|
||||
<configuration>
|
||||
- <jarName>${project.artifactId}-api-${project.version}</jarName>
|
||||
+ <classifier>api</classifier>
|
||||
<archive>
|
||||
<manifestFile>${project.build.directory}/osgi-api/MANIFEST.MF</manifestFile>
|
||||
</archive>
|
||||
@@ -288,7 +292,7 @@ under the License.
|
||||
<goal>jar</goal>
|
||||
</goals>
|
||||
<configuration>
|
||||
- <jarName>${project.artifactId}-adapters-${project.version}</jarName>
|
||||
+ <classifier>adapters</classifier>
|
||||
<archive>
|
||||
<manifestFile>${project.build.directory}/osgi-adapters/MANIFEST.MF</manifestFile>
|
||||
</archive>
|
||||
@@ -346,39 +350,6 @@ under the License.
|
||||
|
||||
<plugin>
|
||||
<!--
|
||||
- - Attach the adapters and api jars to the normal artifact. This way
|
||||
- - they will be deployed when the normal artifact is deployed.
|
||||
- -->
|
||||
- <groupId>org.codehaus.mojo</groupId>
|
||||
- <artifactId>build-helper-maven-plugin</artifactId>
|
||||
- <version>1.0</version>
|
||||
- <executions>
|
||||
- <execution>
|
||||
- <id>attach-artifacts</id>
|
||||
- <phase>package</phase>
|
||||
- <goals>
|
||||
- <goal>attach-artifact</goal>
|
||||
- </goals>
|
||||
- <configuration>
|
||||
- <artifacts>
|
||||
- <artifact>
|
||||
- <file>${project.build.directory}/${project.artifactId}-adapters-${project.version}.jar</file>
|
||||
- <type>jar</type>
|
||||
- <classifier>adapters</classifier>
|
||||
- </artifact>
|
||||
- <artifact>
|
||||
- <file>${project.build.directory}/${project.artifactId}-api-${project.version}.jar</file>
|
||||
- <type>jar</type>
|
||||
- <classifier>api</classifier>
|
||||
- </artifact>
|
||||
- </artifacts>
|
||||
- </configuration>
|
||||
- </execution>
|
||||
- </executions>
|
||||
- </plugin>
|
||||
-
|
||||
- <plugin>
|
||||
- <!--
|
||||
- Many of JCL's tests use tricky techniques to place the generated
|
||||
- JCL jarfiles on the classpath in various configurations. This means
|
||||
- that those tests must be run *after* the "package" build phase.
|
||||
@@ -442,9 +413,9 @@ under the License.
|
||||
<logkit>${logkit:logkit:jar}</logkit>
|
||||
<servlet-api>${javax.servlet:servlet-api:jar}</servlet-api>
|
||||
<commons-logging>target/${project.build.finalName}.jar</commons-logging>
|
||||
- <commons-logging-api>target/${project.artifactId}-api-${project.version}.jar</commons-logging-api>
|
||||
- <commons-logging-adapters>target/${project.artifactId}-adapters-${project.version}.jar</commons-logging-adapters>
|
||||
- <testclasses>target/commons-logging-tests.jar</testclasses>
|
||||
+ <commons-logging-api>target/${project.artifactId}-${project.version}-api.jar</commons-logging-api>
|
||||
+ <commons-logging-adapters>target/${project.artifactId}-${project.version}-adapters.jar</commons-logging-adapters>
|
||||
+ <testclasses>target/commons-logging-${project.version}-tests.jar</testclasses>
|
||||
</systemPropertyVariables>
|
||||
</configuration>
|
||||
</execution>
|
||||
diff --git a/src/test/java/org/apache/commons/logging/pathable/ChildFirstTestCase.java b/src/test/java/org/apache/commons/logging/pathable/ChildFirstTestCase.java
|
||||
index 1aeb12d..eb67ec1 100644
|
||||
--- a/src/test/java/org/apache/commons/logging/pathable/ChildFirstTestCase.java
|
||||
+++ b/src/test/java/org/apache/commons/logging/pathable/ChildFirstTestCase.java
|
||||
@@ -213,11 +213,11 @@ public class ChildFirstTestCase extends TestCase {
|
||||
// getResource where it is accessable to both classloaders. The one visible
|
||||
// to the child should be returned. The URL returned will be of form
|
||||
// jar:file:/x/y.jar!path/to/resource. The filename part should include the jarname
|
||||
- // of form commons-logging-adapters-nnnn.jar, not commons-logging-nnnn.jar
|
||||
+ // of form commons-logging-nnnn-adapters.jar, not commons-logging-nnnn.jar
|
||||
resource = childLoader.getResource("org/apache/commons/logging/impl/Log4JLogger.class");
|
||||
assertNotNull("Unable to locate Log4JLogger.class resource", resource);
|
||||
assertTrue("Incorrect source for Log4JLogger class",
|
||||
- resource.toString().indexOf("/commons-logging-adapters-1.") > 0);
|
||||
+ resource.toString().indexOf("/commons-logging-1.2-adapters.jar!") > 0);
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -269,9 +269,9 @@ public class ChildFirstTestCase extends TestCase {
|
||||
urlsToStrings[1] = urls[1].toString();
|
||||
Arrays.sort(urlsToStrings);
|
||||
assertTrue("Incorrect source for Log4JLogger class",
|
||||
- urlsToStrings[0].indexOf("/commons-logging-1.") > 0);
|
||||
+ urlsToStrings[0].indexOf("/commons-logging-1.2-adapters.jar!") > 0);
|
||||
assertTrue("Incorrect source for Log4JLogger class",
|
||||
- urlsToStrings[1].indexOf("/commons-logging-adapters-1.") > 0);
|
||||
+ urlsToStrings[1].indexOf("/commons-logging-1.2.jar!") > 0);
|
||||
}
|
||||
|
||||
/**
|
||||
diff --git a/src/test/java/org/apache/commons/logging/pathable/ParentFirstTestCase.java b/src/test/java/org/apache/commons/logging/pathable/ParentFirstTestCase.java
|
||||
index f9bf452..fc10c8e 100644
|
||||
--- a/src/test/java/org/apache/commons/logging/pathable/ParentFirstTestCase.java
|
||||
+++ b/src/test/java/org/apache/commons/logging/pathable/ParentFirstTestCase.java
|
||||
@@ -210,11 +210,11 @@ public class ParentFirstTestCase extends TestCase {
|
||||
// getResource where it is accessable to both classloaders. The one visible
|
||||
// to the parent should be returned. The URL returned will be of form
|
||||
// jar:file:/x/y.jar!path/to/resource. The filename part should include the jarname
|
||||
- // of form commons-logging-nnnn.jar, not commons-logging-adapters-nnnn.jar
|
||||
+ // of form commons-logging-nnnn.jar, not commons-logging-nnnn-adapters.jar
|
||||
resource = childLoader.getResource("org/apache/commons/logging/impl/Log4JLogger.class");
|
||||
assertNotNull("Unable to locate Log4JLogger.class resource", resource);
|
||||
assertTrue("Incorrect source for Log4JLogger class",
|
||||
- resource.toString().indexOf("/commons-logging-1.") > 0);
|
||||
+ resource.toString().indexOf("/commons-logging-1.2.jar!") > 0);
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -259,9 +259,9 @@ public class ParentFirstTestCase extends TestCase {
|
||||
urlsToStrings[1] = urls[1].toString();
|
||||
Arrays.sort(urlsToStrings);
|
||||
assertTrue("Incorrect source for Log4JLogger class",
|
||||
- urlsToStrings[0].indexOf("/commons-logging-1.") > 0);
|
||||
+ urlsToStrings[0].indexOf("/commons-logging-1.2-adapters.jar!") > 0);
|
||||
assertTrue("Incorrect source for Log4JLogger class",
|
||||
- urlsToStrings[1].indexOf("/commons-logging-adapters-1.") > 0);
|
||||
+ urlsToStrings[1].indexOf("/commons-logging-1.2.jar!") > 0);
|
||||
|
||||
}
|
||||
|
||||
--
|
||||
2.5.5
|
||||
|
320
apache-commons-logging.spec
Normal file
320
apache-commons-logging.spec
Normal file
@ -0,0 +1,320 @@
|
||||
%bcond_with bootstrap
|
||||
|
||||
Name: apache-commons-logging
|
||||
Version: 1.2
|
||||
Release: 31%{?dist}
|
||||
Summary: Apache Commons Logging
|
||||
License: ASL 2.0
|
||||
URL: http://commons.apache.org/logging
|
||||
BuildArch: noarch
|
||||
ExclusiveArch: %{java_arches} noarch
|
||||
|
||||
Source0: http://www.apache.org/dist/commons/logging/source/commons-logging-%{version}-src.tar.gz
|
||||
Source2: http://mirrors.ibiblio.org/pub/mirrors/maven2/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.pom
|
||||
|
||||
Patch0: 0001-Generate-different-Bundle-SymbolicName-for-different.patch
|
||||
Patch1: 0002-Port-to-maven-jar-plugin-3.0.0.patch
|
||||
|
||||
%if %{with bootstrap}
|
||||
BuildRequires: javapackages-bootstrap
|
||||
%else
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(javax.servlet:servlet-api)
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(org.apache.commons:commons-parent:pom:)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-failsafe-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-dependency-plugin)
|
||||
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||
%endif
|
||||
|
||||
%description
|
||||
The commons-logging package provides a simple, component oriented
|
||||
interface (org.apache.commons.logging.Log) together with wrappers for
|
||||
logging systems. The user can choose at runtime which system they want
|
||||
to use. In addition, a small number of basic implementations are
|
||||
provided to allow users to use the package standalone.
|
||||
commons-logging was heavily influenced by Avalon's Logkit and Log4J. The
|
||||
commons-logging abstraction is meant to minimize the differences between
|
||||
the two, and to allow a developer to not tie himself to a particular
|
||||
logging implementation.
|
||||
|
||||
%{?javadoc_package}
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n commons-logging-%{version}-src
|
||||
|
||||
%pom_remove_dep -r :avalon-framework
|
||||
%pom_remove_dep -r :logkit
|
||||
%pom_remove_dep -r :log4j
|
||||
rm src/main/java/org/apache/commons/logging/impl/AvalonLogger.java
|
||||
rm src/main/java/org/apache/commons/logging/impl/Log4JLogger.java
|
||||
rm src/main/java/org/apache/commons/logging/impl/LogKitLogger.java
|
||||
rm -r src/test/java/org/apache/commons/logging/{avalon,log4j,logkit}
|
||||
rm src/test/java/org/apache/commons/logging/pathable/{Parent,Child}FirstTestCase.java
|
||||
|
||||
|
||||
# Avoid hard-coded versions in OSGi metadata
|
||||
%pom_xpath_set "pom:properties/pom:commons.osgi.import" '*;resolution:=optional'
|
||||
|
||||
%pom_remove_plugin :cobertura-maven-plugin
|
||||
%pom_remove_plugin :maven-scm-publish-plugin
|
||||
|
||||
sed -i 's/\r//' RELEASE-NOTES.txt LICENSE.txt NOTICE.txt
|
||||
|
||||
# for compatibility reasons
|
||||
%mvn_file ":commons-logging{*}" "commons-logging@1" "%{name}@1"
|
||||
%mvn_alias ":commons-logging{*}" "org.apache.commons:commons-logging@1" "apache:commons-logging@1"
|
||||
|
||||
# Remove log4j12 tests
|
||||
rm -rf src/test/java/org/apache/commons/logging/log4j/log4j12
|
||||
|
||||
%build
|
||||
%mvn_build -- -Dmaven.compiler.source=1.7 -Dmaven.compiler.target=1.7 -Dcommons.osgi.symbolicName=org.apache.commons.logging
|
||||
|
||||
# The build produces more artifacts from one pom
|
||||
%mvn_artifact %{SOURCE2} target/commons-logging-%{version}-api.jar
|
||||
%mvn_artifact commons-logging:commons-logging-adapters:%{version} target/commons-logging-%{version}-adapters.jar
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%license LICENSE.txt NOTICE.txt
|
||||
%doc PROPOSAL.html RELEASE-NOTES.txt
|
||||
|
||||
%changelog
|
||||
* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-31
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sat Feb 05 2022 Jiri Vanek <jvanek@redhat.com> - 1.2-30
|
||||
- Rebuilt for java-17-openjdk as system jdk
|
||||
|
||||
* Wed Jan 19 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-29
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Tue Nov 02 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-28
|
||||
- Bump Java compiler source/target levels to 1.7
|
||||
|
||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon May 17 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-26
|
||||
- Bootstrap build
|
||||
- Non-bootstrap build
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Thu Sep 10 2020 Mat Booth <mat.booth@redhat.com> - 1.2-24
|
||||
- Build against log4j 2
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jul 10 2020 Jiri Vanek <jvanek@redhat.com> - 1.2-22
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Thu Jun 04 2020 Fabio Valentini <decathorpe@gmail.com> - 1.2-21
|
||||
- Override javac source and target versions to fix builds with Java 11.
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Nov 09 2019 Fabio Valentini <decathorpe@gmail.com> - 1.2-19
|
||||
- Disable avalon support by default.
|
||||
|
||||
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-15
|
||||
- Mass rebuild for javapackages-tools 201902
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-14
|
||||
- Mass rebuild for javapackages-tools 201901
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Dec 18 2018 Mat Booth <mat.booth@redhat.com> - 1.2-16
|
||||
- Fix OSGi metadata
|
||||
|
||||
* Mon Dec 17 2018 Mat Booth <mat.booth@redhat.com> - 1.2-15
|
||||
- Rebuild to regenerate requires, fixes rhbz#1660117
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Jan 29 2018 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-12
|
||||
- Cleanup spec file
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Mar 22 2017 Michael Simacek <msimacek@redhat.com> - 1.2-10
|
||||
- Avoid %%add_maven_depmap
|
||||
|
||||
* Mon Feb 13 2017 Michael Simacek <msimacek@redhat.com> - 1.2-9
|
||||
- Fix conditional
|
||||
|
||||
* Fri Feb 10 2017 Michael Simacek <msimacek@redhat.com> - 1.2-8
|
||||
- Use log4j12
|
||||
- Add avalon conditional
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue May 31 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-6
|
||||
- Port to maven-jar-plugin 3.0.0
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Mon Mar 9 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-3
|
||||
- Add aliases for apache groupId
|
||||
|
||||
* Tue Jul 29 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-2
|
||||
- Generate different Bundle-SymbolicName for different JARs
|
||||
- Resolves: rhbz#1123055
|
||||
|
||||
* Sun Jul 20 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-1
|
||||
- Update to upstream version 1.2
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue May 13 2014 Michael Simacek <msimacek@redhat.com> - 1.1.3-12
|
||||
- Disable tests that use log4j12
|
||||
|
||||
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.3-11
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Thu Feb 20 2014 Michael Simacek <msimacek@redhat.com> - 1.1.3-10
|
||||
- Set logkit dependency scope to provided
|
||||
|
||||
* Thu Feb 20 2014 Michael Simacek <msimacek@redhat.com> - 1.1.3-9
|
||||
- Set avalon dependency scope to provided
|
||||
|
||||
* Wed Jan 22 2014 Michal Srb <msrb@redhat.com> - 1.1.3-8
|
||||
- Run all the tests agains
|
||||
|
||||
* Sun Aug 11 2013 Michal Srb <msrb@redhat.com> - 1.1.3-7
|
||||
- Make this package noarch again (Resolves: rhbz#995756)
|
||||
|
||||
* Tue Aug 06 2013 Michal Srb <msrb@redhat.com> - 1.1.3-6
|
||||
- Temporarily remove test which fails in koji
|
||||
|
||||
* Mon Aug 05 2013 Michal Srb <msrb@redhat.com> - 1.1.3-5
|
||||
- Add missing BR: maven-dependency-plugin, build-helper-maven-plugin
|
||||
|
||||
* Mon Aug 05 2013 Michal Srb <msrb@redhat.com> - 1.1.3-4
|
||||
- Add missing BR: maven-failsafe-plugin
|
||||
|
||||
* Mon Aug 05 2013 Michal Srb <msrb@redhat.com> - 1.1.3-3
|
||||
- Adapt to current guidelines
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue May 21 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.3-1
|
||||
- Update to upstream version 1.1.3
|
||||
- Remove OSGi Bundle-SymbolicName patch (accepted upstream)
|
||||
|
||||
* Tue Apr 9 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.2-2
|
||||
- Set OSGi Bundle-SymbolicName to org.apache.commons.logging
|
||||
- Resolves: rhbz#949842
|
||||
|
||||
* Mon Apr 8 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.2-1
|
||||
- Update to upstream version 1.1.2
|
||||
- Convert POM to POM macros
|
||||
- Remove OSGi manifest patch; fixed upstream
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 1.1.1-22
|
||||
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||
- Replace maven BuildRequires with maven-local
|
||||
|
||||
* Thu Nov 22 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.1-21
|
||||
- Install NOTICE file
|
||||
- Resolves: rhbz#879581
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue May 1 2012 Alexander Kurtakov <akurtako@redhat.com> 1.1.1-19
|
||||
- Bring back jakarta-commons-logging provides/obsoletes - the comment was misleading.
|
||||
|
||||
* Mon Apr 30 2012 Alexander Kurtakov <akurtako@redhat.com> 1.1.1-18
|
||||
- Fix build with latest libs.
|
||||
- Adapt to current guidelines.
|
||||
|
||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Apr 21 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-16
|
||||
- Build with maven 3
|
||||
- Fix build for avalon-framework
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Dec 16 2010 Alexander Kurtakov <akurtako@redhat.com> 1.1.1-14
|
||||
- Bring back commons-logging* symlinks.
|
||||
|
||||
* Thu Dec 16 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-13
|
||||
- Replace tomcat6 BR with servlet25 only
|
||||
- Cleanups according to new packaging guidelines
|
||||
- Install maven metadata for -api jar
|
||||
- Versionless jars/javadocs
|
||||
|
||||
* Tue Nov 9 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-12
|
||||
- Add depmaps for api and adapters subpackages
|
||||
- Use apache-commons-parent BR instead of maven-*
|
||||
- Replace tomcat5 BR with tomcat6
|
||||
- Reenable tests
|
||||
|
||||
* Thu Jul 8 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-11
|
||||
- Add license to javadoc subpackage
|
||||
|
||||
* Wed Jun 9 2010 Alexander Kurtakov <akurtako@redhat.com> 1.1.1-10
|
||||
- Add osgi manifest entries.
|
||||
|
||||
* Fri May 21 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-9
|
||||
- Correct depmap filename for backward compatibility
|
||||
|
||||
* Mon May 17 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-8
|
||||
- Fix wrong depmap JPP name to short_name
|
||||
- Add obsoletes to javadoc subpackage
|
||||
|
||||
* Wed May 12 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-7
|
||||
- Fix symlink problems introduced previously in r5
|
||||
|
||||
* Tue May 11 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-6
|
||||
- Add one more add_to_maven_depmap for backward compatibility
|
||||
|
||||
* Mon May 10 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-5
|
||||
- Fix up add_to_maven_depmap
|
||||
- Add jpackage-utils Requires for javadoc
|
||||
- Cleanup install a bit
|
||||
|
||||
* Fri May 7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-4
|
||||
- Fix provides
|
||||
|
||||
* Thu May 6 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-3
|
||||
- Revert to using default permissions
|
||||
- Drop "Package" from summary, improve javadoc summary text
|
||||
|
||||
* Thu May 6 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-2
|
||||
- Fix EOLs on docs
|
||||
- Create javadoc symlinks during install
|
||||
- Use version macro in Source0 URL, use _mavenpomdir macro
|
||||
|
||||
* Thu May 6 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.1.1-1
|
||||
- Rename and rebase from jakarta-commons-logging
|
165
commons-logging-api-1.1.pom
Normal file
165
commons-logging-api-1.1.pom
Normal file
@ -0,0 +1,165 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?><project>
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>commons-logging</groupId>
|
||||
<artifactId>commons-logging-api</artifactId>
|
||||
<name>Logging</name>
|
||||
<version>1.1</version>
|
||||
<description>Commons Logging is a thin adapter allowing configurable bridging to other,
|
||||
well known logging systems.</description>
|
||||
<url>http://jakarta.apache.org/commons/logging/</url>
|
||||
<issueManagement>
|
||||
<url>http://issues.apache.org/jira/browse/LOGGING</url>
|
||||
</issueManagement>
|
||||
<ciManagement>
|
||||
<notifiers>
|
||||
<notifier>
|
||||
<configuration>
|
||||
<address>commons-dev@jakarta.apache.org</address>
|
||||
</configuration>
|
||||
</notifier>
|
||||
</notifiers>
|
||||
</ciManagement>
|
||||
<inceptionYear>2001</inceptionYear>
|
||||
<mailingLists>
|
||||
<mailingList>
|
||||
<name>Commons Dev List</name>
|
||||
<subscribe>commons-dev-subscribe@jakarta.apache.org</subscribe>
|
||||
<unsubscribe>commons-dev-unsubscribe@jakarta.apache.org</unsubscribe>
|
||||
<archive>http://mail-archives.apache.org/mod_mbox/jakarta-commons-dev/</archive>
|
||||
</mailingList>
|
||||
<mailingList>
|
||||
<name>Commons User List</name>
|
||||
<subscribe>commons-user-subscribe@jakarta.apache.org</subscribe>
|
||||
<unsubscribe>commons-user-unsubscribe@jakarta.apache.org</unsubscribe>
|
||||
<archive>http://mail-archives.apache.org/mod_mbox/jakarta-commons-user/</archive>
|
||||
</mailingList>
|
||||
</mailingLists>
|
||||
<developers>
|
||||
<developer>
|
||||
<id>morgand</id>
|
||||
<name>Morgan Delagrange</name>
|
||||
<email>morgand at apache dot org</email>
|
||||
<organization>Apache</organization>
|
||||
<roles>
|
||||
<role>Java Developer</role>
|
||||
</roles>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>rwaldhoff</id>
|
||||
<name>Rodney Waldhoff</name>
|
||||
<email>rwaldhoff at apache org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>craigmcc</id>
|
||||
<name>Craig McClanahan</name>
|
||||
<email>craigmcc at apache org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>sanders</id>
|
||||
<name>Scott Sanders</name>
|
||||
<email>sanders at apache dot org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>rdonkin</id>
|
||||
<name>Robert Burrell Donkin</name>
|
||||
<email>rdonkin at apache dot org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>donaldp</id>
|
||||
<name>Peter Donald</name>
|
||||
<email>donaldp at apache dot org</email>
|
||||
<organization></organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>costin</id>
|
||||
<name>Costin Manolache</name>
|
||||
<email>costin at apache dot org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>rsitze</id>
|
||||
<name>Richard Sitze</name>
|
||||
<email>rsitze at apache dot org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>baliuka</id>
|
||||
<name>Juozas Baliuka</name>
|
||||
<email>baliuka@apache.org</email>
|
||||
<organization></organization>
|
||||
<roles>
|
||||
<role>Java Developer</role>
|
||||
</roles>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>skitching</id>
|
||||
<name>Simon Kitching</name>
|
||||
<email>skitching@apache.org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>dennisl</id>
|
||||
<name>Dennis Lundberg</name>
|
||||
<email>dennisl@apache.org</email>
|
||||
<organization>Apache Software Foundation</organization>
|
||||
</developer>
|
||||
<developer>
|
||||
<id>bstansberry</id>
|
||||
<name>Brian Stansberry</name>
|
||||
</developer>
|
||||
</developers>
|
||||
<licenses>
|
||||
<license>
|
||||
<name>The Apache Software License, Version 2.0</name>
|
||||
<url>/LICENSE.txt</url>
|
||||
</license>
|
||||
</licenses>
|
||||
<scm>
|
||||
<connection>scm:svn:http://svn.apache.org/repos/asf/jakarta/commons/proper/logging/trunk/</connection>
|
||||
<url>http://svn.apache.org/repos/asf/jakarta/commons/proper/logging/trunk/</url>
|
||||
</scm>
|
||||
<organization>
|
||||
<name>The Apache Software Foundation</name>
|
||||
<url>http://jakarta.apache.org</url>
|
||||
</organization>
|
||||
<build>
|
||||
<sourceDirectory>src/java</sourceDirectory>
|
||||
<testSourceDirectory>src/test</testSourceDirectory>
|
||||
<plugins>
|
||||
<plugin>
|
||||
<artifactId>maven-xdoc-plugin</artifactId>
|
||||
<version>1.9.2</version>
|
||||
<configuration>
|
||||
<optional>true</optional>
|
||||
<comment><strong>Site Only</strong> - v1.9.2 (minimum)</comment>
|
||||
</configuration>
|
||||
</plugin>
|
||||
</plugins>
|
||||
</build>
|
||||
<dependencies>
|
||||
<dependency>
|
||||
<groupId>junit</groupId>
|
||||
<artifactId>junit</artifactId>
|
||||
<version>3.8.1</version>
|
||||
<scope>test</scope>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
<distributionManagement>
|
||||
<repository>
|
||||
<id>default</id>
|
||||
<name>Default Repository</name>
|
||||
<url>file:///www/jakarta.apache.org/builds/jakarta-commons/logging/</url>
|
||||
</repository>
|
||||
<site>
|
||||
<id>default</id>
|
||||
<name>Default Site</name>
|
||||
<url>scp://people.apache.org//www/jakarta.apache.org/commons/logging/</url>
|
||||
</site>
|
||||
<status>converted</status>
|
||||
</distributionManagement>
|
||||
</project>
|
Loading…
Reference in New Issue
Block a user