diff --git a/.gitignore b/.gitignore
index 0c901d3..80cb8a8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -18,3 +18,4 @@
/commons-lang3-3.11-src.tar.gz
/commons-lang3-3.12.0-src.tar.gz
/commons-lang3-3.13.0-src.tar.gz
+/commons-lang3-3.14.0-src.tar.gz
diff --git a/0001-Remove-test-dependency-on-JUnit-Pioneer.patch b/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
index acd1a51..1206547 100644
--- a/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
+++ b/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
@@ -24,14 +24,15 @@ sed -i '/^import org.junitpioneer/ d
.../apache/commons/lang3/time/DateUtilsTest.java | 11 +++++------
.../lang3/time/DurationFormatUtilsTest.java | 3 +--
.../commons/lang3/time/FastDateFormatTest.java | 14 +++++---------
+ .../time/FastDateParser_TimeZoneStrategyTest.java | 7 +------
.../commons/lang3/time/FastDatePrinterTest.java | 10 +++-------
- 7 files changed, 17 insertions(+), 36 deletions(-)
+ 8 files changed, 18 insertions(+), 42 deletions(-)
diff --git a/pom.xml b/pom.xml
-index 99e87fd..8052c4e 100644
+index 1c62e33..c8b4d1a 100644
--- a/pom.xml
+++ b/pom.xml
-@@ -530,12 +530,6 @@
+@@ -526,12 +526,6 @@
junit-jupiter
test
@@ -45,7 +46,7 @@ index 99e87fd..8052c4e 100644
org.hamcrest
hamcrest
diff --git a/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java b/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
-index b152a8d..b1cfd54 100644
+index 87c5548..a2cb3dc 100644
--- a/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
+++ b/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
@@ -27,7 +27,6 @@ import static org.junit.jupiter.api.Assertions.assertTrue;
@@ -57,7 +58,7 @@ index b152a8d..b1cfd54 100644
/**
* Unit tests {@link org.apache.commons.lang3.StringUtils} - Contains methods
@@ -230,7 +229,7 @@ public class StringUtilsContainsTest extends AbstractLangTest {
- assertFalse(StringUtils.containsAny(CharU20001, CharU20000));
+ assertTrue(StringUtils.containsAnyIgnoreCase("abc", "d", "abc"));
}
- @DefaultLocale(language = "de", country = "DE")
@@ -150,10 +151,10 @@ index d3e7abb..47dc56d 100644
public void testLANG799_EN_WITH_DE_LOCALE() throws ParseException {
DateUtils.parseDate("Mi, 09 Apr 2008 23:55:38 GMT", Locale.GERMAN, "EEE, dd MMM yyyy HH:mm:ss zzz");
diff --git a/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java b/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java
-index 545b220..980047d 100644
+index baedbce..30b67e3 100644
--- a/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java
+++ b/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java
-@@ -32,7 +32,6 @@ import java.util.TimeZone;
+@@ -33,7 +33,6 @@ import java.util.TimeZone;
import org.apache.commons.lang3.AbstractLangTest;
import org.junit.jupiter.api.Test;
@@ -161,7 +162,7 @@ index 545b220..980047d 100644
/**
* Tests {@link DurationFormatUtils}.
-@@ -112,7 +111,6 @@ public class DurationFormatUtilsTest extends AbstractLangTest {
+@@ -157,7 +156,6 @@ public class DurationFormatUtilsTest extends AbstractLangTest {
/** Attempting to test edge cases in DurationFormatUtils.formatPeriod. */
@Test
@@ -169,16 +170,16 @@ index 545b220..980047d 100644
public void testEdgeDurations() {
// This test case must use a time zone without DST
TimeZone.setDefault(FastTimeZone.getGmtTimeZone());
-@@ -204,6 +202,7 @@ public class DurationFormatUtilsTest extends AbstractLangTest {
+@@ -249,6 +247,7 @@ public class DurationFormatUtilsTest extends AbstractLangTest {
}
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
@Test
- public void testFormatDuration() {
- long duration = 0;
+ public void testEmptyOptionals() {
+ assertEquals(
diff --git a/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java b/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
-index dda25cb..0d4cfef 100644
+index ffaf5a0..51530e0 100644
--- a/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
+++ b/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
@@ -40,8 +40,6 @@ import java.util.concurrent.atomic.AtomicLongArray;
@@ -237,8 +238,34 @@ index dda25cb..0d4cfef 100644
@Test
public void test_getInstance_String_TimeZone_Locale() {
final FastDateFormat format1 = FastDateFormat.getInstance("MM/DD/yyyy",
+diff --git a/src/test/java/org/apache/commons/lang3/time/FastDateParser_TimeZoneStrategyTest.java b/src/test/java/org/apache/commons/lang3/time/FastDateParser_TimeZoneStrategyTest.java
+index c46498c..9b1827b 100644
+--- a/src/test/java/org/apache/commons/lang3/time/FastDateParser_TimeZoneStrategyTest.java
++++ b/src/test/java/org/apache/commons/lang3/time/FastDateParser_TimeZoneStrategyTest.java
+@@ -40,13 +40,7 @@ import org.junit.jupiter.api.AfterAll;
+ import org.junit.jupiter.api.Test;
+ import org.junit.jupiter.params.ParameterizedTest;
+ import org.junit.jupiter.params.provider.MethodSource;
+-import org.junitpioneer.jupiter.DefaultLocale;
+-import org.junitpioneer.jupiter.DefaultTimeZone;
+-import org.junitpioneer.jupiter.ReadsDefaultLocale;
+-import org.junitpioneer.jupiter.ReadsDefaultTimeZone;
+
+-/* Make test reproducible */ @DefaultLocale(language = "en")
+-/* Make test reproducible */ @DefaultTimeZone(TimeZones.GMT_ID)
+ /* Make test reproducible */ @ReadsDefaultLocale
+ /* Make test reproducible */ @ReadsDefaultTimeZone
+ public class FastDateParser_TimeZoneStrategyTest extends AbstractLangTest {
+@@ -68,6 +62,7 @@ public class FastDateParser_TimeZoneStrategyTest extends AbstractLangTest {
+ return ArraySorter.sort(Locale.getAvailableLocales(), Comparator.comparing(Locale::toString));
+ }
+
++@org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
+ @Test
+ public void testLang1219() throws ParseException {
+ final FastDateParser parser = new FastDateParser("dd.MM.yyyy HH:mm:ss z", TimeZone.getDefault(), Locale.GERMAN);
diff --git a/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java b/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
-index cf7c248..fa36f33 100644
+index 8da22d4..73944c6 100644
--- a/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
+++ b/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
@@ -33,8 +33,6 @@ import java.util.TimeZone;
@@ -280,5 +307,5 @@ index cf7c248..fa36f33 100644
public void testWeekYear() {
final GregorianCalendar cal = new GregorianCalendar(2020, 12, 31, 0, 0, 0);
--
-2.41.0
+2.43.0
diff --git a/apache-commons-lang3.spec b/apache-commons-lang3.spec
index 3132244..7fb8b0b 100644
--- a/apache-commons-lang3.spec
+++ b/apache-commons-lang3.spec
@@ -1,8 +1,8 @@
%bcond_with bootstrap
Name: apache-commons-lang3
-Version: 3.13.0
-Release: 3%{?dist}
+Version: 3.14.0
+Release: 1%{?dist}
Summary: Provides a host of helper utilities for the java.lang API
License: Apache-2.0
URL: https://commons.apache.org/lang
@@ -82,6 +82,9 @@ sed -i '//d' pom.xml
%doc RELEASE-NOTES.txt
%changelog
+* Mon Dec 18 2023 Marian Koncek - 3.14.0-1
+- Update to upstream version 3.14.0
+
* Wed Sep 20 2023 Mikolaj Izdebski - 3.13.0-3
- Rebuild to regenerate auto-Requires on java
diff --git a/sources b/sources
index 19453af..c020c04 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (commons-lang3-3.13.0-src.tar.gz) = 6fca0ce86aea84458021360bac3f6775135a1a5c1826194921e2d4ead7c12f6ac560e7c3fc240112f862aaee24be8754c37dd867f45e9449cde4a388018d8691
+SHA512 (commons-lang3-3.14.0-src.tar.gz) = 1ee4176c3588c11594a79f416a1f34b063cddb10c2124a37640fee48e5d8135091573002b6bf1eda5a60a324c1125665dadc93f9bfda32c9270c35113b6e1bea