diff --git a/.gitignore b/.gitignore
index 1281a95..0c901d3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -17,3 +17,4 @@
/commons-lang3-3.10-src.tar.gz
/commons-lang3-3.11-src.tar.gz
/commons-lang3-3.12.0-src.tar.gz
+/commons-lang3-3.13.0-src.tar.gz
diff --git a/0001-Remove-test-dependency-on-JUnit-Pioneer.patch b/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
index 9492ec0..acd1a51 100644
--- a/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
+++ b/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
@@ -22,32 +22,33 @@ sed -i '/^import org.junitpioneer/ d
.../commons/lang3/StringUtilsContainsTest.java | 3 +--
.../commons/lang3/time/DateFormatUtilsTest.java | 6 ++----
.../apache/commons/lang3/time/DateUtilsTest.java | 11 +++++------
+ .../lang3/time/DurationFormatUtilsTest.java | 3 +--
.../commons/lang3/time/FastDateFormatTest.java | 14 +++++---------
.../commons/lang3/time/FastDatePrinterTest.java | 10 +++-------
- 6 files changed, 16 insertions(+), 34 deletions(-)
+ 7 files changed, 17 insertions(+), 36 deletions(-)
diff --git a/pom.xml b/pom.xml
-index 167a85a47..d08c66336 100644
+index 99e87fd..8052c4e 100644
--- a/pom.xml
+++ b/pom.xml
-@@ -533,12 +533,6 @@
+@@ -530,12 +530,6 @@
junit-jupiter
test
-
- org.junit-pioneer
- junit-pioneer
-- 1.3.0
+- 1.9.1
- test
-
org.hamcrest
hamcrest
diff --git a/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java b/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
-index 6ef2732a1..2e9d44f55 100644
+index b152a8d..b1cfd54 100644
--- a/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
+++ b/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
-@@ -23,7 +23,6 @@
+@@ -27,7 +27,6 @@ import static org.junit.jupiter.api.Assertions.assertTrue;
import java.util.Locale;
import org.junit.jupiter.api.Test;
@@ -55,7 +56,7 @@ index 6ef2732a1..2e9d44f55 100644
/**
* Unit tests {@link org.apache.commons.lang3.StringUtils} - Contains methods
-@@ -248,7 +247,7 @@ public void testContainsAny_StringWithSupplementaryChars() {
+@@ -230,7 +229,7 @@ public class StringUtilsContainsTest extends AbstractLangTest {
assertFalse(StringUtils.containsAny(CharU20001, CharU20000));
}
@@ -65,20 +66,20 @@ index 6ef2732a1..2e9d44f55 100644
public void testContainsIgnoreCase_LocaleIndependence() {
final Locale[] locales = { Locale.ENGLISH, new Locale("tr"), Locale.getDefault() };
diff --git a/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java b/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java
-index cff1aac5e..515650a98 100644
+index 3e8fd08..17ef99f 100644
--- a/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java
+++ b/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java
-@@ -30,8 +30,6 @@
- import java.util.TimeZone;
+@@ -31,8 +31,6 @@ import java.util.TimeZone;
+ import org.apache.commons.lang3.AbstractLangTest;
import org.junit.jupiter.api.Test;
-import org.junitpioneer.jupiter.DefaultLocale;
-import org.junitpioneer.jupiter.DefaultTimeZone;
/**
* TestCase for DateFormatUtils.
-@@ -153,7 +151,7 @@ public void testLANG1000() throws Exception {
- DateFormatUtils.ISO_DATETIME_TIME_ZONE_FORMAT.parse(date);
+@@ -160,7 +158,7 @@ public class DateFormatUtilsTest extends AbstractLangTest {
+ assertEquals("20030608221112", DateFormatUtils.format(calendar, "yyyyMMddHHmmss"));
}
- @DefaultTimeZone("UTC")
@@ -86,7 +87,7 @@ index cff1aac5e..515650a98 100644
@Test
public void testLang530() throws ParseException {
final Date d = new Date();
-@@ -205,7 +203,7 @@ public void testLang916() {
+@@ -212,7 +210,7 @@ public class DateFormatUtilsTest extends AbstractLangTest {
}
}
@@ -96,21 +97,21 @@ index cff1aac5e..515650a98 100644
public void testSMTP() {
TimeZone timeZone = TimeZone.getTimeZone("GMT-3");
diff --git a/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java b/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java
-index dd6025dce..00a97010e 100644
+index d3e7abb..47dc56d 100644
--- a/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java
+++ b/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java
-@@ -39,7 +39,6 @@
+@@ -41,7 +41,6 @@ import org.junit.jupiter.api.AfterEach;
import org.junit.jupiter.api.BeforeAll;
import org.junit.jupiter.api.BeforeEach;
import org.junit.jupiter.api.Test;
-import org.junitpioneer.jupiter.DefaultLocale;
/**
- * Unit tests {@link org.apache.commons.lang3.time.DateUtils}.
-@@ -795,13 +794,13 @@ public void testLANG799() throws ParseException {
+ * Tests {@link org.apache.commons.lang3.time.DateUtils}.
+@@ -806,13 +805,13 @@ public class DateUtilsTest extends AbstractLangTest {
}
- // Parse English date with German Locale
+ /** Parse English date with German Locale. */
- @DefaultLocale(language = "de")
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
@Test
@@ -123,7 +124,7 @@ index dd6025dce..00a97010e 100644
@Test
public void testLANG799_DE_OK() throws ParseException {
DateUtils.parseDate("Mi, 09 Apr 2008 23:55:38 GMT", "EEE, dd MMM yyyy HH:mm:ss zzz");
-@@ -809,13 +808,13 @@ public void testLANG799_DE_OK() throws ParseException {
+@@ -820,13 +819,13 @@ public class DateUtilsTest extends AbstractLangTest {
}
// Parse German date with English Locale
@@ -139,29 +140,57 @@ index dd6025dce..00a97010e 100644
@Test
public void testLANG799_EN_OK() throws ParseException {
DateUtils.parseDate("Wed, 09 Apr 2008 23:55:38 GMT", "EEE, dd MMM yyyy HH:mm:ss zzz");
-@@ -823,7 +822,7 @@ public void testLANG799_EN_OK() throws ParseException {
+@@ -834,7 +833,7 @@ public class DateUtilsTest extends AbstractLangTest {
}
- // Parse German date with English Locale, specifying German Locale override
+ /** Parse German date with English Locale, specifying German Locale override. */
- @DefaultLocale(language = "en")
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
@Test
public void testLANG799_EN_WITH_DE_LOCALE() throws ParseException {
DateUtils.parseDate("Mi, 09 Apr 2008 23:55:38 GMT", Locale.GERMAN, "EEE, dd MMM yyyy HH:mm:ss zzz");
+diff --git a/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java b/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java
+index 545b220..980047d 100644
+--- a/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java
++++ b/src/test/java/org/apache/commons/lang3/time/DurationFormatUtilsTest.java
+@@ -32,7 +32,6 @@ import java.util.TimeZone;
+
+ import org.apache.commons.lang3.AbstractLangTest;
+ import org.junit.jupiter.api.Test;
+-import org.junitpioneer.jupiter.DefaultTimeZone;
+
+ /**
+ * Tests {@link DurationFormatUtils}.
+@@ -112,7 +111,6 @@ public class DurationFormatUtilsTest extends AbstractLangTest {
+
+ /** Attempting to test edge cases in DurationFormatUtils.formatPeriod. */
+ @Test
+- @DefaultTimeZone(TimeZones.GMT_ID)
+ public void testEdgeDurations() {
+ // This test case must use a time zone without DST
+ TimeZone.setDefault(FastTimeZone.getGmtTimeZone());
+@@ -204,6 +202,7 @@ public class DurationFormatUtilsTest extends AbstractLangTest {
+
+ }
+
++ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
+ @Test
+ public void testFormatDuration() {
+ long duration = 0;
diff --git a/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java b/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
-index b945d1748..fcf41956d 100644
+index dda25cb..0d4cfef 100644
--- a/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
+++ b/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
-@@ -36,8 +36,6 @@
- import java.util.concurrent.atomic.AtomicLongArray;
+@@ -40,8 +40,6 @@ import java.util.concurrent.atomic.AtomicLongArray;
+ import org.apache.commons.lang3.AbstractLangTest;
import org.junit.jupiter.api.Test;
-import org.junitpioneer.jupiter.DefaultLocale;
-import org.junitpioneer.jupiter.DefaultTimeZone;
/**
* Unit tests {@link org.apache.commons.lang3.time.FastDateFormat}.
-@@ -92,7 +90,7 @@ private AtomicLongArray measureTime(final Format printer, final Format parser) t
+@@ -99,7 +97,7 @@ public class FastDateFormatTest extends AbstractLangTest {
return totalElapsed;
}
@@ -170,7 +199,7 @@ index b945d1748..fcf41956d 100644
@Test
public void test_changeDefault_Locale_DateInstance() {
final FastDateFormat format1 = FastDateFormat.getDateInstance(FastDateFormat.FULL, Locale.GERMANY);
-@@ -107,7 +105,7 @@ public void test_changeDefault_Locale_DateInstance() {
+@@ -114,7 +112,7 @@ public class FastDateFormatTest extends AbstractLangTest {
assertNotSame(format2, format3);
}
@@ -179,7 +208,7 @@ index b945d1748..fcf41956d 100644
@Test
public void test_changeDefault_Locale_DateTimeInstance() {
final FastDateFormat format1 = FastDateFormat.getDateTimeInstance(FastDateFormat.FULL, FastDateFormat.FULL, Locale.GERMANY);
-@@ -147,7 +145,7 @@ public void test_getInstance_String() {
+@@ -154,7 +152,7 @@ public class FastDateFormatTest extends AbstractLangTest {
assertEquals(TimeZone.getDefault(), format2.getTimeZone());
}
@@ -188,7 +217,7 @@ index b945d1748..fcf41956d 100644
@Test
public void test_getInstance_String_Locale() {
final FastDateFormat format1 = FastDateFormat.getInstance("MM/DD/yyyy", Locale.GERMANY);
-@@ -159,8 +157,7 @@ public void test_getInstance_String_Locale() {
+@@ -166,8 +164,7 @@ public class FastDateFormatTest extends AbstractLangTest {
assertEquals(Locale.GERMANY, format1.getLocale());
}
@@ -198,7 +227,7 @@ index b945d1748..fcf41956d 100644
@Test
public void test_getInstance_String_TimeZone() {
-@@ -180,8 +177,7 @@ public void test_getInstance_String_TimeZone() {
+@@ -187,8 +184,7 @@ public class FastDateFormatTest extends AbstractLangTest {
assertNotSame(format4, format6);
}
@@ -209,11 +238,11 @@ index b945d1748..fcf41956d 100644
public void test_getInstance_String_TimeZone_Locale() {
final FastDateFormat format1 = FastDateFormat.getInstance("MM/DD/yyyy",
diff --git a/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java b/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
-index f3511a51e..d4de29113 100644
+index cf7c248..fa36f33 100644
--- a/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
+++ b/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
-@@ -32,8 +32,6 @@
-
+@@ -33,8 +33,6 @@ import java.util.TimeZone;
+ import org.apache.commons.lang3.AbstractLangTest;
import org.apache.commons.lang3.SerializationUtils;
import org.junit.jupiter.api.Test;
-import org.junitpioneer.jupiter.DefaultLocale;
@@ -221,7 +250,7 @@ index f3511a51e..d4de29113 100644
/**
* Unit tests {@link org.apache.commons.lang3.time.FastDatePrinter}.
-@@ -166,8 +164,7 @@ public void testEquals() {
+@@ -166,8 +164,7 @@ public class FastDatePrinterTest extends AbstractLangTest {
assertNotEquals(printer1, new Object());
}
@@ -231,7 +260,7 @@ index f3511a51e..d4de29113 100644
@Test
public void testFormat() {
final GregorianCalendar cal1 = new GregorianCalendar(2003, 0, 10, 15, 33, 20);
-@@ -407,7 +404,7 @@ public void testStringBufferOptions() {
+@@ -407,7 +404,7 @@ public class FastDatePrinterTest extends AbstractLangTest {
assertEquals(expected, format.format(epoch, sb).toString());
}
@@ -240,7 +269,7 @@ index f3511a51e..d4de29113 100644
@Test
public void testTimeZoneAsZ() {
final Calendar c = Calendar.getInstance(FastTimeZone.getGmtTimeZone());
-@@ -433,8 +430,7 @@ public void testToStringContainsName() {
+@@ -433,8 +430,7 @@ public class FastDatePrinterTest extends AbstractLangTest {
assertTrue(printer.toString().startsWith("FastDate"));
}
@@ -251,5 +280,5 @@ index f3511a51e..d4de29113 100644
public void testWeekYear() {
final GregorianCalendar cal = new GregorianCalendar(2020, 12, 31, 0, 0, 0);
--
-2.29.2
+2.41.0
diff --git a/apache-commons-lang3.spec b/apache-commons-lang3.spec
index 10840cb..ef402fc 100644
--- a/apache-commons-lang3.spec
+++ b/apache-commons-lang3.spec
@@ -1,8 +1,8 @@
%bcond_with bootstrap
Name: apache-commons-lang3
-Version: 3.12.0
-Release: 9%{?dist}
+Version: 3.13.0
+Release: 1%{?dist}
Summary: Provides a host of helper utilities for the java.lang API
License: Apache-2.0
URL: https://commons.apache.org/lang
@@ -13,9 +13,9 @@ Source0: https://archive.apache.org/dist/commons/lang/source/commons-lang
Patch1: 0001-Remove-test-dependency-on-JUnit-Pioneer.patch
%if %{with bootstrap}
-BuildRequires: javapackages-bootstrap-openjdk8
+BuildRequires: javapackages-bootstrap
%else
-BuildRequires: maven-local-openjdk8
+BuildRequires: maven-local
BuildRequires: mvn(biz.aQute.bnd:biz.aQute.bndlib)
BuildRequires: mvn(com.google.code.findbugs:jsr305)
BuildRequires: mvn(org.apache.commons:commons-parent:pom:)
@@ -48,12 +48,12 @@ package.
%prep
%setup -q -n commons-lang3-%{version}-src
-%patch1 -p1
+%patch 1 -p1
%pom_remove_plugin :maven-javadoc-plugin
%pom_remove_dep org.openjdk.jmh:jmh-core
%pom_remove_dep org.openjdk.jmh:jmh-generator-annprocess
-%pom_remove_dep :junit-bom
+%pom_remove_dep org.apache.commons:commons-text
%mvn_file : %{name} commons-lang3
@@ -72,7 +72,7 @@ sed -i '//d' pom.xml
%build
# See "-DcommonsLang3Version" in maven-surefire for the tested version
-%mvn_build
+%mvn_build -f
%install
%mvn_install
@@ -82,6 +82,9 @@ sed -i '//d' pom.xml
%doc RELEASE-NOTES.txt
%changelog
+* Fri Aug 11 2023 Marian Koncek - 3.13.0-1
+- Update to upstream version 3.13.0
+
* Wed Jul 19 2023 Fedora Release Engineering - 3.12.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
diff --git a/sources b/sources
index 1233e7b..19453af 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (commons-lang3-3.12.0-src.tar.gz) = 80d1b960ae0b02859be329ea60d68cef33f3c7be7ec19752b3c9cfef442adef480878317ce2cfa309a27e662e2c72cab22023eaa3702e27970a1e5d55ca43f57
+SHA512 (commons-lang3-3.13.0-src.tar.gz) = 6fca0ce86aea84458021360bac3f6775135a1a5c1826194921e2d4ead7c12f6ac560e7c3fc240112f862aaee24be8754c37dd867f45e9449cde4a388018d8691