import apache-commons-lang3-3.12.0-5.el9
This commit is contained in:
commit
922395311a
1
.apache-commons-lang3.metadata
Normal file
1
.apache-commons-lang3.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
16a0fbd2b4927189fdee1428c0b74a837abd187c SOURCES/commons-lang3-3.12.0-src.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/commons-lang3-3.12.0-src.tar.gz
|
255
SOURCES/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
Normal file
255
SOURCES/0001-Remove-test-dependency-on-JUnit-Pioneer.patch
Normal file
@ -0,0 +1,255 @@
|
|||||||
|
From 98753efcb2ff4d531a1eca08ded5c227ae6149b6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||||
|
Date: Thu, 11 Mar 2021 13:14:20 +0100
|
||||||
|
Subject: [PATCH] Remove test dependency on JUnit Pioneer
|
||||||
|
|
||||||
|
sed -i '/<groupId>org.junit-pioneer/,/<dependency>/d' pom.xml
|
||||||
|
|
||||||
|
sed -i '/^import org.junitpioneer/ d
|
||||||
|
/@Default\(Locale\|TimeZone\)([^)]*)/ {
|
||||||
|
h
|
||||||
|
d
|
||||||
|
}
|
||||||
|
/@Test/ {
|
||||||
|
x
|
||||||
|
s/\( *\)..*/\1@org.junit.jupiter.api.Disabled("JUnit Pioneer not available")/
|
||||||
|
/./p
|
||||||
|
s/.*//
|
||||||
|
x
|
||||||
|
}' $(grep org.junitpioneer -rl src/test/java/)
|
||||||
|
---
|
||||||
|
pom.xml | 6 ------
|
||||||
|
.../commons/lang3/StringUtilsContainsTest.java | 3 +--
|
||||||
|
.../commons/lang3/time/DateFormatUtilsTest.java | 6 ++----
|
||||||
|
.../apache/commons/lang3/time/DateUtilsTest.java | 11 +++++------
|
||||||
|
.../commons/lang3/time/FastDateFormatTest.java | 14 +++++---------
|
||||||
|
.../commons/lang3/time/FastDatePrinterTest.java | 10 +++-------
|
||||||
|
6 files changed, 16 insertions(+), 34 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/pom.xml b/pom.xml
|
||||||
|
index 167a85a47..d08c66336 100644
|
||||||
|
--- a/pom.xml
|
||||||
|
+++ b/pom.xml
|
||||||
|
@@ -533,12 +533,6 @@
|
||||||
|
<artifactId>junit-jupiter</artifactId>
|
||||||
|
<scope>test</scope>
|
||||||
|
</dependency>
|
||||||
|
- <dependency>
|
||||||
|
- <groupId>org.junit-pioneer</groupId>
|
||||||
|
- <artifactId>junit-pioneer</artifactId>
|
||||||
|
- <version>1.3.0</version>
|
||||||
|
- <scope>test</scope>
|
||||||
|
- </dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.hamcrest</groupId>
|
||||||
|
<artifactId>hamcrest</artifactId>
|
||||||
|
diff --git a/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java b/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
|
||||||
|
index 6ef2732a1..2e9d44f55 100644
|
||||||
|
--- a/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
|
||||||
|
+++ b/src/test/java/org/apache/commons/lang3/StringUtilsContainsTest.java
|
||||||
|
@@ -23,7 +23,6 @@
|
||||||
|
import java.util.Locale;
|
||||||
|
|
||||||
|
import org.junit.jupiter.api.Test;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultLocale;
|
||||||
|
|
||||||
|
/**
|
||||||
|
* Unit tests {@link org.apache.commons.lang3.StringUtils} - Contains methods
|
||||||
|
@@ -248,7 +247,7 @@ public void testContainsAny_StringWithSupplementaryChars() {
|
||||||
|
assertFalse(StringUtils.containsAny(CharU20001, CharU20000));
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "de", country = "DE")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testContainsIgnoreCase_LocaleIndependence() {
|
||||||
|
final Locale[] locales = { Locale.ENGLISH, new Locale("tr"), Locale.getDefault() };
|
||||||
|
diff --git a/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java b/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java
|
||||||
|
index cff1aac5e..515650a98 100644
|
||||||
|
--- a/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java
|
||||||
|
+++ b/src/test/java/org/apache/commons/lang3/time/DateFormatUtilsTest.java
|
||||||
|
@@ -30,8 +30,6 @@
|
||||||
|
import java.util.TimeZone;
|
||||||
|
|
||||||
|
import org.junit.jupiter.api.Test;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultLocale;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultTimeZone;
|
||||||
|
|
||||||
|
/**
|
||||||
|
* TestCase for DateFormatUtils.
|
||||||
|
@@ -153,7 +151,7 @@ public void testLANG1000() throws Exception {
|
||||||
|
DateFormatUtils.ISO_DATETIME_TIME_ZONE_FORMAT.parse(date);
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultTimeZone("UTC")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testLang530() throws ParseException {
|
||||||
|
final Date d = new Date();
|
||||||
|
@@ -205,7 +203,7 @@ public void testLang916() {
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testSMTP() {
|
||||||
|
TimeZone timeZone = TimeZone.getTimeZone("GMT-3");
|
||||||
|
diff --git a/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java b/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java
|
||||||
|
index dd6025dce..00a97010e 100644
|
||||||
|
--- a/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java
|
||||||
|
+++ b/src/test/java/org/apache/commons/lang3/time/DateUtilsTest.java
|
||||||
|
@@ -39,7 +39,6 @@
|
||||||
|
import org.junit.jupiter.api.BeforeAll;
|
||||||
|
import org.junit.jupiter.api.BeforeEach;
|
||||||
|
import org.junit.jupiter.api.Test;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultLocale;
|
||||||
|
|
||||||
|
/**
|
||||||
|
* Unit tests {@link org.apache.commons.lang3.time.DateUtils}.
|
||||||
|
@@ -795,13 +794,13 @@ public void testLANG799() throws ParseException {
|
||||||
|
}
|
||||||
|
|
||||||
|
// Parse English date with German Locale
|
||||||
|
- @DefaultLocale(language = "de")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testLANG799_DE_FAIL() {
|
||||||
|
assertThrows(ParseException.class, () -> DateUtils.parseDate("Wed, 09 Apr 2008 23:55:38 GMT", "EEE, dd MMM yyyy HH:mm:ss zzz"));
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "de")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testLANG799_DE_OK() throws ParseException {
|
||||||
|
DateUtils.parseDate("Mi, 09 Apr 2008 23:55:38 GMT", "EEE, dd MMM yyyy HH:mm:ss zzz");
|
||||||
|
@@ -809,13 +808,13 @@ public void testLANG799_DE_OK() throws ParseException {
|
||||||
|
}
|
||||||
|
|
||||||
|
// Parse German date with English Locale
|
||||||
|
- @DefaultLocale(language = "en")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testLANG799_EN_FAIL() {
|
||||||
|
assertThrows(ParseException.class, () -> DateUtils.parseDate("Mi, 09 Apr 2008 23:55:38 GMT", "EEE, dd MMM yyyy HH:mm:ss zzz"));
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testLANG799_EN_OK() throws ParseException {
|
||||||
|
DateUtils.parseDate("Wed, 09 Apr 2008 23:55:38 GMT", "EEE, dd MMM yyyy HH:mm:ss zzz");
|
||||||
|
@@ -823,7 +822,7 @@ public void testLANG799_EN_OK() throws ParseException {
|
||||||
|
}
|
||||||
|
|
||||||
|
// Parse German date with English Locale, specifying German Locale override
|
||||||
|
- @DefaultLocale(language = "en")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testLANG799_EN_WITH_DE_LOCALE() throws ParseException {
|
||||||
|
DateUtils.parseDate("Mi, 09 Apr 2008 23:55:38 GMT", Locale.GERMAN, "EEE, dd MMM yyyy HH:mm:ss zzz");
|
||||||
|
diff --git a/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java b/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
|
||||||
|
index b945d1748..fcf41956d 100644
|
||||||
|
--- a/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
|
||||||
|
+++ b/src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
|
||||||
|
@@ -36,8 +36,6 @@
|
||||||
|
import java.util.concurrent.atomic.AtomicLongArray;
|
||||||
|
|
||||||
|
import org.junit.jupiter.api.Test;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultLocale;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultTimeZone;
|
||||||
|
|
||||||
|
/**
|
||||||
|
* Unit tests {@link org.apache.commons.lang3.time.FastDateFormat}.
|
||||||
|
@@ -92,7 +90,7 @@ private AtomicLongArray measureTime(final Format printer, final Format parser) t
|
||||||
|
return totalElapsed;
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en", country = "US")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void test_changeDefault_Locale_DateInstance() {
|
||||||
|
final FastDateFormat format1 = FastDateFormat.getDateInstance(FastDateFormat.FULL, Locale.GERMANY);
|
||||||
|
@@ -107,7 +105,7 @@ public void test_changeDefault_Locale_DateInstance() {
|
||||||
|
assertNotSame(format2, format3);
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en", country = "US")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void test_changeDefault_Locale_DateTimeInstance() {
|
||||||
|
final FastDateFormat format1 = FastDateFormat.getDateTimeInstance(FastDateFormat.FULL, FastDateFormat.FULL, Locale.GERMANY);
|
||||||
|
@@ -147,7 +145,7 @@ public void test_getInstance_String() {
|
||||||
|
assertEquals(TimeZone.getDefault(), format2.getTimeZone());
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en", country = "US")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void test_getInstance_String_Locale() {
|
||||||
|
final FastDateFormat format1 = FastDateFormat.getInstance("MM/DD/yyyy", Locale.GERMANY);
|
||||||
|
@@ -159,8 +157,7 @@ public void test_getInstance_String_Locale() {
|
||||||
|
assertEquals(Locale.GERMANY, format1.getLocale());
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en", country = "US")
|
||||||
|
- @DefaultTimeZone("America/New_York")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void test_getInstance_String_TimeZone() {
|
||||||
|
|
||||||
|
@@ -180,8 +177,7 @@ public void test_getInstance_String_TimeZone() {
|
||||||
|
assertNotSame(format4, format6);
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en", country = "US")
|
||||||
|
- @DefaultTimeZone("America/New_York")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void test_getInstance_String_TimeZone_Locale() {
|
||||||
|
final FastDateFormat format1 = FastDateFormat.getInstance("MM/DD/yyyy",
|
||||||
|
diff --git a/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java b/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
|
||||||
|
index f3511a51e..d4de29113 100644
|
||||||
|
--- a/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
|
||||||
|
+++ b/src/test/java/org/apache/commons/lang3/time/FastDatePrinterTest.java
|
||||||
|
@@ -32,8 +32,6 @@
|
||||||
|
|
||||||
|
import org.apache.commons.lang3.SerializationUtils;
|
||||||
|
import org.junit.jupiter.api.Test;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultLocale;
|
||||||
|
-import org.junitpioneer.jupiter.DefaultTimeZone;
|
||||||
|
|
||||||
|
/**
|
||||||
|
* Unit tests {@link org.apache.commons.lang3.time.FastDatePrinter}.
|
||||||
|
@@ -166,8 +164,7 @@ public void testEquals() {
|
||||||
|
assertNotEquals(printer1, new Object());
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en", country = "US")
|
||||||
|
- @DefaultTimeZone("America/New_York")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testFormat() {
|
||||||
|
final GregorianCalendar cal1 = new GregorianCalendar(2003, 0, 10, 15, 33, 20);
|
||||||
|
@@ -407,7 +404,7 @@ public void testStringBufferOptions() {
|
||||||
|
assertEquals(expected, format.format(epoch, sb).toString());
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultTimeZone("UTC")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testTimeZoneAsZ() {
|
||||||
|
final Calendar c = Calendar.getInstance(FastTimeZone.getGmtTimeZone());
|
||||||
|
@@ -433,8 +430,7 @@ public void testToStringContainsName() {
|
||||||
|
assertTrue(printer.toString().startsWith("FastDate"));
|
||||||
|
}
|
||||||
|
|
||||||
|
- @DefaultLocale(language = "en", country = "US")
|
||||||
|
- @DefaultTimeZone("America/New_York")
|
||||||
|
+ @org.junit.jupiter.api.Disabled("JUnit Pioneer not available")
|
||||||
|
@Test
|
||||||
|
public void testWeekYear() {
|
||||||
|
final GregorianCalendar cal = new GregorianCalendar(2020, 12, 31, 0, 0, 0);
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
248
SPECS/apache-commons-lang3.spec
Normal file
248
SPECS/apache-commons-lang3.spec
Normal file
@ -0,0 +1,248 @@
|
|||||||
|
%bcond_with bootstrap
|
||||||
|
|
||||||
|
Name: apache-commons-lang3
|
||||||
|
Version: 3.12.0
|
||||||
|
Release: 5%{?dist}
|
||||||
|
Summary: Provides a host of helper utilities for the java.lang API
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: https://commons.apache.org/lang
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
Source0: https://archive.apache.org/dist/commons/lang/source/commons-lang3-%{version}-src.tar.gz
|
||||||
|
Patch1: 0001-Remove-test-dependency-on-JUnit-Pioneer.patch
|
||||||
|
|
||||||
|
BuildRequires: maven-local-openjdk8
|
||||||
|
%if %{with bootstrap}
|
||||||
|
BuildRequires: javapackages-bootstrap
|
||||||
|
%else
|
||||||
|
BuildRequires: mvn(biz.aQute.bnd:biz.aQute.bndlib)
|
||||||
|
BuildRequires: mvn(com.google.code.findbugs:jsr305)
|
||||||
|
BuildRequires: mvn(org.apache.commons:commons-parent:pom:)
|
||||||
|
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
|
||||||
|
BuildRequires: mvn(org.easymock:easymock)
|
||||||
|
BuildRequires: mvn(org.hamcrest:hamcrest)
|
||||||
|
BuildRequires: mvn(org.junit.jupiter:junit-jupiter)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
The standard Java libraries fail to provide enough methods for
|
||||||
|
manipulation of its core classes. The Commons Lang Component provides
|
||||||
|
these extra methods.
|
||||||
|
The Commons Lang Component provides a host of helper utilities for the
|
||||||
|
java.lang API, notably String manipulation methods, basic numerical
|
||||||
|
methods, object reflection, creation and serialization, and System
|
||||||
|
properties. Additionally it contains an inheritable enum type, an
|
||||||
|
exception structure that supports multiple types of nested-Exceptions
|
||||||
|
and a series of utilities dedicated to help with building methods, such
|
||||||
|
as hashCode, toString and equals.
|
||||||
|
|
||||||
|
With version of commons-lang 3.x, developers decided to change API and
|
||||||
|
therefore created differently named artifact and jar files. This is
|
||||||
|
the new version, while apache-commons-lang is the compatibility
|
||||||
|
package.
|
||||||
|
|
||||||
|
%{?javadoc_package}
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -n commons-lang3-%{version}-src
|
||||||
|
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%pom_remove_plugin :maven-javadoc-plugin
|
||||||
|
%pom_remove_dep org.openjdk.jmh:jmh-core
|
||||||
|
%pom_remove_dep org.openjdk.jmh:jmh-generator-annprocess
|
||||||
|
%pom_remove_dep :junit-bom
|
||||||
|
|
||||||
|
%mvn_file : %{name} commons-lang3
|
||||||
|
|
||||||
|
# testParseSync() test fails on ARM and PPC64LE for unknown reason
|
||||||
|
sed -i 's/\s*public void testParseSync().*/@org.junit.jupiter.api.Disabled\n&/' \
|
||||||
|
src/test/java/org/apache/commons/lang3/time/FastDateFormatTest.java
|
||||||
|
|
||||||
|
# non-deterministic tests fail randomly
|
||||||
|
rm src/test/java/org/apache/commons/lang3/RandomStringUtilsTest.java
|
||||||
|
|
||||||
|
# Missing dependencies
|
||||||
|
rm src/test/java/org/apache/commons/lang3/HashSetvBitSetTest.java
|
||||||
|
|
||||||
|
# Remove limits and Java 11 options
|
||||||
|
sed -i '/<argLine>/d' pom.xml
|
||||||
|
|
||||||
|
%build
|
||||||
|
# See "-DcommonsLang3Version" in maven-surefire for the tested version
|
||||||
|
%mvn_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%mvn_install
|
||||||
|
|
||||||
|
%files -f .mfiles
|
||||||
|
%license LICENSE.txt NOTICE.txt
|
||||||
|
%doc RELEASE-NOTES.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 3.12.0-5
|
||||||
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
|
Related: rhbz#1991688
|
||||||
|
|
||||||
|
* Wed Jun 09 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.12.0-4
|
||||||
|
- Rebuild to workaround DistroBaker issue
|
||||||
|
|
||||||
|
* Tue Jun 08 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.12.0-3
|
||||||
|
- Bootstrap Maven for CentOS Stream 9
|
||||||
|
|
||||||
|
* Mon May 17 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.12.0-2
|
||||||
|
- Bootstrap build
|
||||||
|
- Non-bootstrap build
|
||||||
|
|
||||||
|
* Wed Mar 10 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.12.0-1
|
||||||
|
- Update to upstream version 3.12.0
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.11-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Aug 12 2020 Fabio Valentini <decathorpe@gmail.com> - 3.11-1
|
||||||
|
- Update to version 3.11.
|
||||||
|
- Fixes RHBZ#1699692
|
||||||
|
|
||||||
|
* Tue Aug 04 2020 Marian Koncek <mkoncek@redhat.com> - 3.11-1
|
||||||
|
- Update to upstream version 3.11
|
||||||
|
|
||||||
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.1-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 10 2020 Jiri Vanek <jvanek@redhat.com> - 3.8.1-6
|
||||||
|
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||||
|
|
||||||
|
* Wed Apr 15 2020 Marian Koncek <mkoncek@redhat.com> - 3.10-1
|
||||||
|
- Update to upstream version 3.10
|
||||||
|
|
||||||
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.1-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 25 2020 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.9-4
|
||||||
|
- Build with OpenJDK 8
|
||||||
|
|
||||||
|
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.9-3
|
||||||
|
- Mass rebuild for javapackages-tools 201902
|
||||||
|
|
||||||
|
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.9-2
|
||||||
|
- Mass rebuild for javapackages-tools 201901
|
||||||
|
|
||||||
|
* Mon May 13 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.9-1
|
||||||
|
- Update to upstream version 3.9
|
||||||
|
|
||||||
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Oct 12 2018 Marian Koncek <mkoncek@redhat.com> - 3.8.1-2
|
||||||
|
- Fix incorrect OSGi metadata
|
||||||
|
- Resolves: rhbz#1636556
|
||||||
|
|
||||||
|
* Mon Oct 01 2018 Marian Koncek <mkoncek@redhat.com> - 3.8.1-1
|
||||||
|
- Update to upstream version 3.8.1
|
||||||
|
- Resolves: rhbz#1619243
|
||||||
|
|
||||||
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.7-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.7-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 29 2018 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.7-2
|
||||||
|
- Cleanup spec file
|
||||||
|
|
||||||
|
* Thu Nov 09 2017 Michael Simacek <msimacek@redhat.com> - 3.7-1
|
||||||
|
- Update to upstream version 3.7
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 10 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6-2
|
||||||
|
- Conditionalize BR on jmh
|
||||||
|
|
||||||
|
* Mon Jul 03 2017 Michael Simacek <msimacek@redhat.com> - 3.6-1
|
||||||
|
- Update to upstream version 3.6
|
||||||
|
|
||||||
|
* Tue Mar 14 2017 Michael Simacek <msimacek@redhat.com> - 3.5-3
|
||||||
|
- Disable non-deterministic test
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Oct 19 2016 Michael Simacek <msimacek@redhat.com> - 3.5-1
|
||||||
|
- Update to upstream version 3.5
|
||||||
|
|
||||||
|
* Wed Mar 09 2016 Michael Simacek <msimacek@redhat.com> - 3.4-5
|
||||||
|
- Fix unapplied patch
|
||||||
|
|
||||||
|
* Mon Feb 15 2016 Michael Simacek <msimacek@redhat.com> - 3.4-4
|
||||||
|
- Fix parsing of ISO dates with UTC TZ
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 12 2015 Alexander Kurtakov <akurtako@redhat.com> 3.4-1
|
||||||
|
- Update to upstream 3.4.
|
||||||
|
|
||||||
|
* Wed Jul 30 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.3.2-3
|
||||||
|
- Fix build-requires on apache-commons-parent
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Apr 14 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.3.2-1
|
||||||
|
- Update to upstream version 3.3.2
|
||||||
|
|
||||||
|
* Thu Mar 20 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.3.1-2
|
||||||
|
- Disable test failing on PPC64LE
|
||||||
|
|
||||||
|
* Thu Mar 20 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.3.1-1
|
||||||
|
- Update to upstream version 3.3.1
|
||||||
|
|
||||||
|
* Tue Mar 11 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.3-1
|
||||||
|
- Update to upstream version 3.3
|
||||||
|
|
||||||
|
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.1-2
|
||||||
|
- Use Requires: java-headless rebuild (#1067528)
|
||||||
|
|
||||||
|
* Thu Jan 9 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.2.1-1
|
||||||
|
- Update to upstream version 3.2.1
|
||||||
|
|
||||||
|
* Thu Jan 2 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.2-1
|
||||||
|
- Update to upstream version 3.2
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 29 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1-6
|
||||||
|
- Build with xmvn
|
||||||
|
- Update to current packaging guidelines
|
||||||
|
|
||||||
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 3.1-4
|
||||||
|
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||||
|
- Replace maven BuildRequires with maven-local
|
||||||
|
|
||||||
|
* Mon Aug 27 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.1-3
|
||||||
|
- Make easymock3 dependency conditional for Fedora
|
||||||
|
|
||||||
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 16 2012 gil cattaneo <puntogil@libero.it> - 3.1-1
|
||||||
|
- update to 3.1
|
||||||
|
|
||||||
|
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 3 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.0.1-1
|
||||||
|
- Initial version of the package
|
Loading…
Reference in New Issue
Block a user