import apache-commons-lang-2.6-21.module+el8+2598+06babf2e
This commit is contained in:
commit
c5587af5f7
1
.apache-commons-lang.metadata
Normal file
1
.apache-commons-lang.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
e828934b6e21b41b824a2392cb1a4c62f241d4c3 SOURCES/commons-lang-2.6-src.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/commons-lang-2.6-src.tar.gz
|
71
SOURCES/0002-Fix-FastDateFormat-for-Java-7-behaviour.patch
Normal file
71
SOURCES/0002-Fix-FastDateFormat-for-Java-7-behaviour.patch
Normal file
@ -0,0 +1,71 @@
|
|||||||
|
From 6af11cb2cfdf83ce013a531005077259984c55e7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||||
|
Date: Wed, 22 Feb 2012 11:21:06 +0100
|
||||||
|
Subject: [PATCH 2/2] Fix FastDateFormat for Java 7 behaviour
|
||||||
|
|
||||||
|
Backported from 1146138
|
||||||
|
See https://issues.apache.org/jira/browse/LANG-719 for more information
|
||||||
|
---
|
||||||
|
.../apache/commons/lang/time/FastDateFormat.java | 14 ++++++++++----
|
||||||
|
.../commons/lang/time/FastDateFormatTest.java | 5 +++--
|
||||||
|
2 files changed, 13 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/main/java/org/apache/commons/lang/time/FastDateFormat.java b/src/main/java/org/apache/commons/lang/time/FastDateFormat.java
|
||||||
|
index 2ca7e5c..b7e19ec 100644
|
||||||
|
--- a/src/main/java/org/apache/commons/lang/time/FastDateFormat.java
|
||||||
|
+++ b/src/main/java/org/apache/commons/lang/time/FastDateFormat.java
|
||||||
|
@@ -49,7 +49,7 @@ import org.apache.commons.lang.text.StrBuilder;
|
||||||
|
* </p>
|
||||||
|
*
|
||||||
|
* <p>Only formatting is supported, but all patterns are compatible with
|
||||||
|
- * SimpleDateFormat (except time zones - see below).</p>
|
||||||
|
+ * SimpleDateFormat (except time zones and some year patterns - see below).</p>
|
||||||
|
*
|
||||||
|
* <p>Java 1.4 introduced a new pattern letter, <code>'Z'</code>, to represent
|
||||||
|
* time zones in RFC822 format (eg. <code>+0800</code> or <code>-1100</code>).
|
||||||
|
@@ -60,6 +60,12 @@ import org.apache.commons.lang.text.StrBuilder;
|
||||||
|
* This introduces a minor incompatibility with Java 1.4, but at a gain of
|
||||||
|
* useful functionality.</p>
|
||||||
|
*
|
||||||
|
+ * <p>Javadoc cites for the year pattern: <i>For formatting, if the number of
|
||||||
|
+ * pattern letters is 2, the year is truncated to 2 digits; otherwise it is
|
||||||
|
+ * interpreted as a number.</i> Starting with Java 1.7 a pattern of 'Y' or
|
||||||
|
+ * 'YYY' will be formatted as '2003', while it was '03' in former Java
|
||||||
|
+ * versions. FastDateFormat implements the behavior of Java 7.</p>
|
||||||
|
+ *
|
||||||
|
* @author Apache Software Foundation
|
||||||
|
* @author TeaTrove project
|
||||||
|
* @author Brian S O'Neill
|
||||||
|
@@ -606,10 +612,10 @@ public class FastDateFormat extends Format {
|
||||||
|
rule = new TextField(Calendar.ERA, ERAs);
|
||||||
|
break;
|
||||||
|
case 'y': // year (number)
|
||||||
|
- if (tokenLen >= 4) {
|
||||||
|
- rule = selectNumberRule(Calendar.YEAR, tokenLen);
|
||||||
|
- } else {
|
||||||
|
+ if (tokenLen == 2) {
|
||||||
|
rule = TwoDigitYearField.INSTANCE;
|
||||||
|
+ } else {
|
||||||
|
+ rule = selectNumberRule(Calendar.YEAR, tokenLen < 4 ? 4 : tokenLen);
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
case 'M': // month in year (text and number)
|
||||||
|
diff --git a/src/test/java/org/apache/commons/lang/time/FastDateFormatTest.java b/src/test/java/org/apache/commons/lang/time/FastDateFormatTest.java
|
||||||
|
index 8232747..bd4d664 100644
|
||||||
|
--- a/src/test/java/org/apache/commons/lang/time/FastDateFormatTest.java
|
||||||
|
+++ b/src/test/java/org/apache/commons/lang/time/FastDateFormatTest.java
|
||||||
|
@@ -230,8 +230,9 @@ public class FastDateFormatTest extends TestCase {
|
||||||
|
" dddd ddd dd d DDDD DDD DD D EEEE EEE EE E aaaa aaa aa a zzzz zzz zz z";
|
||||||
|
fdf = FastDateFormat.getInstance(pattern);
|
||||||
|
sdf = new SimpleDateFormat(pattern);
|
||||||
|
- assertEquals(sdf.format(date1), fdf.format(date1));
|
||||||
|
- assertEquals(sdf.format(date2), fdf.format(date2));
|
||||||
|
+ // SDF bug fix starting with Java 7
|
||||||
|
+ assertEquals(sdf.format(date1).replaceAll("2003 03 03 03", "2003 2003 03 2003"), fdf.format(date1));
|
||||||
|
+ assertEquals(sdf.format(date2).replaceAll("2003 03 03 03", "2003 2003 03 2003"), fdf.format(date2));
|
||||||
|
|
||||||
|
} finally {
|
||||||
|
Locale.setDefault(realDefaultLocale);
|
||||||
|
--
|
||||||
|
1.7.7.6
|
||||||
|
|
156
SPECS/apache-commons-lang.spec
Normal file
156
SPECS/apache-commons-lang.spec
Normal file
@ -0,0 +1,156 @@
|
|||||||
|
|
||||||
|
%global base_name lang
|
||||||
|
%global short_name commons-%{base_name}
|
||||||
|
|
||||||
|
Name: apache-%{short_name}
|
||||||
|
Version: 2.6
|
||||||
|
Release: 21%{?dist}
|
||||||
|
Summary: Provides a host of helper utilities for the java.lang API
|
||||||
|
License: ASL 2.0
|
||||||
|
Group: Development/Libraries
|
||||||
|
URL: http://commons.apache.org/%{base_name}
|
||||||
|
Source0: http://archive.apache.org/dist/commons/%{base_name}/source/%{short_name}-%{version}-src.tar.gz
|
||||||
|
Patch1: 0002-Fix-FastDateFormat-for-Java-7-behaviour.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: maven-local
|
||||||
|
BuildRequires: apache-commons-parent
|
||||||
|
BuildRequires: maven-surefire-provider-junit
|
||||||
|
|
||||||
|
%description
|
||||||
|
The standard Java libraries fail to provide enough methods for
|
||||||
|
manipulation of its core classes. The Commons Lang Component provides
|
||||||
|
these extra methods.
|
||||||
|
The Commons Lang Component provides a host of helper utilities for the
|
||||||
|
java.lang API, notably String manipulation methods, basic numerical
|
||||||
|
methods, object reflection, creation and serialization, and System
|
||||||
|
properties. Additionally it contains an inheritable enum type, an
|
||||||
|
exception structure that supports multiple types of nested-Exceptions
|
||||||
|
and a series of utilities dedicated to help with building methods, such
|
||||||
|
as hashCode, toString and equals.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: API documentation for %{name}
|
||||||
|
Group: Documentation
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{short_name}-%{version}-src
|
||||||
|
%patch1 -p1
|
||||||
|
sed -i 's/\r//' *.txt *.html
|
||||||
|
|
||||||
|
# "enum" is used as a Java identifier, which is prohibited in Java >= 1.5
|
||||||
|
%pom_add_plugin org.apache.maven.plugins:maven-javadoc-plugin . "
|
||||||
|
<configuration><source>1.3</source></configuration>"
|
||||||
|
|
||||||
|
|
||||||
|
%mvn_file : %{name} %{short_name}
|
||||||
|
%mvn_alias : org.apache.commons: %{base_name}:%{base_name}
|
||||||
|
# this package needs to be compiled with -source 1.3 option
|
||||||
|
%mvn_config buildSettings/compilerSource 1.3
|
||||||
|
|
||||||
|
%build
|
||||||
|
%mvn_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%mvn_install
|
||||||
|
|
||||||
|
%files -f .mfiles
|
||||||
|
%doc PROPOSAL.html LICENSE.txt RELEASE-NOTES.txt NOTICE.txt
|
||||||
|
|
||||||
|
%files javadoc -f .mfiles-javadoc
|
||||||
|
%doc LICENSE.txt NOTICE.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-21
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-20
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-18
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu May 29 2014 Alexander Kurtakov <akurtako@redhat.com> 2.6-15
|
||||||
|
- Drop old jakarta provides/obsoletes.
|
||||||
|
|
||||||
|
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-14
|
||||||
|
- Use Requires: java-headless rebuild (#1067528)
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Apr 22 2013 Michal Srb <msrb@redhat.com> - 2.6-12
|
||||||
|
- Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 09 2013 Michal Srb <msrb@redhat.com> - 2.6-11
|
||||||
|
- Properly specify XMvn's compilerSource option
|
||||||
|
|
||||||
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 2.6-9
|
||||||
|
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||||
|
- Replace maven BuildRequires with maven-local
|
||||||
|
|
||||||
|
* Fri Jan 11 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.6-8
|
||||||
|
- Build with xmvn
|
||||||
|
|
||||||
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 22 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-6
|
||||||
|
- Add backported fix for JDK 1.7
|
||||||
|
|
||||||
|
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jun 27 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-4
|
||||||
|
- Use new add_maven_depmap macro
|
||||||
|
- Fix maven3 build
|
||||||
|
|
||||||
|
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-2
|
||||||
|
- Fix commons-lang symlink
|
||||||
|
|
||||||
|
* Tue Jan 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-1
|
||||||
|
- Update to 2.6
|
||||||
|
- Versionless jars & javadocs
|
||||||
|
- Use maven 3 to build
|
||||||
|
|
||||||
|
* Wed Nov 10 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.5-7
|
||||||
|
- Use apache-commons-parent instead of maven-*
|
||||||
|
|
||||||
|
* Thu Jul 8 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.5-6
|
||||||
|
- Add license to javadoc subpackage
|
||||||
|
|
||||||
|
* Wed May 26 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.5-5
|
||||||
|
- Add another old depmap to prevent groupId dependency problems
|
||||||
|
|
||||||
|
* Fri May 21 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.5-4
|
||||||
|
- Correct depmap filename for backward compatibility
|
||||||
|
|
||||||
|
* Mon May 17 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.5-3
|
||||||
|
- Fix maven depmap JPP name to short_name
|
||||||
|
|
||||||
|
* Mon May 10 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.5-2
|
||||||
|
- Added export for MAVEN_LOCAL_REPO and mkdir
|
||||||
|
- Added more add_to_maven_depmap to assure backward compatibility
|
||||||
|
- Add symlink to short_name.jar
|
||||||
|
|
||||||
|
* Mon May 10 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.5-1
|
||||||
|
- Rename and rebase of jakarta-commons-lang
|
||||||
|
- Re-did whole spec file to use maven, dropped gcj support
|
Loading…
Reference in New Issue
Block a user