Initial import of apache-commons-jxpath
This commit is contained in:
parent
ccd4903a77
commit
2be5587ec4
@ -0,0 +1 @@
|
||||
commons-jxpath-1.3-src.tar.gz
|
184
apache-commons-jxpath.spec
Normal file
184
apache-commons-jxpath.spec
Normal file
@ -0,0 +1,184 @@
|
||||
|
||||
%global base_name jxpath
|
||||
%global short_name commons-%{base_name}
|
||||
|
||||
Name: apache-%{short_name}
|
||||
Version: 1.3
|
||||
Release: 2%{?dist}
|
||||
Summary: Simple XPath interpreter
|
||||
|
||||
Group: Development/Libraries
|
||||
License: ASL 2.0
|
||||
URL: http://commons.apache.org/%{base_name}/
|
||||
Source0: http://www.apache.org/dist/commons/%{base_name}/source/%{short_name}-%{version}-src.tar.gz
|
||||
Patch0: %{short_name}-mockrunner.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: apache-commons-beanutils
|
||||
BuildRequires: apache-commons-logging
|
||||
BuildRequires: java-devel >= 1:1.6.0
|
||||
BuildRequires: jpackage-utils >= 0:1.6
|
||||
BuildRequires: tomcat5-jsp-2.0-api
|
||||
BuildRequires: maven-doxia-sitetools
|
||||
BuildRequires: maven-plugin-build-helper
|
||||
BuildRequires: maven-plugin-bundle
|
||||
BuildRequires: maven-surefire-maven-plugin
|
||||
BuildRequires: maven2-plugin-antrun
|
||||
BuildRequires: maven2-plugin-assembly
|
||||
BuildRequires: maven2-plugin-compiler
|
||||
BuildRequires: maven2-plugin-install
|
||||
BuildRequires: maven2-plugin-idea
|
||||
BuildRequires: maven2-plugin-jar
|
||||
BuildRequires: maven2-plugin-javadoc
|
||||
BuildRequires: maven2-plugin-resources
|
||||
BuildRequires: maven2-plugin-site
|
||||
# change to apache-commons-collections once they are renamed
|
||||
BuildRequires: jakarta-commons-collections >= 0:2.1.1
|
||||
Requires: jakarta-commons-collections >= 0:2.1.1
|
||||
Requires: apache-commons-logging
|
||||
Requires: xml-commons-apis
|
||||
Requires: xerces-j2
|
||||
Requires: servletapi5
|
||||
Requires: jdom >= 0:1.0
|
||||
Requires: tomcat5-jsp-2.0-api
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
Requires(post): jpackage-utils >= 1.7.2
|
||||
Requires(postun): jpackage-utils >= 1.7.2
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
# This should go away with F-17
|
||||
Provides: jakarta-%{short_name} = 0:%{version}-%{release}
|
||||
Obsoletes: jakarta-%{short_name} < 0:%{version}-%{release}
|
||||
|
||||
%description
|
||||
Defines a simple interpreter of an expression language called XPath.
|
||||
JXPath applies XPath expressions to graphs of objects of all kinds:
|
||||
JavaBeans, Maps, Servlet contexts, DOM etc, including mixtures thereof.
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
Group: Documentation
|
||||
Requires: jpackage-utils
|
||||
|
||||
# This should go away with F-17
|
||||
Provides: jakarta-%{short_name}-javadoc = 0:%{version}-%{release}
|
||||
Obsoletes: jakarta-%{short_name}-javadoc < 0:%{version}-%{release}
|
||||
|
||||
%description javadoc
|
||||
%{summary}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{short_name}-%{version}-src
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
|
||||
mkdir -p $MAVEN_REPO_LOCAL
|
||||
|
||||
# we are skipping tests because we don't have com.mockrunner in repos yet
|
||||
mvn-jpp \
|
||||
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||
-Dmaven.test.skip=true \
|
||||
install javadoc:javadoc
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
install -Dpm 644 target/%{short_name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
|
||||
pushd $RPM_BUILD_ROOT%{_javadir}
|
||||
for jar in *-%{version}*; do
|
||||
ln -sf ${jar} `echo $jar| sed "s|apache-||g"`
|
||||
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||
ln -sf ${jar} `echo $jar| sed "s|apache-\(.*\)-%{version}|\1|g"`
|
||||
done
|
||||
popd # come back from javadir
|
||||
|
||||
# javadoc
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
ln -sf %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
|
||||
# Install pom
|
||||
# pom
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
|
||||
install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{short_name}.pom
|
||||
%add_to_maven_depmap org.apache.commons %{short_name} %{version} JPP %{short_name}
|
||||
|
||||
# following line is only for backwards compatibility. New packages
|
||||
# should use proper groupid org.apache.commons and also artifactid
|
||||
%add_to_maven_depmap %{short_name} %{short_name} %{version} JPP %{short_name}
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
%update_maven_depmap
|
||||
|
||||
%postun
|
||||
%update_maven_depmap
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc LICENSE.txt
|
||||
%{_javadir}/*.jar
|
||||
%{_mavenpomdir}/JPP-%{short_name}.pom
|
||||
%{_mavendepmapfragdir}/*
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadocdir}/%{name}
|
||||
%{_javadocdir}/%{name}-%{version}
|
||||
|
||||
%changelog
|
||||
* Tue May 25 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.3-2
|
||||
- Fix ownership of some directories
|
||||
|
||||
* Tue May 25 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.3-1
|
||||
- Rename package (jakarta-commons-jxpath->apache-commons-jxpath)
|
||||
- Cleanup spec file
|
||||
- Build using maven, drop old pom file from sources
|
||||
- Update to upstream version
|
||||
|
||||
* Thu Aug 20 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.2-9
|
||||
- Fix random spaces.
|
||||
|
||||
* Wed Aug 19 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.2-8
|
||||
- BuildRequires java-devel >= 1.6.0.
|
||||
|
||||
* Wed Aug 19 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.2-7
|
||||
- Initial package for Fedora.
|
||||
|
||||
* Sun May 17 2009 Fernando Nasser <fnasser@redhat.com> - 0:1.2-6
|
||||
- Fix License
|
||||
- Provide intructions for obtaining source and refresh source tar ball
|
||||
|
||||
* Wed Mar 18 2009 Yong Yang <yyang@redhat.com> - 0:1.2-5
|
||||
- rebuild with new maven2 2.0.8 built in bootstrap mode
|
||||
|
||||
* Thu Feb 05 2009 Yong Yang <yyang@redhat.com> - 0:1.2-4
|
||||
- Fix release tag
|
||||
|
||||
* Thu Jan 08 2009 Yong Yang <yyang@redhat.com> - 0:1.2-3jpp.1
|
||||
- Import from dbhole's maven 2.0.8 packages, initial building
|
||||
|
||||
* Wed Apr 09 2008 Deepak Bhole <dbhole@redhat.com> - 0:1.2-2jpp.1
|
||||
- Import from JPackage
|
||||
- Added pom file
|
||||
|
||||
* Wed Jun 07 2006 Fernando Nasser <fnasser@redhat.com> - 0:1.2-2jpp
|
||||
- First JPP 1.7 build
|
||||
|
||||
* Sat Sep 18 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.2-1jpp
|
||||
- Upgrade to 1.2
|
||||
- Use jdom-1.0-0.rc1.1jpp
|
||||
- Relax some versioned dependencies
|
||||
|
||||
* Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:1.1-3jpp
|
||||
- Rebuild with ant-1.6.2
|
||||
|
||||
* Tue Jun 01 2004 Randy Watler <rwatler at finali.com> - 0:1.1-2jpp
|
||||
- Upgrade to Ant 1.6.X
|
||||
|
||||
* Mon Jan 19 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.1-1jpp
|
||||
- First JPackage release
|
47
commons-jxpath-mockrunner.patch
Normal file
47
commons-jxpath-mockrunner.patch
Normal file
@ -0,0 +1,47 @@
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 1a4f2c4..f5fa596 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -160,42 +160,6 @@ under the License.
|
||||
<version>1.7.0</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
- <dependency>
|
||||
- <groupId>com.mockrunner</groupId>
|
||||
- <artifactId>mockrunner-jdk1.3-j2ee1.3</artifactId>
|
||||
- <version>0.4</version>
|
||||
- <scope>test</scope>
|
||||
- <exclusions>
|
||||
- <exclusion>
|
||||
- <groupId>cglib-nodep</groupId>
|
||||
- <artifactId>cglib-nodep</artifactId>
|
||||
- </exclusion>
|
||||
- <exclusion>
|
||||
- <groupId>jboss</groupId>
|
||||
- <artifactId>jboss-jee</artifactId>
|
||||
- </exclusion>
|
||||
- <exclusion>
|
||||
- <groupId>nekohtml</groupId>
|
||||
- <artifactId>nekohtml</artifactId>
|
||||
- </exclusion>
|
||||
- <exclusion>
|
||||
- <groupId>struts</groupId>
|
||||
- <artifactId>struts</artifactId>
|
||||
- </exclusion>
|
||||
- <exclusion>
|
||||
- <groupId>oro</groupId>
|
||||
- <artifactId>oro</artifactId>
|
||||
- </exclusion>
|
||||
- <exclusion>
|
||||
- <groupId>commons-validator</groupId>
|
||||
- <artifactId>commons-validator</artifactId>
|
||||
- </exclusion>
|
||||
- <exclusion>
|
||||
- <groupId>commons-digester</groupId>
|
||||
- <artifactId>commons-digester</artifactId>
|
||||
- </exclusion>
|
||||
- </exclusions>
|
||||
- </dependency>
|
||||
</dependencies>
|
||||
<reporting>
|
||||
<plugins>
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
||||
apache-commons-jxpath-1_3-2_fc12:HEAD:apache-commons-jxpath-1.3-2.fc12.src.rpm:1274863375
|
Loading…
Reference in New Issue
Block a user