auto-import changelog data from antlr-2.7.2-3jpp.src.rpm
2.7.2-3jpp - Add non-versioned javadoc dir symlink. - Crosslink with local J2SE javadocs. - Spec cleanups, change to UTF-8. 2.7.2-2jpp - Rebuild for JPackage 1.5. Sat Mar 01 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.7.2-1jpp - Update to 2.7.2. - Include antlr script and jEdit mode (see antlr-jedit RPM description). - Use sed instead of bash 2 extension when symlinking jars during build. Tue May 07 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-8jpp - really section macro - hardcoded distribution and vendor tag - group tag again Thu May 02 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-7jpp - distribution tag - group tag - section macro Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-6jpp - versioned dir for javadoc - no dependencies for manual and javadoc packages - additional sources in individual archives Sat Dec 01 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-5jpp - javadoc in javadoc package Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.7.1-4jpp - removed packager tag - new jpp extension Sat Oct 06 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-3jpp - used a build file instead of makefile - build classes instead of blindly jared them ! - used original tarball - corrected license spelling Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-2jpp - first unified release - s/jPackage/JPackage Tue Aug 28 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-1mdk - first Mandrake release
This commit is contained in:
parent
90b6210107
commit
a8926f18e1
@ -0,0 +1 @@
|
|||||||
|
antlr-2.7.2.tar.gz
|
71
antlr-build.xml
Normal file
71
antlr-build.xml
Normal file
@ -0,0 +1,71 @@
|
|||||||
|
<!-- simple generic build file -->
|
||||||
|
|
||||||
|
<project name="antlr" default="all" basedir=".">
|
||||||
|
|
||||||
|
<!-- Properties -->
|
||||||
|
|
||||||
|
<property name="name" value="antlr"/>
|
||||||
|
<property name="src" value="src"/>
|
||||||
|
<property name="build" value="work"/>
|
||||||
|
<property name="build.classes" value="${build}/classes"/>
|
||||||
|
<property name="build.doc" value="${build}/api"/>
|
||||||
|
<property name="build.lib" value="${build}/lib"/>
|
||||||
|
<property name="packagenames" value="antlr.*"/>
|
||||||
|
<property name="j2se.apidoc" value="http://java.sun.com/j2se/1.4/docs/api/"/>
|
||||||
|
|
||||||
|
<!-- Targets -->
|
||||||
|
|
||||||
|
<!-- Prepare build directories -->
|
||||||
|
<target name="prepare">
|
||||||
|
<mkdir dir="${src}"/>
|
||||||
|
<mkdir dir="${build}"/>
|
||||||
|
<mkdir dir="${build.classes}"/>
|
||||||
|
<mkdir dir="${build.lib}"/>
|
||||||
|
<mkdir dir="${build.doc}"/>
|
||||||
|
<copy todir="${src}/antlr">
|
||||||
|
<fileset dir="antlr"/>
|
||||||
|
</copy>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Kill all the created directories -->
|
||||||
|
<target name="clean">
|
||||||
|
<delete dir="${build}"/>
|
||||||
|
<delete dir="${src}"/>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build classes -->
|
||||||
|
<target name="classes" depends="prepare">
|
||||||
|
<javac srcdir="${src}" destdir="${build.classes}"
|
||||||
|
debug="off" optimize="on" deprecation="on"/>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build jar archives -->
|
||||||
|
<target name="jar" depends="classes">
|
||||||
|
<jar jarfile="${build.lib}/${name}.jar" basedir="${build.classes}"
|
||||||
|
index="true">
|
||||||
|
<manifest>
|
||||||
|
<attribute name="Main-Class" value="antlr.Tool"/>
|
||||||
|
</manifest>
|
||||||
|
</jar>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build the full JavaDocs -->
|
||||||
|
<target name="javadoc" depends="prepare">
|
||||||
|
<javadoc sourcepath="${src}"
|
||||||
|
destdir="${build.doc}"
|
||||||
|
doctitle="${name} Javadoc"
|
||||||
|
windowtitle="${name} Javadoc"
|
||||||
|
package="true"
|
||||||
|
author="true"
|
||||||
|
version="true"
|
||||||
|
packagenames="${packagenames}"
|
||||||
|
splitindex="true"
|
||||||
|
use="true">
|
||||||
|
<link href="${j2se.apidoc}"/>
|
||||||
|
</javadoc>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build everything -->
|
||||||
|
<target name="all" depends="jar,javadoc"/>
|
||||||
|
|
||||||
|
</project>
|
33
antlr-jedit.patch
Normal file
33
antlr-jedit.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
--- extras/antlr-jedit.xml~ 2003-03-01 23:28:04.000000000 +0200
|
||||||
|
+++ extras/antlr-jedit.xml 2003-03-01 23:38:17.000000000 +0200
|
||||||
|
@@ -16,9 +16,6 @@
|
||||||
|
</PROPS>
|
||||||
|
|
||||||
|
<RULES DEFAULT="KEYWORD1">
|
||||||
|
- <!-- whitespace: (space and tab) -->
|
||||||
|
- <WHITESPACE> </WHITESPACE>
|
||||||
|
- <WHITESPACE> </WHITESPACE>
|
||||||
|
|
||||||
|
<!-- antlr specific rules -->
|
||||||
|
<SPAN DELEGATE="java::MAIN" TYPE="KEYWORD1">
|
||||||
|
@@ -97,9 +94,7 @@
|
||||||
|
</RULES>
|
||||||
|
|
||||||
|
<RULES DEFAULT="KEYWORD2" SET="PRODUCTION">
|
||||||
|
- <!-- whitespace: (space and tab) -->
|
||||||
|
- <WHITESPACE> </WHITESPACE>
|
||||||
|
- <WHITESPACE> </WHITESPACE>
|
||||||
|
+
|
||||||
|
<!-- Silly comment -->
|
||||||
|
<SEQ TYPE="COMMENT1">/**/</SEQ>
|
||||||
|
|
||||||
|
@@ -149,9 +144,6 @@
|
||||||
|
</RULES>
|
||||||
|
|
||||||
|
<RULES SET="KEYVALUE">
|
||||||
|
- <!-- whitespace: (space and tab) -->
|
||||||
|
- <WHITESPACE> </WHITESPACE>
|
||||||
|
- <WHITESPACE> </WHITESPACE>
|
||||||
|
|
||||||
|
<SEQ TYPE="KEYWORD1">{</SEQ>
|
||||||
|
|
25
antlr-script
Normal file
25
antlr-script
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
#
|
||||||
|
# antlr script
|
||||||
|
# JPackage Project <http://www.jpackage.org/>
|
||||||
|
|
||||||
|
# Source functions library
|
||||||
|
if [ -f /usr/share/java-utils/java-functions ] ; then
|
||||||
|
. /usr/share/java-utils/java-functions
|
||||||
|
else
|
||||||
|
echo "Can't find functions library, aborting"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
# Configuration
|
||||||
|
MAIN_CLASS="antlr.Tool"
|
||||||
|
BASE_FLAGS=""
|
||||||
|
BASE_JARS="antlr.jar"
|
||||||
|
|
||||||
|
# Set parameters
|
||||||
|
set_jvm
|
||||||
|
set_classpath $BASE_JARS
|
||||||
|
set_flags $BASE_FLAGS
|
||||||
|
|
||||||
|
# Let's start
|
||||||
|
run "$@"
|
169
antlr.spec
Normal file
169
antlr.spec
Normal file
@ -0,0 +1,169 @@
|
|||||||
|
%define section free
|
||||||
|
|
||||||
|
Summary: ANother Tool for Language Recognition
|
||||||
|
Name: antlr
|
||||||
|
Version: 2.7.2
|
||||||
|
Release: 3jpp
|
||||||
|
Epoch: 0
|
||||||
|
License: Public Domain
|
||||||
|
URL: http://www.antlr.org/
|
||||||
|
Group: Development/Code Generators
|
||||||
|
Vendor: JPackage Project
|
||||||
|
Distribution: JPackage
|
||||||
|
Source0: http://www.antlr.org/download/antlr-2.7.2.tar.gz
|
||||||
|
Source1: %{name}-build.xml
|
||||||
|
Source2: %{name}-script
|
||||||
|
Patch0: %{name}-jedit.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: ant, perl, java-javadoc
|
||||||
|
Requires: jpackage-utils
|
||||||
|
|
||||||
|
%description
|
||||||
|
ANTLR, ANother Tool for Language Recognition, (formerly PCCTS) is a
|
||||||
|
language tool that provides a framework for constructing recognizers,
|
||||||
|
compilers, and translators from grammatical descriptions containing
|
||||||
|
C++ or Java actions [You can use PCCTS 1.xx to generate C-based
|
||||||
|
parsers].
|
||||||
|
|
||||||
|
%package manual
|
||||||
|
Group: Development/Code Generators
|
||||||
|
Summary: Manual for %{name}
|
||||||
|
|
||||||
|
%description manual
|
||||||
|
Documentation for %{name}.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Group: Development/Documentation
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
Javadoc for %{name}.
|
||||||
|
|
||||||
|
%package jedit
|
||||||
|
Group: Text Editors
|
||||||
|
Summary: ANTLR mode for jEdit
|
||||||
|
Requires: jedit >= 0:4.1
|
||||||
|
|
||||||
|
%description jedit
|
||||||
|
ANTLR mode for jEdit. To enable this mode, insert the following into your
|
||||||
|
%{_datadir}/jedit/modes/catalog:
|
||||||
|
|
||||||
|
<MODE NAME="antlr" FILE="antlr.xml" FILE_NAME_GLOB="*.g"/>
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p0
|
||||||
|
cp -p %{SOURCE1} build.xml
|
||||||
|
# remove all binary libs
|
||||||
|
find . -name "*.jar" -exec rm -f {} \;
|
||||||
|
# fixup paths to manual
|
||||||
|
perl -pi -e 's|"doc/|"%{_docdir}/%{name}-manual-%{version}/|g' \
|
||||||
|
install.html
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
ant -Dj2se.apidoc=%{_javadocdir}/java
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
# jars
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||||
|
cp -p work/lib/%{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
|
||||||
|
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
|
||||||
|
|
||||||
|
# script (use the same name as in scripts/)
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||||
|
cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/run-antlr
|
||||||
|
|
||||||
|
# javadoc
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||||
|
cp -pr work/api/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||||
|
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
# jedit mode
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_datadir}/jedit/modes
|
||||||
|
cp -p extras/antlr-jedit.xml $RPM_BUILD_ROOT%{_datadir}/jedit/modes/antlr.xml
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%post javadoc
|
||||||
|
rm -f %{_javadocdir}/%{name}
|
||||||
|
ln -s %{name}-%{version} %{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%doc install.html RIGHTS
|
||||||
|
%attr(0755,root,root) %{_bindir}/*
|
||||||
|
%{_javadir}/*
|
||||||
|
|
||||||
|
%files manual
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%doc doc/*
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%doc %{_javadocdir}/%{name}-%{version}
|
||||||
|
%ghost %doc %{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
%files jedit
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%{_datadir}/jedit/modes/*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Dec 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.7.2-3jpp
|
||||||
|
- Add non-versioned javadoc dir symlink.
|
||||||
|
- Crosslink with local J2SE javadocs.
|
||||||
|
- Spec cleanups, change to UTF-8.
|
||||||
|
|
||||||
|
* Sun Mar 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.7.2-2jpp
|
||||||
|
- Rebuild for JPackage 1.5.
|
||||||
|
|
||||||
|
* Sat Mar 1 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.7.2-1jpp
|
||||||
|
- Update to 2.7.2.
|
||||||
|
- Include antlr script and jEdit mode (see antlr-jedit RPM description).
|
||||||
|
- Use sed instead of bash 2 extension when symlinking jars during build.
|
||||||
|
|
||||||
|
* Tue May 07 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-8jpp
|
||||||
|
- really section macro
|
||||||
|
- hardcoded distribution and vendor tag
|
||||||
|
- group tag again
|
||||||
|
|
||||||
|
* Thu May 2 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-7jpp
|
||||||
|
- distribution tag
|
||||||
|
- group tag
|
||||||
|
- section macro
|
||||||
|
|
||||||
|
* Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-6jpp
|
||||||
|
- versioned dir for javadoc
|
||||||
|
- no dependencies for manual and javadoc packages
|
||||||
|
- additional sources in individual archives
|
||||||
|
|
||||||
|
* Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-5jpp
|
||||||
|
- javadoc in javadoc package
|
||||||
|
|
||||||
|
* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.7.1-4jpp
|
||||||
|
- removed packager tag
|
||||||
|
- new jpp extension
|
||||||
|
|
||||||
|
* Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-3jpp
|
||||||
|
- used a build file instead of makefile
|
||||||
|
- build classes instead of blindly jared them !
|
||||||
|
- used original tarball
|
||||||
|
- corrected license spelling
|
||||||
|
|
||||||
|
* Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-2jpp
|
||||||
|
- first unified release
|
||||||
|
- s/jPackage/JPackage
|
||||||
|
|
||||||
|
* Tue Aug 28 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.7.1-1mdk
|
||||||
|
- first Mandrake release
|
Loading…
Reference in New Issue
Block a user