parent
b21fd677ed
commit
e1f1af3f1a
@ -1,25 +0,0 @@
|
||||
--- build.xml~ 2018-02-07 11:48:12.344520649 +0100
|
||||
+++ build.xml 2018-02-07 11:56:28.314072462 +0100
|
||||
@@ -383,9 +383,6 @@
|
||||
</condition>
|
||||
<property name="ignoresystemclasses" value="false"/>
|
||||
<available property="jdk9+" classname="java.lang.module.ModuleDescriptor"/>
|
||||
- <condition property="jdk10+">
|
||||
- <javaversion atleast="10"/>
|
||||
- </condition>
|
||||
<available property="kaffe" classname="kaffe.util.NotImplemented"/>
|
||||
<available property="harmony"
|
||||
classname="org.apache.harmony.luni.util.Base64"/>
|
||||
@@ -1616,11 +1613,7 @@
|
||||
|
||||
<target name="test-init" depends="probe-offline,check-optional-packages,dump-info">
|
||||
<mkdir dir="${build.junit.tmpdir}"/>
|
||||
- <condition property="sun.io.useCanonCaches" value="false">
|
||||
- <not>
|
||||
- <javaversion atleast="9"/>
|
||||
- </not>
|
||||
- </condition>
|
||||
+ <property name="sun.io.useCanonCaches" value="false"/>
|
||||
<macrodef name="test-junit">
|
||||
<element name="junit-nested" implicit="true"/>
|
||||
<sequential>
|
9
ant.spec
9
ant.spec
@ -35,7 +35,7 @@
|
||||
|
||||
Name: ant
|
||||
Version: 1.10.2
|
||||
Release: 0.1%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Epoch: 0
|
||||
Summary: Java build tool
|
||||
Summary(it): Tool per la compilazione di programmi java
|
||||
@ -47,11 +47,10 @@ Source2: apache-ant-1.8.ant.conf
|
||||
|
||||
# Fix some places where copies of classes are included in the wrong jarfiles
|
||||
Patch4: apache-ant-class-path-in-manifest.patch
|
||||
Patch5: ant-1.10.2-bootstrap.patch
|
||||
|
||||
BuildRequires: javapackages-local
|
||||
BuildRequires: java-devel >= 1:1.8.0
|
||||
BuildRequires: ant
|
||||
BuildRequires: ant >= 1.10.2
|
||||
BuildRequires: ant-junit
|
||||
|
||||
BuildRequires: mvn(antlr:antlr)
|
||||
@ -325,7 +324,6 @@ find -name build.xml -o -name pom.xml | xargs sed -i -e s/-SNAPSHOT//
|
||||
|
||||
# Fix class-path-in-manifest rpmlint warning
|
||||
%patch4
|
||||
%patch5
|
||||
|
||||
# clean jar files
|
||||
find . -name "*.jar" | xargs -t rm
|
||||
@ -594,9 +592,6 @@ cp -pr build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Wed Feb 7 2018 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.10.2-0.1
|
||||
- Bootstrap build
|
||||
|
||||
* Wed Feb 7 2018 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.10.2-1
|
||||
- Update to upstream version 1.10.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user