Update to upstream 1.8.3 release.
Drop old stuff.
This commit is contained in:
parent
47e6951153
commit
d74a2cd399
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
apache-ant-1.7.1-src.tar.bz2
|
||||
/apache-ant-1.8.1-src.tar.bz2
|
||||
apache-ant-1.8.2-src.tar.bz2
|
||||
apache-ant-1.8.3-src.tar.bz2
|
||||
|
@ -1,19 +0,0 @@
|
||||
diff --git a/src/script/.ant.swp b/src/script/.ant.swp
|
||||
index 7962473..b214d30 100644
|
||||
Binary files a/src/script/.ant.swp and b/src/script/.ant.swp differ
|
||||
diff --git a/src/script/ant b/src/script/ant
|
||||
index 0dc84e0..11c1b59 100644
|
||||
--- a/src/script/ant
|
||||
+++ b/src/script/ant
|
||||
@@ -176,10 +176,7 @@ if $rpm_mode && [ -x /usr/bin/build-classpath ] ; then
|
||||
*.rpmnew) ;;
|
||||
*)
|
||||
for dep in `cat "$file"`; do
|
||||
- case "$OPT_JAR_LIST" in
|
||||
- *"$dep"*) ;;
|
||||
- *) OPT_JAR_LIST="$OPT_JAR_LIST${OPT_JAR_LIST:+ }$dep"
|
||||
- esac
|
||||
+ OPT_JAR_LIST="$OPT_JAR_LIST${OPT_JAR_LIST:+ }$dep"
|
||||
done
|
||||
esac
|
||||
fi
|
48
ant.spec
48
ant.spec
@ -46,11 +46,10 @@
|
||||
%global ant_home %{_datadir}/ant
|
||||
|
||||
%global major_version 1.8
|
||||
%global cvs_version 1.8.2
|
||||
|
||||
Name: ant
|
||||
Version: 1.8.2
|
||||
Release: 9%{?dist}
|
||||
Version: 1.8.3
|
||||
Release: 1%{?dist}
|
||||
Epoch: 0
|
||||
Summary: Build tool for java
|
||||
Summary(it): Tool per la compilazione di programmi java
|
||||
@ -58,14 +57,13 @@ Summary(fr): Outil de compilation pour java
|
||||
License: ASL 2.0
|
||||
URL: http://ant.apache.org/
|
||||
Group: Development/Tools
|
||||
Source0: http://www.apache.org/dist/ant/source/apache-ant-%{cvs_version}-src.tar.bz2
|
||||
Source0: http://www.apache.org/dist/ant/source/apache-ant-%{version}-src.tar.bz2
|
||||
Source2: apache-ant-%{major_version}.ant.conf
|
||||
|
||||
# Fix some places where copies of classes are included in the wrong jarfiles
|
||||
Patch1: apache-ant-bz163689.patch
|
||||
Patch3: apache-ant-no-test-jar.patch
|
||||
Patch4: apache-ant-class-path-in-manifest.patch
|
||||
Patch5: %{name}-classpath-check.patch
|
||||
|
||||
BuildRequires: jpackage-utils >= 0:1.7.5
|
||||
BuildRequires: java-devel >= 0:1.5.0
|
||||
@ -427,26 +425,20 @@ Javadoc pour %{name}.
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
%prep
|
||||
%setup -q -n apache-ant-%{cvs_version}
|
||||
%setup -q -n apache-ant-%{version}
|
||||
#Fixup version
|
||||
find -name build.xml -o -name pom.xml | xargs sed -i -e s/-SNAPSHOT//
|
||||
#https://issues.apache.org/bugzilla/show_bug.cgi?id=47669
|
||||
sed -i -e "s|IMAGE_FILE_TYPE|BINARY_FILE_TYPE|g" src/main/org/apache/tools/ant/taskdefs/optional/net/FTP.java
|
||||
# Disable the style and xmlvalidate tasks on ppc64 and s390x (#163689).
|
||||
%ifarch ppc64 s390x
|
||||
%patch1 -p1
|
||||
%endif
|
||||
|
||||
# When bootstrapping, we don't have junit
|
||||
%patch3 -p1
|
||||
%patch3
|
||||
|
||||
# Fix class-path-in-manifest rpmlint warning
|
||||
%patch4
|
||||
|
||||
# Removed checking for classpath duplicates (cause for BZ #755325)
|
||||
# Accepted in upstream, release pending
|
||||
%patch5 -p1
|
||||
|
||||
# clean jar files
|
||||
find . -name "*.jar" | %{_bindir}/xargs -t rm
|
||||
|
||||
@ -461,27 +453,7 @@ mv KEYS.utf8 KEYS
|
||||
iconv LICENSE -f iso-8859-1 -t utf-8 -o LICENSE.utf8
|
||||
mv LICENSE.utf8 LICENSE
|
||||
|
||||
# Provides: exclude perl(oata), perl(examples)
|
||||
cat <<__EOF__ > %{name}-perl.prov
|
||||
#!/bin/sh
|
||||
/usr/lib/rpm/perl.prov \$* | grep -v '^perl(oata)$' | grep -v '^perl(examples)$'
|
||||
__EOF__
|
||||
%define __perl_provides %{_builddir}/apache-ant-%{cvs_version}/%{name}-perl.prov
|
||||
chmod +x %{__perl_provides}
|
||||
|
||||
|
||||
# Requires: exclude bogus perl(the)
|
||||
cat <<__EOF__ > %{name}-perl.req
|
||||
#!/bin/sh
|
||||
/usr/lib/rpm/perl.req \$* | grep -v '^perl(the)$'
|
||||
__EOF__
|
||||
%define __perl_requires %{_builddir}/apache-ant-%{cvs_version}/%{name}-perl.req
|
||||
chmod +x %{__perl_requires}
|
||||
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
%build
|
||||
export OPT_JAR_LIST=:
|
||||
%if %without bootstrap
|
||||
%{ant} jars test-jar
|
||||
%if %{build_javadoc}
|
||||
@ -494,6 +466,8 @@ export CLASSPATH=$JAVA_HOME/lib/tools.jar
|
||||
sh ./build.sh --noconfig jars
|
||||
%endif
|
||||
|
||||
#remove empty jai and netrexx jars. Due to missing dependencies they contain only manifests.
|
||||
rm -fr build/lib/ant-jai.jar build/lib/ant-netrexx.jar
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
%install
|
||||
@ -592,7 +566,7 @@ cp -pr build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
%endif
|
||||
|
||||
# fix link between manual and javadoc
|
||||
(cd docs/manual; ln -sf %{_javadocdir}/%{name} api)
|
||||
(cd manual; ln -sf %{_javadocdir}/%{name} api)
|
||||
|
||||
%if %with bootstrap
|
||||
find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
@ -756,7 +730,7 @@ find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
%attr(0755,root,root) %{_bindir}/*.py*
|
||||
|
||||
%files manual
|
||||
%doc docs/*
|
||||
%doc manual/*
|
||||
|
||||
%if %{build_javadoc}
|
||||
%files javadoc
|
||||
@ -767,6 +741,10 @@ find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Wed Feb 29 2012 Alexander Kurtakov <akurtako@redhat.com> 0:1.8.3-1
|
||||
- Update to upstream 1.8.3 release.
|
||||
- Drop old stuff.
|
||||
|
||||
* Tue Feb 07 2012 Tomas Radej <tradej@redhat.com> - 0:1.8.2-9
|
||||
- Added patch
|
||||
|
||||
|
@ -1,15 +1,13 @@
|
||||
--- build.xml.orig 2010-12-28 14:45:24.000000000 +0200
|
||||
+++ build.xml 2010-12-28 14:46:40.843377673 +0200
|
||||
@@ -730,10 +730,10 @@
|
||||
--- build.xml.orig 2012-02-29 13:29:12.000000000 +0200
|
||||
+++ build.xml 2012-02-29 13:31:36.787937053 +0200
|
||||
@@ -728,10 +728,6 @@
|
||||
<include name="LICENSE.txt"/>
|
||||
<include name="NOTICE.txt"/>
|
||||
</metainf>
|
||||
- <manifest>
|
||||
+ <!--manifest>
|
||||
<attribute name="Class-Path"
|
||||
value="ant.jar xalan.jar"/>
|
||||
- <attribute name="Class-Path"
|
||||
- value="ant.jar xalan.jar"/>
|
||||
- </manifest>
|
||||
+ </manifest-->
|
||||
</jar>
|
||||
|
||||
<macrodef name="optional-jar">
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- apache-ant-1.8.1/build.xml.orig 2010-04-30 16:05:05.000000000 -0600
|
||||
+++ apache-ant-1.8.1/build.xml 2010-08-16 12:19:41.227167815 -0600
|
||||
@@ -792,7 +792,7 @@
|
||||
--- build.xml.orig 2012-02-29 13:24:37.000000000 +0200
|
||||
+++ build.xml 2012-02-29 13:28:04.606216384 +0200
|
||||
@@ -884,7 +884,7 @@
|
||||
===================================================================
|
||||
-->
|
||||
<target name="dist-lite"
|
||||
|
Loading…
Reference in New Issue
Block a user