Fix build failures
Resolves: RHEL-5365
This commit is contained in:
parent
0b44e5df7c
commit
a62588af16
@ -1,14 +1,5 @@
|
||||
--- build.xml~ 2021-05-17 12:32:48.406394876 +0200
|
||||
+++ build.xml 2021-05-17 12:32:39.990389601 +0200
|
||||
@@ -145,8 +145,6 @@
|
||||
-->
|
||||
<pathelement location="${src.junit}"/>
|
||||
<pathelement location="${tests.etc.dir}"/>
|
||||
- <!-- Otherwise many tests fail with "com.sun.tools.javac.Main is not on the classpath.": -->
|
||||
- <pathelement location="${java.home}/../lib/tools.jar"/>
|
||||
</path>
|
||||
|
||||
<!--
|
||||
@@ -819,7 +817,6 @@
|
||||
</metainf>
|
||||
<manifest>
|
||||
|
20
ant.spec
20
ant.spec
@ -70,8 +70,6 @@ BuildRequires: mvn(xml-resolver:xml-resolver)
|
||||
BuildRequires: mvn(org.hamcrest:hamcrest-core)
|
||||
BuildRequires: mvn(org.hamcrest:hamcrest-library)
|
||||
|
||||
BuildRequires: junit5
|
||||
|
||||
# Theoretically Ant might be usable with just JRE, but typical Ant
|
||||
# workflow requires full JDK, so we recommend it here.
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
@ -273,16 +271,6 @@ Optional junit tasks for %{name}.
|
||||
%description junit -l fr
|
||||
Taches junit optionelles pour %{name}.
|
||||
|
||||
%package junit5
|
||||
Summary: Optional junit5 tasks for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description junit5
|
||||
Optional junit5 tasks for %{name}.
|
||||
|
||||
%description junit5 -l fr
|
||||
Taches junit5 optionelles pour %{name}.
|
||||
|
||||
%package testutil
|
||||
Summary: Test utility classes for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
@ -339,7 +327,7 @@ rm src/tests/junit/org/apache/tools/ant/types/selectors/SignedSelectorTest.java
|
||||
src/tests/junit/org/apache/tools/mail/MailMessageTest.java
|
||||
|
||||
#install jars
|
||||
build-jar-repository -s -p lib/optional antlr bcel javamail/mailapi jdepend junit oro regexp bsf commons-logging commons-net jsch xalan-j2 xml-commons-resolver xalan-j2-serializer hamcrest/core hamcrest/library xz-java junit5 opentest4j
|
||||
build-jar-repository -s -p lib/optional antlr bcel javamail/mailapi jdepend junit oro regexp bsf commons-logging commons-net jsch xalan-j2 xml-commons-resolver xalan-j2-serializer hamcrest/core hamcrest/library xz-java
|
||||
|
||||
# fix hardcoded paths in ant script and conf
|
||||
cp -p %{SOURCE2} %{name}.conf
|
||||
@ -380,6 +368,7 @@ rm -fr build/lib/ant-jai.jar build/lib/ant-netrexx.jar
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
rm -fr build/lib/ant-apache-log4j.jar
|
||||
rm -fr build/lib/ant-junitlauncher.jar
|
||||
|
||||
%install
|
||||
# ANT_HOME and subdirs
|
||||
@ -458,7 +447,6 @@ echo "jdepend ant/ant-jdepend" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/jdepend
|
||||
echo "jsch ant/ant-jsch" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/jsch
|
||||
echo "junit hamcrest/core ant/ant-junit" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/junit
|
||||
echo "junit hamcrest/core ant/ant-junit4" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/junit4
|
||||
echo "junit5 hamcrest/core junit opentest4j ant/ant-junitlauncher" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/junitlauncher
|
||||
echo "testutil ant/ant-testutil" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/testutil
|
||||
echo "xz-java ant/ant-xz" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/xz
|
||||
|
||||
@ -580,10 +568,6 @@ export LC_ALL=C.UTF-8
|
||||
%{ant_home}/etc/junit-frames-saxon.xsl
|
||||
%{ant_home}/etc/junit-noframes-saxon.xsl
|
||||
|
||||
%files junit5 -f .mfiles-junitlauncher
|
||||
%{ant_home}/lib/%{name}-junitlauncher.jar
|
||||
%config(noreplace) %{_sysconfdir}/%{name}.d/junitlauncher
|
||||
|
||||
%files testutil -f .mfiles-testutil
|
||||
%{ant_home}/lib/%{name}-testutil.jar
|
||||
%config(noreplace) %{_sysconfdir}/%{name}.d/testutil
|
||||
|
Loading…
Reference in New Issue
Block a user