Remove bootstrap code
This commit is contained in:
parent
397502e00d
commit
a0d3b1e9e6
79
ant.spec
79
ant.spec
@ -28,20 +28,10 @@
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
|
||||
%bcond_with bootstrap
|
||||
|
||||
%if %with bootstrap
|
||||
%bcond_with tests
|
||||
%bcond_with javadoc
|
||||
%else
|
||||
%bcond_without tests
|
||||
%bcond_without javadoc
|
||||
%endif
|
||||
|
||||
%global with_manifest_only 0
|
||||
|
||||
%global ant_home %{_datadir}/ant
|
||||
|
||||
%global major_version 1.8
|
||||
|
||||
Name: ant
|
||||
@ -57,17 +47,14 @@ Source0: http://www.apache.org/dist/ant/source/apache-ant-%{version}-src.
|
||||
Source2: apache-ant-%{major_version}.ant.conf
|
||||
|
||||
# Fix some places where copies of classes are included in the wrong jarfiles
|
||||
Patch3: apache-ant-no-test-jar.patch
|
||||
Patch4: apache-ant-class-path-in-manifest.patch
|
||||
|
||||
BuildRequires: jpackage-utils >= 0:1.7.5
|
||||
BuildRequires: java-devel >= 0:1.5.0
|
||||
%if %without bootstrap
|
||||
BuildRequires: ant
|
||||
BuildRequires: ant-junit
|
||||
BuildRequires: junit
|
||||
BuildRequires: xalan-j2
|
||||
%endif
|
||||
|
||||
Requires: jpackage-utils >= 0:1.7.5
|
||||
Requires: java-devel >= 0:1.5.0
|
||||
@ -108,24 +95,6 @@ Optional swing tasks for %{name}.
|
||||
%description swing -l fr
|
||||
Taches swing optionelles pour %{name}.
|
||||
|
||||
%if %without bootstrap
|
||||
%if %{with_manifest_only}
|
||||
%package manifest-only
|
||||
Summary: Manifest-only jars for %{name}
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-icontract = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-netrexx = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-starteam = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-stylebook = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-vaj = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-weblogic = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-xalan1 = %{epoch}:%{version}-%{release}
|
||||
Provides: %{name}-xslp = %{epoch}:%{version}-%{release}
|
||||
|
||||
%description manifest-only
|
||||
Manifest-only jars for %{name}.
|
||||
%endif
|
||||
|
||||
%package antlr
|
||||
Summary: Optional antlr tasks for %{name}
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
@ -351,7 +320,6 @@ Javadoc for %{name}.
|
||||
|
||||
%description javadoc -l fr
|
||||
Javadoc pour %{name}.
|
||||
%endif
|
||||
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
@ -362,9 +330,6 @@ find -name build.xml -o -name pom.xml | xargs sed -i -e s/-SNAPSHOT//
|
||||
|
||||
sed -i "s/ jaxp_parser_impl xml-commons-apis//" src/script/ant
|
||||
|
||||
# When bootstrapping, we don't have junit
|
||||
%patch3
|
||||
|
||||
# Fix class-path-in-manifest rpmlint warning
|
||||
%patch4
|
||||
|
||||
@ -377,9 +342,7 @@ rm src/tests/junit/org/apache/tools/ant/types/selectors/SignedSelectorTest.java
|
||||
src/tests/junit/org/apache/tools/ant/taskdefs/condition/IsSignedTest.java
|
||||
|
||||
#install jars
|
||||
%if %without bootstrap
|
||||
build-jar-repository -s -p lib/optional antlr bcel javamail/mailapi jdepend junit log4j oro regexp bsf commons-logging commons-net jsch xalan-j2 xml-commons-resolver xalan-j2-serializer
|
||||
%endif
|
||||
|
||||
# Fix file-not-utf8 rpmlint warning
|
||||
iconv KEYS -f iso-8859-1 -t utf-8 -o KEYS.utf8
|
||||
@ -388,17 +351,12 @@ iconv LICENSE -f iso-8859-1 -t utf-8 -o LICENSE.utf8
|
||||
mv LICENSE.utf8 LICENSE
|
||||
|
||||
%build
|
||||
%if %without bootstrap
|
||||
%{ant} jars test-jar
|
||||
|
||||
%if %with javadoc
|
||||
export CLASSPATH=$(build-classpath antlr bcel javamail/mailapi jdepend junit log4j oro regexp bsf commons-logging commons-net jsch xalan-j2 xml-commons-resolver)
|
||||
%{ant} javadocs
|
||||
%endif
|
||||
%else
|
||||
export JAVA_HOME=%{java_home}
|
||||
export CLASSPATH=$JAVA_HOME/lib/tools.jar
|
||||
sh ./build.sh --noconfig jars
|
||||
%endif
|
||||
|
||||
#remove empty jai and netrexx jars. Due to missing dependencies they contain only manifests.
|
||||
rm -fr build/lib/ant-jai.jar build/lib/ant-netrexx.jar
|
||||
@ -451,11 +409,7 @@ cp -p src/etc/*.xsl $RPM_BUILD_ROOT%{ant_home}/etc
|
||||
|
||||
# install everything else
|
||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||
%if %without bootstrap
|
||||
cp -p src/script/* $RPM_BUILD_ROOT%{_bindir}
|
||||
%else
|
||||
cp -p src/script/ant{,Run} $RPM_BUILD_ROOT%{_bindir}
|
||||
%endif
|
||||
|
||||
# default ant.conf
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
|
||||
@ -465,7 +419,6 @@ cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d
|
||||
echo "ant/ant-jmf" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/jmf
|
||||
echo "ant/ant-swing" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/swing
|
||||
%if %without bootstrap
|
||||
echo "antlr ant/ant-antlr" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/antlr
|
||||
echo "bsf ant/ant-apache-bsf" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-bsf
|
||||
echo "xml-commons-resolver ant/ant-apache-resolver" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-resolver
|
||||
@ -483,7 +436,6 @@ echo "jsch ant/ant-jsch" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/jsch
|
||||
echo "junit ant/ant-junit" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/junit
|
||||
echo "junit ant/ant-junit4" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/junit4
|
||||
echo "testutil ant/ant-testutil" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/testutil
|
||||
%endif
|
||||
|
||||
%if %with javadoc
|
||||
# javadoc
|
||||
@ -494,18 +446,6 @@ cp -pr build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
# fix link between manual and javadoc
|
||||
(cd manual; ln -sf %{_javadocdir}/%{name} api)
|
||||
|
||||
%if %with bootstrap
|
||||
find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
-a ! -name ant-update.xsl \
|
||||
-a ! -name changelog.xsl \
|
||||
-a ! -name coverage-frames.xsl \
|
||||
-a ! -name junit-frames-xalan1.xsl \
|
||||
-a ! -name log.xsl \
|
||||
-a ! -name mmetrics-frames.xsl \
|
||||
-a ! -name tagdiff.xsl \
|
||||
| xargs -t rm
|
||||
%endif
|
||||
|
||||
%if %with tests
|
||||
%check
|
||||
%{ant} test
|
||||
@ -532,10 +472,8 @@ find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
%{ant_home}/etc/log.xsl
|
||||
%{ant_home}/etc/tagdiff.xsl
|
||||
%{ant_home}/etc/junit-frames-xalan1.xsl
|
||||
%if %without bootstrap
|
||||
%{ant_home}/etc/common2master.xsl
|
||||
%{ant_home}/etc/printFailingTests.xsl
|
||||
%endif
|
||||
%dir %{ant_home}/lib
|
||||
%{ant_home}/lib/%{name}.jar
|
||||
%{ant_home}/lib/%{name}-launcher.jar
|
||||
@ -554,19 +492,6 @@ find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
%{ant_home}/lib/%{name}-swing.jar
|
||||
%config(noreplace) %{_sysconfdir}/%{name}.d/swing
|
||||
|
||||
%if %without bootstrap
|
||||
%if %{with_manifest_only}
|
||||
%files manifest-only
|
||||
%{_javadir}/%{name}/ant-icontract.jar
|
||||
%{_javadir}/%{name}/ant-netrexx.jar
|
||||
%{_javadir}/%{name}/ant-starteam.jar
|
||||
%{_javadir}/%{name}/ant-stylebook.jar
|
||||
%{_javadir}/%{name}/ant-vaj.jar
|
||||
%{_javadir}/%{name}/ant-weblogic.jar
|
||||
%{_javadir}/%{name}/ant-xalan1.jar
|
||||
%{_javadir}/%{name}/ant-xslp.jar
|
||||
%endif
|
||||
|
||||
%files antlr
|
||||
%{_javadir}/%{name}/%{name}-antlr.jar
|
||||
%{ant_home}/lib/%{name}-antlr.jar
|
||||
@ -672,7 +597,6 @@ find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
%doc LICENSE NOTICE
|
||||
%{_javadocdir}/%{name}
|
||||
%endif
|
||||
%endif
|
||||
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
@ -685,6 +609,7 @@ find $RPM_BUILD_ROOT%{_datadir}/ant/etc -type f -name "*.xsl" \
|
||||
- Run tests in %%check instead of %%build
|
||||
- Remove dependencies on xerces-j2 and xml-commons-apis
|
||||
- Convert %%global build_javadoc to conditional
|
||||
- Remove bootstrap code
|
||||
|
||||
* Mon Jun 03 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0:1.9.1-2
|
||||
- Enable unit tests
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- build.xml.orig 2012-02-29 13:24:37.000000000 +0200
|
||||
+++ build.xml 2012-02-29 13:28:04.606216384 +0200
|
||||
@@ -884,7 +884,7 @@
|
||||
===================================================================
|
||||
-->
|
||||
<target name="dist-lite"
|
||||
- depends="jars,test-jar"
|
||||
+ depends="jars"
|
||||
description="--> creates a minimum distribution to run Apache Ant">
|
||||
|
||||
<mkdir dir="${dist.dir}"/>
|
Loading…
Reference in New Issue
Block a user