Added patch to fix jvm version detection
This commit is contained in:
parent
64dcde303e
commit
99c5a8ef7d
6
ant.spec
6
ant.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: ant
|
Name: ant
|
||||||
Version: 1.6.5
|
Version: 1.6.5
|
||||||
Release: %{jpprelease}_7fc
|
Release: %{jpprelease}_8fc
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
Summary: Ant build tool for java
|
Summary: Ant build tool for java
|
||||||
Summary(it): Tool per la compilazione di programmi java
|
Summary(it): Tool per la compilazione di programmi java
|
||||||
@ -23,6 +23,7 @@ Patch1: apache-ant-1.6.5-rpm.patch
|
|||||||
Patch2: apache-ant-1.6.5-javah.patch
|
Patch2: apache-ant-1.6.5-javah.patch
|
||||||
Patch4: apache-ant-jars.patch
|
Patch4: apache-ant-jars.patch
|
||||||
Patch5: apache-ant-bz163689.patch
|
Patch5: apache-ant-bz163689.patch
|
||||||
|
Patch6: apache-ant-1.6.5-jvm1.5-detect.patch
|
||||||
Requires: jaxp_parser_impl
|
Requires: jaxp_parser_impl
|
||||||
Requires: jpackage-utils >= 0:1.5
|
Requires: jpackage-utils >= 0:1.5
|
||||||
Requires: java-devel
|
Requires: java-devel
|
||||||
@ -752,6 +753,9 @@ fi
|
|||||||
# -----------------------------------------------------------------------------
|
# -----------------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 1 2006 Deepak Bhole <dbhole@redhat.com> - 0:1.6.5-1jpp_8fc
|
||||||
|
- Added patch to fix jvm version detection
|
||||||
|
|
||||||
* Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:1.6.5-1jpp_7fc
|
* Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:1.6.5-1jpp_7fc
|
||||||
- stop scriptlet spew
|
- stop scriptlet spew
|
||||||
|
|
||||||
|
22
apache-ant-1.6.5-jvm1.5-detect.patch
Normal file
22
apache-ant-1.6.5-jvm1.5-detect.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- ./src/main/org/apache/tools/ant/util/JavaEnvUtils.java.sav 2006-05-31 18:18:10.000000000 -0400
|
||||||
|
+++ ./src/main/org/apache/tools/ant/util/JavaEnvUtils.java 2006-05-31 18:18:18.000000000 -0400
|
||||||
|
@@ -95,7 +95,7 @@
|
||||||
|
Class.forName("java.lang.CharSequence");
|
||||||
|
javaVersion = JAVA_1_4;
|
||||||
|
javaVersionNumber++;
|
||||||
|
- Class.forName("java.lang.Readable");
|
||||||
|
+ Class.forName("java.net.Proxy");
|
||||||
|
javaVersion = JAVA_1_5;
|
||||||
|
javaVersionNumber++;
|
||||||
|
} catch (Throwable t) {
|
||||||
|
--- ./build.xml.sav 2006-05-31 18:18:28.000000000 -0400
|
||||||
|
+++ ./build.xml 2006-05-31 18:18:37.000000000 -0400
|
||||||
|
@@ -365,7 +365,7 @@
|
||||||
|
<target name="check_for_optional_packages">
|
||||||
|
<available property="jdk1.3+" classname="java.lang.StrictMath"/>
|
||||||
|
<available property="jdk1.4+" classname="java.lang.CharSequence"/>
|
||||||
|
- <available property="jdk1.5+" classname="java.lang.Readable"/>
|
||||||
|
+ <available property="jdk1.5+" classname="java.net.Proxy"/>
|
||||||
|
<available property="kaffe" classname="kaffe.util.NotImplemented"/>
|
||||||
|
<available property="bsf.present"
|
||||||
|
classname="org.apache.bsf.BSFManager"
|
Loading…
Reference in New Issue
Block a user