remove workaround for jarsigner issues / RHBZ#1869017
This commit is contained in:
parent
3f8033c51e
commit
7c6030948f
@ -1,82 +0,0 @@
|
|||||||
diff --git a/src/tests/junit/org/apache/tools/ant/AntClassLoaderTest.java b/src/tests/junit/org/apache/tools/ant/AntClassLoaderTest.java
|
|
||||||
index cedeed0..34d0c1c 100644
|
|
||||||
--- a/src/tests/junit/org/apache/tools/ant/AntClassLoaderTest.java
|
|
||||||
+++ b/src/tests/junit/org/apache/tools/ant/AntClassLoaderTest.java
|
|
||||||
@@ -157,6 +157,7 @@ public class AntClassLoaderTest {
|
|
||||||
FileUtils.getFileUtils().getFileURL(testJar), codeSourceLocation);
|
|
||||||
}
|
|
||||||
|
|
||||||
+/*
|
|
||||||
@Test
|
|
||||||
public void testSignedJar() throws Exception {
|
|
||||||
buildRule.executeTarget("signTestJar");
|
|
||||||
@@ -174,6 +175,7 @@ public class AntClassLoaderTest {
|
|
||||||
.getCertificates());
|
|
||||||
assertNotNull("should be signed", foo.getSigners());
|
|
||||||
}
|
|
||||||
+*/
|
|
||||||
|
|
||||||
/**
|
|
||||||
* @see <a href="https://issues.apache.org/bugzilla/show_bug.cgi?id=47593">bug 47593</a>
|
|
||||||
diff --git a/src/tests/junit/org/apache/tools/ant/taskdefs/SignJarTest.java b/src/tests/junit/org/apache/tools/ant/taskdefs/SignJarTest.java
|
|
||||||
index 4d5f29c..b5f2f1b 100644
|
|
||||||
--- a/src/tests/junit/org/apache/tools/ant/taskdefs/SignJarTest.java
|
|
||||||
+++ b/src/tests/junit/org/apache/tools/ant/taskdefs/SignJarTest.java
|
|
||||||
@@ -58,6 +58,7 @@ public class SignJarTest {
|
|
||||||
return Boolean.getBoolean("offline");
|
|
||||||
}
|
|
||||||
|
|
||||||
+/*
|
|
||||||
@Test
|
|
||||||
public void testSigFile() {
|
|
||||||
buildRule.executeTarget("sigfile");
|
|
||||||
@@ -72,7 +73,9 @@ public class SignJarTest {
|
|
||||||
assertTrue("must find signature with sigfile attribute",
|
|
||||||
sj.isSigned());
|
|
||||||
}
|
|
||||||
+*/
|
|
||||||
|
|
||||||
+/*
|
|
||||||
@Test
|
|
||||||
public void testInvalidChars() {
|
|
||||||
buildRule.executeTarget("invalidchars");
|
|
||||||
@@ -83,6 +86,7 @@ public class SignJarTest {
|
|
||||||
sj.setJar(new File(buildRule.getProject().getProperty("test.jar")));
|
|
||||||
assertTrue(sj.isSigned());
|
|
||||||
}
|
|
||||||
+*/
|
|
||||||
|
|
||||||
/**
|
|
||||||
* subclass in order to get access to protected isSigned method if
|
|
||||||
@@ -94,10 +98,12 @@ public class SignJarTest {
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+/*
|
|
||||||
@Test
|
|
||||||
public void testURLKeystoreFile() {
|
|
||||||
buildRule.executeTarget("urlKeystoreFile");
|
|
||||||
}
|
|
||||||
+*/
|
|
||||||
|
|
||||||
@Test
|
|
||||||
public void testURLKeystoreHTTP() {
|
|
||||||
@@ -112,9 +118,10 @@ public class SignJarTest {
|
|
||||||
buildRule.executeTarget("testTsaLocalhost");
|
|
||||||
}
|
|
||||||
|
|
||||||
- /**
|
|
||||||
+/*
|
|
||||||
+ /* *
|
|
||||||
* @see <a href="https://issues.apache.org/bugzilla/show_bug.cgi?id=50081">bug 50081</a>
|
|
||||||
- */
|
|
||||||
+ * /
|
|
||||||
@Test
|
|
||||||
public void testSignUnnormalizedJar() throws Exception {
|
|
||||||
buildRule.executeTarget("jar");
|
|
||||||
@@ -133,4 +140,5 @@ public class SignJarTest {
|
|
||||||
s.setKeystore("testkeystore");
|
|
||||||
s.execute();
|
|
||||||
}
|
|
||||||
+*/
|
|
||||||
}
|
|
10
ant.spec
10
ant.spec
@ -37,7 +37,7 @@
|
|||||||
Name: ant
|
Name: ant
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
Version: 1.10.8
|
Version: 1.10.8
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: Java build tool
|
Summary: Java build tool
|
||||||
Summary(it): Tool per la compilazione di programmi java
|
Summary(it): Tool per la compilazione di programmi java
|
||||||
Summary(fr): Outil de compilation pour java
|
Summary(fr): Outil de compilation pour java
|
||||||
@ -48,10 +48,6 @@ Source2: apache-ant-1.8.ant.conf
|
|||||||
# manpage
|
# manpage
|
||||||
Source3: ant.asciidoc
|
Source3: ant.asciidoc
|
||||||
|
|
||||||
# temporarily disable AntClassLoaderTest.testSignedJar()
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1869017
|
|
||||||
Patch0: 00-disable-jarsigner-test.patch
|
|
||||||
|
|
||||||
BuildRequires: javapackages-local
|
BuildRequires: javapackages-local
|
||||||
BuildRequires: java-devel >= 1:1.8.0
|
BuildRequires: java-devel >= 1:1.8.0
|
||||||
BuildRequires: ant >= 1.10.2
|
BuildRequires: ant >= 1.10.2
|
||||||
@ -351,7 +347,6 @@ Javadoc pour %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n apache-ant-%{version}
|
%setup -q -n apache-ant-%{version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
# Fix class-path-in-manifest rpmlint warning
|
# Fix class-path-in-manifest rpmlint warning
|
||||||
%pom_xpath_remove 'attribute[@name="Class-Path"]' build.xml
|
%pom_xpath_remove 'attribute[@name="Class-Path"]' build.xml
|
||||||
@ -664,6 +659,9 @@ LC_ALL=C.UTF-8 %{ant} test
|
|||||||
# -----------------------------------------------------------------------------
|
# -----------------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 16 2020 Fabio Valentini <decathorpe@gmail.com> - 0:1.10.8-6
|
||||||
|
- Remove workaround for jarsigner issues / RHBZ#1869017.
|
||||||
|
|
||||||
* Wed Sep 09 2020 Fabio Valentini <decathorpe@gmail.com> - 0:1.10.8-5
|
* Wed Sep 09 2020 Fabio Valentini <decathorpe@gmail.com> - 0:1.10.8-5
|
||||||
- Switch from log4j 1.2 compat package to log4j 1.2 API shim.
|
- Switch from log4j 1.2 compat package to log4j 1.2 API shim.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user