Remove patch already incorporated upstream
This commit is contained in:
parent
8e9448ca8d
commit
3b03f90c73
4
ant.spec
4
ant.spec
@ -65,7 +65,6 @@ URL: http://ant.apache.org/
|
||||
Group: Development/Build Tools
|
||||
Source0: http://www.apache.org/dist/ant/source/apache-ant-%{cvs_version}-src.tar.gz
|
||||
Source2: apache-ant-%{major_version}.ant.conf
|
||||
Patch1: apache-ant-1.6.5-rpm.patch
|
||||
# javah: BZ 157750
|
||||
# https://www.zarb.org/pipermail/jpackage-discuss/2005-September/008781.html
|
||||
# https://www.zarb.org/pipermail/jpackage-discuss/2005-September/008785.html
|
||||
@ -606,9 +605,6 @@ Javadoc pour %{name}.
|
||||
%prep
|
||||
%setup -q -n apache-ant-%{cvs_version}
|
||||
|
||||
# Build OPT_JAR_LIST from the contents of /etc/ant.d/
|
||||
%patch1 -p1
|
||||
|
||||
# #157750: make the javah task work with java-gcj-compat
|
||||
%patch2 -p1
|
||||
|
||||
|
@ -1,31 +0,0 @@
|
||||
--- apache-ant-1.6.5/src/script/ant.original 2005-10-27 17:06:55.000000000 -0400
|
||||
+++ apache-ant-1.6.5/src/script/ant 2005-10-27 17:08:45.000000000 -0400
|
||||
@@ -150,6 +150,28 @@
|
||||
# variable
|
||||
if $rpm_mode && [ -f /usr/bin/build-classpath ] ; then
|
||||
LOCALCLASSPATH="$(/usr/bin/build-classpath ant ant-launcher jaxp_parser_impl xml-commons-apis)"
|
||||
+
|
||||
+ # If no optional jars have been specified then build the default list
|
||||
+ if [ -z "$OPT_JAR_LIST" ] ; then
|
||||
+ for file in /etc/ant.d/*; do
|
||||
+ if [ -f "$file" ]; then
|
||||
+ case "$file" in
|
||||
+ *~) ;;
|
||||
+ *#*) ;;
|
||||
+ *.rpmsave) ;;
|
||||
+ *.rpmnew) ;;
|
||||
+ *)
|
||||
+ for dep in `cat "$file"`; do
|
||||
+ case "$OPT_JAR_LIST" in
|
||||
+ *"$dep"*) ;;
|
||||
+ *) OPT_JAR_LIST="$OPT_JAR_LIST${OPT_JAR_LIST:+ }$dep"
|
||||
+ esac
|
||||
+ done
|
||||
+ esac
|
||||
+ fi
|
||||
+ done
|
||||
+ fi
|
||||
+
|
||||
# If the user requested to try to add some other jars to the classpath
|
||||
if [ -n "$OPT_JAR_LIST" ] ; then
|
||||
_OPTCLASSPATH="$(/usr/bin/build-classpath $OPT_JAR_LIST 2> /dev/null)"
|
Loading…
Reference in New Issue
Block a user