Disable the style and xmlvalidate tasks on ppc64 and s390x (#163689)
This commit is contained in:
parent
8c7bb9de91
commit
20a4da3fa6
15
ant.spec
15
ant.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Name: ant
|
||||
Version: 1.6.2
|
||||
Release: 3jpp_12fc
|
||||
Release: 3jpp_13fc
|
||||
Epoch: 0
|
||||
Summary: Ant build tool for java
|
||||
Summary(it): Tool per la compilazione di programmi java
|
||||
@ -18,6 +18,7 @@ Patch0: apache-ant-%{version}.patch
|
||||
Patch1: apache-ant-%{version}-rpm.patch
|
||||
Patch3: apache-ant-bz157750.patch
|
||||
Patch4: apache-ant-jars.patch
|
||||
Patch5: apache-ant-bz163689.patch
|
||||
Requires: jaxp_parser_impl
|
||||
Requires: jpackage-utils >= 0:1.5
|
||||
Requires: java-devel
|
||||
@ -358,12 +359,17 @@ Javadoc pour %{name}.
|
||||
# Build OPT_JAR_LIST from the contents of /etc/ant.d/
|
||||
%patch1 -p1
|
||||
|
||||
# build the javah task (#157750) and make it work with java-gcj-compat
|
||||
# Build the javah task (#157750) and make it work with java-gcj-compat
|
||||
%patch3 -p1 -b .orig
|
||||
|
||||
# fix some places where copies of classes are included in the wrong jarfiles
|
||||
# Fix some places where copies of classes are included in the wrong jarfiles
|
||||
%patch4 -p1 -b .orig
|
||||
|
||||
# Disable the style and xmlvalidate tasks on ppc64 and s390x (#163689).
|
||||
%ifarch ppc64 s390x
|
||||
%patch5 -p1 -b .orig
|
||||
%endif
|
||||
|
||||
# clean jar files
|
||||
find . -name "*.jar" -exec rm -f {} \;
|
||||
|
||||
@ -738,6 +744,9 @@ fi
|
||||
# -----------------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Thu Jul 21 2005 Gary Benson <gbenson at redhat.com> 0:1.6.2-3jpp_13fc
|
||||
- Disable the style and xmlvalidate tasks on ppc64 and s390x (#163689).
|
||||
|
||||
* Mon Jul 18 2005 Gary Benson <gbenson at redhat.com> 0:1.6.2-3jpp_12fc
|
||||
- Built on ia64, ppc64, s390 and s390x.
|
||||
- Switch to aot-compile-rpm (also BC-compiles subpackages).
|
||||
|
87
apache-ant-bz163689.patch
Normal file
87
apache-ant-bz163689.patch
Normal file
@ -0,0 +1,87 @@
|
||||
--- apache-ant-1.6.2/src/main/org/apache/tools/ant/taskdefs/optional/TraXLiaison.java~ 2004-07-16 08:57:36.000000000 +0100
|
||||
+++ apache-ant-1.6.2/src/main/org/apache/tools/ant/taskdefs/optional/TraXLiaison.java 2005-07-21 17:05:18.000000000 +0100
|
||||
@@ -119,39 +119,12 @@
|
||||
}
|
||||
|
||||
public void transform(File infile, File outfile) throws Exception {
|
||||
- if (transformer == null) {
|
||||
- createTransformer();
|
||||
- }
|
||||
-
|
||||
- InputStream fis = null;
|
||||
- OutputStream fos = null;
|
||||
- try {
|
||||
- fis = new BufferedInputStream(new FileInputStream(infile));
|
||||
- fos = new BufferedOutputStream(new FileOutputStream(outfile));
|
||||
- StreamResult res = new StreamResult(fos);
|
||||
- // not sure what could be the need of this...
|
||||
- res.setSystemId(JAXPUtils.getSystemId(outfile));
|
||||
- Source src = getSource(fis, infile);
|
||||
- transformer.transform(src, res);
|
||||
- } finally {
|
||||
- // make sure to close all handles, otherwise the garbage
|
||||
- // collector will close them...whenever possible and
|
||||
- // Windows may complain about not being able to delete files.
|
||||
- try {
|
||||
- if (fis != null) {
|
||||
- fis.close();
|
||||
- }
|
||||
- } catch (IOException ignored) {
|
||||
- // ignore
|
||||
- }
|
||||
- try {
|
||||
- if (fos != null) {
|
||||
- fos.close();
|
||||
- }
|
||||
- } catch (IOException ignored) {
|
||||
- // ignore
|
||||
- }
|
||||
+ if (logger != null) {
|
||||
+ logger.log("The style task is disabled on this platform");
|
||||
+ logger.log(
|
||||
+ "http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=163689");
|
||||
}
|
||||
+ new FileOutputStream(outfile).close();
|
||||
}
|
||||
|
||||
/**
|
||||
--- apache-ant-1.6.2/src/main/org/apache/tools/ant/taskdefs/optional/XMLValidateTask.java~ 2004-07-16 08:57:36.000000000 +0100
|
||||
+++ apache-ant-1.6.2/src/main/org/apache/tools/ant/taskdefs/optional/XMLValidateTask.java 2005-07-21 17:37:23.000000000 +0100
|
||||
@@ -272,35 +272,8 @@
|
||||
"Specify at least one source - " + "a file or a fileset.");
|
||||
}
|
||||
|
||||
- initValidator();
|
||||
-
|
||||
- if (file != null) {
|
||||
- if (file.exists() && file.canRead() && file.isFile()) {
|
||||
- doValidate(file);
|
||||
- fileProcessed++;
|
||||
- } else {
|
||||
- String errorMsg = "File " + file + " cannot be read";
|
||||
- if (failOnError) {
|
||||
- throw new BuildException(errorMsg);
|
||||
- } else {
|
||||
- log(errorMsg, Project.MSG_ERR);
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- for (int i = 0; i < filesets.size(); i++) {
|
||||
-
|
||||
- FileSet fs = (FileSet) filesets.elementAt(i);
|
||||
- DirectoryScanner ds = fs.getDirectoryScanner(getProject());
|
||||
- String[] files = ds.getIncludedFiles();
|
||||
-
|
||||
- for (int j = 0; j < files.length; j++) {
|
||||
- File srcFile = new File(fs.getDir(getProject()), files[j]);
|
||||
- doValidate(srcFile);
|
||||
- fileProcessed++;
|
||||
- }
|
||||
- }
|
||||
- log(fileProcessed + " file(s) have been successfully validated.");
|
||||
+ log("The xmlvalidate task is disabled on this platform");
|
||||
+ log("http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=163689");
|
||||
}
|
||||
|
||||
/**
|
Loading…
Reference in New Issue
Block a user