diff --git a/ant-contrib-1.0b3.pom b/ant-contrib-1.0b3.pom
new file mode 100644
index 0000000..59dea4a
--- /dev/null
+++ b/ant-contrib-1.0b3.pom
@@ -0,0 +1,25 @@
+
+ 4.0.0
+ ant-contrib
+ ant-contrib
+ jar
+ Ant-Contrib Tasks
+ 1.0b3
+ http://ant-contrib.sourceforge.net
+
+
+ http://ant-contrib.sourceforge.net/tasks/LICENSE.txt
+
+
+
+ https://svn.sourceforge.net/svnroot/ant-contrib ant-contrib
+
+ A collection of tasks (and at one point maybe types and other tools) for Apache Ant
+
+
+ ant
+ ant
+ 1.5
+
+
+
diff --git a/ant-contrib-pom.patch b/ant-contrib-pom.patch
new file mode 100644
index 0000000..e6d42f3
--- /dev/null
+++ b/ant-contrib-pom.patch
@@ -0,0 +1,13 @@
+diff --git a/ant-contrib-1.0b3.pom b/ant-contrib-1.0b3.pom
+index 59dea4a..ca99233 100644
+--- a/ant-contrib-1.0b3.pom
++++ b/ant-contrib-1.0b3.pom
+@@ -17,7 +17,7 @@
+ A collection of tasks (and at one point maybe types and other tools) for Apache Ant
+
+
+- ant
++ org.apache.ant
+ ant
+ 1.5
+
diff --git a/ant-contrib.spec b/ant-contrib.spec
index 47b9063..9a133ce 100644
--- a/ant-contrib.spec
+++ b/ant-contrib.spec
@@ -3,27 +3,28 @@
Summary: Collection of tasks for Ant
Name: ant-contrib
Version: 1.0
-Release: 0.32.%{beta_number}%{?dist}
+Release: 0.23.%{beta_number}%{?dist}
License: ASL 2.0 and ASL 1.1
URL: http://ant-contrib.sourceforge.net/
+Group: Development/Libraries
Source0: https://downloads.sourceforge.net/project/ant-contrib/ant-contrib/1.0b3/ant-contrib-1.0b3-src.tar.bz2
+Source1: http://mirrors.ibiblio.org/pub/mirrors/maven2/%{name}/%{name}/1.0b3/%{name}-1.0b3.pom
# ASL 2.0 Licence text
# Upstream bug at https://sourceforge.net/tracker/?func=detail&aid=3590371&group_id=36177&atid=416920
Source2: http://www.apache.org/licenses/LICENSE-2.0.txt
+Patch0: local-ivy.patch
Patch2: %{name}-antservertest.patch
-BuildRequires: ivy-local
-BuildRequires: junit
-BuildRequires: ant-junit
+Patch3: %{name}-pom.patch
+BuildRequires: jpackage-utils >= 1.5
+BuildRequires: junit >= 3.8.0
+BuildRequires: ant-junit >= 1.6.2
BuildRequires: xerces-j2
-BuildRequires: bcel
-BuildRequires: java-devel
+BuildRequires: bcel >= 5.0
+BuildRequires: java-devel >= 1.4.2
BuildRequires: apache-ivy
-BuildRequires: jakarta-commons-httpclient
-BuildRequires: apache-commons-logging
-BuildRequires: apache-commons-parent
-Requires: java-headless
-Requires: junit
-Requires: ant
+Requires: java >= 1.4.2
+Requires: junit >= 3.8.0
+Requires: ant >= 1.6.2
Requires: xerces-j2
BuildArch: noarch
@@ -42,8 +43,12 @@ Api documentation for %{name}.
%prep
%setup -q -n %{name}
+%patch0 -b .sav
%patch2
+cp %{SOURCE1} %{name}-1.0b3.pom
+%patch3 -p1
+
cp %{SOURCE2} LICENSE-2.0.txt
find -name '*.class' -exec rm -f '{}' \;
@@ -53,63 +58,44 @@ sed -i "s|xercesImpl|xerces-j2|g" ivy.xml
# needs porting to latest ivy
rm -fr src/java/net/sf/antcontrib/net/URLImportTask.java
-sed -i '/ $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ant-contrib
+echo "ant/ant-contrib" > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ant-contrib
-%files -f .mfiles
+install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
+install -pm 644 %{name}-1.0b3.pom $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP.ant-%{name}.pom
+
+%add_maven_depmap JPP.ant-%{name}.pom ant/%{name}.jar
+
+%files
%{_sysconfdir}/ant.d/ant-contrib
+%{_javadir}/ant/*.jar
+%{_mavenpomdir}/*
+%{_mavendepmapfragdir}/*
%doc target/docs/LICENSE.txt LICENSE-2.0.txt
%doc target/docs/manual/tasks/*
-%files javadoc -f .mfiles-javadoc
+%files javadoc
%doc target/docs/LICENSE.txt LICENSE-2.0.txt
+%doc %{_javadocdir}/%{name}
%changelog
-* Wed Feb 07 2018 Fedora Release Engineering - 1.0-0.32.b3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+* Fri Dec 27 2013 Daniel Mach - 1.0-0.23.b3
+- Mass rebuild 2013-12-27
-* Wed Jul 26 2017 Fedora Release Engineering - 1.0-0.31.b3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
-
-* Fri Feb 10 2017 Fedora Release Engineering - 1.0-0.30.b3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
-
-* Wed Feb 03 2016 Fedora Release Engineering - 1.0-0.29.b3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
-
-* Tue Jun 16 2015 Fedora Release Engineering - 1.0-0.28.b3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
-
-* Tue Sep 09 2014 Clément David - 1.0-0.27.b3
-- Fix incorrect ant.d path.
-
-* Mon Aug 11 2014 Mikolaj Izdebski - 1.0-0.26.b3
-- Build using XMvn Ivy resolver
-
-* Sat Jun 07 2014 Fedora Release Engineering - 1.0-0.25.b3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
-
-* Wed May 21 2014 Mikolaj Izdebski - 1.0-0.24.b3
-- Use .mfiles generated during build
-
-* Tue Mar 04 2014 Stanislav Ochotnicky - 1.0-0.23.b3
-- Use Requires: java-headless rebuild (#1067528)
-
-* Sat Aug 03 2013 Fedora Release Engineering - 1.0-0.22.b3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+* Fri Jun 28 2013 Mikolaj Izdebski - 1.0-0.22.b3
+- Rebuild to regenerate API documentation
+- Resolves: CVE-2013-1571
* Wed Feb 13 2013 Fedora Release Engineering - 1.0-0.21.b3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
diff --git a/local-ivy.patch b/local-ivy.patch
new file mode 100644
index 0000000..a8627e7
--- /dev/null
+++ b/local-ivy.patch
@@ -0,0 +1,43 @@
+--- build.xml.sav 2006-11-02 18:44:02.000000000 +0200
++++ build.xml 2011-12-15 13:36:38.630460824 +0200
+@@ -20,22 +20,7 @@
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
++
+
+
+
+--- ivy-conf.xml.sav 2006-10-28 14:57:58.000000000 +0300
++++ ivy-conf.xml 2011-12-15 14:35:15.155840710 +0200
+@@ -5,11 +5,11 @@
+
+
+
+-
+-
++
++
+
+
+-
++
+
+
+
diff --git a/sources b/sources
index ae5e96f..98b492e 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (ant-contrib-1.0b3-src.tar.bz2) = 8147ed51612eed9d41515c00ef2bb7210ebd50dba8b471abfadf8a56c67b53c030602ce9e49e9070d72d383de61f290e941a76c282e223330fee606f3633b0a8
+SHA1 (ant-contrib-1.0b3-src.tar.bz2) = 23694f563392959d8b152ef86e67747674491761