Annocheck: Skip FORTIFY and GLIBC_ASSERTIONS tests for LLVM produced binaries with unparseable DW_AT_producer attributes in their DWARF debug info.
Resolves: RHEL-65411
This commit is contained in:
parent
852c9e5d6a
commit
d63f7a9836
21
annobin-gcc-plugin-input-filename.patch
Normal file
21
annobin-gcc-plugin-input-filename.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- annobin.orig/gcc-plugin/annobin.cc 2024-11-04 10:17:09.628685926 +0000
|
||||
+++ annobin-12.72/gcc-plugin/annobin.cc 2024-11-04 10:18:01.542935615 +0000
|
||||
@@ -540,7 +540,17 @@ annobin_gen_string_note (annobin_functio
|
||||
|
||||
if (use_extended_string)
|
||||
{
|
||||
- size_t len = strlen (annobin_note_buffer) + 1 + strlen (annobin_input_filename);
|
||||
+ // For some reason this is happening with RHEL-10 builds.
|
||||
+ if (annobin_input_filename == NULL)
|
||||
+ {
|
||||
+ if (!init_annobin_input_filename ())
|
||||
+ {
|
||||
+ ice ("annobin_gen_string_note called without an input filename\n");
|
||||
+ return;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ size_t len = strlen (dst) + 1 + strlen (annobin_input_filename);
|
||||
|
||||
if (! is_global (info))
|
||||
len += strlen (get_func_name (info)) + 1;
|
26
annobin.spec
26
annobin.spec
@ -1,8 +1,8 @@
|
||||
|
||||
Name: annobin
|
||||
Summary: Annotate and examine compiled binary files
|
||||
Version: 12.55
|
||||
Release: 3%{?dist}
|
||||
Version: 12.72
|
||||
Release: 1%{?dist}
|
||||
License: GPL-3.0-or-later AND LGPL-2.0-or-later AND (GPL-2.0-or-later WITH GCC-exception-2.0) AND (LGPL-2.0-or-later WITH GCC-exception-2.0) AND GFDL-1.3-or-later
|
||||
URL: https://sourceware.org/annobin/
|
||||
# Maintainer: nickc@redhat.com
|
||||
@ -73,6 +73,7 @@ Source: https://nickc.fedorapeople.org/%{annobin_sources}
|
||||
|
||||
# Insert patches here, if needed. Eg:
|
||||
# Patch01: annobin-plugin-default-string-notes.patch
|
||||
Patch01: annobin-gcc-plugin-input-filename.patch
|
||||
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
@ -532,6 +533,27 @@ make check
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Fri Nov 01 2024 Nick Clifton <nickc@redhat.com> - 12.72-1
|
||||
- Annocheck: Skip FORTIFY and GLIBC_ASSERTIONS tests for LLVM produced binaries with unparseable DW_AT_producer attributes in their DWARF debug info. (RHEL-65411)
|
||||
- GCC Plugin: Change type of the .annobin.notes section from SHT_STRTAB to SHT_PROGBITS.
|
||||
- Clang & LLVM Plugins: Include install directory in binary. (RHEL-54069)
|
||||
- BuiltBy: Fix seg-fault when comparing language version strings. (RHEL-53497)
|
||||
- Annocheck: Stop spurious assembler warnings. (RHEL-53213)
|
||||
- Annocheck: Stop warnings about known gaps. (RHEL-53218)
|
||||
- Annocheck: Fix stack realign test. (#2302427)
|
||||
- Annocheck: Fix recording arguments for later re-use. (RHEL-50802)
|
||||
- GCC Plugin: Fix building AArch64 components with gcc earlier than 11.3.
|
||||
- Annocheck: Add improvements to the builtby utility.
|
||||
- Annocheck: Add support for ADA binaries.
|
||||
- Annocheck: Add support for binaries built from more than two high level source languages.
|
||||
- Annocheck: Add support for object files containing no executable code.
|
||||
- Annocheck: Do not FAIL LLVM compiled binaries that have not been built with sanitize-cfi and/or sanitize-safe-stack.
|
||||
- Annocheck: Add support for Fortran binaries.
|
||||
- Annocheck: Add heuristic for detecting parts of the CGO runtime library.
|
||||
- Annocheck: Add improvements for handling Clang runtime binaries.
|
||||
- Annocheck: Add tweaks for mixed Rust/C binaries. (#2284605)
|
||||
- Annocheck: Add more glibc source file names.
|
||||
|
||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 12.55-3
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
Resolves: RHEL-64018
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (annobin-12.55.tar.xz) = b63f866c997487bf4f9638dc5fd5bc76dab6ca1c437b05e745e410c9ca04e0ca8d7b4f89ebf855437a2413ef2b0695dfdbade38666eb4474c111de903ca8312c
|
||||
SHA512 (annobin-12.72.tar.xz) = 314bccd27be7814ebc01e03e1f4fd587fde9cd07c6b89d9cd83d05bb0eb82e4b56e055996238a4e5db63cc6dc4d452198945096047f0f329711ced5b49916a9a
|
||||
|
Loading…
Reference in New Issue
Block a user