Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/annobin.git#3ed514a41ce9d1d5ae17bef21c4c8425ce680e5a
This commit is contained in:
parent
d59752eb01
commit
8a9708fecd
@ -1,36 +0,0 @@
|
||||
--- a/gcc-plugin/annobin.cc 2020-12-02 11:59:10.000000000 +0100
|
||||
+++ b/gcc-plugin/annobin.cc 2020-12-06 11:44:44.446266880 +0100
|
||||
@@ -752,12 +752,12 @@ annobin_get_str_option_by_name (const ch
|
||||
#if GCCPLUGIN_VERSION_MAJOR >= 11
|
||||
/* GCC version 11 introduced the cl_vars array which provides offsets for
|
||||
fields in global_options which are not handled by cl_options. */
|
||||
- struct cl_var * var = cl_vars;
|
||||
+ const struct cl_var * var = cl_vars;
|
||||
|
||||
- for (var = cl_vars; var->name != NULL; var ++)
|
||||
- if (strmp (var->name, name) == 0)
|
||||
+ for (var = cl_vars; var->var_name != NULL; var ++)
|
||||
+ if (strcmp (var->var_name, name) == 0)
|
||||
// FIXME: Cache the result ?
|
||||
- return (const char *) (* (const char **) (((char *) annobin_global_options) + var->var_offset));
|
||||
+ return * (const char **) (((char *) annobin_global_options) + var->var_offset);
|
||||
|
||||
annobin_inform (INFORM_VERBOSE, "WARN: gcc variable '%s' not found within cl_vars array", name);
|
||||
#endif
|
||||
@@ -772,12 +772,12 @@ annobin_get_int_option_by_name (const ch
|
||||
#if GCCPLUGIN_VERSION_MAJOR >= 11
|
||||
/* GCC version 11 introduced the cl_vars array which provides offsets for
|
||||
fields in global_options which are not handled by cl_options. */
|
||||
- struct cl_var * var = cl_vars;
|
||||
+ const struct cl_var * var = cl_vars;
|
||||
|
||||
- for (var = cl_vars; var->name != NULL; var ++)
|
||||
- if (strmp (var->name, name) == 0)
|
||||
+ for (var = cl_vars; var->var_name != NULL; var ++)
|
||||
+ if (strcmp (var->var_name, name) == 0)
|
||||
// FIXME: Cache the result ?
|
||||
- return (const int) (* (const int **) (((char *) annobin_global_options) + var->var_offset));
|
||||
+ return * (int *) (((char *) annobin_global_options) + var->var_offset);
|
||||
|
||||
annobin_inform (INFORM_VERBOSE, "WARN: gcc variable '%s' not found within cl_vars array", name);
|
||||
#endif
|
23
annobin.spec
23
annobin.spec
@ -1,8 +1,8 @@
|
||||
|
||||
Name: annobin
|
||||
Summary: Annotate and examine compiled binary files
|
||||
Version: 9.48
|
||||
Release: 4%{?dist}
|
||||
Version: 9.46
|
||||
Release: 2%{?dist}
|
||||
License: GPLv3+
|
||||
# ProtocolURL: https://fedoraproject.org/wiki/Toolchain/Watermark
|
||||
# Maintainer: nickc@redhat.com
|
||||
@ -36,7 +36,7 @@ License: GPLv3+
|
||||
# checking logic or when building on RHEL-7 or earlier.
|
||||
%global with_hard_gcc_version_requirement 1
|
||||
|
||||
%bcond_without plugin_rebuild
|
||||
%bcond_with plugin_rebuild
|
||||
# Allow the building of annobin without using annobin itself.
|
||||
# This is because if we are bootstrapping a new build environment we can have
|
||||
# a new version of gcc installed, but without a new of annobin installed.
|
||||
@ -57,7 +57,7 @@ Source: https://nickc.fedorapeople.org/annobin-%{version}.tar.xz
|
||||
# For the latest sources use: git clone git://sourceware.org/git/annobin.git
|
||||
|
||||
# Insert patches here, if needed.
|
||||
Patch01: annobin-gcc11.patch
|
||||
# Patch01: annobin-xxx.patch
|
||||
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
@ -323,21 +323,6 @@ fi
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Sun Dec 06 2020 Jakub Jelinek <jakub@redhat.com> - 9.48-4
|
||||
- Revert back to previous settings.
|
||||
|
||||
* Sun Dec 06 2020 Jakub Jelinek <jakub@redhat.com> - 9.48-3
|
||||
- Another NVR bump for GCC 11 rebuild.
|
||||
|
||||
* Sun Dec 06 2020 Jakub Jelinek <jakub@redhat.com> - 9.48-2
|
||||
- NVR bump for GCC 11 rebuild.
|
||||
|
||||
* Wed Dec 02 2020 Nick Clifton <nickc@redhat.com> - 9.48-1
|
||||
- gcc plugin: Tweak generation of end symbols for PPC64 when LTO is active. (#1898075)
|
||||
|
||||
* Tue Dec 01 2020 Nick Clifton <nickc@redhat.com> - 9.47-1
|
||||
- gcc plugin: Add support for GCC 11's cl_vars array.
|
||||
|
||||
* Fri Nov 27 2020 Jakub Jelinek <jakub@redhat.com> - 9.46-2
|
||||
- NVR bump for another ELN sidetag rebuild.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (annobin-9.48.tar.xz) = 9844cf1129947d70453f2403b2e27e570d2a4fc3f6efc52df74fe32708e7cd7be2ba5fdd2a9a50cec96ca10ccab825383efef86d5476794de6b574b761de5c3f
|
||||
SHA512 (annobin-9.46.tar.xz) = f040247a48319f7b3c4e897431b3208c6cdf5eba0f1df716297193cd0bff611558f233e3a64ac81218314bda981e3567ad4ca89e3a94ebdbd5a610126b7bbc5d
|
||||
|
Loading…
Reference in New Issue
Block a user