Rebuild for LLVM 13.0.0-rc1
This commit is contained in:
parent
c76d8664da
commit
438dd33afc
@ -0,0 +1,27 @@
|
||||
From bda340f0754972944ec115a72f1a8547ffa21f1c Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Mon, 16 Aug 2021 18:04:53 +0000
|
||||
Subject: [PATCH] llvm-plugin: Add -flegacy-pass-manager option to the test
|
||||
case
|
||||
|
||||
The plugin does not work with the new pass manager yet.
|
||||
---
|
||||
llvm-plugin/Makefile.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/llvm-plugin/Makefile.in b/llvm-plugin/Makefile.in
|
||||
index bdd8b19..92bcc9a 100644
|
||||
--- a/llvm-plugin/Makefile.in
|
||||
+++ b/llvm-plugin/Makefile.in
|
||||
@@ -48,7 +48,7 @@ PLUGIN_TEST_OPTIONS = \
|
||||
# -fcf-protection \
|
||||
|
||||
check: @srcdir@/hello.c
|
||||
- @ $(CLANG) -Xclang -load -Xclang $(PLUGIN) $(PLUGIN_TEST_OPTIONS) -c @srcdir@/hello.c
|
||||
+ @ $(CLANG) -flegacy-pass-manager -Xclang -load -Xclang $(PLUGIN) $(PLUGIN_TEST_OPTIONS) -c @srcdir@/hello.c
|
||||
@ $(READELF) --wide --notes hello.o > llvm-plugin-test.out
|
||||
@ grep --silent -e "annobin built by llvm version" llvm-plugin-test.out
|
||||
@ grep --silent -e "running on LLVM version" llvm-plugin-test.out
|
||||
--
|
||||
2.26.2
|
||||
|
@ -2,7 +2,7 @@
|
||||
Name: annobin
|
||||
Summary: Annotate and examine compiled binary files
|
||||
Version: 9.87
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv3+
|
||||
# Maintainer: nickc@redhat.com
|
||||
# Web Page: https://sourceware.org/annobin/
|
||||
@ -61,6 +61,9 @@ Source: https://nickc.fedorapeople.org/annobin-%{version}.tar.xz
|
||||
|
||||
# Insert patches here, if needed. Eg:
|
||||
# Patch01: annobin-foo.patch
|
||||
# We need to force use of legacy pass manager until annobin is ported to the new
|
||||
# pass manager.
|
||||
Patch0: 0001-llvm-plugin-Add-flegacy-pass-manager-option-to-the-t.patch
|
||||
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
@ -460,6 +463,9 @@ fi
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Wed Aug 16 2021 Tom Stellard <tstellar@redhat.com> - 9.87-2
|
||||
- Rebuild for LLVM 13.0.0-rc1
|
||||
|
||||
* Mon Aug 16 2021 Nick Clifton <nickc@redhat.com> - 9.87-1
|
||||
- Annocheck: Fix memory corruption. (#1988715)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user