import annobin-9.72-1.el8_5.2
This commit is contained in:
parent
256ec6cb61
commit
0838e4a573
@ -1 +1 @@
|
||||
8f065c03bd8a5b86e99a66cfc9caa28ea362793f SOURCES/annobin-9.65.tar.xz
|
||||
ef2dd2da3cf83071af47dfa2fd95309e18317dd4 SOURCES/annobin-9.72.tar.xz
|
||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/annobin-9.65.tar.xz
|
||||
SOURCES/annobin-9.72.tar.xz
|
||||
|
12
SOURCES/annobin-nop.patch
Normal file
12
SOURCES/annobin-nop.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -rup annobin.orig/gcc-plugin/annobin.cc annobin-9.72/gcc-plugin/annobin.cc
|
||||
--- annobin.orig/gcc-plugin/annobin.cc 2021-05-17 17:25:32.693441649 +0100
|
||||
+++ annobin-9.72/gcc-plugin/annobin.cc 2021-05-17 17:25:50.176331776 +0100
|
||||
@@ -1722,7 +1722,7 @@ annobin_emit_start_sym_and_version_note
|
||||
Ensure that we do not have empty special text sections so that the
|
||||
annobin start symbols are never beyond the end of the sections. */
|
||||
if (* suffix && enable_ppc64_nops)
|
||||
- annobin_emit_asm (".nop", "Inserted by the annobin plugin. Disable with -fplugin-arg-annobin-no-ppc64-nops");
|
||||
+ annobin_emit_asm ("nop", "Inserted by the annobin plugin. Disable with -fplugin-arg-annobin-no-ppc64-nops");
|
||||
}
|
||||
else
|
||||
fprintf (asm_out_file, "\t.equiv %s%s, .\n", annobin_output_filesym, suffix);
|
@ -1,31 +0,0 @@
|
||||
diff --git a/annocheck/hardened.c b/annocheck/hardened.c
|
||||
index d41c740..83645a7 100644
|
||||
--- a/annocheck/hardened.c
|
||||
+++ b/annocheck/hardened.c
|
||||
@@ -3523,8 +3523,12 @@ finish (annocheck_data * data)
|
||||
case TEST_STACK_PROT:
|
||||
if (per_file.current_tool == TOOL_GO)
|
||||
skip (data, i, SOURCE_FINAL_SCAN, "GO is stack safe");
|
||||
+ else if (per_file.seen_tools == TOOL_GAS
|
||||
+ || (per_file.gcc_from_comment && per_file.seen_tools == (TOOL_GAS | TOOL_GCC)))
|
||||
+ skip (data, i, SOURCE_FINAL_SCAN, "no compiled code found");
|
||||
else if (is_C_compiler (per_file.seen_tools))
|
||||
- maybe (data, i, SOURCE_FINAL_SCAN, "no valid notes found regarding this test");
|
||||
+ /* The skip is necessary because some glibc code is built this way. */
|
||||
+ skip (data, i, SOURCE_FINAL_SCAN, "no notes found regarding this feature");
|
||||
else
|
||||
skip (data, i, SOURCE_FINAL_SCAN, "not compiled code");
|
||||
break;
|
||||
diff --git a/tests/glibc-notes-test b/tests/glibc-notes-test
|
||||
index ab9e639..8496af8 100755
|
||||
--- a/tests/glibc-notes-test
|
||||
+++ b/tests/glibc-notes-test
|
||||
@@ -31,7 +31,7 @@ $GCC -pie -Wl,-z,now hello.o hello2.o hello3.o -L. -lhello -o glibc-notes.exe
|
||||
|
||||
# Run annocheck
|
||||
|
||||
-$ANNOCHECK glibc-notes.exe --skip-cf-protection --skip-property-note --ignore-gaps > glibc-notes.out
|
||||
+$ANNOCHECK glibc-notes.exe --skip-cf-protection --skip-property-note --skip-stack-realign --ignore-gaps > glibc-notes.out
|
||||
grep -e "PASS" glibc-notes.out
|
||||
if [ $? != 0 ];
|
||||
then
|
412
SOURCES/annobin.unicode.patch
Normal file
412
SOURCES/annobin.unicode.patch
Normal file
@ -0,0 +1,412 @@
|
||||
--- /dev/null 2021-10-25 08:23:06.499675237 +0100
|
||||
+++ annobin-9.85/tests/unicode-test 2021-10-26 17:50:14.620383879 +0100
|
||||
@@ -0,0 +1,45 @@
|
||||
+#!/bin/bash
|
||||
+
|
||||
+# Copyright (c) 2021 Red Hat.
|
||||
+#
|
||||
+# This is free software; you can redistribute it and/or modify it
|
||||
+# under the terms of the GNU General Public License as published
|
||||
+# by the Free Software Foundation; either version 3, or (at your
|
||||
+# option) any later version.
|
||||
+#
|
||||
+# It is distributed in the hope that it will be useful, but
|
||||
+# WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+
|
||||
+TEST_NAME=unicode
|
||||
+. $srcdir/common.sh
|
||||
+
|
||||
+OPTS="-O2 -g -Wl,-z,now -pie -fpie"
|
||||
+
|
||||
+start_test
|
||||
+
|
||||
+$GCC $OPTS $srcdir/trick-hello.s -o trick-hello.exe
|
||||
+if [ $? != 0 ];
|
||||
+then
|
||||
+ echo "unicode-test: FAIL: Could not compile test source file"
|
||||
+ end_test
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
+# Run annocheck
|
||||
+
|
||||
+OPTS="--ignore-gaps --skip-all --test-unicode"
|
||||
+
|
||||
+$ANNOCHECK trick-hello.exe $OPTS > unicode.out
|
||||
+grep -e "FAIL: unicode" unicode.out
|
||||
+if [ $? != 0 ];
|
||||
+then
|
||||
+ echo "unicode-test: FAIL: annocheck did not detect suspicious symbol names"
|
||||
+ $ANNOCHECK trick-hello.exe $OPTS --verbose
|
||||
+ end_test
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
+end_test
|
||||
+
|
||||
--- /dev/null 2021-10-25 08:23:06.499675237 +0100
|
||||
+++ annobin-9.85/tests/trick-hello.s 2021-10-26 17:15:25.803197562 +0100
|
||||
@@ -0,0 +1,33 @@
|
||||
+ .file "trick-hello.c"
|
||||
+ .text
|
||||
+ .section .rodata
|
||||
+.LC0:
|
||||
+ .string "hah, gotcha!"
|
||||
+ .text
|
||||
+ .globl heoll
|
||||
+ .type heoll, @function
|
||||
+heoll:
|
||||
+.LFB0:
|
||||
+ nop
|
||||
+.LFE0:
|
||||
+ .size heoll, .-heoll
|
||||
+ .section .rodata
|
||||
+.LC1:
|
||||
+ .string "Hello world"
|
||||
+ .text
|
||||
+ .globl hello
|
||||
+ .type hello, @function
|
||||
+hello:
|
||||
+.LFB1:
|
||||
+ nop
|
||||
+.LFE1:
|
||||
+ .size hello, .-hello
|
||||
+ .globl main
|
||||
+ .type main, @function
|
||||
+main:
|
||||
+.LFB2:
|
||||
+ nop
|
||||
+.LFE2:
|
||||
+ .size main, .-main
|
||||
+ .ident "GCC: (GNU) 11.2.1 20210728 (Red Hat 11.2.1-1)"
|
||||
+ .section .note.GNU-stack,"",@progbits
|
||||
diff -rup annobin.orig/Makefile.in annobin-9.72/Makefile.in
|
||||
--- annobin.orig/Makefile.in 2021-10-27 17:34:09.438721166 +0100
|
||||
+++ annobin-9.72/Makefile.in 2021-10-27 17:34:19.226658425 +0100
|
||||
@@ -323,6 +323,7 @@ plugindir = @plugindir@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
psdir = @psdir@
|
||||
+runstatedir = @runstatedir@
|
||||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
srcdir = @srcdir@
|
||||
diff -rup annobin.orig/annocheck/Makefile.in annobin-9.72/annocheck/Makefile.in
|
||||
--- annobin.orig/annocheck/Makefile.in 2021-10-27 17:34:09.443721134 +0100
|
||||
+++ annobin-9.72/annocheck/Makefile.in 2021-10-27 17:34:19.227658419 +0100
|
||||
@@ -314,6 +314,7 @@ plugindir = @plugindir@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
psdir = @psdir@
|
||||
+runstatedir = @runstatedir@
|
||||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
srcdir = @srcdir@
|
||||
diff -rup annobin.orig/annocheck/hardened.c annobin-9.72/annocheck/hardened.c
|
||||
--- annobin.orig/annocheck/hardened.c 2021-10-27 17:34:09.443721134 +0100
|
||||
+++ annobin-9.72/annocheck/hardened.c 2021-10-27 17:35:14.200306024 +0100
|
||||
@@ -37,7 +37,8 @@
|
||||
#define SOURCE_SEGMENT_CONTENTS "segment contents"
|
||||
#define SOURCE_SEGMENT_HEADERS "segment headers"
|
||||
#define SOURCE_STRING_SECTION "string section"
|
||||
-#define SOURCE_COMMENT_SECTION "comment section"
|
||||
+#define SOURCE_COMMENT_SECTION "comment section"
|
||||
+#define SOURCE_SYMBOL_SECTION "symbol section"
|
||||
|
||||
#define GOLD_COLOUR "\e[33;40m"
|
||||
#define RED_COLOUR "\x1B[31;47m"
|
||||
@@ -199,6 +200,7 @@ enum test_index
|
||||
TEST_STACK_REALIGN,
|
||||
TEST_TEXTREL,
|
||||
TEST_THREADS,
|
||||
+ TEST_UNICODE,
|
||||
TEST_WARNINGS,
|
||||
TEST_WRITEABLE_GOT,
|
||||
|
||||
@@ -243,6 +245,7 @@ static test tests [TEST_MAX] =
|
||||
TEST (stack-realign, STACK_REALIGN, "Compiled with -mstackrealign (i686 only)"),
|
||||
TEST (textrel, TEXTREL, "There are no text relocations in the binary"),
|
||||
TEST (threads, THREADS, "Compiled with -fexceptions"),
|
||||
+ TEST (unicode, UNICODE, "No unicode symbol names"),
|
||||
TEST (warnings, WARNINGS, "Compiled with -Wall"),
|
||||
TEST (writeable-got, WRITEABLE_GOT, "The .got section is not writeable"),
|
||||
};
|
||||
@@ -1099,6 +1102,11 @@ interesting_sec (annocheck_data * da
|
||||
if (streq (sec->secname, ".gdb_index"))
|
||||
per_file.debuginfo_file = true;
|
||||
|
||||
+ if (tests[TEST_UNICODE].enabled
|
||||
+ && (sec->shdr.sh_type == SHT_SYMTAB
|
||||
+ || sec->shdr.sh_type == SHT_DYNSYM))
|
||||
+ return true;
|
||||
+
|
||||
if (streq (sec->secname, ".text"))
|
||||
{
|
||||
/* Separate debuginfo files have a .text section with a non-zero
|
||||
@@ -2829,6 +2837,64 @@ check_code_section (annocheck_data *
|
||||
}
|
||||
|
||||
static bool
|
||||
+contains_suspicious_characters (const unsigned char * name)
|
||||
+{
|
||||
+ uint i;
|
||||
+ uint len = strlen ((const char *) name);
|
||||
+
|
||||
+ /* FIXME: Test that locale is UTF-8. */
|
||||
+
|
||||
+ for (i = 0; i < len; i++)
|
||||
+ {
|
||||
+ unsigned char c = name[i];
|
||||
+
|
||||
+ if (isgraph (c))
|
||||
+ continue;
|
||||
+
|
||||
+ /* Control characters are always suspect. So are spaces and DEL */
|
||||
+ if (iscntrl (c) || c == ' ' || c == 0x7f)
|
||||
+ return true;
|
||||
+
|
||||
+ if (c < 0x7f) /* This test is probably redundant. */
|
||||
+ continue;
|
||||
+
|
||||
+ return true;
|
||||
+ }
|
||||
+
|
||||
+ return false;
|
||||
+}
|
||||
+
|
||||
+static bool
|
||||
+check_symbol_section (annocheck_data * data, annocheck_section * sec)
|
||||
+{
|
||||
+ if (! tests[TEST_UNICODE].enabled)
|
||||
+ return true;
|
||||
+
|
||||
+ /* Scan the symbols looking for non-ASCII characters in their names
|
||||
+ that might cause problems. Note - we do not examine the string
|
||||
+ tables directly as there are perfectly legitimate reasons why these
|
||||
+ characters might appear in strings. But when they are used for
|
||||
+ identifier names, their use is ... problematic. */
|
||||
+ GElf_Sym sym;
|
||||
+ uint symndx;
|
||||
+
|
||||
+ for (symndx = 1; gelf_getsym (sec->data, symndx, & sym) != NULL; symndx++)
|
||||
+ {
|
||||
+ const char * symname = elf_strptr (data->elf, sec->shdr.sh_link, sym.st_name);
|
||||
+
|
||||
+ if (contains_suspicious_characters ((const unsigned char *) symname))
|
||||
+ {
|
||||
+ fail (data, TEST_UNICODE, SOURCE_SYMBOL_SECTION, "suspicious characters were found in a symbol name");
|
||||
+ einfo (VERBOSE, "%s: info: symname: '%s', (%lu bytes long) in section: %s",
|
||||
+ get_filename (data), symname, (unsigned long) strlen (symname), sec->secname);
|
||||
+ if (!BE_VERBOSE)
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ return true;
|
||||
+}
|
||||
+
|
||||
+static bool
|
||||
check_sec (annocheck_data * data,
|
||||
annocheck_section * sec)
|
||||
{
|
||||
@@ -2839,6 +2905,8 @@ check_sec (annocheck_data * data,
|
||||
selected in interesting_sec(). */
|
||||
switch (sec->shdr.sh_type)
|
||||
{
|
||||
+ case SHT_SYMTAB:
|
||||
+ case SHT_DYNSYM: return check_symbol_section (data, sec);
|
||||
case SHT_NOTE: return check_note_section (data, sec);
|
||||
case SHT_STRTAB: return check_string_section (data, sec);
|
||||
case SHT_DYNAMIC: return check_dynamic_section (data, sec);
|
||||
@@ -3526,6 +3594,7 @@ finish (annocheck_data * data)
|
||||
case TEST_RWX_SEG:
|
||||
case TEST_TEXTREL:
|
||||
case TEST_THREADS:
|
||||
+ case TEST_UNICODE:
|
||||
case TEST_WRITEABLE_GOT:
|
||||
/* The absence of a result for these tests actually means that they have passed. */
|
||||
pass (data, i, SOURCE_FINAL_SCAN, NULL);
|
||||
Only in annobin-9.72/annocheck: hardened.c.orig
|
||||
Only in annobin-9.72/annocheck: hardened.c.rej
|
||||
diff -rup annobin.orig/configure annobin-9.72/configure
|
||||
--- annobin.orig/configure 2021-10-27 17:34:09.438721166 +0100
|
||||
+++ annobin-9.72/configure 2021-10-27 17:34:19.229658406 +0100
|
||||
@@ -763,6 +763,7 @@ infodir
|
||||
docdir
|
||||
oldincludedir
|
||||
includedir
|
||||
+runstatedir
|
||||
localstatedir
|
||||
sharedstatedir
|
||||
sysconfdir
|
||||
@@ -860,6 +861,7 @@ datadir='${datarootdir}'
|
||||
sysconfdir='${prefix}/etc'
|
||||
sharedstatedir='${prefix}/com'
|
||||
localstatedir='${prefix}/var'
|
||||
+runstatedir='${localstatedir}/run'
|
||||
includedir='${prefix}/include'
|
||||
oldincludedir='/usr/include'
|
||||
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
|
||||
@@ -1112,6 +1114,15 @@ do
|
||||
| -silent | --silent | --silen | --sile | --sil)
|
||||
silent=yes ;;
|
||||
|
||||
+ -runstatedir | --runstatedir | --runstatedi | --runstated \
|
||||
+ | --runstate | --runstat | --runsta | --runst | --runs \
|
||||
+ | --run | --ru | --r)
|
||||
+ ac_prev=runstatedir ;;
|
||||
+ -runstatedir=* | --runstatedir=* | --runstatedi=* | --runstated=* \
|
||||
+ | --runstate=* | --runstat=* | --runsta=* | --runst=* | --runs=* \
|
||||
+ | --run=* | --ru=* | --r=*)
|
||||
+ runstatedir=$ac_optarg ;;
|
||||
+
|
||||
-sbindir | --sbindir | --sbindi | --sbind | --sbin | --sbi | --sb)
|
||||
ac_prev=sbindir ;;
|
||||
-sbindir=* | --sbindir=* | --sbindi=* | --sbind=* | --sbin=* \
|
||||
@@ -1249,7 +1260,7 @@ fi
|
||||
for ac_var in exec_prefix prefix bindir sbindir libexecdir datarootdir \
|
||||
datadir sysconfdir sharedstatedir localstatedir includedir \
|
||||
oldincludedir docdir infodir htmldir dvidir pdfdir psdir \
|
||||
- libdir localedir mandir
|
||||
+ libdir localedir mandir runstatedir
|
||||
do
|
||||
eval ac_val=\$$ac_var
|
||||
# Remove trailing slashes.
|
||||
@@ -1402,6 +1413,7 @@ Fine tuning of the installation director
|
||||
--sysconfdir=DIR read-only single-machine data [PREFIX/etc]
|
||||
--sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
|
||||
--localstatedir=DIR modifiable single-machine data [PREFIX/var]
|
||||
+ --runstatedir=DIR modifiable per-process data [LOCALSTATEDIR/run]
|
||||
--libdir=DIR object code libraries [EPREFIX/lib]
|
||||
--includedir=DIR C header files [PREFIX/include]
|
||||
--oldincludedir=DIR C header files for non-gcc [/usr/include]
|
||||
Only in annobin-9.72: configure.orig
|
||||
diff -rup annobin.orig/doc/Makefile.in annobin-9.72/doc/Makefile.in
|
||||
--- annobin.orig/doc/Makefile.in 2021-10-27 17:34:09.439721160 +0100
|
||||
+++ annobin-9.72/doc/Makefile.in 2021-10-27 17:34:19.229658406 +0100
|
||||
@@ -329,6 +329,7 @@ plugindir = @plugindir@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
psdir = @psdir@
|
||||
+runstatedir = @runstatedir@
|
||||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
srcdir = @srcdir@
|
||||
diff -rup annobin.orig/doc/annobin.info annobin-9.72/doc/annobin.info
|
||||
--- annobin.orig/doc/annobin.info 2021-10-27 17:34:09.440721153 +0100
|
||||
+++ annobin-9.72/doc/annobin.info 2021-10-27 17:34:19.230658399 +0100
|
||||
@@ -737,6 +737,7 @@ File: annobin.info, Node: Hardened, Ne
|
||||
[-skip-stack-realign]
|
||||
[-skip-textrel]
|
||||
[-skip-threads]
|
||||
+ [-skip-unicode]
|
||||
[-skip-warnings]
|
||||
[-skip-writeable-got]
|
||||
[-test-NAME]
|
||||
@@ -863,6 +864,10 @@ code to support the test.
|
||||
Check that the program was built by a production-ready compiler.
|
||||
Disabled by '--skip-production'.
|
||||
|
||||
+'Unicode'
|
||||
+ This test checks for the presence of multibyte characters in symbol
|
||||
+ names, which are unusual and potentially dangerous.
|
||||
+
|
||||
The tool does support a couple of other command line options as well:
|
||||
|
||||
'--skip-future'
|
||||
Only in annobin-9.72/doc: annobin.info.orig
|
||||
Only in annobin-9.72/doc: annobin.info.rej
|
||||
diff -rup annobin.orig/doc/annobin.texi annobin-9.72/doc/annobin.texi
|
||||
--- annobin.orig/doc/annobin.texi 2021-10-27 17:34:09.439721160 +0100
|
||||
+++ annobin-9.72/doc/annobin.texi 2021-10-27 17:34:19.230658399 +0100
|
||||
@@ -842,6 +842,7 @@ annocheck
|
||||
[@b{--skip-stack-realign}]
|
||||
[@b{--skip-textrel}]
|
||||
[@b{--skip-threads}]
|
||||
+ [@b{--skip-unicode}]
|
||||
[@b{--skip-warnings}]
|
||||
[@b{--skip-writeable-got}]
|
||||
[@b{--test-@var{name}}]
|
||||
@@ -983,6 +984,11 @@ Check that the program makes consistent
|
||||
@item Production Ready Compiler
|
||||
Check that the program was built by a production-ready compiler.
|
||||
Disabled by @option{--skip-production}.
|
||||
+
|
||||
+@item Unicode
|
||||
+This test checks for the presence of multibyte characters in symbol
|
||||
+names, which are unusual and potentially dangerous.
|
||||
+
|
||||
@end table
|
||||
|
||||
The tool does support a couple of other command line options as well:
|
||||
Only in annobin-9.72/doc: annobin.texi.orig
|
||||
diff -rup annobin.orig/gcc-plugin/Makefile.in annobin-9.72/gcc-plugin/Makefile.in
|
||||
--- annobin.orig/gcc-plugin/Makefile.in 2021-10-27 17:34:09.443721134 +0100
|
||||
+++ annobin-9.72/gcc-plugin/Makefile.in 2021-10-27 17:34:19.230658399 +0100
|
||||
@@ -333,6 +333,7 @@ plugindir = @plugindir@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
psdir = @psdir@
|
||||
+runstatedir = @runstatedir@
|
||||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
srcdir = @srcdir@
|
||||
diff -rup annobin.orig/scripts/Makefile.in annobin-9.72/scripts/Makefile.in
|
||||
--- annobin.orig/scripts/Makefile.in 2021-10-27 17:34:09.441721146 +0100
|
||||
+++ annobin-9.72/scripts/Makefile.in 2021-10-27 17:34:19.230658399 +0100
|
||||
@@ -284,6 +284,7 @@ plugindir = @plugindir@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
psdir = @psdir@
|
||||
+runstatedir = @runstatedir@
|
||||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
srcdir = @srcdir@
|
||||
diff -rup annobin.orig/tests/Makefile.am annobin-9.72/tests/Makefile.am
|
||||
--- annobin.orig/tests/Makefile.am 2021-10-27 17:34:09.444721127 +0100
|
||||
+++ annobin-9.72/tests/Makefile.am 2021-10-27 17:34:19.230658399 +0100
|
||||
@@ -22,6 +22,7 @@ TESTS=compile-test \
|
||||
missing-notes-test \
|
||||
active-checks-test \
|
||||
property-note-test \
|
||||
+ unicode-test \
|
||||
hardening-fail-test
|
||||
|
||||
if HAVE_DEBUGINFOD
|
||||
diff -rup annobin.orig/tests/Makefile.in annobin-9.72/tests/Makefile.in
|
||||
--- annobin.orig/tests/Makefile.in 2021-10-27 17:34:09.444721127 +0100
|
||||
+++ annobin-9.72/tests/Makefile.in 2021-10-27 17:34:19.230658399 +0100
|
||||
@@ -459,6 +459,7 @@ plugindir = @plugindir@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
psdir = @psdir@
|
||||
+runstatedir = @runstatedir@
|
||||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
srcdir = @srcdir@
|
||||
@@ -479,7 +480,7 @@ TESTS = compile-test abi-test active-che
|
||||
hardening-test instrumentation-test lto-test \
|
||||
missing-notes-test objcopy-test section-size-test \
|
||||
missing-notes-test active-checks-test property-note-test \
|
||||
- hardening-fail-test $(am__append_1)
|
||||
+ unicode-test hardening-fail-test $(am__append_1)
|
||||
all: all-am
|
||||
|
||||
.SUFFIXES:
|
||||
@@ -764,6 +765,13 @@ property-note-test.log: property-note-te
|
||||
$(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
--log-file $$b.log --trs-file $$b.trs \
|
||||
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
+ "$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
+unicode-test.log: unicode-test
|
||||
+ @p='unicode-test'; \
|
||||
+ b='unicode-test'; \
|
||||
+ $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
+ --log-file $$b.log --trs-file $$b.trs \
|
||||
+ $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
"$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
debuginfod-test.log: debuginfod-test
|
||||
@p='debuginfod-test'; \
|
||||
Only in annobin-9.72/tests: trick-hello.s
|
||||
Only in annobin-9.72/tests: unicode-test
|
@ -1,8 +1,8 @@
|
||||
|
||||
Name: annobin
|
||||
Summary: Annotate and examine compiled binary files
|
||||
Version: 9.65
|
||||
Release: 1%{?dist}
|
||||
Version: 9.72
|
||||
Release: 1%{?dist}.2
|
||||
License: GPLv3+
|
||||
# ProtocolURL: https://fedoraproject.org/wiki/Toolchain/Watermark
|
||||
# Maintainer: nickc@redhat.com
|
||||
@ -55,7 +55,8 @@ Source: annobin-%{version}.tar.xz
|
||||
# For the latest sources use: git clone git://sourceware.org/git/annobin.git
|
||||
|
||||
# Insert patches here, if needed.
|
||||
Patch01: annobin-skip-stack-prot.patch
|
||||
Patch01: annobin-nop.patch
|
||||
Patch02: annobin.unicode.patch
|
||||
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
@ -192,6 +193,7 @@ fi
|
||||
echo "Requires: (gcc >= %{gcc_major} and gcc < %{gcc_next})"
|
||||
|
||||
%autosetup -p1
|
||||
chmod +x tests/unicode-test
|
||||
|
||||
# The plugin has to be configured with the same arcane configure
|
||||
# scripts used by gcc. Hence we must not allow the Fedora build
|
||||
@ -317,6 +319,28 @@ fi
|
||||
#---------------------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Mon Nov 1 2021 Siddhesh Poyarekar <siddhesh@redhat.com> - 9.72-1.2
|
||||
- Bump NVR and rebuild to use the new gcc. (#2017362)
|
||||
|
||||
* Wed Oct 27 2021 Nick Clifton <nickc@redhat.com> - 9.72-1.1
|
||||
- Annocheck: Add test for multibyte characters in symbol names. (#2017362)
|
||||
|
||||
* Mon May 17 2021 Nick Clifton <nickc@redhat.com> - 9.72-1
|
||||
- Rebase to 9.72. (#1960299)
|
||||
- annocheck: Accept 0 as a valid number for gcc minor versions and release numbers.
|
||||
- gcc-plugin: Add support for ARM and RISCV targets.
|
||||
- timing: do not initialise the clock if the timing tool is disabled.
|
||||
- gcc-plugin: Replace ICE messsages with verbose messages.
|
||||
- Fix the testsuite so that it can be run in parallel.
|
||||
- Annocheck: WARN if the annobin plugin was built for a newer version of the compiler than the one on which it was run. (#1950657)
|
||||
- Annocheck: Improve detection of missing GNU-stack support.
|
||||
- Correct a package rename (bug #1949570)
|
||||
- Require docs subpackage by the other ones because of a license
|
||||
- Build-requiring perl-interpreter is enough
|
||||
- Fix bz1949570
|
||||
- Fix anomolies reported by covscan.
|
||||
- Move documentation into a sub-package.
|
||||
|
||||
* Wed Mar 17 2021 Nick Clifton <nickc@redhat.com> - 9.65-1
|
||||
- gcc-plugin: Use a fixed filename when running in LTO mode.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user