diff --git a/0001-Restore-fix-for-RHBZ-1323012-set_name-not-setName.patch b/0001-Restore-fix-for-RHBZ-1323012-set_name-not-setName.patch
new file mode 100644
index 0000000..3fe8bc1
--- /dev/null
+++ b/0001-Restore-fix-for-RHBZ-1323012-set_name-not-setName.patch
@@ -0,0 +1,34 @@
+From e4d336b9c005f5b74bf46f4534f7884f9daeadbf Mon Sep 17 00:00:00 2001
+From: Adam Williamson <awilliam@redhat.com>
+Date: Tue, 19 Dec 2017 14:57:14 -0800
+Subject: [PATCH] Restore fix for RHBZ #1323012 (`set_name` not `setName`)
+
+This was initially fixed in blivet by
+https://github.com/rhinstaller/blivet/pull/354 , but the fix
+was inadvertently reversed by a refactoring commit that
+landed shortly afterwards:
+https://github.com/storaged-project/blivet/commit/d3ac10d8
+The wrong code was then subsequently moved to anaconda, still
+with the wrong method name. So, let's fix it again.
+
+Signed-off-by: Adam Williamson <awilliam@redhat.com>
+---
+ pyanaconda/storage/osinstall.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyanaconda/storage/osinstall.py b/pyanaconda/storage/osinstall.py
+index 251bae338..6ad6a80b0 100644
+--- a/pyanaconda/storage/osinstall.py
++++ b/pyanaconda/storage/osinstall.py
+@@ -1247,7 +1247,7 @@ class InstallerStorage(Blivet):
+                 # Set the boot partition's name on disk labels that support it
+                 if dev.parted_partition.disk.supportsFeature(parted.DISK_TYPE_PARTITION_NAME):
+                     ped_partition = dev.parted_partition.getPedPartition()
+-                    ped_partition.setName(dev.format.name)
++                    ped_partition.set_name(dev.format.name)
+                     log.info("Setting label on %s to '%s'", dev, dev.format.name)
+ 
+                 dev.disk.setup()
+-- 
+2.15.1
+
diff --git a/anaconda.spec b/anaconda.spec
index 953dd32..51d11bc 100644
--- a/anaconda.spec
+++ b/anaconda.spec
@@ -3,7 +3,7 @@
 Summary: Graphical system installer
 Name:    anaconda
 Version: 28.14
-Release: 1%{?dist}
+Release: 2%{?dist}
 License: GPLv2+ and MIT
 Group:   Applications/System
 URL:     http://fedoraproject.org/wiki/Anaconda
@@ -15,6 +15,11 @@ URL:     http://fedoraproject.org/wiki/Anaconda
 # make dist
 Source0: %{name}-%{version}.tar.bz2
 
+# Downstream patch as no anaconda devs are around and Rawhide is
+# busted: re-fix RHBZ #1323012, see
+# https://github.com/rhinstaller/anaconda/pull/1281
+Patch0: 0001-Restore-fix-for-RHBZ-1323012-set_name-not-setName.patch
+
 # Versions of required components (done so we make sure the buildrequires
 # match the requires versions of things).
 
@@ -239,6 +244,7 @@ runtime on NFS/HTTP/FTP servers or local disks.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 # use actual build-time release number, not tarball creation time release number
@@ -335,6 +341,9 @@ update-desktop-database &> /dev/null || :
 %{_prefix}/libexec/anaconda/dd_*
 
 %changelog
+* Tue Dec 19 2017 Adam Williamson <awilliam@redhat.com> - 28.14-2
+- Backport #1281 to re-fix RHBZ #1323012 (crash in UEFI installs)
+
 * Mon Dec 18 2017 Martin Kolman <mkolman@redhat.com> - 28.14-1
 - Use observers in the install manager (vponcova)
 - Modify readme file for tests (jkonecny)