[packit] 40.22.3.1 upstream release

Upstream tag: anaconda-40.22.3.1-1
Upstream commit: da245278

Resolves: RHEL-33385
This commit is contained in:
Katerina Koukiou 2024-04-19 16:36:19 +02:00
parent d149f2792f
commit 7447b5864c
7 changed files with 20 additions and 167 deletions

1
.gitignore vendored
View File

@ -396,3 +396,4 @@
/anaconda-40.18.tar.bz2
/anaconda-40.20.tar.bz2
/anaconda-40.21.tar.bz2
/anaconda-40.22.3.1.tar.bz2

View File

@ -9,6 +9,7 @@ specfile_path: anaconda.spec
upstream_package_name: anaconda
upstream_tag_template: anaconda-{version}-1
copy_upstream_release_description: true
downstream_package_name: anaconda
srpm_build_deps:
- automake
@ -25,6 +26,13 @@ srpm_build_deps:
- nss_wrapper
- nodejs-npm
packages:
anaconda-fedora:
specfile_path: anaconda.spec
anaconda-centos:
specfile_path: anaconda.spec
pkg_tool: centpkg
actions:
post-upstream-clone:
- ./autogen.sh
@ -35,29 +43,8 @@ actions:
jobs:
- job: propose_downstream
trigger: release
dist_git_branches: main
- job: tests
trigger: pull_request
targets:
- fedora-rawhide
- job: copr_build
trigger: pull_request
targets:
- fedora-rawhide
- fedora-eln
- job: copr_build
trigger: commit
targets:
- fedora-rawhide
- fedora-eln
branch: master
owner: "@rhinstaller"
project: Anaconda
preserve_project: True
packages: [anaconda-centos]
dist_git_branches: c10s

View File

@ -1,29 +0,0 @@
From c8c29ebbf867e507405247eb62e82b8b9cfa60bc Mon Sep 17 00:00:00 2001
From: Adam Williamson <awilliam@redhat.com>
Date: Tue, 6 Feb 2024 15:19:02 -0800
Subject: [PATCH] Resolve symlinks in ostree install bind mount destinations
(#2262892)
Signed-off-by: Adam Williamson <awilliam@redhat.com>
---
.../modules/payloads/payload/rpm_ostree/installation.py | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py b/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py
index 1c8af4d93f..0ac8583b78 100644
--- a/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py
+++ b/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py
@@ -160,6 +160,10 @@ class PrepareOSTreeMountTargetsTask(Task):
# Canonicalize dest to the full path
dest = self._sysroot + dest
+ # Resolve symlinks as bind mounting over symlinks does not
+ # seem to work on btrfs:
+ # https://bugzilla.redhat.com/show_bug.cgi?id=2262892
+ dest = os.path.realpath(dest)
if bind_ro:
safe_exec_with_redirect("mount", ["--bind", src, src])
--
2.43.0

View File

@ -1,101 +0,0 @@
diff -ru anaconda-40.21.orig/pyanaconda/core/configuration/system.py anaconda-40.21/pyanaconda/core/configuration/system.py
--- anaconda-40.21.orig/pyanaconda/core/configuration/system.py 2024-02-06 10:44:42.794561313 -0600
+++ anaconda-40.21/pyanaconda/core/configuration/system.py 2024-02-27 21:16:15.104704752 -0600
@@ -168,6 +168,11 @@
return self._is_boot_iso or self._is_live_os or self._is_booted_os
@property
+ def provides_resolver_config(self):
+ """Can we copy /etc/resolv.conf to the target system?"""
+ return self._is_boot_iso
+
+ @property
def provides_liveuser(self):
"""Is the user `liveuser` available?"""
return self._is_live_os
diff -ru anaconda-40.21.orig/pyanaconda/installation.py anaconda-40.21/pyanaconda/installation.py
--- anaconda-40.21.orig/pyanaconda/installation.py 2024-02-06 10:44:42.798561322 -0600
+++ anaconda-40.21/pyanaconda/installation.py 2024-02-27 21:15:11.002380768 -0600
@@ -28,6 +28,7 @@
from pyanaconda import flags
from pyanaconda.core import util
from pyanaconda.core.path import open_with_perm
+from pyanaconda.core.service import is_service_installed
from pyanaconda import network
from pyanaconda.core.i18n import _
from pyanaconda.core.threads import thread_manager
@@ -370,6 +371,17 @@
_("Running pre-installation tasks")
)
+ # Make name resolution work for rpm scripts in chroot.
+ # Also make sure dns resolution works in %post scripts
+ # when systemd-resolved is not available.
+ if conf.system.provides_resolver_config and \
+ not is_service_installed("systemd-resolved.service"):
+ pre_install.append(Task(
+ "Copy resolv.conf to sysroot",
+ network.copy_resolv_conf_to_root,
+ (conf.target.system_root, )
+ ))
+
if is_module_available(SECURITY):
security_proxy = SECURITY.get_proxy()
diff -ru anaconda-40.21.orig/pyanaconda/network.py anaconda-40.21/pyanaconda/network.py
--- anaconda-40.21.orig/pyanaconda/network.py 2024-02-06 10:44:42.830561405 -0600
+++ anaconda-40.21/pyanaconda/network.py 2024-02-27 21:17:34.122336801 -0600
@@ -16,8 +16,10 @@
#
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+import shutil
import socket
import itertools
+import os
import time
import threading
import re
@@ -29,6 +31,7 @@
from pyanaconda.core import util, constants
from pyanaconda.core.i18n import _
from pyanaconda.core.kernel import kernel_arguments
+from pyanaconda.core.path import make_directories
from pyanaconda.core.regexes import HOSTNAME_PATTERN_WITHOUT_ANCHORS, \
IPV6_ADDRESS_IN_DRACUT_IP_OPTION, MAC_OCTET
from pyanaconda.core.configuration.anaconda import conf
@@ -53,8 +56,9 @@
__all__ = ["get_supported_devices", "status_message", "wait_for_connectivity",
"wait_for_connecting_NM_thread", "wait_for_network_devices", "wait_for_connected_NM",
- "initialize_network", "prefix_to_netmask", "netmask_to_prefix", "get_first_ip_address",
- "is_valid_hostname", "check_ip_address", "get_nm_client", "write_configuration"]
+ "initialize_network", "copy_resolv_conf_to_root", "prefix_to_netmask",
+ "netmask_to_prefix", "get_first_ip_address", "is_valid_hostname", "check_ip_address",
+ "get_nm_client", "write_configuration"]
def get_nm_client():
@@ -214,6 +218,22 @@
return route_info[route_info.index("dev") + 1]
+def copy_resolv_conf_to_root(root="/"):
+ """Copy resolv.conf to a system root."""
+ src = "/etc/resolv.conf"
+ dst = os.path.join(root, src.lstrip('/'))
+ if not os.path.isfile(src):
+ log.debug("%s does not exist", src)
+ return
+ if os.path.isfile(dst):
+ log.debug("%s already exists", dst)
+ return
+ dst_dir = os.path.dirname(dst)
+ if not os.path.isdir(dst_dir):
+ make_directories(dst_dir)
+ shutil.copyfile(src, dst)
+
+
def run_network_initialization_task(task_path):
"""Run network initialization task and log the result."""
task_proxy = NETWORK.get_proxy(task_path)

View File

@ -1,3 +1,3 @@
This repository is maintained by packit.
https://packit.dev/
The file was generated using packit 0.90.0.post1.dev9+g1f0325d1.
The file was generated using packit 0.94.0.

View File

@ -1,7 +1,7 @@
Summary: Graphical system installer
Name: anaconda
Version: 40.21
Release: 4%{?dist}
Version: 40.22.3.1
Release: 1%{?dist}
License: GPL-2.0-or-later
URL: http://fedoraproject.org/wiki/Anaconda
@ -12,15 +12,6 @@ URL: http://fedoraproject.org/wiki/Anaconda
# make dist
Source0: https://github.com/rhinstaller/%{name}/releases/download/%{name}-%{version}-1/%{name}-%{version}.tar.bz2
# https://github.com/rhinstaller/anaconda/pull/5460
# https://bugzilla.redhat.com/show_bug.cgi?id=2262892
# Fix ostree installs to btrfs with util-linux 2.40+
Patch: 0001-Resolve-symlinks-in-ostree-install-bind-mount-destin.patch
# https://github.com/rhinstaller/anaconda/pull/5494/commits
# https://issues.redhat.com/browse/RHEL-26651
Patch: 0002-backport-7e5f538ac2-copy-resolvconf.patch
# Versions of required components (done so we make sure the buildrequires
# match the requires versions of things).
@ -49,7 +40,7 @@ Patch: 0002-backport-7e5f538ac2-copy-resolvconf.patch
%define nmver 1.0
%define pykickstartver 3.52-1
%define pypartedver 2.5-2
%define pythonblivetver 1:3.8.2-2
%define pythonblivetver 1:3.9.0-1
%define rpmver 4.15.0
%define simplelinever 1.9.0-1
%define subscriptionmanagerver 1.26
@ -476,6 +467,10 @@ rm -rf \
%{_prefix}/libexec/anaconda/dd_*
%changelog
* Fri Apr 19 2024 Katerina Koukiou <kkoukiou@redhat.com> - 40.22.3.1-1
- Get latest changes from fedora-40 branch to RHEL-10
Resolves: RHEL-33385
* Tue Feb 27 2024 Brian Stinson <bstinson@redhat.com> - 40.21-4
- Backport PR #5494 which re-enables copying resolv.conf into the target system to allow resolving dns names in %post
Resolves: RHEL-26651

View File

@ -1 +1 @@
SHA512 (anaconda-40.21.tar.bz2) = dccb68285b4fc233edffda6242541879971f32b76a4e53d3a4253675c7541fe6d2a7eb59ad28bd627133c16347a8e641a9004ac4081051a23d618d796b025cf0
SHA512 (anaconda-40.22.3.1.tar.bz2) = f141c7e761e98edd38a1eb23108c898c75ff4a3aedba4d0664d712560a57985dca07633790c34fd89a776dff7ea3ccbd146167773a41682c068120a35d768ba1