updated to 1.1.7

This commit is contained in:
Jaroslav Kysela 2018-10-16 10:27:40 +02:00
parent 68558e01e8
commit d7051cd0e9
2 changed files with 30 additions and 95 deletions

View File

@ -1,85 +0,0 @@
From 93e03bdc2a3dcd5d12516f5de78e14d88a32ff2c Mon Sep 17 00:00:00 2001
From: Jaroslav Kysela <perex@perex.cz>
Date: Wed, 4 Apr 2018 09:58:12 +0200
Subject: [PATCH 1/2] alsa.conf: change the location for add-on configs to
/etc/alsa/conf.d
The add-on configuration files should be placed to a volatile place.
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
---
src/conf/alsa.conf | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)
diff --git a/src/conf/alsa.conf b/src/conf/alsa.conf
index f22918fb..bb00ff40 100644
--- a/src/conf/alsa.conf
+++ b/src/conf/alsa.conf
@@ -8,13 +8,7 @@
{
func load
files [
- {
- @func concat
- strings [
- { @func datadir }
- "/alsa.conf.d/"
- ]
- }
+ "/etc/alsa/conf.d"
"/etc/asound.conf"
"~/.asoundrc"
]
--
2.13.6
From 78505dccd23546cc77e5221cb21c01325bc0138d Mon Sep 17 00:00:00 2001
From: Jaroslav Kysela <perex@perex.cz>
Date: Wed, 4 Apr 2018 10:02:49 +0200
Subject: [PATCH 2/2] conf: remove alsa.conf.d from the datadir
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
---
src/conf/Makefile.am | 2 +-
src/conf/alsa.conf.d/Makefile.am | 8 --------
src/conf/alsa.conf.d/README | 2 --
3 files changed, 1 insertion(+), 11 deletions(-)
delete mode 100644 src/conf/alsa.conf.d/Makefile.am
delete mode 100644 src/conf/alsa.conf.d/README
diff --git a/src/conf/Makefile.am b/src/conf/Makefile.am
index ef2ea9c1..2b46f95c 100644
--- a/src/conf/Makefile.am
+++ b/src/conf/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS=cards pcm alsa.conf.d
+SUBDIRS=cards pcm
if BUILD_UCM
SUBDIRS += ucm
diff --git a/src/conf/alsa.conf.d/Makefile.am b/src/conf/alsa.conf.d/Makefile.am
deleted file mode 100644
index c91661e9..00000000
--- a/src/conf/alsa.conf.d/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-alsaconfigdir = @ALSA_CONFIG_DIR@
-alsadir = $(alsaconfigdir)/alsa.conf.d
-cfg_files = README
-
-alsa_DATA = $(cfg_files)
-
-EXTRA_DIST = \
- $(cfg_files)
diff --git a/src/conf/alsa.conf.d/README b/src/conf/alsa.conf.d/README
deleted file mode 100644
index 99978848..00000000
--- a/src/conf/alsa.conf.d/README
+++ /dev/null
@@ -1,2 +0,0 @@
-You can place files named *.conf in this folder and they will be processed
-when initialising alsa-lib.
--
2.13.6

View File

@ -4,8 +4,8 @@
Summary: The Advanced Linux Sound Architecture (ALSA) library Summary: The Advanced Linux Sound Architecture (ALSA) library
Name: alsa-lib Name: alsa-lib
Version: 1.1.6 Version: 1.1.7
Release: 3%{?prever_dot}%{?dist} Release: 1%{?prever_dot}%{?dist}
License: LGPLv2+ License: LGPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.alsa-project.org/ URL: http://www.alsa-project.org/
@ -16,7 +16,6 @@ Source11: modprobe-dist-alsa.conf
Source12: modprobe-dist-oss.conf Source12: modprobe-dist-oss.conf
Patch0: alsa-lib-1.0.24-config.patch Patch0: alsa-lib-1.0.24-config.patch
Patch1: alsa-lib-1.0.14-glibc-open.patch Patch1: alsa-lib-1.0.14-glibc-open.patch
Patch10: alsa-lib-addon-dir.patch
BuildRequires: doxygen BuildRequires: doxygen
BuildRequires: autoconf automake libtool BuildRequires: autoconf automake libtool
@ -44,19 +43,29 @@ This package includes the ALSA development libraries for developing
against the ALSA libraries and interfaces. against the ALSA libraries and interfaces.
%package -n alsa-ucm %package -n alsa-ucm
Summary: ALSA Universal Configuration Manager Summary: ALSA Use Case Manager configuration
Group: System Environment/Libraries Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release} BuildArch: noarch
Requires: %{name} = %{version}-%{release}
%description -n alsa-ucm %description -n alsa-ucm
The Advanced Linux Sound Architecture (ALSA) Universal Configuration The Advanced Linux Sound Architecture (ALSA) Use Case Manager configuration
Manager allows configuration of Audio input/output names and routing contains alsa-lib configuration of Audio input/output names and routing
%package -n alsa-topology
Summary: ALSA Topology configuration
Group: System Environment/Libraries
BuildArch: noarch
Requires: %{name} = %{version}-%{release}
%description -n alsa-topology
The Advanced Linux Sound Architecture (ALSA) topology configuration
contains alsa-lib configuration of SoC topology
%prep %prep
%setup -q -n %{name}-%{version}%{?prever}%{?postver} %setup -q -n %{name}-%{version}%{?prever}%{?postver}
%patch0 -p1 -b .config %patch0 -p1 -b .config
%patch1 -p1 -b .glibc-open %patch1 -p1 -b .glibc-open
%patch10 -p1 -b .addon-dir
%build %build
autoreconf -vif autoreconf -vif
@ -90,7 +99,10 @@ install -p -m 644 %{SOURCE12} .
# Create UCM directory # Create UCM directory
mkdir -p %{buildroot}/%{_datadir}/alsa/ucm mkdir -p %{buildroot}/%{_datadir}/alsa/ucm
#Remove libtool archives. # Create topology directory
mkdir -p %{buildroot}/%{_datadir}/alsa/topology
# Remove libtool archives.
find %{buildroot} -name '*.la' -delete find %{buildroot} -name '*.la' -delete
%post -p /sbin/ldconfig %post -p /sbin/ldconfig
@ -107,6 +119,7 @@ find %{buildroot} -name '*.la' -delete
#{_libdir}/alsa-lib/ #{_libdir}/alsa-lib/
%{_datadir}/alsa/ %{_datadir}/alsa/
%exclude %{_datadir}/alsa/ucm %exclude %{_datadir}/alsa/ucm
%exclude %{_datadir}/alsa/topology
/lib/modprobe.d/dist-* /lib/modprobe.d/dist-*
%files devel %files devel
@ -120,7 +133,14 @@ find %{buildroot} -name '*.la' -delete
%files -n alsa-ucm %files -n alsa-ucm
%{_datadir}/alsa/ucm %{_datadir}/alsa/ucm
%files -n alsa-topology
%{_datadir}/alsa/topology
%changelog %changelog
* Tue Oct 16 2018 Jaroslav Kysela <perex@perex.cz> - 1.1.7-1
- Moved topology files to alsa-topology
- Updated to 1.1.7
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.6-3 * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild