import alsa-lib-1.2.5.1-2.el9
This commit is contained in:
commit
c4b6a97185
3
.alsa-lib.metadata
Normal file
3
.alsa-lib.metadata
Normal file
@ -0,0 +1,3 @@
|
||||
842612c57e47c36b6f0f9f08de8255f6ba7ba065 SOURCES/alsa-lib-1.2.5.1.tar.bz2
|
||||
8c1d225b9fe108797349e8d0cb6161271aab0f50 SOURCES/alsa-topology-conf-1.2.5.tar.bz2
|
||||
d7b1be995fcd0b4cb31b09e128ea1bc7d5c4d061 SOURCES/alsa-ucm-conf-1.2.5.1.tar.bz2
|
3
.gitignore
vendored
Normal file
3
.gitignore
vendored
Normal file
@ -0,0 +1,3 @@
|
||||
SOURCES/alsa-lib-1.2.5.1.tar.bz2
|
||||
SOURCES/alsa-topology-conf-1.2.5.tar.bz2
|
||||
SOURCES/alsa-ucm-conf-1.2.5.1.tar.bz2
|
219
SOURCES/alsa-git.patch
Normal file
219
SOURCES/alsa-git.patch
Normal file
@ -0,0 +1,219 @@
|
||||
From e47c11822d6b459a9b3704b3ee6a4a5c9a1b85be Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Tue, 29 Jun 2021 18:02:27 +0200
|
||||
Subject: [PATCH 1/2] control: remap - assign right name to the child handle
|
||||
for no-op
|
||||
|
||||
Fixes: https://github.com/alsa-project/alsa-utils/issues/100
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/control/control_remap.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/control/control_remap.c b/src/control/control_remap.c
|
||||
index a85c1725..81524014 100644
|
||||
--- a/src/control/control_remap.c
|
||||
+++ b/src/control/control_remap.c
|
||||
@@ -1173,6 +1173,10 @@ int snd_ctl_remap_open(snd_ctl_t **handlep, const char *name, snd_config_t *rema
|
||||
/* no-op check, remove the plugin */
|
||||
if (priv->map_items == 0 && priv->remap_items == 0) {
|
||||
remap_free(priv);
|
||||
+ free(child->name);
|
||||
+ child->name = name ? strdup(name) : NULL;
|
||||
+ if (name && !child->name)
|
||||
+ return -ENOMEM;
|
||||
*handlep = child;
|
||||
return 0;
|
||||
}
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
||||
From 23a191a82c693456e61431ab699cddc1e5782a26 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Tue, 29 Jun 2021 19:31:28 +0200
|
||||
Subject: [PATCH 2/2] control: remap - assign right name to the child handle
|
||||
for no-op (2nd case)
|
||||
|
||||
Fixes: https://github.com/alsa-project/alsa-utils/issues/100
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/control/control_remap.c | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/control/control_remap.c b/src/control/control_remap.c
|
||||
index 81524014..4914f960 100644
|
||||
--- a/src/control/control_remap.c
|
||||
+++ b/src/control/control_remap.c
|
||||
@@ -1154,6 +1154,10 @@ int snd_ctl_remap_open(snd_ctl_t **handlep, const char *name, snd_config_t *rema
|
||||
snd_ctl_t *ctl;
|
||||
int result, err;
|
||||
|
||||
+ /* no-op, remove the plugin */
|
||||
+ if (!remap && !map)
|
||||
+ goto _noop;
|
||||
+
|
||||
priv = calloc(1, sizeof(*priv));
|
||||
if (priv == NULL)
|
||||
return -ENOMEM;
|
||||
@@ -1173,6 +1177,7 @@ int snd_ctl_remap_open(snd_ctl_t **handlep, const char *name, snd_config_t *rema
|
||||
/* no-op check, remove the plugin */
|
||||
if (priv->map_items == 0 && priv->remap_items == 0) {
|
||||
remap_free(priv);
|
||||
+ _noop:
|
||||
free(child->name);
|
||||
child->name = name ? strdup(name) : NULL;
|
||||
if (name && !child->name)
|
||||
@@ -1316,11 +1321,6 @@ int _snd_ctl_remap_open(snd_ctl_t **handlep, char *name, snd_config_t *root, snd
|
||||
err = _snd_ctl_open_child(&cctl, root, child, mode, conf);
|
||||
if (err < 0)
|
||||
return err;
|
||||
- /* no-op, remove the plugin */
|
||||
- if (!remap && !map) {
|
||||
- *handlep = cctl;
|
||||
- return 0;
|
||||
- }
|
||||
err = snd_ctl_remap_open(handlep, name, remap, map, cctl, mode);
|
||||
if (err < 0)
|
||||
snd_ctl_close(cctl);
|
||||
--
|
||||
2.31.1
|
||||
|
||||
From dd609ef9684987d3ca61d5c5cc3c77589ff9c29f Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Mon, 21 Jun 2021 09:28:41 +0200
|
||||
Subject: [PATCH] pcm: direct plugins - fix hw_ptr in the status callback
|
||||
|
||||
The parent hw_ptr may be in another range (boundary limit).
|
||||
Set the correct value for the caller.
|
||||
|
||||
BugLink: https://github.com/alsa-project/alsa-lib/issues/155
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/pcm/pcm_dmix.c | 1 +
|
||||
src/pcm/pcm_dshare.c | 1 +
|
||||
src/pcm/pcm_dsnoop.c | 1 +
|
||||
3 files changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/pcm/pcm_dmix.c b/src/pcm/pcm_dmix.c
|
||||
index 0d0d0bff..94dbb1e0 100644
|
||||
--- a/src/pcm/pcm_dmix.c
|
||||
+++ b/src/pcm/pcm_dmix.c
|
||||
@@ -491,6 +491,7 @@ static int snd_pcm_dmix_status(snd_pcm_t *pcm, snd_pcm_status_t * status)
|
||||
}
|
||||
|
||||
status->state = snd_pcm_dmix_state(pcm);
|
||||
+ status->hw_ptr = *pcm->hw.ptr; /* boundary may be different */
|
||||
status->appl_ptr = *pcm->appl.ptr; /* slave PCM doesn't set appl_ptr */
|
||||
status->trigger_tstamp = dmix->trigger_tstamp;
|
||||
status->avail = snd_pcm_mmap_playback_avail(pcm);
|
||||
diff --git a/src/pcm/pcm_dshare.c b/src/pcm/pcm_dshare.c
|
||||
index a918512b..01814dc8 100644
|
||||
--- a/src/pcm/pcm_dshare.c
|
||||
+++ b/src/pcm/pcm_dshare.c
|
||||
@@ -243,6 +243,7 @@ static int snd_pcm_dshare_status(snd_pcm_t *pcm, snd_pcm_status_t * status)
|
||||
break;
|
||||
}
|
||||
status->state = snd_pcm_dshare_state(pcm);
|
||||
+ status->hw_ptr = *pcm->hw.ptr; /* boundary may be different */
|
||||
status->appl_ptr = *pcm->appl.ptr; /* slave PCM doesn't set appl_ptr */
|
||||
status->trigger_tstamp = dshare->trigger_tstamp;
|
||||
status->avail = snd_pcm_mmap_playback_avail(pcm);
|
||||
diff --git a/src/pcm/pcm_dsnoop.c b/src/pcm/pcm_dsnoop.c
|
||||
index 2c3b9f43..3f28df99 100644
|
||||
--- a/src/pcm/pcm_dsnoop.c
|
||||
+++ b/src/pcm/pcm_dsnoop.c
|
||||
@@ -193,6 +193,7 @@ static int snd_pcm_dsnoop_status(snd_pcm_t *pcm, snd_pcm_status_t * status)
|
||||
snd_pcm_status(dsnoop->spcm, status);
|
||||
state = snd_pcm_state(dsnoop->spcm);
|
||||
status->state = state == SND_PCM_STATE_RUNNING ? dsnoop->state : state;
|
||||
+ status->hw_ptr = *pcm->hw.ptr; /* boundary may be different */
|
||||
status->appl_ptr = *pcm->appl.ptr; /* slave PCM doesn't set appl_ptr */
|
||||
status->trigger_tstamp = dsnoop->trigger_tstamp;
|
||||
status->avail = snd_pcm_mmap_capture_avail(pcm);
|
||||
--
|
||||
2.31.1
|
||||
|
||||
From e0e084659083c2ab75d5c894f24227ea2f67010f Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Mon, 21 Jun 2021 15:14:18 +0200
|
||||
Subject: [PATCH] pcm: direct plugins - fix bad memory access when channel
|
||||
bindings do not match hw
|
||||
|
||||
Fix and cleanup snd_pcm_direct_check_interleave() function.
|
||||
Add requested / hardware channel check and use goto when the interleaved
|
||||
|
||||
Fixes: https://github.com/alsa-project/alsa-lib/issues/117
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/pcm/pcm_direct.c | 40 +++++++++++++++++-----------------------
|
||||
1 file changed, 17 insertions(+), 23 deletions(-)
|
||||
|
||||
diff --git a/src/pcm/pcm_direct.c b/src/pcm/pcm_direct.c
|
||||
index d50503e3..90417b2f 100644
|
||||
--- a/src/pcm/pcm_direct.c
|
||||
+++ b/src/pcm/pcm_direct.c
|
||||
@@ -1627,43 +1627,37 @@ int snd_pcm_direct_set_timer_params(snd_pcm_direct_t *dmix)
|
||||
int snd_pcm_direct_check_interleave(snd_pcm_direct_t *dmix, snd_pcm_t *pcm)
|
||||
{
|
||||
unsigned int chn, channels;
|
||||
- int bits, interleaved = 1;
|
||||
+ int bits;
|
||||
const snd_pcm_channel_area_t *dst_areas;
|
||||
const snd_pcm_channel_area_t *src_areas;
|
||||
|
||||
bits = snd_pcm_format_physical_width(pcm->format);
|
||||
if ((bits % 8) != 0)
|
||||
- interleaved = 0;
|
||||
+ goto __nointerleaved;
|
||||
channels = dmix->channels;
|
||||
+ if (channels != dmix->spcm->channels)
|
||||
+ goto __nointerleaved;
|
||||
dst_areas = snd_pcm_mmap_areas(dmix->spcm);
|
||||
src_areas = snd_pcm_mmap_areas(pcm);
|
||||
for (chn = 1; chn < channels; chn++) {
|
||||
- if (dst_areas[chn-1].addr != dst_areas[chn].addr) {
|
||||
- interleaved = 0;
|
||||
- break;
|
||||
- }
|
||||
- if (src_areas[chn-1].addr != src_areas[chn].addr) {
|
||||
- interleaved = 0;
|
||||
- break;
|
||||
- }
|
||||
+ if (dst_areas[chn-1].addr != dst_areas[chn].addr)
|
||||
+ goto __nointerleaved;
|
||||
+ if (src_areas[chn-1].addr != src_areas[chn].addr)
|
||||
+ goto __nointerleaved;
|
||||
}
|
||||
for (chn = 0; chn < channels; chn++) {
|
||||
- if (dmix->bindings && dmix->bindings[chn] != chn) {
|
||||
- interleaved = 0;
|
||||
- break;
|
||||
- }
|
||||
+ if (dmix->bindings && dmix->bindings[chn] != chn)
|
||||
+ goto __nointerleaved;
|
||||
if (dst_areas[chn].first != chn * bits ||
|
||||
- dst_areas[chn].step != channels * bits) {
|
||||
- interleaved = 0;
|
||||
- break;
|
||||
- }
|
||||
+ dst_areas[chn].step != channels * bits)
|
||||
+ goto __nointerleaved;
|
||||
if (src_areas[chn].first != chn * bits ||
|
||||
- src_areas[chn].step != channels * bits) {
|
||||
- interleaved = 0;
|
||||
- break;
|
||||
- }
|
||||
+ src_areas[chn].step != channels * bits)
|
||||
+ goto __nointerleaved;
|
||||
}
|
||||
- return dmix->interleaved = interleaved;
|
||||
+ return dmix->interleaved = 1;
|
||||
+__nointerleaved:
|
||||
+ return dmix->interleaved = 0;
|
||||
}
|
||||
|
||||
/*
|
||||
--
|
||||
2.31.1
|
||||
|
11
SOURCES/alsa-lib-1.0.14-glibc-open.patch
Normal file
11
SOURCES/alsa-lib-1.0.14-glibc-open.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- alsa-lib-1.0.14/aserver/aserver.c 2007-05-31 10:05:13.000000000 +0200
|
||||
+++ alsa-lib-1.0.14.lennart/aserver/aserver.c 2007-08-15 15:53:32.000000000 +0200
|
||||
@@ -35,6 +35,8 @@
|
||||
|
||||
#include "aserver.h"
|
||||
|
||||
+#undef open
|
||||
+
|
||||
char *command;
|
||||
|
||||
#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 95)
|
44
SOURCES/alsa-lib-1.2.3.1-config.patch
Normal file
44
SOURCES/alsa-lib-1.2.3.1-config.patch
Normal file
@ -0,0 +1,44 @@
|
||||
diff --git a/src/conf/alsa.conf b/src/conf/alsa.conf
|
||||
index 18427ec6..1915af4e 100644
|
||||
--- a/src/conf/alsa.conf
|
||||
+++ b/src/conf/alsa.conf
|
||||
@@ -80,8 +80,7 @@ defaults.pcm.nonblock 1
|
||||
defaults.pcm.compat 0
|
||||
defaults.pcm.minperiodtime 5000 # in us
|
||||
defaults.pcm.ipc_key 5678293
|
||||
-defaults.pcm.ipc_gid audio
|
||||
-defaults.pcm.ipc_perm 0660
|
||||
+defaults.pcm.ipc_perm 0600
|
||||
defaults.pcm.tstamp_type default
|
||||
defaults.pcm.dmix.max_periods 0
|
||||
defaults.pcm.dmix.channels 2
|
||||
diff --git a/src/conf/pcm/dmix.conf b/src/conf/pcm/dmix.conf
|
||||
index 50e573da..70523f29 100644
|
||||
--- a/src/conf/pcm/dmix.conf
|
||||
+++ b/src/conf/pcm/dmix.conf
|
||||
@@ -48,10 +48,6 @@ pcm.!dmix {
|
||||
@func refer
|
||||
name defaults.pcm.ipc_key
|
||||
}
|
||||
- ipc_gid {
|
||||
- @func refer
|
||||
- name defaults.pcm.ipc_gid
|
||||
- }
|
||||
ipc_perm {
|
||||
@func refer
|
||||
name defaults.pcm.ipc_perm
|
||||
diff --git a/src/conf/pcm/dsnoop.conf b/src/conf/pcm/dsnoop.conf
|
||||
index f4336e5f..60b9f212 100644
|
||||
--- a/src/conf/pcm/dsnoop.conf
|
||||
+++ b/src/conf/pcm/dsnoop.conf
|
||||
@@ -41,10 +41,6 @@ pcm.!dsnoop {
|
||||
@func refer
|
||||
name defaults.pcm.ipc_key
|
||||
}
|
||||
- ipc_gid {
|
||||
- @func refer
|
||||
- name defaults.pcm.ipc_gid
|
||||
- }
|
||||
ipc_perm {
|
||||
@func refer
|
||||
name defaults.pcm.ipc_perm
|
0
SOURCES/alsa-ucm-conf.patch
Normal file
0
SOURCES/alsa-ucm-conf.patch
Normal file
3
SOURCES/asound.conf
Normal file
3
SOURCES/asound.conf
Normal file
@ -0,0 +1,3 @@
|
||||
#
|
||||
# Place your global alsa-lib configuration here...
|
||||
#
|
9
SOURCES/modprobe-dist-alsa.conf
Normal file
9
SOURCES/modprobe-dist-alsa.conf
Normal file
@ -0,0 +1,9 @@
|
||||
# ALSA Sound Support
|
||||
#
|
||||
# We want to ensure that snd-seq is always loaded for those who want to use
|
||||
# the sequencer interface, but we can't do this automatically through udev
|
||||
# at the moment...so we have this rule (just for the moment).
|
||||
#
|
||||
# Remove the following line if you don't want the sequencer.
|
||||
|
||||
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-seq
|
8
SOURCES/modprobe-dist-oss.conf
Normal file
8
SOURCES/modprobe-dist-oss.conf
Normal file
@ -0,0 +1,8 @@
|
||||
# OSS Sound Support
|
||||
# This has been disabled in F11 onwards because it can interfere with the
|
||||
# PulseAudio sound service (a legacy OSS application can prevent PulseAudio
|
||||
# applications from playing sound by preventing PulseAudio from (re-)opening
|
||||
# the sound device). To re-enable support, copy this file to
|
||||
# the /etc/modprobe.d directory.
|
||||
#
|
||||
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss
|
421
SPECS/alsa-lib.spec
Normal file
421
SPECS/alsa-lib.spec
Normal file
@ -0,0 +1,421 @@
|
||||
#define prever rc3
|
||||
#define prever_dot .rc3
|
||||
#define postver a
|
||||
|
||||
%define version_alsa_lib 1.2.5.1
|
||||
%define version_alsa_ucm 1.2.5.1
|
||||
%define version_alsa_tplg 1.2.5
|
||||
|
||||
Summary: The Advanced Linux Sound Architecture (ALSA) library
|
||||
Name: alsa-lib
|
||||
Version: %{version_alsa_lib}
|
||||
Release: 2%{?prever_dot}%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: http://www.alsa-project.org/
|
||||
|
||||
Source: ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}%{?prever}%{?postver}.tar.bz2
|
||||
Source1: ftp://ftp.alsa-project.org/pub/lib/alsa-ucm-conf-%{version_alsa_ucm}.tar.bz2
|
||||
Source2: ftp://ftp.alsa-project.org/pub/lib/alsa-topology-conf-%{version_alsa_tplg}.tar.bz2
|
||||
Source10: asound.conf
|
||||
Source11: modprobe-dist-alsa.conf
|
||||
Source12: modprobe-dist-oss.conf
|
||||
Source40: alsa-ucm-conf.patch
|
||||
Patch0: alsa-git.patch
|
||||
Patch1: alsa-lib-1.2.3.1-config.patch
|
||||
Patch2: alsa-lib-1.0.14-glibc-open.patch
|
||||
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: make
|
||||
|
||||
%description
|
||||
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
|
||||
functionality to the Linux operating system.
|
||||
|
||||
This package includes the ALSA runtime libraries to simplify application
|
||||
programming and provide higher level functionality as well as support for
|
||||
the older OSS API, providing binary compatibility for most OSS programs.
|
||||
|
||||
%package devel
|
||||
Summary: Development files from the ALSA library
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
|
||||
functionality to the Linux operating system.
|
||||
|
||||
This package includes the ALSA development libraries for developing
|
||||
against the ALSA libraries and interfaces.
|
||||
|
||||
%package -n alsa-ucm
|
||||
Summary: ALSA Use Case Manager configuration
|
||||
BuildArch: noarch
|
||||
License: BSD
|
||||
Requires: %{name} >= %{version_alsa_ucm}
|
||||
|
||||
%description -n alsa-ucm
|
||||
The Advanced Linux Sound Architecture (ALSA) Use Case Manager configuration
|
||||
contains alsa-lib configuration of Audio input/output names and routing
|
||||
|
||||
%package -n alsa-topology
|
||||
Summary: ALSA Topology configuration
|
||||
BuildArch: noarch
|
||||
License: BSD
|
||||
Requires: %{name} >= %{version_alsa_tplg}
|
||||
|
||||
%description -n alsa-topology
|
||||
The Advanced Linux Sound Architecture (ALSA) topology configuration
|
||||
contains alsa-lib configuration of SoC topology
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?prever}%{?postver}
|
||||
%patch0 -p1 -b .alsa-git
|
||||
%patch1 -p1 -b .config
|
||||
%patch2 -p1 -b .glibc-open
|
||||
|
||||
%build
|
||||
# This package uses top level ASM constructs which are incompatible with LTO.
|
||||
# Top level ASMs are often used to implement symbol versioning. gcc-10
|
||||
# introduces a new mechanism for symbol versioning which works with LTO.
|
||||
# Converting packages to use that mechanism instead of toplevel ASMs is
|
||||
# recommended.
|
||||
# Note: The v1.2.4 contains changes wich are compatible with gcc-10 LTO
|
||||
# although using the old ASM constructs.
|
||||
# Enable custom LTO flags
|
||||
%define _lto_cflags -flto -ffat-lto-objects -flto-partition=none
|
||||
|
||||
autoreconf -vif
|
||||
%configure --disable-aload --with-plugindir=%{_libdir}/alsa-lib --disable-alisp
|
||||
|
||||
# Remove useless /usr/lib64 rpath on 64bit archs
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
|
||||
make %{?_smp_mflags} V=1
|
||||
make doc
|
||||
|
||||
%install
|
||||
%global sysmodprobedir %{_prefix}/lib/modprobe.d
|
||||
|
||||
make DESTDIR=%{buildroot} install
|
||||
|
||||
# Install global configuration files
|
||||
mkdir -p -m 755 %{buildroot}/etc
|
||||
install -p -m 644 %{SOURCE10} %{buildroot}/etc
|
||||
|
||||
# Install the modprobe files for ALSA
|
||||
mkdir -p -m 755 %{buildroot}%{sysmodprobedir}
|
||||
install -p -m 644 %{SOURCE11} %{buildroot}%{sysmodprobedir}/dist-alsa.conf
|
||||
# bug#926973, place this file to the doc directory
|
||||
install -p -m 644 %{SOURCE12} .
|
||||
|
||||
# Create UCM directories
|
||||
mkdir -p %{buildroot}/%{_datadir}/alsa/ucm
|
||||
mkdir -p %{buildroot}/%{_datadir}/alsa/ucm2
|
||||
|
||||
# Unpack UCMs
|
||||
tar xvjf %{SOURCE1} -C %{buildroot}/%{_datadir}/alsa --strip-components=1 "*/ucm" "*/ucm2"
|
||||
patch -d %{buildroot}/%{_datadir}/alsa -p1 < %{SOURCE40}
|
||||
|
||||
# Create topology directory
|
||||
mkdir -p %{buildroot}/%{_datadir}/alsa/topology
|
||||
|
||||
# Unpack topologies
|
||||
tar xvjf %{SOURCE2} -C %{buildroot}/%{_datadir}/alsa --strip-components=1 "*/topology"
|
||||
|
||||
# Remove libtool archives.
|
||||
find %{buildroot} -name '*.la' -delete
|
||||
|
||||
# Remove /usr/include/asoundlib.h
|
||||
rm %{buildroot}/%{_includedir}/asoundlib.h
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc doc/asoundrc.txt modprobe-dist-oss.conf
|
||||
%config %{_sysconfdir}/asound.conf
|
||||
/%{_libdir}/libasound.so.*
|
||||
/%{_libdir}/libatopology.so.*
|
||||
%{_bindir}/aserver
|
||||
#{_libdir}/alsa-lib/
|
||||
%{_datadir}/alsa/
|
||||
%exclude %{_datadir}/alsa/ucm
|
||||
%exclude %{_datadir}/alsa/ucm2
|
||||
%exclude %{_datadir}/alsa/topology
|
||||
%{sysmodprobedir}/dist-*
|
||||
|
||||
%files devel
|
||||
%doc TODO doc/doxygen/
|
||||
%{_includedir}/alsa/
|
||||
%{_includedir}/sys/asoundlib.h
|
||||
%{_libdir}/libasound.so
|
||||
%{_libdir}/libatopology.so
|
||||
%{_libdir}/pkgconfig/alsa.pc
|
||||
%{_libdir}/pkgconfig/alsa-topology.pc
|
||||
%{_datadir}/aclocal/alsa.m4
|
||||
|
||||
%files -n alsa-ucm
|
||||
# BSD
|
||||
%{_datadir}/alsa/ucm
|
||||
%{_datadir}/alsa/ucm2
|
||||
|
||||
%files -n alsa-topology
|
||||
# BSD
|
||||
%{_datadir}/alsa/topology
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.2.5.1-2
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Thu Jul 29 2021 Jaroslav Kysela <perex@perex.cz> - 1.2.5.1-1
|
||||
- update to 1.2.5.1
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 1.2.4-6
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Oct 19 2020 Jaroslav Kysela <perex@perex.cz> - 1.2.4-4
|
||||
- update to 1.2.4
|
||||
- enable LTO
|
||||
|
||||
* Fri Jul 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3.2-5
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jul 1 2020 Jeff Law <law@redhat.com> - 1.2.3.2-3
|
||||
- Disable LTO
|
||||
|
||||
* Mon Jun 29 2020 Jaroslav Kysela <perex@perex.cz> - 1.2.3.2-2
|
||||
- update to 1.2.3.2
|
||||
|
||||
* Thu Jun 18 2020 Jaroslav Kysela <perex@perex.cz> - 1.2.3.1-1
|
||||
- update to 1.2.3.1
|
||||
|
||||
* Sun Jun 7 2020 Jaroslav Kysela <perex@perex.cz> - 1.2.3-8
|
||||
- update to 1.2.3
|
||||
|
||||
* Mon Apr 6 2020 Jaroslav Kysela <perex@perex.cz> - 1.2.2-2
|
||||
- UCM2 fixes (RemoveDevice), bug#1786723
|
||||
|
||||
* Wed Feb 19 2020 Jaroslav Kysela <perex@perex.cz> - 1.2.2-1
|
||||
- Updated to 1.2.2
|
||||
|
||||
* Sun Feb 9 2020 Jaroslav Kysela <perex@perex.cz> - 1.2.1.2-6
|
||||
- More UCM2 related fixes
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Mon Dec 9 2019 Jaroslav Kysela <perex@perex.cz> - 1.2.1.2-4
|
||||
- Fixes for sof-hda-dsp UCM2 configuration
|
||||
|
||||
* Tue Dec 3 2019 Jaroslav Kysela <perex@perex.cz> - 1.2.1.2-3
|
||||
- Fixed more UCM2 related issues
|
||||
|
||||
* Fri Nov 29 2019 Jaroslav Kysela <perex@perex.cz> - 1.2.1.2-1
|
||||
- Updated to 1.2.1.2
|
||||
|
||||
* Tue Nov 19 2019 Jaroslav Kysela <perex@perex.cz> - 1.2.1.1-1
|
||||
- Updated to 1.2.1.1
|
||||
|
||||
* Wed Nov 13 2019 Jaroslav Kysela <perex@perex.cz> - 1.2.1-3
|
||||
- Updated to 1.2.1
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri May 10 2019 Jaroslav Kysela <perex@perex.cz> - 1.1.9-1
|
||||
- Updated to 1.1.9
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Jan 7 2019 Jaroslav Kysela <perex@perex.cz> - 1.1.8-1
|
||||
- Updated to 1.1.8
|
||||
|
||||
* Tue Dec 25 2018 Hans de Goede <hdegoede@redhat.com> - 1.1.7-3
|
||||
- Fix broken chtrt5645 UCM profile, fixing mic input on chtrt5645 devices
|
||||
|
||||
* Wed Oct 24 2018 Jaroslav Kysela <perex@perex.cz> - 1.1.7-2
|
||||
- Moved topology files to alsa-topology
|
||||
- Updated to 1.1.7
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Apr 04 2018 Jaroslav Kysela <perex@perex.cz> - 1.1.6-2
|
||||
- Changed add-on directory to /etc/alsa/conf.d
|
||||
|
||||
* Tue Apr 03 2018 Jaroslav Kysela <perex@perex.cz> - 1.1.6-1
|
||||
- Updated to 1.1.6
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Tue Nov 14 2017 Jaroslav Kysela <perex@perex.cz> - 1.1.5-1
|
||||
- Updated to 1.1.5
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Jun 13 2017 Jaroslav Kysela <perex@perex.cz> - 1.1.4.1-1
|
||||
- Updated to 1.1.4.1
|
||||
|
||||
* Fri May 12 2017 Jaroslav Kysela <perex@perex.cz> - 1.1.4-1
|
||||
- Updated to 1.1.4
|
||||
|
||||
* Mon Mar 20 2017 Peter Robinson <pbrobinson@fedoraproject.org> 1.1.3-3
|
||||
- Add upstream patch for Raspberry Pi HDMI audio
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Dec 20 2016 Jaroslav Kysela <perex@perex.cz> - 1.1.3-1
|
||||
- Updated to 1.1.3
|
||||
|
||||
* Tue Aug 2 2016 Jaroslav Kysela <perex@perex.cz> - 1.1.2-1
|
||||
- Updated to 1.1.2
|
||||
|
||||
* Tue Jul 19 2016 Bastien Nocera <bnocera@redhat.com> - 1.1.1-2
|
||||
- Add Surface 3 configuration file
|
||||
|
||||
* Thu Mar 31 2016 Jaroslav Kysela <perex@perex.cz> - 1.1.1-1
|
||||
- Updated to 1.1.1
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Nov 9 2015 Jaroslav Kysela <perex@perex.cz> - 1.1.0-3
|
||||
- Replaced source files with the alsa-lib v1.1.0 final
|
||||
|
||||
* Thu Nov 5 2015 Jaroslav Kysela <perex@perex.cz> - 1.1.0-2
|
||||
- Replaced source files with the alsa-lib v1.1.0 test2
|
||||
|
||||
* Tue Oct 27 2015 Jaroslav Kysela <perex@perex.cz> - 1.1.0-1
|
||||
- Updated to 1.1.0 test1
|
||||
|
||||
* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Feb 26 2015 Jaroslav Kysela <perex@perex.cz> - 1.0.29-1
|
||||
- Updated to 1.0.29
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.0.28-4
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Tue Feb 3 2015 Peter Robinson <pbrobinson@fedoraproject.org> 1.0.28-3
|
||||
- Add UCM sub package
|
||||
- Use %%license
|
||||
|
||||
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.28-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Thu Jul 24 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.0.28-1
|
||||
- Update to 1.0.28
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.27.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Aug 1 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.0.27.2-2
|
||||
- Fix build with unversioned %%{_docdir_fmt}.
|
||||
|
||||
* Mon Jul 08 2013 Jaroslav Kysela <perex@perex.cz> - 1.0.27.2-1
|
||||
- Updated to 1.0.27.2
|
||||
|
||||
* Thu May 30 2013 Jaroslav Kysela <perex@perex.cz> - 1.0.27.1-2
|
||||
- Fixed bug#953352
|
||||
|
||||
* Tue May 21 2013 Jaroslav Kysela <perex@perex.cz> - 1.0.27.1-1
|
||||
- Updated to 1.0.27.1
|
||||
|
||||
* Tue May 07 2013 Rex Dieter <rdieter@fedoraproject.org> 1.0.27-3
|
||||
- pull in upstream fix for building in C90 mode
|
||||
|
||||
* Thu Apr 11 2013 Jaroslav Kysela <perex@perex.cz> - 1.0.27-2
|
||||
- move dist-oss.conf to doc as modprobe-dist-oss.conf
|
||||
|
||||
* Thu Apr 11 2013 Jaroslav Kysela <perex@perex.cz> - 1.0.27-1
|
||||
- Updated to 1.0.27
|
||||
|
||||
* Wed Apr 03 2013 Stephen Gallagher <sgallagh@redhat.com> - 1.0.26-4
|
||||
- Add upstream patch to explicitly include sys/types.h
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.26-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Mon Dec 3 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.0.26-2
|
||||
- Create and own ucm directory so alsaucm doesn't crash.
|
||||
- Cleanup and modernise spec
|
||||
|
||||
* Thu Sep 6 2012 Jaroslav Kysela <jkysela@redhat.com> - 1.0.26-1
|
||||
- Updated to 1.0.26
|
||||
|
||||
* Thu Jul 26 2012 Michael Schwendt <mschwendt@fedoraproject.org> - 1.0.25-6
|
||||
- Don't package ancient ChangeLog that ends at alsa-lib 0.2.0 (#510212).
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed May 2 2012 Josh Boyer <jwboyer@redhat.com> - 1.0.25-4
|
||||
- Install ALSA related module conf files
|
||||
|
||||
* Wed Feb 1 2012 Jaroslav Kysela <jkysela@redhat.com> - 1.0.25-3
|
||||
- Remove the pulse audio configuration from /etc/asound.conf
|
||||
|
||||
* Sat Jan 28 2012 Jaroslav Kysela <jkysela@redhat.com> - 1.0.25-1
|
||||
- Updated to 1.0.25 final
|
||||
|
||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.24-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.24-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Jan 28 2011 Jaroslav Kysela <jkysela@redhat.com> - 1.0.24-1
|
||||
- Updated to 1.0.24 final
|
||||
|
||||
* Tue Nov 9 2010 Jochen Schmitt <Jochen herr-schmitt de> 1.0.23-2
|
||||
- Set plugindir to %%{_libdir}/alsa-lib (bz#651507)
|
||||
|
||||
* Fri Apr 16 2010 Jaroslav Kysela <jkysela@redhat.com> - 1.0.23-1
|
||||
- Updated to 1.0.23 final
|
||||
|
||||
* Mon Dec 28 2009 Jaroslav Kysela <jkysela@redhat.com> - 1.0.22-1
|
||||
- Updated to 1.0.22 final
|
||||
- Fix file descriptor leak in pcm_hw plugin
|
||||
- Fix sound distortions for S24_LE - softvol plugin
|
||||
|
||||
* Wed Sep 9 2009 Jaroslav Kysela <jkysela@redhat.com> - 1.0.21-3
|
||||
- Add Speaker and Beep control names to mixer weight list
|
||||
- Fix redhat bug #521988
|
||||
|
||||
* Wed Sep 2 2009 Jaroslav Kysela <jkysela@redhat.com> - 1.0.21-1
|
||||
- Updated to 1.0.21 final
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.20-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed May 6 2009 Jaroslav Kysela <jkysela@redhat.com> - 1.0.20-1
|
||||
- Updated to 1.0.20 final
|
||||
|
||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.19-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Feb 4 2009 Jaroslav Kysela <jkysela@redhat.com> - 1.0.19-2
|
||||
- Make doxygen documentation same for all architectures (bz#465205)
|
||||
|
||||
* Tue Jan 20 2009 Jaroslav Kysela <jkysela@redhat.com> - 1.0.19-1
|
||||
- Updated to 1.0.19 final
|
Loading…
Reference in New Issue
Block a user