- fixed #251307 - fix plugindir directory specification

- fix build with newer glibc where open() is a macro
This commit is contained in:
Martin Stransky 2007-08-16 10:48:00 +00:00
parent aa626bb0cb
commit afea195f11
3 changed files with 33 additions and 3 deletions

View File

@ -0,0 +1,11 @@
--- alsa-lib-1.0.14/aserver/aserver.c 2007-05-31 10:05:13.000000000 +0200
+++ alsa-lib-1.0.14.lennart/aserver/aserver.c 2007-08-15 15:53:32.000000000 +0200
@@ -35,6 +35,8 @@
#include "aserver.h"
+#undef open
+
char *command;
#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 95)

View File

@ -0,0 +1,11 @@
--- alsa-lib-1.0.14/configure.in~ 2007-05-31 09:05:13.000000000 +0100
+++ alsa-lib-1.0.14/configure.in 2007-06-06 23:48:06.000000000 +0100
@@ -93,7 +93,7 @@
esac
plugindir="$dir/$PACKAGE"
fi
-AC_DEFINE_UNQUOTED(ALSA_PLUGIN_DIR, "plugindir", [directory containing ALSA add-on modules])
+AC_DEFINE_UNQUOTED(ALSA_PLUGIN_DIR, "$plugindir", [directory containing ALSA add-on modules])
ALSA_PLUGIN_DIR="$plugindir"
AC_SUBST(ALSA_PLUGIN_DIR)

View File

@ -3,11 +3,13 @@
Summary: The Advanced Linux Sound Architecture (ALSA) library.
Name: alsa-lib
Version: %{version_main}
Release: 1%{?dist}
Release: 2%{?dist}
License: LGPL
Group: System Environment/Libraries
Source: ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version_main}%{?prever}.tar.bz2
Patch: alsa-lib-1.0.14rc1-config.patch
Patch0: alsa-lib-1.0.14rc1-config.patch
Patch1: alsa-lib-1.0.14-plugindir.patch
Patch2: alsa-lib-1.0.14-glibc-open.patch
URL: http://www.alsa-project.org/
BuildRoot: %{_tmppath}/%{name}-%{version_main}-root
BuildRequires: doxygen
@ -35,7 +37,9 @@ against the ALSA libraries and interfaces.
%prep
%setup -q -n %{name}-%{version_main}%{?prever}
%patch -p1 -b .config
%patch0 -p1 -b .config
%patch1 -p1 -b .plugindir
%patch2 -p1 -b .glibc-open
%build
%configure \
@ -90,6 +94,10 @@ ln -snf ../../etc/alsa %{_datadir}/alsa
%{_datadir}/aclocal/alsa.m4
%changelog
* Wed Aug 15 2007 Lennart Poettering <lpoetter@redhat.com> 1.0.14-2
- fixed #251307 - fix plugindir directory specification
- fix build with newer glibc where open() is a macro
* Wed Jul 25 2007 Martin Stransky <stransky@redhat.com> 1.0.14-1
- bumped release number
- fixed #246011 - alsa-lib should own /usr/lib/alsa-lib/smixer