Update to v1.2.13
Resolves: RHEL-60918 Signed-off-by: Jaroslav Kysela <jkysela@redhat.com>
This commit is contained in:
parent
d765f46b99
commit
035a11419c
256
alsa-git.patch
Normal file
256
alsa-git.patch
Normal file
@ -0,0 +1,256 @@
|
||||
From 76edab4e595bd5f3f4c636cccc8d7976d3c519d6 Mon Sep 17 00:00:00 2001
|
||||
From: Nicholas Vinson <nvinson234@gmail.com>
|
||||
Date: Thu, 14 Nov 2024 07:49:53 -0500
|
||||
Subject: [PATCH 1/5] src/Versions.in.in: Update *_tempo_base name
|
||||
|
||||
Change @SYMBOL_PREFIX@snd_has_tempo_base to
|
||||
@SYMBOL_PREFIX@snd_has_queue_tempo_base.
|
||||
|
||||
Starting with version 1.2.13, alsa-lib fails to link with ld.lld-19 due
|
||||
to "version script assignment of 'ALSA_1.2.13' to symbol
|
||||
'snd_seq_has_tempo_base' failed: symbol not defined".
|
||||
|
||||
Per commit 769d1db1b0a213a39c7e59c0d1d724e7f45b1ac3 the correct name for
|
||||
the symbol is @SYMBOL_PREFIX@snd_has_queue_tempo_base; therefore, update
|
||||
src/Vesions.in.in to match.
|
||||
|
||||
Fixes bug #420
|
||||
Fixes Gentoo bug 943399 (https://bugs.gentoo.org/943399)
|
||||
|
||||
Closes: https://github.com/alsa-project/alsa-lib/pull/421
|
||||
Signed-off-by: Nicholas Vinson <nvinson234@gmail.com>
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/Versions.in.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/Versions.in.in b/src/Versions.in.in
|
||||
index 350ec3d8..7ad6a633 100644
|
||||
--- a/src/Versions.in.in
|
||||
+++ b/src/Versions.in.in
|
||||
@@ -212,7 +212,7 @@ ALSA_1.2.13 {
|
||||
@SYMBOL_PREFIX@snd_seq_create_ump_block;
|
||||
@SYMBOL_PREFIX@snd_seq_queue_tempo_get_tempo_base;
|
||||
@SYMBOL_PREFIX@snd_seq_queue_tempo_set_tempo_base;
|
||||
- @SYMBOL_PREFIX@snd_seq_has_tempo_base;
|
||||
+ @SYMBOL_PREFIX@snd_seq_has_queue_tempo_base;
|
||||
@SYMBOL_PREFIX@snd_seq_port_info_get_ump_is_midi1;
|
||||
@SYMBOL_PREFIX@snd_seq_port_info_set_ump_is_midi1;
|
||||
#endif
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 6880219ad4ba55ae8a94a34b7a987b3369f7c96f Mon Sep 17 00:00:00 2001
|
||||
From: Takashi Iwai <tiwai@suse.de>
|
||||
Date: Sun, 24 Nov 2024 09:32:29 +0100
|
||||
Subject: [PATCH 2/5] configure: Make sequencer dependent on rawmidi
|
||||
|
||||
The sequencer feature requires rawmidi implicitly, and it became more
|
||||
obvious with UMP support. Add the dependency check to configure
|
||||
script.
|
||||
|
||||
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
||||
---
|
||||
configure.ac | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 1cd22a59..69aeb978 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -483,6 +483,12 @@ fi
|
||||
AC_SUBST(PYTHON_LIBS)
|
||||
AC_SUBST(PYTHON_INCLUDES)
|
||||
|
||||
+if test "$build_rawmidi" != "yes"; then
|
||||
+ if test "$build_seq" = "yes"; then
|
||||
+ AC_ERROR([Cannot enable sequencer without rawmidi])
|
||||
+ fi
|
||||
+fi
|
||||
+
|
||||
AM_CONDITIONAL([BUILD_MIXER], [test x$build_mixer = xyes])
|
||||
AM_CONDITIONAL([BUILD_PCM], [test x$build_pcm = xyes])
|
||||
AM_CONDITIONAL([BUILD_RAWMIDI], [test x$build_rawmidi = xyes])
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 07cee0ba05179a56764c35975d5822420d4f31f9 Mon Sep 17 00:00:00 2001
|
||||
From: Takashi Iwai <tiwai@suse.de>
|
||||
Date: Sun, 24 Nov 2024 09:33:16 +0100
|
||||
Subject: [PATCH 3/5] seq: include UMP headers
|
||||
|
||||
Some applications seem including alsa/seqmid.h individually, and this
|
||||
got broken with the update of alsa-lib because now we have
|
||||
dependencies to UMP stuff. Include the necessary UMP headers
|
||||
internally. Also, add the inclusion of rawmidi.h in ump.h for similar
|
||||
reasons.
|
||||
|
||||
Link: https://bugzilla.suse.com/show_bug.cgi?id=1233682
|
||||
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
||||
---
|
||||
include/seq.h | 2 ++
|
||||
include/seq_event.h | 2 ++
|
||||
include/ump.h | 2 ++
|
||||
3 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/include/seq.h b/include/seq.h
|
||||
index 2eee95a6..5082ad0a 100644
|
||||
--- a/include/seq.h
|
||||
+++ b/include/seq.h
|
||||
@@ -29,6 +29,8 @@
|
||||
#ifndef __ALSA_SEQ_H
|
||||
#define __ALSA_SEQ_H
|
||||
|
||||
+#include "ump.h"
|
||||
+
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
#endif
|
||||
diff --git a/include/seq_event.h b/include/seq_event.h
|
||||
index 9ca384ee..0b59202f 100644
|
||||
--- a/include/seq_event.h
|
||||
+++ b/include/seq_event.h
|
||||
@@ -28,6 +28,8 @@
|
||||
#ifndef __ALSA_SEQ_EVENT_H
|
||||
#define __ALSA_SEQ_EVENT_H
|
||||
|
||||
+#include "ump_msg.h"
|
||||
+
|
||||
/**
|
||||
* \defgroup SeqEvents Sequencer Event Definitions
|
||||
* Sequencer Event Definitions
|
||||
diff --git a/include/ump.h b/include/ump.h
|
||||
index 1043d237..06c86a5e 100644
|
||||
--- a/include/ump.h
|
||||
+++ b/include/ump.h
|
||||
@@ -9,6 +9,8 @@
|
||||
#ifndef __ALSA_UMP_H
|
||||
#define __ALSA_UMP_H
|
||||
|
||||
+#include "rawmidi.h"
|
||||
+
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
#endif
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 76d2d285c10b1e368b4bf9494cf9270ae46197cb Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Mon, 25 Nov 2024 15:11:27 +0100
|
||||
Subject: [PATCH 4/5] rawmidi: ump - fix snd_ump_block_info_get_block_id double
|
||||
version
|
||||
|
||||
The changes for 1.2.13 in Versions.in.in file matches also old
|
||||
1.2.10 function snd_ump_block_info_get_block_id:
|
||||
|
||||
1 Removed function:
|
||||
|
||||
[D] 'function void snd_ump_block_info_set_block_id(snd_ump_block_info_t*, unsigned int)' {snd_ump_block_info_set_block_id@@ALSA_1.2.10}
|
||||
|
||||
Add 1.2.10 symbol back, but keep 1.2.13 symbol as default.
|
||||
|
||||
Closes: https://github.com/alsa-project/alsa-lib/issues/422
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/rawmidi/ump.c | 9 +++++++++
|
||||
1 file changed, 9 insertions(+)
|
||||
|
||||
diff --git a/src/rawmidi/ump.c b/src/rawmidi/ump.c
|
||||
index d3676afb..b1246c33 100644
|
||||
--- a/src/rawmidi/ump.c
|
||||
+++ b/src/rawmidi/ump.c
|
||||
@@ -750,11 +750,20 @@ int snd_ump_block_info_get_device(const snd_ump_block_info_t *info)
|
||||
* \param info pointer to a snd_ump_block_info_t structure
|
||||
* \return ID number of the given UMP block
|
||||
*/
|
||||
+#ifndef DOXYGEN
|
||||
+EXPORT_SYMBOL unsigned int INTERNAL(snd_ump_block_info_get_block_id)(const snd_ump_block_info_t *info)
|
||||
+#else
|
||||
unsigned int snd_ump_block_info_get_block_id(const snd_ump_block_info_t *info)
|
||||
+#endif
|
||||
{
|
||||
return info->block_id;
|
||||
}
|
||||
|
||||
+#ifndef DOC_HIDDEN
|
||||
+use_symbol_version(__snd_ump_block_info_get_block_id, snd_ump_block_info_get_block_id, ALSA_1.2.10);
|
||||
+use_default_symbol_version(__snd_ump_block_info_get_block_id, snd_ump_block_info_get_block_id, ALSA_1.2.13);
|
||||
+#endif /* DOC_HIDDEN */
|
||||
+
|
||||
/**
|
||||
* \brief get UMP block activeness
|
||||
* \param info pointer to a snd_ump_block_info_t structure
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 352cbc5eb94a271a9c3c0ff5bf1742232a69e0d0 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Mon, 25 Nov 2024 16:17:30 +0100
|
||||
Subject: [PATCH 5/5] rawmidi: ump - fix snd_ump_block_info_set_block_id double
|
||||
version
|
||||
|
||||
Fix mistake snd_ump_block_info_get_block_id / snd_ump_block_info_set_block_id .
|
||||
|
||||
Fixes: 76d2d285 ("rawmidi: ump - fix snd_ump_block_info_get_block_id double version")
|
||||
Link: https://github.com/alsa-project/alsa-lib/issues/422
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/rawmidi/ump.c | 19 ++++++++++---------
|
||||
1 file changed, 10 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/src/rawmidi/ump.c b/src/rawmidi/ump.c
|
||||
index b1246c33..6807e877 100644
|
||||
--- a/src/rawmidi/ump.c
|
||||
+++ b/src/rawmidi/ump.c
|
||||
@@ -750,20 +750,11 @@ int snd_ump_block_info_get_device(const snd_ump_block_info_t *info)
|
||||
* \param info pointer to a snd_ump_block_info_t structure
|
||||
* \return ID number of the given UMP block
|
||||
*/
|
||||
-#ifndef DOXYGEN
|
||||
-EXPORT_SYMBOL unsigned int INTERNAL(snd_ump_block_info_get_block_id)(const snd_ump_block_info_t *info)
|
||||
-#else
|
||||
unsigned int snd_ump_block_info_get_block_id(const snd_ump_block_info_t *info)
|
||||
-#endif
|
||||
{
|
||||
return info->block_id;
|
||||
}
|
||||
|
||||
-#ifndef DOC_HIDDEN
|
||||
-use_symbol_version(__snd_ump_block_info_get_block_id, snd_ump_block_info_get_block_id, ALSA_1.2.10);
|
||||
-use_default_symbol_version(__snd_ump_block_info_get_block_id, snd_ump_block_info_get_block_id, ALSA_1.2.13);
|
||||
-#endif /* DOC_HIDDEN */
|
||||
-
|
||||
/**
|
||||
* \brief get UMP block activeness
|
||||
* \param info pointer to a snd_ump_block_info_t structure
|
||||
@@ -881,12 +872,22 @@ void snd_ump_block_info_set_device(snd_ump_block_info_t *info, unsigned int devi
|
||||
*
|
||||
* This function is mostly used for setting the block ID to query.
|
||||
*/
|
||||
+#ifndef DOXYGEN
|
||||
+EXPORT_SYMBOL void INTERNAL(snd_ump_block_info_set_block_id)(snd_ump_block_info_t *info,
|
||||
+ unsigned int id)
|
||||
+#else
|
||||
void snd_ump_block_info_set_block_id(snd_ump_block_info_t *info,
|
||||
unsigned int id)
|
||||
+#endif
|
||||
{
|
||||
info->block_id = id;
|
||||
}
|
||||
|
||||
+#ifndef DOC_HIDDEN
|
||||
+use_symbol_version(__snd_ump_block_info_set_block_id, snd_ump_block_info_set_block_id, ALSA_1.2.10);
|
||||
+use_default_symbol_version(__snd_ump_block_info_set_block_id, snd_ump_block_info_set_block_id, ALSA_1.2.13);
|
||||
+#endif /* DOC_HIDDEN */
|
||||
+
|
||||
/**
|
||||
* \brief set activeness to snd_ump_block_info_t structure
|
||||
* \param info pointer to a snd_ump_block_info_t structure
|
||||
--
|
||||
2.47.0
|
||||
|
@ -2,15 +2,15 @@
|
||||
#define prever_dot .rc3
|
||||
#define postver a
|
||||
|
||||
%define version_alsa_lib 1.2.12
|
||||
%define version_alsa_ucm 1.2.12
|
||||
%define version_alsa_lib 1.2.13
|
||||
%define version_alsa_ucm 1.2.13
|
||||
%define version_alsa_tplg 1.2.5
|
||||
|
||||
Summary: The Advanced Linux Sound Architecture (ALSA) library
|
||||
Name: alsa-lib
|
||||
Version: %{version_alsa_lib}
|
||||
Release: 1%{?prever_dot}%{?dist}
|
||||
License: LGPLv2+
|
||||
License: LGPL-2.1-or-later
|
||||
URL: http://www.alsa-project.org/
|
||||
|
||||
Source: https://www.alsa-project.org/files/pub/lib/%{name}-%{version}%{?prever}%{?postver}.tar.bz2
|
||||
@ -19,8 +19,8 @@ Source2: https://www.alsa-project.org/files/pub/lib/alsa-topology-conf-%{versio
|
||||
Source10: asound.conf
|
||||
Source11: modprobe-dist-alsa.conf
|
||||
Source12: modprobe-dist-oss.conf
|
||||
#Source40: alsa-ucm-conf.patch
|
||||
#Patch0: alsa-git.patch
|
||||
Source40: alsa-ucm-conf.patch
|
||||
Patch0: alsa-git.patch
|
||||
Patch1: alsa-lib-1.2.3.1-config.patch
|
||||
Patch2: alsa-lib-1.2.10-glibc-open.patch
|
||||
|
||||
@ -70,7 +70,7 @@ contains alsa-lib configuration of SoC topology
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?prever}%{?postver}
|
||||
#patch -P 0 -p1 -b .alsa-git
|
||||
%patch -P 0 -p1 -b .alsa-git
|
||||
%patch -P 1 -p1 -b .config
|
||||
%patch -P 2 -p1 -b .glibc-open
|
||||
|
||||
@ -116,7 +116,7 @@ mkdir -p %{buildroot}/%{_datadir}/alsa/ucm2
|
||||
|
||||
# Unpack UCMs
|
||||
tar xvjf %{SOURCE1} -C %{buildroot}/%{_datadir}/alsa --strip-components=1 "*/ucm" "*/ucm2"
|
||||
#patch -d %{buildroot}/%{_datadir}/alsa -p1 < %{SOURCE40}
|
||||
patch -d %{buildroot}/%{_datadir}/alsa -p1 < %{SOURCE40}
|
||||
|
||||
# Create topology directory
|
||||
mkdir -p %{buildroot}/%{_datadir}/alsa/topology
|
||||
@ -167,6 +167,9 @@ rm %{buildroot}/%{_includedir}/asoundlib.h
|
||||
%{_datadir}/alsa/topology
|
||||
|
||||
%changelog
|
||||
* Fri Nov 15 2024 Jaroslav Kysela <perex@perex.cz> - 1.2.13-1
|
||||
- update to alsa-lib 1.2.13 and alsa-ucm-conf 1.2.13
|
||||
|
||||
* Fri Jun 15 2024 Jaroslav Kysela <perex@perex.cz> - 1.2.12-1
|
||||
- update to alsa-lib 1.2.12 and alsa-ucm-conf 1.2.12
|
||||
|
||||
|
354
alsa-ucm-conf.patch
Normal file
354
alsa-ucm-conf.patch
Normal file
@ -0,0 +1,354 @@
|
||||
From 11b028a9a01e47fc9b48e4a566803752011902e2 Mon Sep 17 00:00:00 2001
|
||||
From: Seppo Ingalsuo <seppo.ingalsuo@linux.intel.com>
|
||||
Date: Wed, 13 Nov 2024 14:48:38 +0200
|
||||
Subject: [PATCH 1/8] UCM2: Intel: sof-hda-dsp: Fix handling of empty
|
||||
sys_vendor
|
||||
|
||||
The mistake in UCM syntax caused in alsaucm start error:
|
||||
|
||||
ALSA lib ucm_cond.c:367:(if_eval) unknown If.Condition.Type
|
||||
|
||||
Fixes: 13022a97711d ("sof-hda-dsp: Fix the case where sysfs dmi
|
||||
sys_vendor attribute is not set")
|
||||
|
||||
Closes: https://github.com/alsa-project/alsa-ucm-conf/pull/463
|
||||
Signed-off-by: Seppo Ingalsuo <seppo.ingalsuo@linux.intel.com>
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/Intel/sof-hda-dsp/HiFi-sof.conf | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf b/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
index fea8159..c755ba2 100644
|
||||
--- a/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
+++ b/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
@@ -6,8 +6,8 @@ Define.SOFVendor "$${sys:devices/virtual/dmi/id/sys_vendor}"
|
||||
|
||||
If.SOFVendor {
|
||||
Condition {
|
||||
- Type Empty
|
||||
- String "${var:SOFVendor}"
|
||||
+ Type String
|
||||
+ Empty "${var:SOFVendor}"
|
||||
}
|
||||
True.Define.SOFVendor "${sys:devices/virtual/dmi/id/board_vendor}"
|
||||
}
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 6397c663d7086b87ca5cbba323ea3dcd0ecd3200 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Wed, 13 Nov 2024 16:19:15 +0100
|
||||
Subject: [PATCH 2/8] sof-hda-dsp: Fix the case where sysfs dmi product_name
|
||||
attribute is not set
|
||||
|
||||
!!DMI Information
|
||||
!!---------------
|
||||
|
||||
Manufacturer:
|
||||
Product Name:
|
||||
Product Version:
|
||||
Firmware Version: R6G07
|
||||
System SKU: Default string
|
||||
Board Vendor: Default string
|
||||
Board Name: Default string
|
||||
|
||||
BugLink: https://bugzilla.redhat.com/show_bug.cgi?id=2292583
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/Intel/sof-hda-dsp/HiFi-sof.conf | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf b/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
index c755ba2..5fd1843 100644
|
||||
--- a/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
+++ b/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
@@ -3,6 +3,7 @@
|
||||
# File paths for controlling SOF processing
|
||||
|
||||
Define.SOFVendor "$${sys:devices/virtual/dmi/id/sys_vendor}"
|
||||
+Define.SOFProduct "$${sys:devices/virtual/dmi/id/product_name}"
|
||||
|
||||
If.SOFVendor {
|
||||
Condition {
|
||||
@@ -12,6 +13,14 @@ If.SOFVendor {
|
||||
True.Define.SOFVendor "${sys:devices/virtual/dmi/id/board_vendor}"
|
||||
}
|
||||
|
||||
+If.SOFProduct {
|
||||
+ Condition {
|
||||
+ Type String
|
||||
+ Empty "${var:SOFProduct}"
|
||||
+ }
|
||||
+ True.Define.SOFProduct "${sys:devices/virtual/dmi/id/board_name}"
|
||||
+}
|
||||
+
|
||||
If.SOFIPCVer {
|
||||
Condition {
|
||||
Type ControlExists
|
||||
@@ -43,7 +52,7 @@ If.SOFPath {
|
||||
HeadphoneIirBlob "${var:BlobPath}/eq_iir/pass.blob"
|
||||
HeadphoneFirBlob "${var:BlobPath}/eq_fir/pass.blob"
|
||||
HeadphoneDrcBlob "${var:BlobPath}/drc/passthrough.blob"
|
||||
- ConfPathFromDMI "${var:SOFVendor}/${sys:devices/virtual/dmi/id/product_name}.conf"
|
||||
+ ConfPathFromDMI "${var:SOFVendor}/${var:SOFProduct}"
|
||||
SOFProductConfig "/blobs/sof/product_configs/${var:ConfPathFromDMI}"
|
||||
SOFConfFullPath "${ConfTopDir}${var:SOFProductConfig}"
|
||||
SOFUserConfig "/blobs/sof/user_configs/${var:ConfPathFromDMI}"
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 70f5bff86035d454312c9d01e304a95791668ea5 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Ujfalusi <peter.ujfalusi@linux.intel.com>
|
||||
Date: Tue, 19 Nov 2024 11:51:15 +0200
|
||||
Subject: [PATCH 3/8] sof-soundwire: cs42l43-spk: Correct PlaybackPCM and
|
||||
routing
|
||||
|
||||
For speaker the correct PCM device to use is "hw:${CardId},2", the
|
||||
"hw:${CardId},0" is for headset playback.
|
||||
|
||||
Adjust the routing as well since with :0,2 the DP6RX1/2 needs to be
|
||||
selected for the speaker.
|
||||
|
||||
Closes: https://github.com/alsa-project/alsa-ucm-conf/pull/465
|
||||
Signed-off-by: Peter Ujfalusi <peter.ujfalusi@linux.intel.com>
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/sof-soundwire/cs42l43-spk.conf | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/ucm2/sof-soundwire/cs42l43-spk.conf b/ucm2/sof-soundwire/cs42l43-spk.conf
|
||||
index 73f1299..693c450 100644
|
||||
--- a/ucm2/sof-soundwire/cs42l43-spk.conf
|
||||
+++ b/ucm2/sof-soundwire/cs42l43-spk.conf
|
||||
@@ -8,8 +8,8 @@ SectionDevice."Speaker" {
|
||||
]
|
||||
|
||||
EnableSequence [
|
||||
- cset "name='cs42l43 Speaker L Input 1' 'DP5RX1'"
|
||||
- cset "name='cs42l43 Speaker R Input 1' 'DP5RX2'"
|
||||
+ cset "name='cs42l43 Speaker L Input 1' 'DP6RX1'"
|
||||
+ cset "name='cs42l43 Speaker R Input 1' 'DP6RX2'"
|
||||
]
|
||||
|
||||
DisableSequence [
|
||||
@@ -19,7 +19,7 @@ SectionDevice."Speaker" {
|
||||
|
||||
Value {
|
||||
PlaybackPriority 100
|
||||
- PlaybackPCM "hw:${CardId},0"
|
||||
+ PlaybackPCM "hw:${CardId},2"
|
||||
PlaybackMixerElem "cs42l43 Speaker Digital"
|
||||
}
|
||||
}
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 02f4fb77d10ab08a2253d77b90942b5ce9a7ed87 Mon Sep 17 00:00:00 2001
|
||||
From: lbilli <lbilli@users.noreply.github.com>
|
||||
Date: Thu, 14 Nov 2024 20:06:48 -0500
|
||||
Subject: [PATCH 4/8] avs_nau8825: Fix JackControl name
|
||||
|
||||
This is the name reported by amixer events.
|
||||
|
||||
Closes: https://github.com/alsa-project/alsa-ucm-conf/pull/464
|
||||
Signed-off-by: lbilli <lbilli@users.noreply.github.com>
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/Intel/avs/avs_nau8825/avs_nau8825-HiFi.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ucm2/Intel/avs/avs_nau8825/avs_nau8825-HiFi.conf b/ucm2/Intel/avs/avs_nau8825/avs_nau8825-HiFi.conf
|
||||
index 3f3e6c9..71f7ed0 100644
|
||||
--- a/ucm2/Intel/avs/avs_nau8825/avs_nau8825-HiFi.conf
|
||||
+++ b/ucm2/Intel/avs/avs_nau8825/avs_nau8825-HiFi.conf
|
||||
@@ -21,7 +21,7 @@ SectionDevice."Mic" {
|
||||
Value {
|
||||
CapturePCM "hw:${CardId},1"
|
||||
CaptureCTL "Mic"
|
||||
- JackControl "Headset Mic"
|
||||
+ JackControl "Headset Mic Jack"
|
||||
}
|
||||
|
||||
EnableSequence [
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 30989bd0c2aa3f9f4b6f5e393397b39678717f45 Mon Sep 17 00:00:00 2001
|
||||
From: Charles Keepax <ckeepax@opensource.cirrus.com>
|
||||
Date: Wed, 20 Nov 2024 10:06:06 +0000
|
||||
Subject: [PATCH 5/8] sof-soundwire: cs42l43: Correct CapturePCM and routing
|
||||
|
||||
For headset microphone capture the correct PCM device to use is
|
||||
"hw:${CardId},1", "hw:${CardId},4" is for built in microphone capture.
|
||||
|
||||
Adjust the routing as well since :0,1 is connected to data port 2 on the
|
||||
codec.
|
||||
|
||||
Closes: https://github.com/alsa-project/alsa-ucm-conf/pull/466
|
||||
Signed-off-by: Charles Keepax <ckeepax@opensource.cirrus.com>
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/sof-soundwire/cs42l43.conf | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/ucm2/sof-soundwire/cs42l43.conf b/ucm2/sof-soundwire/cs42l43.conf
|
||||
index dc11840..4b4e118 100644
|
||||
--- a/ucm2/sof-soundwire/cs42l43.conf
|
||||
+++ b/ucm2/sof-soundwire/cs42l43.conf
|
||||
@@ -28,19 +28,19 @@ SectionDevice."Headset" {
|
||||
cset "name='cs42l43 ADC1 Input' 'IN1'"
|
||||
cset "name='cs42l43 Decimator 1 Mode' 'ADC'"
|
||||
|
||||
- cset "name='cs42l43 DP1TX1 Input' 'Decimator 1'"
|
||||
- cset "name='cs42l43 DP1TX2 Input' 'Decimator 1'"
|
||||
+ cset "name='cs42l43 DP2TX1 Input' 'Decimator 1'"
|
||||
+ cset "name='cs42l43 DP2TX2 Input' 'Decimator 1'"
|
||||
]
|
||||
|
||||
DisableSequence [
|
||||
cset "name='cs42l43 Decimator 1 Switch' 0"
|
||||
- cset "name='cs42l43 DP1TX1 Input' 'None'"
|
||||
- cset "name='cs42l43 DP1TX2 Input' 'None'"
|
||||
+ cset "name='cs42l43 DP2TX1 Input' 'None'"
|
||||
+ cset "name='cs42l43 DP2TX2 Input' 'None'"
|
||||
]
|
||||
|
||||
Value {
|
||||
CapturePriority 200
|
||||
- CapturePCM "hw:${CardId},4"
|
||||
+ CapturePCM "hw:${CardId},1"
|
||||
CaptureMixer "default:${CardId}"
|
||||
CaptureMixerElem "cs42l43 Headset Microphone"
|
||||
JackControl "Headset Mic Jack"
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 62acef2efffdcb75a35f90d266bcad145b4eab35 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Fri, 29 Nov 2024 14:04:00 +0100
|
||||
Subject: [PATCH 6/8] sof-soundwire: whitespace cleanup
|
||||
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/common/pcm/hdmi.conf | 2 +-
|
||||
ucm2/sof-soundwire/sof-soundwire.conf | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ucm2/common/pcm/hdmi.conf b/ucm2/common/pcm/hdmi.conf
|
||||
index e2820dc..37338ec 100644
|
||||
--- a/ucm2/common/pcm/hdmi.conf
|
||||
+++ b/ucm2/common/pcm/hdmi.conf
|
||||
@@ -69,7 +69,7 @@ DefineMacro.HdmiPCMSave {
|
||||
}
|
||||
|
||||
FixedBootSequence [
|
||||
- cfg-save "${var:LibDir}/${var:__Name}.conf:hdmi-pcm"
|
||||
+ cfg-save "${var:LibDir}/${var:__Name}.conf:hdmi-pcm"
|
||||
]
|
||||
}
|
||||
|
||||
diff --git a/ucm2/sof-soundwire/sof-soundwire.conf b/ucm2/sof-soundwire/sof-soundwire.conf
|
||||
index 34f9661..bb14ef2 100644
|
||||
--- a/ucm2/sof-soundwire/sof-soundwire.conf
|
||||
+++ b/ucm2/sof-soundwire/sof-soundwire.conf
|
||||
@@ -157,7 +157,7 @@ If.mics-array {
|
||||
Empty "${var:Mics1}"
|
||||
}
|
||||
False.FixedBootSequence {
|
||||
- # dmic array info
|
||||
+ # dmic array info
|
||||
exec "-nhlt-dmic-info -o ${var:LibDir}/dmics-nhlt.json"
|
||||
}
|
||||
}
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 4a01327cc43a18124c0a4a5bcfb840e6ed1efe0a Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Wed, 4 Dec 2024 10:20:51 +0100
|
||||
Subject: [PATCH 7/8] sof-hda-dsp: Add back missing .conf suffix for
|
||||
product/user specific configs
|
||||
|
||||
Fixes: 6397c66 ("sof-hda-dsp: Fix the case where sysfs dmi product_name attribute is not set")
|
||||
Closes: https://github.com/alsa-project/alsa-ucm-conf/issues/482
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/Intel/sof-hda-dsp/HiFi-sof.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf b/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
index 5fd1843..3a4c445 100644
|
||||
--- a/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
+++ b/ucm2/Intel/sof-hda-dsp/HiFi-sof.conf
|
||||
@@ -52,7 +52,7 @@ If.SOFPath {
|
||||
HeadphoneIirBlob "${var:BlobPath}/eq_iir/pass.blob"
|
||||
HeadphoneFirBlob "${var:BlobPath}/eq_fir/pass.blob"
|
||||
HeadphoneDrcBlob "${var:BlobPath}/drc/passthrough.blob"
|
||||
- ConfPathFromDMI "${var:SOFVendor}/${var:SOFProduct}"
|
||||
+ ConfPathFromDMI "${var:SOFVendor}/${var:SOFProduct}.conf"
|
||||
SOFProductConfig "/blobs/sof/product_configs/${var:ConfPathFromDMI}"
|
||||
SOFConfFullPath "${ConfTopDir}${var:SOFProductConfig}"
|
||||
SOFUserConfig "/blobs/sof/user_configs/${var:ConfPathFromDMI}"
|
||||
--
|
||||
2.47.0
|
||||
|
||||
|
||||
From 0782bf435b8332833e7b3fc91501d78473dd6edf Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Fri, 29 Nov 2024 14:17:57 +0100
|
||||
Subject: [PATCH 8/8] amd-soundwire: add support for AMD generic legacy machine
|
||||
driver
|
||||
|
||||
Closes: https://github.com/alsa-project/alsa-ucm-conf/pull/478
|
||||
Closes: https://github.com/alsa-project/alsa-ucm-conf/pull/470
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
ucm2/conf.d/amd-soundwire/amd-soundwire.conf | 1 +
|
||||
ucm2/sof-soundwire/rt722.conf | 15 +++++++++++++++
|
||||
2 files changed, 16 insertions(+)
|
||||
create mode 120000 ucm2/conf.d/amd-soundwire/amd-soundwire.conf
|
||||
|
||||
diff --git a/ucm2/conf.d/amd-soundwire/amd-soundwire.conf b/ucm2/conf.d/amd-soundwire/amd-soundwire.conf
|
||||
new file mode 120000
|
||||
index 0000000..0d00b73
|
||||
--- /dev/null
|
||||
+++ b/ucm2/conf.d/amd-soundwire/amd-soundwire.conf
|
||||
@@ -0,0 +1 @@
|
||||
+../../sof-soundwire/sof-soundwire.conf
|
||||
\ No newline at end of file
|
||||
diff --git a/ucm2/sof-soundwire/rt722.conf b/ucm2/sof-soundwire/rt722.conf
|
||||
index a54664e..a4a431b 100644
|
||||
--- a/ucm2/sof-soundwire/rt722.conf
|
||||
+++ b/ucm2/sof-soundwire/rt722.conf
|
||||
@@ -86,6 +86,21 @@ SectionDevice."Headset" {
|
||||
cset "name='rt722 FU0F Capture Switch' 0"
|
||||
]
|
||||
|
||||
+ If.hsmicsw {
|
||||
+ Condition {
|
||||
+ Type ControlExists
|
||||
+ Control "name='Headset Mic Switch'"
|
||||
+ }
|
||||
+ True {
|
||||
+ EnableSequence [
|
||||
+ cset "name='Headset Mic Switch' on"
|
||||
+ ]
|
||||
+ DisableSequence [
|
||||
+ cset "name='Headset Mic Switch' off"
|
||||
+ ]
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
Value {
|
||||
CapturePriority 200
|
||||
CapturePCM "hw:${CardId},1"
|
||||
--
|
||||
2.47.0
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (alsa-lib-1.2.12.tar.bz2) = 053e36e51c0ff28f07028b89c8845b50682a5c14035ab85c2fc8cae2f2f0d05e4cd45ed879602c15c1596fb7fe84bfd50ec0d119dfb55c66589a2d458a9b317d
|
||||
SHA512 (alsa-ucm-conf-1.2.12.tar.bz2) = 391dde123271172d899c04865d1d6e21b4ad0060ee9b2256dfbc6fc89ad48edcaa43c861893ab0e5c70d972e20d15c528defc19c00308e7465f13f954cce25d7
|
||||
SHA512 (alsa-lib-1.2.13.tar.bz2) = b0c0666e38e881dca985b61386523c045c71072a88be4952c986ffbe2107ec736da528858ebeffdf439de5c290914bf3facc654100a228c6d26fff9429142ef0
|
||||
SHA512 (alsa-ucm-conf-1.2.13.tar.bz2) = cad867268851ac178f3a5378a00e292184b0e0ec7955f297ae7ed56073d3dddb06c08666b23b1bf6b0065068a9370ee34608bd687763658c79d34b64059b1c85
|
||||
SHA512 (alsa-topology-conf-1.2.5.tar.bz2) = 2eb4d8baf2dcbf0b631dd11dbf15bffc51694d9cc6931619e51787f3ba58d1a091d266e6721a3b737c040ec74a28270b93f39fb97f30a3227cf340dd646e5d51
|
||||
|
Loading…
Reference in New Issue
Block a user