2681d69152
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
This is no longer relevant upstream as of this commit:
|
|
|
|
commit ab12f8919f0f7beff0b8db974e98285ede6a285d
|
|
Author: Hannes von Haugwitz <hannes@vonhaugwitz.com>
|
|
Date: Sun Sep 22 07:26:28 2019 +0200
|
|
|
|
Use AC_SYS_LARGEFILE for large-file support
|
|
|
|
- closes #16
|
|
- require C99 compatible compiler
|
|
- stop using readdir_r in favor of readdir
|
|
- remove unused 'size_o member in db_line struct
|
|
- '--disable-largefile' now disables LFS
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index cafe16e95ed68c9f..144d55a9146548c0 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -574,9 +574,10 @@ AC_CACHE_CHECK([for LFS ino_t],ac_cv_ino_type,[
|
|
AC_TRY_RUN([
|
|
#include <unistd.h>
|
|
#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
#include <sys/types.h>
|
|
#include <sys/stat.h>
|
|
-main() { struct stat64 st; ino64_t s; if (sizeof(ino_t) == sizeof(ino64_t)) exit(1); exit((lstat64("/dev/null", &st)==0)?0:1); }],
|
|
+int main() { struct stat64 st; ino64_t s; if (sizeof(ino_t) == sizeof(ino64_t)) exit(1); exit((lstat64("/dev/null", &st)==0)?0:1); }],
|
|
ac_cv_ino_type=ino64_t,ac_cv_ino_type=ino_t,ac_cv_ino_type=cross)])
|
|
AIDE_INO_TYPE=$ac_cv_ino_type
|
|
|