aide/aide-cvs20031104.patch
cvsextras 9fe78cd264 auto-import changelog data from
aide-0.10-0.fdr.0.1.cvs20031104.rh90.src.rpm
0.10-0.fdr.0.1.cvs20031104
- Only tar.gz available upstream.
- byacc not needed when bison -y is available.
- Installed Russian manual pages.
- Updated with changes from CVS (2003-11-04).
- getopt patch merged upstream.
- bison-1.35 patch incorporated upstream.
0.9-0.fdr.0.2.20030902
- Added fixes for further memleaks.
0.9-0.fdr.0.1.20030902
- Initial package version.
2004-11-08 04:00:58 +00:00

357 lines
11 KiB
Diff

diff -Naur aide-CVS-20030902/AUTHORS aide-CVS-20031104/AUTHORS
--- aide-CVS-20030902/AUTHORS 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/AUTHORS 2003-10-03 22:14:14.000000000 +0200
@@ -1,3 +1,7 @@
+If you have any questions about aide, it's use or applications please send
+your inquiries to the mailing list at aide@cs.tut.fi rather than to the
+individuals named below.
+
The main authors of this package are:
* Rami Lehti (rammer@cs.tut.fi)
* Pablo Virolainen (pablo@cs.tut.fi)
@@ -5,5 +9,8 @@
Other contributors (people who have given us code/patches):
* KELEMEN Peter <Peter.Kelemen@cern.ch>
-I would also like to thank the people who have given good
-bug reports.
+This package is currently maintained by:
+ * Richard van den Berg (richard@vdberg.org)
+ * Mike Markley (mike@markley.org)
+
+Thanks to the people who have given good bug reports.
diff -Naur aide-CVS-20030902/ChangeLog aide-CVS-20031104/ChangeLog
--- aide-CVS-20030902/ChangeLog 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/ChangeLog 2003-10-03 22:18:32.000000000 +0200
@@ -1,3 +1,8 @@
+2003-10-03 Richard van den Berg <richard@vdberg.org>
+ * Moved project over to http://sf.net/projects/aide
+ * Fixed problems in conf_yacc.y
+ * Gzip code now uses best (-9) compression
+
2002-07-22 Rami Lehti <Rami.Lehti@Finland.Sun.COM>
* Fixed Unimplemented error message when conf md not compiled in
diff -Naur aide-CVS-20030902/configure.in aide-CVS-20031104/configure.in
--- aide-CVS-20030902/configure.in 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/configure.in 2003-10-29 12:05:34.000000000 +0100
@@ -2,7 +2,7 @@
dnl Initialize automake
AC_INIT(src/aide.c)
-AM_INIT_AUTOMAKE(aide, 0.9)
+AM_INIT_AUTOMAKE(aide, 0.10)
dnl The name of the configure h-file.
AM_CONFIG_HEADER(config.h)
# We want an absolute path to the source-dir.
diff -Naur aide-CVS-20030902/INSTALL aide-CVS-20031104/INSTALL
--- aide-CVS-20030902/INSTALL 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/INSTALL 2003-10-03 22:09:54.000000000 +0200
@@ -179,3 +179,12 @@
`configure' also accepts some other, not widely useful, options.
+Compiling From CVS
+==================
+
+The CVS version of the source code does not come with the `configure' script
+included. Instead a script called `autogen.sh' can be used to generate the
+configure script. At this moment this requires autoconf version 2.13 to be
+present on your system. A newer version of autoconf will not work. If this is
+a problem for you, please do not use the CVS version, but use a released tar
+ball which will include the `configure' script.
diff -Naur aide-CVS-20030902/NEWS aide-CVS-20031104/NEWS
--- aide-CVS-20030902/NEWS 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/NEWS 2003-10-28 18:37:52.000000000 +0100
@@ -2,6 +2,11 @@
AIDE Version History
=========================================================
+Version 0.10
+ * Fixed bugs
+ * Moved project over to sourceforge.net
+ * Change of project ownership
+
Version 0.9
* Fixed bugs
* Added support for keyed md check of db and config
diff -Naur aide-CVS-20030902/README aide-CVS-20031104/README
--- aide-CVS-20030902/README 2003-01-17 10:24:41.000000000 +0100
+++ aide-CVS-20031104/README 2003-10-29 12:05:34.000000000 +0100
@@ -2,7 +2,7 @@
Advanced Intrusion Detection Environment
- Version 0.9.1
+ Version 0.10
*******************************************************************
@@ -43,6 +43,7 @@
Documentation is in doc/ directory.
The manual pages are a good place to start.
Also see doc/manual.html or http://www.cs.tut.fi/~rammer/aide/manual.html
+Other useful information might appear on http://sf.net/projects/aide
Requirements
@@ -81,7 +82,7 @@
software.
Although some pizza delivery guy's feelings were hurt.
-*******************************************************
+*************************************************************
If there is something that ought to be said here
-please send your comments to rammer@cs.tut.fi.
-*******************************************************
+please send your comments to aide-devel@lists.sourceforge.net
+*************************************************************
diff -Naur aide-CVS-20030902/src/aide.c aide-CVS-20031104/src/aide.c
--- aide-CVS-20030902/src/aide.c 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/src/aide.c 2003-10-30 12:20:53.000000000 +0100
@@ -1,7 +1,7 @@
/* aide, Advanced Intrusion Detection Environment
*
* Copyright (C) 1999,2000,2001,2002 Rami Lehti, Pablo Virolainen
- * $Header: /aide/aide/src/aide.c,v 1.1.1.1 2003/01/16 10:37:34 rammer Exp $
+ * $Header: /cvsroot/aide/aide/src/aide.c,v 1.2 2003/10/30 11:20:53 madhack Exp $
*
* This program is free software; you can redistribute it and/or
* modify it under the terms of the GNU General Public License as
@@ -116,7 +116,7 @@
};
while(1){
- option = getopt_long(argc, argv, "hV::vc:B:A:r:e:f:iCu", options, &i);
+ option = getopt_long(argc, argv, "hV::vc:B:A:r:iCuDE", options, &i);
if(option==-1)
break;
switch(option)
diff -Naur aide-CVS-20030902/src/be.c aide-CVS-20031104/src/be.c
--- aide-CVS-20030902/src/be.c 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/src/be.c 2003-08-18 15:06:30.000000000 +0200
@@ -137,7 +137,7 @@
error(200,_("Opening file \"%s\" for %s\n"),u->value,inout?"r":"w+");
#ifdef WITH_ZLIB
if(iszipped && !inout){
- fh=gzopen(u->value,"wb+");
+ fh=gzopen(u->value,"wb9+");
if(fh==NULL){
error(0,_("Couldn't open file %s for %s"),u->value,
inout?"reading\n":"writing\n");
diff -Naur aide-CVS-20030902/src/conf_yacc.y aide-CVS-20031104/src/conf_yacc.y
--- aide-CVS-20030902/src/conf_yacc.y 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/src/conf_yacc.y 2003-08-18 15:03:22.000000000 +0200
@@ -2,7 +2,7 @@
/*
* Copyright (C) 1999,2000,2001,2002 Rami Lehti, Pablo Virolainen
- * $Header: /aide/aide/src/conf_yacc.y,v 1.1.1.1 2003/01/16 10:37:34 rammer Exp $
+ * $Header: /cvsroot/aide/aide/src/conf_yacc.y,v 1.2 2003/08/18 13:03:22 rvdb Exp $
* This program is free software; you can redistribute it and/or
* modify it under the terms of the GNU General Public License as
* published by the Free Software Foundation; either version 2 of the
@@ -143,19 +143,19 @@
| TEOF {
newlinelastinconfig=1;
YYACCEPT;
- } ;
+ }
| TNEWLINE
| TDBSPEC {
error(220,"Got @@dbspec.Stopping\n");
YYACCEPT;
- } ;
+ }
| TBEGIN_DB {
error(220,"Got @@begin_db. Stopping\n");
YYACCEPT;
- } ;
+ }
| TEND_DB {
conferror("Error while reading configuration");
- } ;
+ }
| error {
conferror("Error while reading configuration");
YYABORT;
diff -Naur aide-CVS-20030902/src/db_file.c aide-CVS-20031104/src/db_file.c
--- aide-CVS-20030902/src/db_file.c 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/src/db_file.c 2003-08-18 15:06:30.000000000 +0200
@@ -1,7 +1,7 @@
/* aide, Advanced Intrusion Detection Environment
*
* Copyright (C) 1999,2000,2001,2002 Rami Lehti, Pablo Virolainen
- * $Header: /aide/aide/src/db_file.c,v 1.1.1.1 2003/01/16 10:37:34 rammer Exp $
+ * $Header: /cvsroot/aide/aide/src/db_file.c,v 1.3 2003/08/18 13:06:30 rvdb Exp $
*
* This program is free software; you can redistribute it and/or
* modify it under the terms of the GNU General Public License as
@@ -95,7 +95,8 @@
int retval;
#ifdef WITH_ZLIB
if(conf->gzip_dbout){
- retval=gzflush(conf->db_gzout,Z_SYNC_FLUSH);
+ /* Should not flush using gzip, it degrades compression */
+ retval=Z_OK;
}else {
#endif
retval=fflush(conf->db_out);
@@ -108,27 +109,23 @@
int dofprintf( const char* s,...)
{
+ char buf[3];
int retval;
char* temp=NULL;
va_list ap;
va_start(ap,s);
- temp=(char*)malloc(3);
- if(temp==NULL){
- error(0,"Unable to alloc %i bytes\n",3);
- return -1;
- }
-
- retval=vsnprintf(temp,3,s,ap);
-
- free(temp);
+ retval=vsnprintf(buf,3,s,ap);
+ va_end(ap);
temp=(char*)malloc(retval+2);
if(temp==NULL){
error(0,"Unable to alloc %i bytes\n",retval+2);
return -1;
}
+ va_start(ap,s);
retval=vsnprintf(temp,retval+1,s,ap);
+ va_end(ap);
#ifdef WITH_MHASH
if(conf->do_dbnewmd)
@@ -140,12 +137,13 @@
retval=gzwrite(conf->db_gzout,temp,retval);
}else{
#endif
+ va_start(ap,s);
retval=vfprintf(conf->db_out,s,ap);
+ va_end(ap);
#ifdef WITH_ZLIB
}
#endif
free(temp);
- va_end(ap);
return retval;
}
diff -Naur aide-CVS-20030902/src/error.c aide-CVS-20031104/src/error.c
--- aide-CVS-20030902/src/error.c 2003-01-16 11:37:34.000000000 +0100
+++ aide-CVS-20031104/src/error.c 2003-08-01 21:28:55.000000000 +0200
@@ -184,22 +184,24 @@
)) {
db_line line;
int len;
- va_start(ap,error_msg);
memset(&line,0,sizeof(db_line));
line.filename=(char*)malloc(3);
if (line.filename!=NULL) {
+ va_start(ap,error_msg);
len=vsnprintf(line.filename,2,error_msg,ap);
+ va_end(ap);
free(line.filename);
line.filename=malloc(len+2);
line.filename[0]='#';
if (line.filename!=NULL) {
line.attr=DB_FILENAME;
+ va_start(ap,error_msg);
len=vsnprintf(line.filename+1,len+1,error_msg,ap);
+ va_end(ap);
db_writeline(&line,conf);
free(line.filename);
}
}
- va_end(ap);
}
#endif
diff -Naur aide-CVS-20030902/src/gen_list.c aide-CVS-20031104/src/gen_list.c
--- aide-CVS-20030902/src/gen_list.c 2003-01-17 09:58:38.000000000 +0100
+++ aide-CVS-20031104/src/gen_list.c 2003-09-09 08:55:07.000000000 +0200
@@ -1,7 +1,7 @@
/* aide, Advanced Intrusion Detection Environment
*
* Copyright (C) 1999,2000,2001,2002 Rami Lehti,Pablo Virolainen
- * $Header: /aide/aide/src/gen_list.c,v 1.2 2003/01/17 08:58:38 cvsd Exp $
+ * $Header: /cvsroot/aide/aide/src/gen_list.c,v 1.3 2003/09/09 06:55:07 ramilehti Exp $
*
* This program is free software; you can redistribute it and/or
* modify it under the terms of the GNU General Public License as
@@ -66,16 +66,31 @@
{
char*p=NULL;
int i=0;
+ int j=1;
+ int last_backslash=0;
+ int lastslash_in_p=1;
- /* This assumes that the first character is a slash */
- int lastslash=1;
+ /* The following code assumes that the first character is a slash */
+ int lastslash=0;
+
+ p=(char*)malloc(sizeof(char)*strlen(rx)+1);
+ p[0]='/';
- /* i=0 because we want to return at least the first slash */
for(i=1;i<strlen(rx);i++){
switch(rx[i])
{
case '/':
+ if(last_backslash){
+ strncpy(p+j,rx+last_backslash+1,i-last_backslash);
+ j+=i-last_backslash;
+ }else{
+ strncpy(p+j,rx+lastslash+1,i-lastslash);
+ j+=i-lastslash;
+ }
+
lastslash=i;
+ lastslash_in_p=j-1;
+
break;
case '(':
case '^':
@@ -83,21 +98,23 @@
case '*':
case '.':
case '[':
- /* FIXME: The '\\' character should be handled more gracefully. */
- /* That is, if it is the only special character then */
- /* The next character should be taken literally so */
- /* that the search would be more efficient */
- case '\\':
i=strlen(rx);
break;
+ case '\\':
+ last_backslash=i;
+ strncpy(p+j,rx+lastslash+1,i-lastslash);
+ j+=i-lastslash;
+ /* Skip the next character */
+ i++;
+ /* Don't copy the backslash */
+ j--;
+ break;
default:
break;
}
}
- p=(char*)malloc(sizeof(char)*lastslash+1);
- strncpy(p,rx,lastslash);
- p[lastslash]='\0';
+ p[lastslash_in_p]='\0';
return p;