New upstream devel version
This commit is contained in:
parent
d1477adb70
commit
e6458ec606
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ aide-0.14.tar.gz
|
|||||||
aide-0.14.tar.gz.asc
|
aide-0.14.tar.gz.asc
|
||||||
/aide-0.15.1.tar.gz
|
/aide-0.15.1.tar.gz
|
||||||
/aide-0.15.1.tar.gz.asc
|
/aide-0.15.1.tar.gz.asc
|
||||||
|
/aide-0.16b1.tar.gz
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -ur aide.orig/doc/aide.1.in aide/doc/aide.1.in
|
|
||||||
--- aide.orig/doc/aide.1.in 2010-02-24 13:53:49.000000000 -0500
|
|
||||||
+++ aide/doc/aide.1.in 2010-02-24 13:57:44.000000000 -0500
|
|
||||||
@@ -75,9 +75,9 @@
|
|
||||||
.SH FILES
|
|
||||||
.B @sysconfdir@/aide.conf
|
|
||||||
Default aide configuration file.
|
|
||||||
-.B @sysconfdir@/aide.db
|
|
||||||
+.B @localstatedir@/lib/aide.db
|
|
||||||
Default aide database.
|
|
||||||
-.B @sysconfdir@/aide.db.new
|
|
||||||
+.B @localstatedir@/lib/aide.db.new
|
|
||||||
Default aide output database.
|
|
||||||
.SH SEE ALSO
|
|
||||||
.BR aide.conf (5)
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/src/db_file.c
|
|
||||||
+++ b/src/db_file.c
|
|
||||||
@@ -702,7 +702,7 @@ int db_write_byte_base64(byte*data,size_t len,FILE* file,int i,
|
|
||||||
}
|
|
||||||
|
|
||||||
if(tmpstr){
|
|
||||||
- retval=dofprintf(tmpstr);
|
|
||||||
+ retval=dofprintf("%s",tmpstr);
|
|
||||||
free(tmpstr);
|
|
||||||
return retval;
|
|
||||||
}else {
|
|
||||||
@@ -741,7 +741,7 @@ int db_write_time_base64(time_t i,FILE* file,int a)
|
|
||||||
|
|
||||||
|
|
||||||
tmpstr=encode_base64((byte *)ptr,strlen(ptr));
|
|
||||||
- retval=dofprintf(tmpstr);
|
|
||||||
+ retval=dofprintf("%s",tmpstr);
|
|
||||||
free(tmpstr);
|
|
||||||
free(ptr);
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
diff -up aide-0.15.1/src/aide.c.fipsfix aide-0.15.1/src/aide.c
|
diff -up ./src/aide.c.orig ./aide-0.16b1/src/aide.c
|
||||||
--- aide-0.15.1/src/aide.c.fipsfix 2010-08-08 19:39:31.000000000 +0200
|
--- ./src/aide.c.orig 2016-07-12 11:10:08.013158385 +0200
|
||||||
+++ aide-0.15.1/src/aide.c 2012-11-22 16:59:45.378713818 +0100
|
+++ ./src/aide.c 2016-07-12 11:30:54.867833064 +0200
|
||||||
@@ -484,9 +484,28 @@ int main(int argc,char**argv)
|
@@ -511,9 +511,28 @@ int main(int argc,char**argv)
|
||||||
#endif
|
#endif
|
||||||
umask(0177);
|
umask(0177);
|
||||||
init_sighandler();
|
init_sighandler();
|
||||||
@ -31,7 +31,7 @@ diff -up aide-0.15.1/src/aide.c.fipsfix aide-0.15.1/src/aide.c
|
|||||||
if(read_param(argc,argv)==RETFAIL){
|
if(read_param(argc,argv)==RETFAIL){
|
||||||
error(0, _("Invalid argument\n") );
|
error(0, _("Invalid argument\n") );
|
||||||
exit(INVALID_ARGUMENT_ERROR);
|
exit(INVALID_ARGUMENT_ERROR);
|
||||||
@@ -641,6 +660,9 @@ int main(int argc,char**argv)
|
@@ -646,6 +665,9 @@ int main(int argc,char**argv)
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
}
|
}
|
||||||
@ -41,9 +41,9 @@ diff -up aide-0.15.1/src/aide.c.fipsfix aide-0.15.1/src/aide.c
|
|||||||
return RETOK;
|
return RETOK;
|
||||||
}
|
}
|
||||||
const char* aide_key_3=CONFHMACKEY_03;
|
const char* aide_key_3=CONFHMACKEY_03;
|
||||||
diff -up aide-0.15.1/src/md.c.fipsfix aide-0.15.1/src/md.c
|
diff -up ./src/md.c.orig ./aide-0.16b1/src/md.c
|
||||||
--- aide-0.15.1/src/md.c.fipsfix 2010-08-08 19:39:31.000000000 +0200
|
--- ./src/md.c.orig 2016-04-15 23:30:16.000000000 +0200
|
||||||
+++ aide-0.15.1/src/md.c 2012-11-22 16:59:33.166673632 +0100
|
+++ ./src/md.c 2016-07-12 11:35:04.007675329 +0200
|
||||||
@@ -201,14 +201,7 @@ int init_md(struct md_container* md) {
|
@@ -201,14 +201,7 @@ int init_md(struct md_container* md) {
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
@ -56,7 +56,7 @@ diff -up aide-0.15.1/src/md.c.fipsfix aide-0.15.1/src/md.c
|
|||||||
- gcry_control(GCRYCTL_DISABLE_SECMEM, 0);
|
- gcry_control(GCRYCTL_DISABLE_SECMEM, 0);
|
||||||
- gcry_control(GCRYCTL_INITIALIZATION_FINISHED, 0);
|
- gcry_control(GCRYCTL_INITIALIZATION_FINISHED, 0);
|
||||||
- if(gcry_md_open(&md->mdh,0,0)!=GPG_ERR_NO_ERROR){
|
- if(gcry_md_open(&md->mdh,0,0)!=GPG_ERR_NO_ERROR){
|
||||||
+ if(gcry_md_open(&md->mdh,0,GCRY_MD_FLAG_SECURE)!=GPG_ERR_NO_ERROR){
|
+ if(gcry_md_open(&md->mdh,0,GCRY_MD_FLAG_SECURE)!=GPG_ERR_NO_ERROR){
|
||||||
error(0,"gcrypt_md_open failed\n");
|
error(0,"gcrypt_md_open failed\n");
|
||||||
exit(IO_ERROR);
|
exit(IO_ERROR);
|
||||||
}
|
}
|
||||||
@ -69,10 +69,10 @@ diff -up aide-0.15.1/src/md.c.fipsfix aide-0.15.1/src/md.c
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
#ifdef WITH_MHASH
|
#ifdef WITH_MHASH
|
||||||
diff -up aide-0.15.1/src/util.c.fipsfix aide-0.15.1/src/util.c
|
diff -up ./src/util.c.orig ./aide-0.16b1/src/util.c
|
||||||
--- aide-0.15.1/src/util.c.fipsfix 2010-08-08 19:39:31.000000000 +0200
|
--- ./src/util.c.orig 2016-07-12 11:39:17.023437355 +0200
|
||||||
+++ aide-0.15.1/src/util.c 2012-11-22 16:59:33.166673632 +0100
|
+++ ./src/util.c 2016-07-12 11:39:51.618721157 +0200
|
||||||
@@ -494,28 +494,5 @@ int syslog_facility_lookup(char *s)
|
@@ -519,28 +519,5 @@ int syslog_facility_lookup(char *s)
|
||||||
return(AIDE_SYSLOG_FACILITY);
|
return(AIDE_SYSLOG_FACILITY);
|
||||||
}
|
}
|
||||||
|
|
15
aide-0.16b1-man.patch
Normal file
15
aide-0.16b1-man.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up ./doc/aide.1.in.origman ./doc/aide.1.in
|
||||||
|
--- ./doc/aide.1.in.origman 2016-07-12 11:50:49.859083100 +0200
|
||||||
|
+++ ./doc/aide.1.in 2016-07-12 11:49:20.191333852 +0200
|
||||||
|
@@ -88,9 +88,9 @@ echo <encoded_checksum> | base64 \-d | h
|
||||||
|
.SH FILES
|
||||||
|
.IP \fB@sysconfdir@/aide.conf\fR
|
||||||
|
Default aide configuration file.
|
||||||
|
-.IP \fB@sysconfdir@/aide.db\fR
|
||||||
|
+.IP \fB@localstatedir@/lib/aide/aide.db\fR
|
||||||
|
Default aide database.
|
||||||
|
-.IP \fB@sysconfdir@/aide.db.new\fR
|
||||||
|
+.IP \fB@localstatedir@/lib/aide/aide.db.new\fR
|
||||||
|
Default aide output database.
|
||||||
|
.SH SEE ALSO
|
||||||
|
.BR aide.conf (5)
|
19
aide.spec
19
aide.spec
@ -3,21 +3,19 @@
|
|||||||
|
|
||||||
Summary: Intrusion detection environment
|
Summary: Intrusion detection environment
|
||||||
Name: aide
|
Name: aide
|
||||||
Version: 0.15.1
|
Version: 0.16
|
||||||
Release: 12%{?dist}
|
Release: 0.1.b1%{?dist}
|
||||||
URL: http://sourceforge.net/projects/aide
|
URL: http://sourceforge.net/projects/aide
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source0: http://downloads.sourceforge.net/aide/aide-%{version}.tar.gz
|
Source0: https://sourceforge.net/projects/aide/files/devel/0.16b1/aide-0.16b1.tar.gz
|
||||||
Source1: aide.conf
|
Source1: aide.conf
|
||||||
Source2: README.quickstart
|
Source2: README.quickstart
|
||||||
Source3: aide.logrotate
|
Source3: aide.logrotate
|
||||||
# Customize the database file location in the man page.
|
# Customize the database file location in the man page.
|
||||||
Patch1: aide-0.14-man.patch
|
Patch1: aide-0.16b1-man.patch
|
||||||
# fix aide in FIPS mode
|
# fix aide in FIPS mode
|
||||||
Patch2: aide-0.15.1-fipsfix.patch
|
Patch2: aide-0.16b1-fipsfix.patch
|
||||||
# -Werror=format-security
|
|
||||||
Patch3: aide-0.15.1-format-security.patch
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
|
||||||
BuildRequires: mktemp
|
BuildRequires: mktemp
|
||||||
BuildRequires: elfutils-libelf-devel
|
BuildRequires: elfutils-libelf-devel
|
||||||
@ -39,10 +37,10 @@ checker and intrusion detection program.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}b1
|
||||||
%patch1 -p1 -b .man
|
%patch1 -p1 -b .man
|
||||||
%patch2 -p1 -b .fipsfix
|
%patch2 -p1 -b .fipsfix
|
||||||
%patch3 -p1 -b .format
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-config_file=%{_sysconfdir}/aide.conf \
|
%configure --with-config_file=%{_sysconfdir}/aide.conf \
|
||||||
@ -90,6 +88,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 20 2016 Tomas Sykora <tosykora@redhat.com> - 0.16-0.1.b1
|
||||||
|
- New upstream devel version
|
||||||
|
|
||||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.1-12
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.1-12
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user