- Update to 0.12 release.
- now offers --disable-static, so -no-static patch is obsolete - fill last element of getopt struct array with zeroes
This commit is contained in:
parent
1bc01a772e
commit
de46efc5f3
@ -1 +1,2 @@
|
|||||||
aide-0.12.tar.gz
|
aide-0.12.tar.gz
|
||||||
|
aide-0.12.tar.gz.asc
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
diff -Nur aide-0.11-orig/configure aide-0.11/configure
|
|
||||||
--- aide-0.11-orig/configure 2006-02-18 13:49:06.000000000 +0100
|
|
||||||
+++ aide-0.11/configure 2006-02-19 21:05:57.000000000 +0100
|
|
||||||
@@ -3485,8 +3485,8 @@
|
|
||||||
esac
|
|
||||||
fi
|
|
||||||
|
|
||||||
-CFLAGS="$CFLAGS $LD_STATIC_FLAG"
|
|
||||||
-CPPFLAGS="$CPPFLAGS $LD_STATIC_FLAG"
|
|
||||||
+#CFLAGS="$CFLAGS $LD_STATIC_FLAG"
|
|
||||||
+#CPPFLAGS="$CPPFLAGS $LD_STATIC_FLAG"
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
@@ -8638,7 +8638,7 @@
|
|
||||||
done
|
|
||||||
|
|
||||||
save_LDFLAGS=$LDFLAGS
|
|
||||||
- LDFLAGS="$LDFLAGS $LD_STATIC_FLAG"
|
|
||||||
+ #LDFLAGS="$LDFLAGS $LD_STATIC_FLAG"
|
|
||||||
|
|
||||||
echo "$as_me:$LINENO: checking for gzdopen in -lz" >&5
|
|
||||||
echo $ECHO_N "checking for gzdopen in -lz... $ECHO_C" >&6
|
|
||||||
@@ -10424,7 +10424,7 @@
|
|
||||||
s,@MAINTAINER_MODE_TRUE@,$MAINTAINER_MODE_TRUE,;t t
|
|
||||||
s,@MAINTAINER_MODE_FALSE@,$MAINTAINER_MODE_FALSE,;t t
|
|
||||||
s,@MAINT@,$MAINT,;t t
|
|
||||||
-s,@LD_STATIC_FLAG@,$LD_STATIC_FLAG,;t t
|
|
||||||
+s,@LD_STATIC_FLAG@,,;t t
|
|
||||||
s,@CPP@,$CPP,;t t
|
|
||||||
s,@EGREP@,$EGREP,;t t
|
|
||||||
s,@AIDE_USE_LOCALE@,$AIDE_USE_LOCALE,;t t
|
|
14
aide-0.12-getopt.patch
Normal file
14
aide-0.12-getopt.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
Do what the manual says.
|
||||||
|
|
||||||
|
diff -Nur aide-0.12-orig/src/aide.c aide-0.12/src/aide.c
|
||||||
|
--- aide-0.12-orig/src/aide.c 2006-10-04 12:20:25.000000000 +0200
|
||||||
|
+++ aide-0.12/src/aide.c 2006-10-14 22:35:47.000000000 +0200
|
||||||
|
@@ -109,7 +109,7 @@
|
||||||
|
{ "update", no_argument, NULL, 'u'},
|
||||||
|
{ "config-check", no_argument, NULL, 'D'},
|
||||||
|
{ "compare", no_argument, NULL, 'E'},
|
||||||
|
- { NULL }
|
||||||
|
+ { NULL, 0, NULL, 0 }
|
||||||
|
};
|
||||||
|
|
||||||
|
while(1){
|
32
aide.spec
32
aide.spec
@ -1,20 +1,26 @@
|
|||||||
%{?_with_static: %define nostatic 0}
|
%{?_with_static: %define nostatic %nil }
|
||||||
%{!?_with_static: %define nostatic 1}
|
%{!?_with_static: %define nostatic --disable-static }
|
||||||
|
|
||||||
|
# segfaults
|
||||||
|
%{!?_with_curl: %{!?_without_curl: %define _without_curl --without-curl}}
|
||||||
|
|
||||||
Summary: Intrusion detection environment
|
Summary: Intrusion detection environment
|
||||||
Name: aide
|
Name: aide
|
||||||
Version: 0.11
|
Version: 0.12
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://sourceforge.net/projects/aide
|
URL: http://sourceforge.net/projects/aide
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source0: http://download.sourceforge.net/aide/aide-%{version}.tar.gz
|
Source0: http://download.sourceforge.net/aide/aide-%{version}.tar.gz
|
||||||
Source1: aide.conf
|
Source1: aide.conf
|
||||||
Source2: README.quickstart
|
Source2: README.quickstart
|
||||||
Patch0: aide-0.11-no-static.patch
|
Patch0: aide-0.12-getopt.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
|
||||||
Buildrequires: mhash-devel zlib-devel
|
Buildrequires: mhash-devel zlib-devel
|
||||||
Buildrequires: flex bison
|
Buildrequires: flex bison
|
||||||
|
%if "%{?_with_curl}x" != "x"
|
||||||
|
Buildrequires: curl-devel
|
||||||
|
%endif
|
||||||
#Buildrequires: postgresql-devel libgcrypt-devel
|
#Buildrequires: postgresql-devel libgcrypt-devel
|
||||||
#(needs --with-psql and -lgcrypt in src/Makefile.in)
|
#(needs --with-psql and -lgcrypt in src/Makefile.in)
|
||||||
|
|
||||||
@ -25,15 +31,15 @@ checker and intrusion detection program.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%if 0%{nostatic}
|
%patch0 -p1 -b .getopt
|
||||||
%patch0 -p1 -b .no-static
|
|
||||||
%endif
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-config_file=%{_sysconfdir}/aide.conf \
|
%configure --with-config_file=%{_sysconfdir}/aide.conf \
|
||||||
--with-zlib \
|
--with-zlib \
|
||||||
--with-mhash --enable-mhash
|
--with-mhash --enable-mhash \
|
||||||
|
%{?_with_curl} %{?_without_curl} \
|
||||||
|
%{?nostatic}
|
||||||
|
|
||||||
# Adjust default database paths.
|
# Adjust default database paths.
|
||||||
perl -pi -e 's!%{_sysconfdir}/aide.db!%{_localstatedir}/lib/aide.db!' config.h
|
perl -pi -e 's!%{_sysconfdir}/aide.db!%{_localstatedir}/lib/aide.db!' config.h
|
||||||
@ -51,7 +57,6 @@ mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
|
|||||||
install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
|
install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
|
||||||
mkdir -p -m0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/aide
|
mkdir -p -m0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/aide
|
||||||
install -p %{SOURCE2} README.quickstart
|
install -p %{SOURCE2} README.quickstart
|
||||||
mkdir -p -m0755 $RPM_BUILD_ROOT%{_mandir}/ru/man{1,5}
|
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -70,7 +75,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Oct 02 2006 Michael Schwendt <mschwendt[AT]users.sf.net>
|
* Sat Oct 07 2006 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.12-1
|
||||||
|
- Update to 0.12 release.
|
||||||
|
- now offers --disable-static, so -no-static patch is obsolete
|
||||||
|
- fill last element of getopt struct array with zeroes
|
||||||
|
|
||||||
|
* Mon Oct 02 2006 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.11-3
|
||||||
- rebuilt
|
- rebuilt
|
||||||
|
|
||||||
* Mon Sep 11 2006 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.11-2
|
* Mon Sep 11 2006 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.11-2
|
||||||
|
Loading…
Reference in New Issue
Block a user