Fix building with curl
Resolves: rhbz#1674637
This commit is contained in:
parent
264113e1f4
commit
b919234a9d
@ -0,0 +1,58 @@
|
|||||||
|
From c7caa6027c92b28aa11b8da74d56357e12f56d67 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Daniel=20Kope=C4=8Dek?= <dkopecek@redhat.com>
|
||||||
|
Date: Wed, 20 Feb 2019 12:00:56 +0100
|
||||||
|
Subject: [PATCH] Use LDADD for adding curl library to the linker command
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile.am | 2 +-
|
||||||
|
configure.ac | 5 +++--
|
||||||
|
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index 4b05d7a..1541d56 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -55,7 +55,7 @@ if USE_CURL
|
||||||
|
aide_SOURCES += include/fopen.h src/fopen.c
|
||||||
|
endif
|
||||||
|
|
||||||
|
-aide_LDADD = -lm @PCRELIB@ @CRYPTLIB@ @ACLLIB@ @SELINUXLIB@ @AUDITLIB@ @ATTRLIB@ @E2FSATTRSLIB@ @ELFLIB@
|
||||||
|
+aide_LDADD = -lm @PCRELIB@ @CRYPTLIB@ @ACLLIB@ @SELINUXLIB@ @AUDITLIB@ @ATTRLIB@ @E2FSATTRSLIB@ @ELFLIB@ @CURLLIB@
|
||||||
|
AM_CFLAGS = @AIDE_DEFS@ -W -Wall -g
|
||||||
|
AM_CPPFLAGS = -I$(top_srcdir) \
|
||||||
|
-I$(top_srcdir)/include \
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 3598ebe..0418c59 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -702,24 +702,25 @@ if test x$with_zlib = xyes; then
|
||||||
|
compoptionstring="${compoptionstring}WITH_ZLIB\\n"
|
||||||
|
fi
|
||||||
|
|
||||||
|
+CURLLIB=
|
||||||
|
if test x$with_curl = xyes; then
|
||||||
|
AC_PATH_PROG(curlconfig, "curl-config")
|
||||||
|
if test "_$curlconfig" != _ ; then
|
||||||
|
CURL_CFLAGS=`$curlconfig --cflags`
|
||||||
|
- CURL_LIBS=`$curlconfig --libs`
|
||||||
|
+ CURLLIB=`$curlconfig --libs`
|
||||||
|
else
|
||||||
|
AC_MSG_ERROR([You don't have curl properly installed. Install it or try --without-curl.])
|
||||||
|
fi
|
||||||
|
AC_CHECK_HEADERS(curl/curl.h,,
|
||||||
|
[AC_MSG_ERROR([You don't have curl properly installed. Install it or try --without-curl.])])
|
||||||
|
CFLAGS="$CFLAGS $CURL_CFLAGS"
|
||||||
|
- LDFLAGS="$LDFLAGS $CURL_LIBS"
|
||||||
|
AC_CHECK_LIB(curl,curl_easy_init,havecurl=yes,
|
||||||
|
[AC_MSG_ERROR([You don't have curl properly installed. Install it or try --without-curl.])]
|
||||||
|
)
|
||||||
|
AC_DEFINE(WITH_CURL,1,[use curl])
|
||||||
|
compoptionstring="${compoptionstring}WITH_CURL\\n"
|
||||||
|
fi
|
||||||
|
+AC_SUBST(CURLLIB)
|
||||||
|
AM_CONDITIONAL(USE_CURL, test x$havecurl = xyes)
|
||||||
|
|
||||||
|
AC_ARG_WITH(mhash,
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
12
aide.spec
12
aide.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Intrusion detection environment
|
Summary: Intrusion detection environment
|
||||||
Name: aide
|
Name: aide
|
||||||
Version: 0.16
|
Version: 0.16
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
URL: http://sourceforge.net/projects/aide
|
URL: http://sourceforge.net/projects/aide
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
|
|
||||||
@ -22,12 +22,15 @@ BuildRequires: libacl-devel
|
|||||||
BuildRequires: pkgconfig(libselinux)
|
BuildRequires: pkgconfig(libselinux)
|
||||||
BuildRequires: libattr-devel
|
BuildRequires: libattr-devel
|
||||||
BuildRequires: e2fsprogs-devel
|
BuildRequires: e2fsprogs-devel
|
||||||
Buildrequires: audit-libs-devel
|
BuildRequires: audit-libs-devel
|
||||||
|
BuildRequires: autoconf automake libtool
|
||||||
|
|
||||||
# Customize the database file location in the man page.
|
# Customize the database file location in the man page.
|
||||||
Patch1: aide-0.16rc1-man.patch
|
Patch1: aide-0.16rc1-man.patch
|
||||||
# fix aide in FIPS mode
|
# fix aide in FIPS mode
|
||||||
Patch2: aide-0.16b1-fipsfix.patch
|
Patch2: aide-0.16b1-fipsfix.patch
|
||||||
|
# Bug 1674637 - aide: FTBFS in Fedora rawhide/f30
|
||||||
|
Patch3: aide-0.16-Use-LDADD-for-adding-curl-library-to-the-linker-comm.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
AIDE (Advanced Intrusion Detection Environment) is a file integrity
|
AIDE (Advanced Intrusion Detection Environment) is a file integrity
|
||||||
@ -38,6 +41,7 @@ checker and intrusion detection program.
|
|||||||
cp -a %{S:2} .
|
cp -a %{S:2} .
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
autoreconf -ivf
|
||||||
%configure \
|
%configure \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--with-config_file=%{_sysconfdir}/aide.conf \
|
--with-config_file=%{_sysconfdir}/aide.conf \
|
||||||
@ -71,6 +75,10 @@ mkdir -p -m0700 %{buildroot}%{_localstatedir}/lib/aide
|
|||||||
%dir %attr(0700,root,root) %{_localstatedir}/log/aide
|
%dir %attr(0700,root,root) %{_localstatedir}/log/aide
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 20 2019 Daniel Kopecek <dkopecek@redhat.com> - 0.16-10
|
||||||
|
- Fix building with curl
|
||||||
|
Resolves: rhbz#1674637
|
||||||
|
|
||||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.16-9
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.16-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user