7006bcddd4
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/adwaita-qt#7a75bc37b17e6ef012272d67f474ca39d5397d52
40 lines
1.7 KiB
Diff
40 lines
1.7 KiB
Diff
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
|
|
index d3be838..b6bd930 100644
|
|
--- a/src/lib/CMakeLists.txt
|
|
+++ b/src/lib/CMakeLists.txt
|
|
@@ -74,6 +74,8 @@ target_link_libraries(adwaitaqt
|
|
adwaitaqtpriv
|
|
)
|
|
|
|
+set_target_properties(adwaitaqtpriv PROPERTIES VERSION ${ADWAITAQT_VERSION} SOVERSION 1)
|
|
+
|
|
set_target_properties(adwaitaqt PROPERTIES VERSION ${ADWAITAQT_VERSION} SOVERSION 1)
|
|
target_include_directories(adwaitaqt PUBLIC ${Qt5Core_INCLUDE_DIRS} ${Qt5Gui_INCLUDE_DIRS} ${Qt5Widgets_INCLUDE_DIRS})
|
|
|
|
diff --git a/src/lib/adwaita.h b/src/lib/adwaita.h
|
|
index 1cb7e2c..ba8306d 100644
|
|
--- a/src/lib/adwaita.h
|
|
+++ b/src/lib/adwaita.h
|
|
@@ -168,7 +168,7 @@ enum Metrics {
|
|
// checkboxes and radio buttons
|
|
CheckBox_Size = 22,
|
|
CheckBox_FocusMarginWidth = 3,
|
|
- CheckBox_ItemSpacing = 8,
|
|
+ CheckBox_ItemSpacing = 4,
|
|
|
|
// menubar items
|
|
MenuBarItem_MarginWidth = 8,
|
|
diff --git a/src/style/adwaitastyle.cpp b/src/style/adwaitastyle.cpp
|
|
index 86ba710..08f31ac 100644
|
|
--- a/src/style/adwaitastyle.cpp
|
|
+++ b/src/style/adwaitastyle.cpp
|
|
@@ -1686,7 +1686,7 @@ QRect Style::checkBoxContentsRect(const QStyleOption *option, const QWidget *) c
|
|
//___________________________________________________________________________________________________________________
|
|
QRect Style::checkBoxIndicatorRect(const QStyleOption *option, const QWidget *widget) const
|
|
{
|
|
- return ParentStyleClass::subElementRect(SE_CheckBoxIndicator, option, widget).translated(Metrics::CheckBox_ItemSpacing, 0);
|
|
+ return ParentStyleClass::subElementRect(SE_CheckBoxIndicator, option, widget);
|
|
}
|
|
|
|
//___________________________________________________________________________________________________________________
|