1.3.1
This commit is contained in:
parent
b23fce63ae
commit
c9ae6430b6
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
||||
/adwaita-qt-1.2.0.tar.gz
|
||||
/adwaita-qt-1.2.1.tar.gz
|
||||
/adwaita-qt-1.3.0.tar.gz
|
||||
/adwaita-qt-1.3.1.tar.gz
|
||||
|
@ -1,22 +0,0 @@
|
||||
From b348762c7d5f92fb8cbbcb781c94ed675bf916f8 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Grulich <jgrulich@redhat.com>
|
||||
Date: Mon, 17 May 2021 19:51:25 +0200
|
||||
Subject: [PATCH] Make never versions compatible with old ones
|
||||
|
||||
---
|
||||
src/lib/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
|
||||
index 3f37ce9a..5dd2b8a7 100644
|
||||
--- a/src/lib/CMakeLists.txt
|
||||
+++ b/src/lib/CMakeLists.txt
|
||||
@@ -110,7 +110,7 @@ configure_package_config_file(
|
||||
write_basic_package_version_file(
|
||||
${CMAKE_CURRENT_BINARY_DIR}/AdwaitaQtConfigVersion.cmake
|
||||
VERSION ${ADWAITAQT_VERSION}
|
||||
- COMPATIBILITY SameMinorVersion
|
||||
+ COMPATIBILITY AnyNewerVersion
|
||||
)
|
||||
|
||||
install(FILES
|
@ -1,48 +0,0 @@
|
||||
From 1a089c8f0b1e111fd1b077de2180ac125708b327 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Grulich <jgrulich@redhat.com>
|
||||
Date: Thu, 20 May 2021 14:44:37 +0200
|
||||
Subject: [PATCH] TabWidget: do not stretch tabs to full width/height of tab
|
||||
widget
|
||||
|
||||
---
|
||||
src/style/adwaitastyle.cpp | 20 +++++++++++++-------
|
||||
1 file changed, 13 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/src/style/adwaitastyle.cpp b/src/style/adwaitastyle.cpp
|
||||
index febbea4f..3b53a7e5 100644
|
||||
--- a/src/style/adwaitastyle.cpp
|
||||
+++ b/src/style/adwaitastyle.cpp
|
||||
@@ -2008,11 +2008,12 @@ QRect Style::tabWidgetTabBarRect(const QStyleOption *option, const QWidget *widg
|
||||
// horizontal positioning
|
||||
bool verticalTabs(isVerticalTab(tabOption->shape));
|
||||
if (verticalTabs) {
|
||||
- tabBarRect.setTop(option->rect.top() + 1);
|
||||
- tabBarRect.setBottom(option->rect.bottom() - 1);
|
||||
- //tabBarRect.setHeight( qMin( tabBarRect.height(), rect.height() - 2 ) );
|
||||
- //if( tabBarAlignment == Qt::AlignCenter ) tabBarRect.moveTop( rect.top() + ( rect.height() - tabBarRect.height() )/2 );
|
||||
- //else tabBarRect.moveTop( rect.top()+1 );
|
||||
+ tabBarRect.setHeight(qMin(tabBarRect.height(), rect.height() - 2));
|
||||
+ if (tabBarAlignment == Qt::AlignCenter) {
|
||||
+ tabBarRect.moveTop(rect.top() + (rect.height() - tabBarRect.height()) / 2);
|
||||
+ } else {
|
||||
+ tabBarRect.moveTop(rect.top() + 1);
|
||||
+ }
|
||||
} else {
|
||||
// account for corner rects
|
||||
// need to re-run visualRect to remove right-to-left handling, since it is re-added on tabBarRect at the end
|
||||
@@ -2022,8 +2023,13 @@ QRect Style::tabWidgetTabBarRect(const QStyleOption *option, const QWidget *widg
|
||||
rect.setLeft(leftButtonRect.width());
|
||||
rect.setRight(rightButtonRect.left() - 1);
|
||||
|
||||
- tabBarRect.moveLeft(rect.left() + 1);
|
||||
- tabBarRect.setWidth(rect.width() - 2);
|
||||
+ tabBarRect.setWidth(qMin(tabBarRect.width(), rect.width() - 2));
|
||||
+
|
||||
+ if (tabBarAlignment == Qt::AlignCenter) {
|
||||
+ tabBarRect.moveLeft(rect.left() + (rect.width() - tabBarRect.width()) / 2);
|
||||
+ } else {
|
||||
+ tabBarRect.moveLeft(rect.left() + 1);
|
||||
+ }
|
||||
|
||||
tabBarRect = visualRect(option, tabBarRect);
|
||||
}
|
@ -1,6 +1,6 @@
|
||||
|
||||
Name: adwaita-qt
|
||||
Version: 1.3.0
|
||||
Version: 1.3.1
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+ and GPLv2+
|
||||
Summary: Adwaita theme for Qt-based applications
|
||||
@ -8,9 +8,6 @@ Summary: Adwaita theme for Qt-based applications
|
||||
Url: https://github.com/FedoraQt/adwaita-qt
|
||||
Source0: https://github.com/FedoraQt/adwaita-qt/archive/%{version}/adwaita-qt-%{version}.tar.gz
|
||||
|
||||
Patch0: adwaita-qt-make-newer-versions-compatible-with-old-ones.patch
|
||||
Patch1: adwaita-qt-tabwidget-dont-stretch-tabs-to-full-height-or-width-of-tabs.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
@ -77,6 +74,9 @@ developing applications that use libadwaita-qt5.
|
||||
%{_libdir}/libadwaitaqtpriv.so
|
||||
|
||||
%changelog
|
||||
* Wed Jun 02 2021 Jan Grulich <jgrulich@redhat.com> - 1.3.1-1
|
||||
- 1.3.1
|
||||
|
||||
* Wed Jun 02 2021 Jan Grulich <jgrulich@redhat.com> - 1.3.0-1
|
||||
- 1.3.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (adwaita-qt-1.3.0.tar.gz) = 77f2554826ceb31f2972f272424a8626b83085df4638cdde707837671479ed3bb28c86fae3cd878daefc0c887aca1a58f8b30d0eed9577f9a306af6db703261b
|
||||
SHA512 (adwaita-qt-1.3.1.tar.gz) = 2f6f0e76a7ea35151ea6a2c7f6d8f4714b738935bfecf10be9abb243bee6f297bbe7a31593ca2a17eea1767b26d4d420aadb5ba2c4c11792169579eab4bdd439
|
||||
|
Loading…
Reference in New Issue
Block a user