Update to 1.0.91
This commit is contained in:
parent
9cf81d2c40
commit
68ef056468
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/adwaita-qt-0.98.tar.gz
|
||||
/adwaita-qt-1.0.tar.gz
|
||||
/adwaita-qt-1.0.90.tar.gz
|
||||
/adwaita-qt-1.0.91.tar.gz
|
||||
|
@ -1,85 +0,0 @@
|
||||
From c1e3feb39676a05915110ecb98524cf7daa687c2 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Grulich <jgrulich@redhat.com>
|
||||
Date: Tue, 2 Jul 2019 13:08:36 +0200
|
||||
Subject: Fix build against qt4
|
||||
|
||||
|
||||
diff --git a/style/CMakeLists.txt b/style/CMakeLists.txt
|
||||
index da9baf5..ce2e483 100644
|
||||
--- a/style/CMakeLists.txt
|
||||
+++ b/style/CMakeLists.txt
|
||||
@@ -43,6 +43,7 @@ if (MSVC)
|
||||
endif()
|
||||
|
||||
include_directories(
|
||||
+ ${QT_INCLUDES}
|
||||
${CMAKE_CURRENT_BINARY_DIR} # for adwaita-config.h
|
||||
${CMAKE_CURRENT_SOURCE_DIR}
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/animations/
|
||||
diff --git a/style/adwaita.h b/style/adwaita.h
|
||||
index 9b23aa4..165fb6a 100644
|
||||
--- a/style/adwaita.h
|
||||
+++ b/style/adwaita.h
|
||||
@@ -102,8 +102,8 @@ namespace Adwaita
|
||||
const bool SidePanelDrawFrame { false };
|
||||
const bool MenuItemDrawStrongFocus { true };
|
||||
const int WindowDragMode { 0 };
|
||||
- const QStringList WindowDragWhiteList { };
|
||||
- const QStringList WindowDragBlackList { };
|
||||
+ const QStringList WindowDragWhiteList;
|
||||
+ const QStringList WindowDragBlackList;
|
||||
const bool UseWMMoveResize { true };
|
||||
const bool SplitterProxyEnabled { true };
|
||||
const int SplitterProxyWidth { 3 };
|
||||
diff --git a/style/debug/adwaitawidgetexplorer.cpp b/style/debug/adwaitawidgetexplorer.cpp
|
||||
index 323121d..93ee880 100644
|
||||
--- a/style/debug/adwaitawidgetexplorer.cpp
|
||||
+++ b/style/debug/adwaitawidgetexplorer.cpp
|
||||
@@ -21,14 +21,20 @@
|
||||
#include "adwaitawidgetexplorer.h"
|
||||
|
||||
#include "adwaita.h"
|
||||
+#if QT_VERSION >= 0x050000
|
||||
#include "adwaitadebug.h"
|
||||
+#else
|
||||
+#include <QDebug>
|
||||
+#endif
|
||||
|
||||
#include <QTextStream>
|
||||
#include <QApplication>
|
||||
#include <QMouseEvent>
|
||||
#include <QPainter>
|
||||
|
||||
+#if QT_VERSION >= 0x050000
|
||||
Q_LOGGING_CATEGORY(ADWAITA, "adwaita.widgetexplorer")
|
||||
+#endif
|
||||
|
||||
namespace Adwaita
|
||||
{
|
||||
@@ -108,8 +114,11 @@ bool WidgetExplorer::eventFilter(QObject *object, QEvent *event)
|
||||
QWidget *widget(qobject_cast<QWidget *>(object));
|
||||
if (!widget)
|
||||
return false;
|
||||
-
|
||||
+#if QT_VERSION >= 0x050000
|
||||
qCDebug(ADWAITA)
|
||||
+#else
|
||||
+ qDebug()
|
||||
+#endif
|
||||
<< "Adwaita::WidgetExplorer::eventFilter -"
|
||||
<< " event: " << event << " type: " << eventType(event->type())
|
||||
<< " widget: " << widgetInformation(widget);
|
||||
@@ -117,7 +126,12 @@ bool WidgetExplorer::eventFilter(QObject *object, QEvent *event)
|
||||
// print parent information
|
||||
QWidget *parent(widget->parentWidget());
|
||||
while (parent) {
|
||||
- qCDebug(ADWAITA) << " parent: " << widgetInformation(parent);
|
||||
+#if QT_VERSION >= 0x050000
|
||||
+ qCDebug(ADWAITA)
|
||||
+#else
|
||||
+ qDebug()
|
||||
+#endif
|
||||
+ << " parent: " << widgetInformation(parent);
|
||||
parent = parent->parentWidget();
|
||||
}
|
||||
}
|
@ -1,26 +0,0 @@
|
||||
diff --git a/style/adwaitastyle.cpp b/style/adwaitastyle.cpp
|
||||
index 73ae36d..f079943 100644
|
||||
--- a/style/adwaitastyle.cpp
|
||||
+++ b/style/adwaitastyle.cpp
|
||||
@@ -4754,12 +4758,19 @@ bool Style::drawComboBoxLabelControl(const QStyleOption *option, QPainter *paint
|
||||
//
|
||||
bool Style::drawItemViewItemControl(const QStyleOption *option, QPainter *painter, const QWidget *widget) const
|
||||
{
|
||||
+#if QT_VERSION >= 0x050000
|
||||
const QStyleOptionViewItem *vopt = qstyleoption_cast<const QStyleOptionViewItem *>(option);
|
||||
+#else
|
||||
+ const QStyleOptionViewItemV4 *vopt = qstyleoption_cast<const QStyleOptionViewItemV4 *>(option);
|
||||
+#endif
|
||||
if (!vopt)
|
||||
return true;
|
||||
|
||||
- QStyleOptionViewItem op = QStyleOptionViewItem(*vopt);
|
||||
-
|
||||
+#if QT_VERSION >= 0x050000
|
||||
+ QStyleOptionViewItem op(*vopt);
|
||||
+#else
|
||||
+ QStyleOptionViewItemV4 op(*vopt);
|
||||
+#endif
|
||||
QPalette palette = op.palette;
|
||||
if ((vopt->state & QStyle::State_Enabled) && !(vopt->state & QStyle::State_Active)) {
|
||||
palette.setColor(QPalette::Inactive, QPalette::Text, palette.color(QPalette::Active, QPalette::Text));
|
@ -1,15 +1,12 @@
|
||||
Name: adwaita-qt
|
||||
Version: 1.0.90
|
||||
Release: 2%{?dist}
|
||||
Version: 1.0.91
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Summary: Adwaita theme for Qt-based applications
|
||||
|
||||
Url: https://github.com/FedoraQt/adwaita-qt
|
||||
Source0: https://github.com/FedoraQt/adwaita-qt/archive/%{version}/adwaita-qt-%{version}.tar.gz
|
||||
|
||||
Patch0: adwaita-qt-fix-build-with-qt4.patch
|
||||
Patch1: adwaita-qt-fix-qt4-style-option.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: qt4-devel
|
||||
|
||||
@ -44,9 +41,6 @@ Summary: Adwaita Qt common files
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
|
||||
%patch0 -p1 -b .qt-fix-build-with-qt4
|
||||
%patch1 -p1 -b .qt-fix-qt4-style-option
|
||||
|
||||
%build
|
||||
mkdir -p "%{_target_platform}-qt4"
|
||||
pushd "%{_target_platform}-qt4"
|
||||
@ -80,6 +74,9 @@ make install/fast DESTDIR=%{buildroot} -C "%{_target_platform}-qt5"
|
||||
%files
|
||||
|
||||
%changelog
|
||||
* Fri Jul 11 2019 Jan Grulich <jgrulich@redhat.com> - 1.0.91-1
|
||||
- Update to 1.0.91
|
||||
|
||||
* Mon Jul 08 2019 Jan Grulich <jgrulich@redhat.com> - 1.0.90-2
|
||||
- Fix Qt4 item view widgets
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (adwaita-qt-1.0.90.tar.gz) = a49956f552e1629b90cda779ab60c900e1d82ffb2509b1258700dce2d7e356c7a490fe7a52878bf36d70e65c66a82ac663d7f84a5457461258502521f08bc0f1
|
||||
SHA512 (adwaita-qt-1.0.91.tar.gz) = 1b2c37d4082a0ac00abfd0224a91280f737f13f09fc2a169871752c4d5cb41187ee1bb8f0760288318efdaf8328c3afe9005fcb892c0b4d730b2ed359b3abfa2
|
||||
|
Loading…
Reference in New Issue
Block a user