Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/adwaita-qt.git#786c7b3c16b042ce70333e1133514eae6160cf28
This commit is contained in:
parent
5e54d72ce4
commit
0905923257
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
||||
/adwaita-qt-1.1.2.tar.gz
|
||||
/adwaita-qt-1.1.3.tar.gz
|
||||
/adwaita-qt-1.1.90.tar.gz
|
||||
/adwaita-qt-1.2.0.tar.gz
|
||||
|
@ -1,39 +0,0 @@
|
||||
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
|
||||
index d3be838..b6bd930 100644
|
||||
--- a/src/lib/CMakeLists.txt
|
||||
+++ b/src/lib/CMakeLists.txt
|
||||
@@ -74,6 +74,8 @@ target_link_libraries(adwaitaqt
|
||||
adwaitaqtpriv
|
||||
)
|
||||
|
||||
+set_target_properties(adwaitaqtpriv PROPERTIES VERSION ${ADWAITAQT_VERSION} SOVERSION 1)
|
||||
+
|
||||
set_target_properties(adwaitaqt PROPERTIES VERSION ${ADWAITAQT_VERSION} SOVERSION 1)
|
||||
target_include_directories(adwaitaqt PUBLIC ${Qt5Core_INCLUDE_DIRS} ${Qt5Gui_INCLUDE_DIRS} ${Qt5Widgets_INCLUDE_DIRS})
|
||||
|
||||
diff --git a/src/lib/adwaita.h b/src/lib/adwaita.h
|
||||
index 1cb7e2c..ba8306d 100644
|
||||
--- a/src/lib/adwaita.h
|
||||
+++ b/src/lib/adwaita.h
|
||||
@@ -168,7 +168,7 @@ enum Metrics {
|
||||
// checkboxes and radio buttons
|
||||
CheckBox_Size = 22,
|
||||
CheckBox_FocusMarginWidth = 3,
|
||||
- CheckBox_ItemSpacing = 8,
|
||||
+ CheckBox_ItemSpacing = 4,
|
||||
|
||||
// menubar items
|
||||
MenuBarItem_MarginWidth = 8,
|
||||
diff --git a/src/style/adwaitastyle.cpp b/src/style/adwaitastyle.cpp
|
||||
index 86ba710..08f31ac 100644
|
||||
--- a/src/style/adwaitastyle.cpp
|
||||
+++ b/src/style/adwaitastyle.cpp
|
||||
@@ -1686,7 +1686,7 @@ QRect Style::checkBoxContentsRect(const QStyleOption *option, const QWidget *) c
|
||||
//___________________________________________________________________________________________________________________
|
||||
QRect Style::checkBoxIndicatorRect(const QStyleOption *option, const QWidget *widget) const
|
||||
{
|
||||
- return ParentStyleClass::subElementRect(SE_CheckBoxIndicator, option, widget).translated(Metrics::CheckBox_ItemSpacing, 0);
|
||||
+ return ParentStyleClass::subElementRect(SE_CheckBoxIndicator, option, widget);
|
||||
}
|
||||
|
||||
//___________________________________________________________________________________________________________________
|
@ -2,7 +2,7 @@
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
Name: adwaita-qt
|
||||
Version: 1.1.90
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+ and GPLv2+
|
||||
Summary: Adwaita theme for Qt-based applications
|
||||
@ -10,8 +10,6 @@ Summary: Adwaita theme for Qt-based applications
|
||||
Url: https://github.com/FedoraQt/adwaita-qt
|
||||
Source0: https://github.com/FedoraQt/adwaita-qt/archive/%{version}/adwaita-qt-%{version}.tar.gz
|
||||
|
||||
Patch0: adwaita-qt-upstream-fixes.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
@ -78,6 +76,9 @@ developing applications that use libadwaita-qt5.
|
||||
%{_libdir}/libadwaitaqtpriv.so
|
||||
|
||||
%changelog
|
||||
* Thu Dec 17 2020 Jan Grulich <jgrulich@redhat.com> - 1.2.0-1
|
||||
- 1.2.0
|
||||
|
||||
* Wed Sep 30 2020 Jan Grulich <jgrulich@redhat.com> - 1.1.90-1
|
||||
- 1.1.90
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (adwaita-qt-1.1.90.tar.gz) = ae23a9d018dd64570d03bd7741ef3eafeaf812f55843e1cc527632bda18bd6f23a1ca58185b034b3a48025444c940a4f4b719d8e4cbf60454c8fc8bb7d2189ca
|
||||
SHA512 (adwaita-qt-1.2.0.tar.gz) = 313697ad6474dc15eae8e6650cd6eb2e31dc3005978c6de5aa92003f3c426f9a04523bb839922f9acaca35495566dedb049df9582d1a6666dcf97e8429a7a778
|
||||
|
Loading…
Reference in New Issue
Block a user